[PATCH] import: pypi: Always use pypi.io URL with downcased package name.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170531200415.21780-1-dannym@scratchpost.org
* guix/import/pypi.scm (make-pypi-sexp): Always use pypi.io URL with
downcased package name.
---
guix/import/pypi.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (17 lines)
diff --git a/guix/import/pypi.scm b/guix/import/pypi.scm
index 9c72e7331..90dbe5612 100644
--- a/guix/import/pypi.scm
+++ b/guix/import/pypi.scm
@@ -258,11 +258,7 @@ VERSION, SOURCE-URL, HOME-PAGE, SYNOPSIS, DESCRIPTION, and LICENSE."
;; Sometimes 'pypi-uri' doesn't quite work due to mixed
;; cases in NAME, for instance, as is the case with
;; "uwsgi". In that case, fall back to a full URL.
- (uri ,(if (equal? (pypi-uri name version) source-url)
- `(pypi-uri ,name version)
- `(string-append
- ,@(factorize-uri source-url version))))
-
+ (uri (pypi-uri ,(string-downcase name) version))
(sha256
(base32
,(guix-hash-url temp)))))
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27173@debbugs.gnu.org)
87zidrzzcd.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (21 lines)
> * guix/import/pypi.scm (make-pypi-sexp): Always use pypi.io URL with
> downcased package name.
> ---
> guix/import/pypi.scm | 6 +-----
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/guix/import/pypi.scm b/guix/import/pypi.scm
> index 9c72e7331..90dbe5612 100644
> --- a/guix/import/pypi.scm
> +++ b/guix/import/pypi.scm
> @@ -258,11 +258,7 @@ VERSION, SOURCE-URL, HOME-PAGE, SYNOPSIS, DESCRIPTION, and LICENSE."
> ;; Sometimes 'pypi-uri' doesn't quite work due to mixed
> ;; cases in NAME, for instance, as is the case with
> ;; "uwsgi". In that case, fall back to a full URL.
> - (uri ,(if (equal? (pypi-uri name version) source-url)
> - `(pypi-uri ,name version)
> - `(string-append
> - ,@(factorize-uri source-url version))))
> -
> + (uri (pypi-uri ,(string-downcase name) version))

So is the command above outdated? For instance, does “guix import pypi
uwsgi” work with this change?

If it does, feel free to push after removing the comment.

Thanks,
Ludo’.
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27173@debbugs.gnu.org)
87o9u7zyzp.fsf@gnu.org
ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (26 lines)
> Hi Danny,
>
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> * guix/import/pypi.scm (make-pypi-sexp): Always use pypi.io URL with
>> downcased package name.
>> ---
>> guix/import/pypi.scm | 6 +-----
>> 1 file changed, 1 insertion(+), 5 deletions(-)
>>
>> diff --git a/guix/import/pypi.scm b/guix/import/pypi.scm
>> index 9c72e7331..90dbe5612 100644
>> --- a/guix/import/pypi.scm
>> +++ b/guix/import/pypi.scm
>> @@ -258,11 +258,7 @@ VERSION, SOURCE-URL, HOME-PAGE, SYNOPSIS, DESCRIPTION, and LICENSE."
>> ;; Sometimes 'pypi-uri' doesn't quite work due to mixed
>> ;; cases in NAME, for instance, as is the case with
>> ;; "uwsgi". In that case, fall back to a full URL.
>> - (uri ,(if (equal? (pypi-uri name version) source-url)
>> - `(pypi-uri ,name version)
>> - `(string-append
>> - ,@(factorize-uri source-url version))))
>> -
>> + (uri (pypi-uri ,(string-downcase name) version))
>
> So is the command above outdated?
^------
Should read: “the comment.”

Ludo’.
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170615094942.3d5ced9a@scratchpost.org
close 27173
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27173@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27173
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help