Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* guix/import/pypi.scm (make-pypi-sexp): Always use pypi.io URL with
downcased package name.
---
guix/import/pypi.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
Toggle diff (17 lines)
diff --git a/guix/import/pypi.scm b/guix/import/pypi.scm
index 9c72e7331..90dbe5612 100644
--- a/guix/import/pypi.scm
+++ b/guix/import/pypi.scm
@@ -258,11 +258,7 @@ VERSION, SOURCE-URL, HOME-PAGE, SYNOPSIS, DESCRIPTION, and LICENSE."
;; Sometimes 'pypi-uri' doesn't quite work due to mixed
;; cases in NAME, for instance, as is the case with
;; "uwsgi". In that case, fall back to a full URL.
- (uri ,(if (equal? (pypi-uri name version) source-url)
- `(pypi-uri ,name version)
- `(string-append
- ,@(factorize-uri source-url version))))
-
+ (uri (pypi-uri ,(string-downcase name) version))
(sha256
(base32
,(guix-hash-url temp)))))