Danny Milosavljevic wrote 8 years ago
[PATCH] gnu: build: Improve error reporting.
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/build/file-systems.scm (read-iso9660-primary-volume-descriptor):
Improve error reporting.
---
gnu/build/file-systems.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (16 lines)
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index 17c1182ce..bd6997adc 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -245,7 +245,10 @@ Trailing spaces are trimmed."
"Find and read the first primary volume descriptor, starting at OFFSET.
Return #f if not found."
(let* ((sblock (read-superblock device offset 2048 iso9660-superblock?))
- (type-code (if sblock (array-ref sblock 0) 255)))
+ (type-code (if sblock
+ (array-ref sblock 0)
+ (error (format #f "Could not read ISO9660 primary
+volume descriptor from ~s" device)))))
(match type-code
(255 #f) ; Volume Descriptor Set Terminator.
(1 sblock) ; Primary Volume Descriptor