[PATCH 2/3] gnu: Add libgdata.

  • Done
  • quality assurance status badge
Details
3 participants
  • Kei Kebreau
  • Leo Famulari
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 27 May 2017 05:23
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170527032304.22189-2-kei@openmailbox.org
* gnu/packages/gnome.scm (libgdata): New variable.
---
gnu/packages/gnome.scm | 42 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 41 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 299f11b2d..d7d92dd90 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
@@ -238,6 +238,46 @@ relationship modeling, and network diagrams. The program supports various file
formats like PNG, SVG, PDF and EPS.")
(license license:gpl2+))))
+(define-public libgdata
+ (package
+ (name "libgdata")
+ (version "0.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "09q8h1129xjpw33rvzz7856drygxwlm0s64z9cm0vbmjxiqy0h47"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-tests")
+ #:tests? #f)) ; See <https://bugzilla.gnome.org/show_bug.cgi?id=739956>.
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("uhttpmock" ,uhttpmock)))
+ (inputs
+ `(("cyrus-sasl" ,cyrus-sasl)
+ ("glib" ,glib)
+ ("glib-networking" ,glib-networking)
+ ("json-glib" ,json-glib)
+ ("libsoup" ,libsoup)))
+ (propagated-inputs
+ `(("gcr" ,gcr)
+ ("gnome-online-accounts" ,gnome-online-accounts)
+ ("liboauth" ,liboauth)
+ ("libxml2" ,libxml2)))
+ (home-page "https://wiki.gnome.org/Projects/libgdata")
+ (synopsis "Library for accessing online service APIs")
+ (description
+ "libgdata is a GLib-based library for accessing online service APIs using
+the GData protocol — most notably, Google's services. It provides APIs to
+access the common Google services, and has full asynchronous support.")
+ (license license:lgpl2.1+)))
+
(define-public gnome-common
(package
(name "gnome-common")
--
2.13.0
L
L
Leo Famulari wrote on 27 May 2017 15:58
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27093@debbugs.gnu.org)
20170527135825.GD1387@jasmine
On Fri, May 26, 2017 at 11:23:03PM -0400, Kei Kebreau wrote:
Toggle quote (6 lines)
> * gnu/packages/gnome.scm (libgdata): New variable.

> + (arguments
> + '(#:configure-flags '("--disable-tests")
> + #:tests? #f)) ; See <https://bugzilla.gnome.org/show_bug.cgi?id=739956>.

That bug report is a couple years old. Did they still not release the
fix? Okay if not, I just want to clarify.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkphgAACgkQJkb6MLrK
fwicNw/+NUyjCXrxZ2xQQVhtbuz+XVZiredzU0ecBaOetpRZ3ILqT2eJjAvxn64k
zEUih+2fijg1DdQnlWl0Zrv2c0Y431g8hRzY2AT64oZg5nykxWUK6gSUFiUi7gGv
wbUEszEMK671+KkyIdTL+jeFxEJ9xO7jC/7qXCzMnyE017ZWWIB2gvEsfhMYX1p5
zN6DLMUVNPXrVJDdxBjoaVpnGSv9A+L3wKpozRApYb6zbcfaFHNiFRFcvtK4saGq
YdDD9Z+sCpUMQMP9StKKVpTrktTg4X0HqESzPpQBnBytnPpDhS1Hy2Qw/LcgUeTJ
NjZslMWLVNCsVnRD96EHT6uNPnN+lbsvs43Gu7ThTOtaKkzIQ6mFoSVhHGF1giEl
AVlH71a8zm6M4shmbRaCyyfK+aP4n1NEDbgqJ8glbxzhvw5Zth1HMjx0lQRBguy5
N23u5adrfztjjcPdsb14qp3RzWuLv1u0F9AxU222zQlr+wqWqyX1p9pZEP6X85Yh
ZR07jCTn7DQXRI+0qCalN0ePU9Rz0uBsnP3Te9+iK/WL2JA6hHGQHa8jEdkUWgTf
rfqF/oEMNeSS21bLex5m3go0TWEwFp2HE6XEaYk9MsVAK37Bmf+ysL1xJq4ou2K4
KJhzTHZGwGsEcyHyzGv7uwRtlzTEHI7bNQbUsX302ForYyTISvY=
=IKTf
-----END PGP SIGNATURE-----


K
K
Kei Kebreau wrote on 27 May 2017 17:16
(name . Leo Famulari)(address . leo@famulari.name)(address . 27093@debbugs.gnu.org)
87d1aue3e2.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (11 lines)
> On Fri, May 26, 2017 at 11:23:03PM -0400, Kei Kebreau wrote:
>> * gnu/packages/gnome.scm (libgdata): New variable.
>
>> + (arguments
>> + '(#:configure-flags '("--disable-tests")
>> + #:tests? #f)) ; See
>> <https://bugzilla.gnome.org/show_bug.cgi?id=739956>.
>
> That bug report is a couple years old. Did they still not release the
> fix? Okay if not, I just want to clarify.

I found a follow-up commit that supposedly fixes the tests, so that
build is happening right now (the webkitgtk dependency will take a
while).
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkpmFUACgkQ5qXuPBlG
eg31vw//crRP5/27xDQeVginQR1Wyewm6Qd3UNWmrxsI3CS8TcuNauU+5qnKjcRQ
8QHrA6NHqHCA9yRDGJnvjvH8jy+nZvJ5DMEWojuGQOGNKmFRzLTN/jVVpL6pY0g6
qVrY8VgtSYNiSgE1L4CFdtgWVYFrz1aaSpNusu91KsK7BEOp39v5KpdDgTdWIjhR
IjAeowkQoiFlj1SJPXM4WXVww1wMESb3wbfryzJ45jE533q8bZwzvVmjEnCxG0lC
WJArsRVdITHKqjR2FWi+aTUTdmA2WTJDmJEcVqsEuKWbtv1jp9ChzIExvctmH/FA
25Bj+Hfmtb5IHr7fMFfDRa+IAX1lt1IlKu//6MzDs/kotyZeECoSbzSN/g2Unyzm
hFLO8TNz0fpeeSwjjDwKca8uhqNcK0J7kU4Rfw5yusNSkJK/wuNTFsIn/Nq3pUj6
ko7BcWPtpFwvI0tdGVjxE1G4Md2/zWnReYA0kzKkpQHE1eYlbBo3GRDzEVrGured
9a8O//3RdaWUX8F4sGOTYmlgjBThEshUzWsIbm58q7JCJlxZHjg7WmfKnl/A32Va
3tCBxVrNTLJCjvt8m7HA1FtCkspRWxA2t+gVtLjGRpCPenta8Zf+IydLa98WrhOB
fGrKgfAFmZs8+5M+cuzSmCwzWIsXJutCNutFxLfB9hy8+lTI3Wk=
=8q3d
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 27 May 2017 17:43
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27093@debbugs.gnu.org)
20170527154333.GB26953@jasmine
On Sat, May 27, 2017 at 11:16:37AM -0400, Kei Kebreau wrote:
Toggle quote (17 lines)
> Leo Famulari <leo@famulari.name> writes:
>
> > On Fri, May 26, 2017 at 11:23:03PM -0400, Kei Kebreau wrote:
> >> * gnu/packages/gnome.scm (libgdata): New variable.
> >
> >> + (arguments
> >> + '(#:configure-flags '("--disable-tests")
> >> + #:tests? #f)) ; See
> >> <https://bugzilla.gnome.org/show_bug.cgi?id=739956>.
> >
> > That bug report is a couple years old. Did they still not release the
> > fix? Okay if not, I just want to clarify.
>
> I found a follow-up commit that supposedly fixes the tests, so that
> build is happening right now (the webkitgtk dependency will take a
> while).

Thanks :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkpnqUACgkQJkb6MLrK
fwhusA/9HaypOP6buewFvV9litkbnwO+yRRMWgGRij3gk+UXatDC3rI0Qw4UhyK8
66uPj9p/4eKKbrkrnloK01AIIufN5PCtDNmYrX3OstGDccKgbGNWzphdKSchJmaL
yvKa7/dLWn1+HPI4uxCe60JeTkXNTXV6+5HmDclZgGWF4erWGx651fZSPsYHoCeY
M/KO9wWWmrZfW5qKuMcjiZ8EjvNmUq6aSi+XaQpUV0tOmUPCtb4gP7EVN+j2Gxv+
fxU09tcPbqhKTE5rLXNvsPPhPlmTe5rsxTI8R2FMYe3RkfBS9mRQuPRw113nwORW
+1rXQThlTdrNFsHslD0Z5+pUywowEGq5OoC2eFuXo31ydrUh3XHLbaxZiFfwtYai
jovxbcuGE1Z7UtCA6qHjeGKyPx8xZup1KzG1GOz7AP1ATnQ8fkX82FH1q+xRtrL8
ppqnKkeoQ6kC1e9+E4V6xNV/acFy81nfbPLAvzjPifoMIqF/q86wzmE9uzPw2Kig
r2YNx15FG+d7QDCKvT4pUrR2AMMz2Tvat+v70boxjHGpL7U3FMhKJcEzbAE1FEg7
9siB0I2WicWllUW2gNnZCXebuD42zjEGzGiNdVH6YkJhaguuvkuIzyBuUau3c5bT
+7/BtoDeD+sS1QiCeWgFFe28rlrW1HA20yIw3of+TgYj4JiKzsk=
=7U9L
-----END PGP SIGNATURE-----


K
K
Kei Kebreau wrote on 28 May 2017 02:34
(name . Leo Famulari)(address . leo@famulari.name)(address . 27093@debbugs.gnu.org)
87zidxddk7.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (20 lines)
> On Sat, May 27, 2017 at 11:16:37AM -0400, Kei Kebreau wrote:
>> Leo Famulari <leo@famulari.name> writes:
>>
>> > On Fri, May 26, 2017 at 11:23:03PM -0400, Kei Kebreau wrote:
>> >> * gnu/packages/gnome.scm (libgdata): New variable.
>> >
>> >> + (arguments
>> >> + '(#:configure-flags '("--disable-tests")
>> >> + #:tests? #f)) ; See
>> >> <https://bugzilla.gnome.org/show_bug.cgi?id=739956>.
>> >
>> > That bug report is a couple years old. Did they still not release the
>> > fix? Okay if not, I just want to clarify.
>>
>> I found a follow-up commit that supposedly fixes the tests, so that
>> build is happening right now (the webkitgtk dependency will take a
>> while).
>
> Thanks :)

All tests should be running properly now!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkqGxkACgkQ5qXuPBlG
eg2+2Q//QCe2zIBgPviJUABUIunh68iLtWbwwWeY7kL2pwOI5LB+W/4td2uKVzaz
w1gpdPbbKM0ckRfSNy5+H4jWmojyaNeUBUY7arBG445uQMzOFsuh35F/t6vsjnkU
g09ye5hCSZtDlV6LTExsQd43WhdchHycZ30rhKcmVVkoNffwUu5BiZCLJFq5PYnE
TLqlaK1+92pNlu1P4LP/FFTIrmpGtkzExkXLmKgUlUbul35DTq9mQwjzf/OLSMIr
zr4jqyDcXHmmiUslKJNcLQJlTTuB7VldS8El3Y0c6lvdsGwytRU0njhqLjWQWIWd
pjXNkvoktkO7khEea8GxO3E1O1JLGas43B83dxZs2pAiqW+d3AxcjEeDPFBLak1K
vSUkvOj2W2QfVJLAJ0b6JBGLFV4bgYxDE37wzl/QSPCIpyIewe5IvKF26qYosLE+
uE2hMIyyToIPOmr0NI+JnCfpdskihBnfDDsgOrcHBV0b1BmCffD3wgRqPrNDMLFz
FBeq3GOo3aF8yctGRGvMUf/uuRAD09XIdOFWkLfPrJ5N44d2AYqfbiwishBP8n0C
lminte6ihEBoo6BSaUHWFqt85gPPSwTEG6DxPjGWINFKHaUXxDrVXOVIjRq+36fv
7G1vxlLFJ7eEWsIG+fZD8FXKIJlibVLYN+93PRJv0dF2jYzr/EA=
=K4K7
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 30 May 2017 22:49
(name . Kei Kebreau)(address . kei@openmailbox.org)
87vaoi2hqb.fsf@elephly.net
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (11 lines)
> All tests should be running properly now!
> From 2f4aa38aad8630818caee04c7d769a66488967b3 Mon Sep 17 00:00:00 2001
> From: Kei Kebreau <kei@openmailbox.org>
> Date: Fri, 26 May 2017 01:13:23 -0400
> Subject: [PATCH 2/3] gnu: Add libgdata.
>
> * gnu/packages/gnome.scm (libgdata): New variable.
> * gnu/packages/patches/libgdata-fix-tests.patch,
> gnu/packages/patches/libgdata-glib-duplicate-tests.patch: New files.
> * gnu/local.mk (dist_patch_DATA): Add them.

I wanted to commit this just now but noticed that it depends on
liboauth, which is unavailable. Did you forget to submit that patch?

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 30 May 2017 23:04
control message for bug #27093
(address . control@debbugs.gnu.org)
E1dFoK4-0005WZ-Jh@debbugs.gnu.org
tags 27093 moreinfo
K
K
Kei Kebreau wrote on 30 May 2017 23:06
Re: bug#27093: [PATCH 2/3] gnu: Add libgdata.
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87poeqm4v7.fsf@openmailbox.org
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (17 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> All tests should be running properly now!
>> From 2f4aa38aad8630818caee04c7d769a66488967b3 Mon Sep 17 00:00:00 2001
>> From: Kei Kebreau <kei@openmailbox.org>
>> Date: Fri, 26 May 2017 01:13:23 -0400
>> Subject: [PATCH 2/3] gnu: Add libgdata.
>>
>> * gnu/packages/gnome.scm (libgdata): New variable.
>> * gnu/packages/patches/libgdata-fix-tests.patch,
>> gnu/packages/patches/libgdata-glib-duplicate-tests.patch: New files.
>> * gnu/local.mk (dist_patch_DATA): Add them.
>
> I wanted to commit this just now but noticed that it depends on
> liboauth, which is unavailable. Did you forget to submit that patch?
>

I'm fairly sure I submitted it, as I remember it being
reviewed. Regardless, I've already commited these to the staging
branch.

Toggle quote (5 lines)
> --
> Ricardo
>
> GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
> https://elephly.net
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkt3twACgkQ5qXuPBlG
eg0tvQ//RS4rtPBPvb2SIoVIuj68reQPFzWVPtZeFU9iFpW7CmS3CRAVdPG2NryL
EKJE0vo1gfOfS2raehDlpF5OclgSJLgxkb4fhRMYq3VXn5go+FJXmiFMYTjbkkBr
wZcUO9ZAMQxPmKm4LmliRJxDKkyGpw3cb5+CgVT98frAFvCVwVXTpjJ1khET00nW
n3luE37x/UBpIB8mDICVKG+8NUXAPCSFoKlexB3L5os9T6JJXdlON2EOa9cODUZA
tp84Zzq6I3Mgwt14vLdRGk1m1bYzfoTXvi51m8LH8SVXrDXVozYZ74FaGaLenlbj
4h+RVqoEWknOp3VdIn0EpS4PDgjZiaJeFc5J7xsna2h36JudX1kp9/hMokalP3iQ
vMC6yhUTy2rbzyxsy+bMdKodm2XkUlCs4Y3jQ5EVHPMorLRUfAMzGMHu7Jmqbhrq
7OTWnn7kuYKBtoqak3jBy94EGvjDsmbwOpCLTBbDfLtIQVESAuxwqZM3iOG2xk94
99WkEOqnDC81ZtFQPrVKiAvNA8wVK88DC39fYlXE13Z6xXi3M4SLYxPdnrJCJAJY
dc/L32GhKSzFpjN7oM4oO4p5lJnKTKTyFpuZq+8+fQrbJwfBBDPrmFAMTwgy8Y2H
6TrMZbxSAtS/hsc7S/3sU2rPoHKtQ0WbY3s6z7mppJTn6Yw0rv0=
=+wn6
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 31 May 2017 08:19
(name . Kei Kebreau)(address . kei@openmailbox.org)
87efv535wl.fsf@elephly.net
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (23 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> All tests should be running properly now!
>>> From 2f4aa38aad8630818caee04c7d769a66488967b3 Mon Sep 17 00:00:00 2001
>>> From: Kei Kebreau <kei@openmailbox.org>
>>> Date: Fri, 26 May 2017 01:13:23 -0400
>>> Subject: [PATCH 2/3] gnu: Add libgdata.
>>>
>>> * gnu/packages/gnome.scm (libgdata): New variable.
>>> * gnu/packages/patches/libgdata-fix-tests.patch,
>>> gnu/packages/patches/libgdata-glib-duplicate-tests.patch: New files.
>>> * gnu/local.mk (dist_patch_DATA): Add them.
>>
>> I wanted to commit this just now but noticed that it depends on
>> liboauth, which is unavailable. Did you forget to submit that patch?
>>
>
> I'm fairly sure I submitted it, as I remember it being
> reviewed. Regardless, I've already commited these to the staging
> branch.

Ah, staging. Well in that case I’ll close this bug (and the third of
this series). Sending email to 27093-done@debbugs.gnu.org. Maybe I
didn’t see it because only the first of this series was closed.

I find it helpful to submit a cover letter first, wait for debbugs to
acknowledge it, and then send the patch set to the assigned bug email
address. This way they all stay together.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27093@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27093
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch