[PATCH 1/3] gnu: Add liboauth.

  • Done
  • quality assurance status badge
Details
4 participants
  • Kei Kebreau
  • Leo Famulari
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170527032304.22189-1-kei@openmailbox.org
* gnu/packages/web.scm (liboauth): New variable.
---
gnu/packages/web.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index bcc20bfdd..ea4ad9b31 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,6 +69,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnu-doc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
@@ -708,6 +710,34 @@ modifying pages and incoming and outgoing headers, monitoring pages for
changes, and much more.")
(license l:gpl2+)))
+(define-public liboauth
+ (package
+ (name "liboauth")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/liboauth/liboauth-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "07w1aq8y8wld43wmbk2q8134p3bfkp2vma78mmsfgw2jn1bh3xhd"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags '("--enable-nss")))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("curl" ,curl)
+ ("nss" ,nss)))
+ (home-page "https://sourceforge.net/projects/liboauth")
+ (synopsis "C library implementing the http://oauth.net API")
+ (description
+ "liboauth is a collection of c functions implementing the http://oauth.net
+API. liboauth provides functions to escape and encode stings according to
+OAuth specifications and offers high-level functionality built on top to sign
+requests or verify signatures using either NSS or OpenSSL for calculating the
+hash/signatures.")
+ ;; Source code may be distributed under either license.
+ (license (list l:expat l:gpl2+))))
+
(define-public libyaml
(package
(name "libyaml")
--
2.13.0
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27092@debbugs.gnu.org)
20170527135650.GC1387@jasmine
On Fri, May 26, 2017 at 11:23:02PM -0400, Kei Kebreau wrote:
Toggle quote (4 lines)
> * gnu/packages/web.scm (liboauth): New variable.

> + "liboauth is a collection of c functions implementing the http://oauth.net

s/c/C

Otherwise LGTM!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkphZ4ACgkQJkb6MLrK
fwhqaw//Rmy+RMkOn7hYn78Z3wltTXva73Ffo/aJ/JrnbYgeMfq5vtQ/iaIOeEl3
iGxCIIQZEuXXDjrC5BlWOjwwR7bGe9pBoyYFQ/MW3zbW5g8c2pfZL6R0KDxtr2vX
OLzpyEaVQRyyPVl/i9o3HZQ6nmYWHONcAZgAQq+vvIEeX956I9+NxpxvmoR7TX09
ajMyqvkpc0APVt6RztkL1s3oKF5IuyMHvkOE7cyRC82TRdDvYl9Oh+tRGAc4Zu7q
kU2hvSiPMfi36Kr5I6fuGsoE9/wtKKu8luv9x/VmWJGY70YyJCBtVm6MNaUsFoJM
Ryf7sBaHPypXjlnFQMmC4eSfrjobJC7A+srTgcAjCdscLHsqIwAvlQQbzqOsgpfA
sodfXH9Peg8Ei6z8TWZc5vaHOKNymZv/s06TX/rMHjvtZvEnOUVWmiinc9gjl1ze
cVmEpvAPEAbZFa2HtCZhUI2iNbShAfhPk5Dmbyhx9QuZ8V7VHq/KmG1KJJGn6dK4
766G6LD9CgTOYXCY8IM9FQ/m706BGz0hCOn8nGMRAWnEFPyxKSNcWW9HCpQiqjRr
+G5nvJX5kRQryrD7qRho2KOhGAd4mgxLiR7bthTQg9luZFOxcoXruD4o0TQqafB1
gG44gPIR5dvghd7ljrcpe6UUjWUqrE+9rHKAGoFei+sA1QpsC+U=
=z7TN
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27092-done@debbugs.gnu.org)
87vaolddj4.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (10 lines)
> On Fri, May 26, 2017 at 11:23:02PM -0400, Kei Kebreau wrote:
>> * gnu/packages/web.scm (liboauth): New variable.
>
>> + "liboauth is a collection of c functions implementing the
>> http://oauth.net
>
> s/c/C
>
> Otherwise LGTM!

Thanks! Pushed to staging as 1622637bb74d03cd3070ce14195252ead032d99d.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkqGz8ACgkQ5qXuPBlG
eg2lng/9E5CZ9v1qx8yqyQMfu56JpLIeRGY5D8rTDYx5WTYt2VYya0Z6m4ilEdpL
KDwm+h8Y6mCoQhwFVBQQxMvJ6Sq44I935bZDOsJnnY8Hnn5+O6tBLbaEws2M0CH+
YHX+elWVS7a48KF7uPqP+G3FNJgjZAJeB//4OFFS49cjdTdNWRzibRaBkFRQ3l30
ULRwOBj2L9t7wClyPiJXOFf0IvYOYH0/GmrvPn/EXGk437buenif6gg1ao6MHGyk
1ZAUZ2MGRwAbTo8UdpsefcwlR5G8Ds+00NXH51KAgJRHYZmsTMPec3VYAZhSpKkx
K6eWKYMxcgK2ued/41+GbaZ+lc1h0R28PpceF6XixZTopRwlxYPi8lS+y3RzOX/9
coOIzOsH7MXAF/t6X/m3s88UNOxQ7H9KZ1z+Oi6B99KMf5gs4wypyXjbJQzQrIuz
/p8fUOcrDgPb7QW8iTa96eUl7wesObwevz3uuHwKQfB6n0BcBD/7vbMzXxwYSEJn
FH4biTqfRt85EAsVqrLLQvM1t1+YpMd7AKEzoicDmnr4+dbcjfYZUm9pvReMH3Y6
KGsYvAIcCLir/2Hs7WJOqtfVVYDf7TiTbWgtFmRw7m6ltfaOwJ5D5lJKsYwJvjDu
GSic07W8mIWzgZupBBH2cUrda5zMYdEEBRPCo9C7zoFplf7L/I4=
=cjrB
-----END PGP SIGNATURE-----

Closed
Marius Bakke wrote 8 years ago
(address . 27092-done@debbugs.gnu.org)
874lw4fur2.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (14 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Fri, May 26, 2017 at 11:23:02PM -0400, Kei Kebreau wrote:
>>> * gnu/packages/web.scm (liboauth): New variable.
>>
>>> + "liboauth is a collection of c functions implementing the
>>> http://oauth.net
>>
>> s/c/C
>>
>> Otherwise LGTM!
>
> Thanks! Pushed to staging as 1622637bb74d03cd3070ce14195252ead032d99d.

This push only included "liboauth". Was there anything holding back the
two other patches?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkrV5EACgkQoqBt8qM6
VPoqzwgAq3o1/XWbO4/TOrOz/qJvfobcgsl13xkurA/tKY0MzF3k0O8l7GN5ZLI/
zS1yMa+v9VciOCt+SSTiY6lDMI+1Dp+k1uXoitMfImHdRcTHpD7tVfw0VjKecfJl
cC8iGoaU5PASRtsAyExi47PCB3VbupWJ4BkoP8sg5yK5hKvoAvQ9kWI2ZjL6tVqH
yO681yfJX6pzzArpw3ittfRo0tmXHLw2uFYDK6mudIwrWS8ezvofAmnsYrKgt2rZ
Vjv+ShmZuuD6lSzfZoywVn4Y22uyZXba3Uh3FoFWWWGLT2bzdsERtc3uNqIAWdM2
4Mqbj96H7HevBNxHaI4wbNWvEDSSTg==
=Ncxn
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27092@debbugs.gnu.org)
877f0xdt8a.fsf@gnu.org
Hi!

Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/web.scm (liboauth): New variable.

[...]

Toggle quote (3 lines)
> + (synopsis "C library implementing the http://oauth.net API")

Maybe replace the URL with “OAuth”?

Toggle quote (3 lines)
> + "liboauth is a collection of c functions implementing the http://oauth.net
> +API.

Likewise: @uref{http://oauth.net,OAuth}.

Toggle quote (2 lines)
> liboauth provides functions to escape and encode stings according to

Typo: “strings”.

Toggle quote (4 lines)
> +OAuth specifications and offers high-level functionality built on top to sign
> +requests or verify signatures using either NSS or OpenSSL for calculating the
> +hash/signatures.")

I would omit “using either …” since our package uses just one of them
anyway (and it’s an implementation detail).

OK with these changes, thanks!

Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27092@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27092
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help