Hi Marius,
thanks for the review.
On Thu, 25 May 2017 21:02:13 +0200
Marius Bakke <mbakke@fastmail.com> wrote:
I guess not with tests disabled.
I'll keep trying to get it to work including the tests, but so far that requires the following new packages we didn't have:
- python-jsonpointer
- python-rfc3987
- python-validate-email
- python-flex
It also requires new native-inputs, finally ending up with:
(define-public python-flasgger
(package
(name "python-flasgger")
(version "0.6.3")
(source
(origin
(method url-fetch)
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"1gqzlm0rb55fdpsy5ipkganlx9cnpi454fqyycr03jm22zql14ay"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "Makefile"
(("flake8 flasgger --ignore=F403")
"flake8 flasgger --ignore=E731,F403"))
(setenv "PYTHONPATH" (string-append (getcwd)
":"
(getenv "PYTHONPATH")))
;(zero? (system* "py.test"))
(zero? (system* "make" "test"))
;#t
)))))
(propagated-inputs
`(("python-flask" ,python-flask)
("python-pyyaml" ,python-pyyaml)
("python-jsonschema" ,python-jsonschema)
("python-mistune" ,python-mistune)
("python-six" ,python-six)))
(native-inputs
`(("python-decorator" ,python-decorator)
("python-flake8" ,python-flake8)
("python-flask-restful" ,python-flask-restful)
("python-flex" ,python-flex)
("python-pytest-3.0" ,python-pytest-3.0)
("python-pytest-cov" ,python-pytest-cov)))
(synopsis "Extract Swagger specs from your Flask project")
(description "This package allows extracting Swagger specs from your Flask
project. It is a fork of Flask-Swagger.")
(license license:expat)))
And then the tests finally run and fail.
Let's wait for a few days whether there's an easy fix from upstream. If not, we can still commit it with the tests disabled (ugh).