[PATCH 0/3] Add flask-script, flask-migrate, flasgger.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170525175150.1425-1-dannym@scratchpost.org
Danny Milosavljevic (3):
gnu: Add python-flask-script.
gnu: Add python-flask-migrate.
gnu: Add python-flasgger.

gnu/packages/python.scm | 87 +++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 87 insertions(+)
Danny Milosavljevic wrote 8 years ago
[PATCH 1/3] gnu: Add python-flask-script.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170525175722.1814-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-flask-script,
python2-flask-script): New variables.
---
gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 62fada66a..3bb183084 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14676,3 +14676,30 @@ JSON APIs with Behave.")
(define-public python2-behave-web-api
(package-with-python2 python-behave-web-api))
+
+(define-public python-flask-script
+ (package
+ (name "python-flask-script")
+ (version "2.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Script" version))
+ (sha256
+ (base32
+ "0zqh2yq8zk7m9b4xw1ryqmrljkdigfb3hk5155a3b5hkfnn6xxyf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-argcomplete" ,python-argcomplete)
+ ("python-werkzeug" ,python-werkzeug)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page
+ "http://github.com/smurfix/flask-script")
+ (synopsis "Scripting support for Flask")
+ (description "This package supports scripting in @code{python-flask}.")
+ (license license:bsd-3)))
+
+(define-public python2-flask-script
+ (package-with-python2 python-flask-script))
Danny Milosavljevic wrote 8 years ago
[PATCH 2/3] gnu: Add python-flask-migrate.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170525175722.1814-2-dannym@scratchpost.org
* gnu/packages/python.scm (python-flask-migrate,
python2-flask-migrate): New variables.
---
gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3bb183084..dc87e9738 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14703,3 +14703,31 @@ JSON APIs with Behave.")
(define-public python2-flask-script
(package-with-python2 python-flask-script))
+
+(define-public python-flask-migrate
+ (package
+ (name "python-flask-migrate")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Migrate" version))
+ (sha256
+ (base32
+ "107x78lkqsnbg92dld3dkagg07jvchp3ib3y0sivc4ipz6n1y7rk"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-alembic" ,python-alembic)
+ ("python-sqlalchemy" ,python-sqlalchemy)
+ ("python-flask-script" ,python-flask-script)
+ ("python-flask-sqlalchemy" ,python-flask-sqlalchemy)))
+ (home-page "http://github.com/miguelgrinberg/flask-migrate/")
+ (synopsis "SQLAlchemy database migrations for Flask programs using
+Alembic")
+ (description "This package contains SQLAlchemy database migration tools
+for Flask programs that are using @code{python-alembic}.")
+ (license license:expat)))
+
+(define-public python2-flask-migrate
+ (package-with-python2 python-flask-migrate))
Danny Milosavljevic wrote 8 years ago
[PATCH 3/3] gnu: Add python-flasgger.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170525175722.1814-3-dannym@scratchpost.org
* gnu/packages/python.scm (python-flasgger,
python2-flasgger): New variables.
---
gnu/packages/python.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dc87e9738..b93479d37 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14731,3 +14731,35 @@ for Flask programs that are using @code{python-alembic}.")
(define-public python2-flask-migrate
(package-with-python2 python-flask-migrate))
+
+(define-public python-flasgger
+ (package
+ (name "python-flasgger")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flasgger" version))
+ (sha256
+ (base32
+ "0983v8s8fyarlpk7h9nvha6wys0fbzacwkkaickn2jqhv66wh9c6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-mistune" ,python-mistune)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/rochacbruno/flasgger/")
+ (synopsis "Extract Swagger specs from your Flask project")
+ (description "This package allows extracting Swagger (documentation)
+specs from your Flask project and providing an @code{/apidocs/} endpoint
+in order to view them. It is a fork of Flask-Swagger.")
+ (license license:expat)))
+
+(define-public python2-flasgger
+ (package-with-python2 python-flasgger))
Marius Bakke wrote 8 years ago
Re: bug#27071: [PATCH 1/3] gnu: Add python-flask-script.
87lgpkvk1f.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-flask-script,
> python2-flask-script): New variables.

[...]

Toggle quote (3 lines)
> + (home-page
> + "http://github.com/smurfix/flask-script")

This line break seems unnecessary.

Toggle quote (2 lines)
> + (description "This package supports scripting in @code{python-flask}.")

Can you add a little more information here? What exactly does this
package provide? Why would I want it? The first paragraph here seems
like a much better starting point, but feel free to expand on it:


LGTM with a more useful description!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlknKcwACgkQoqBt8qM6
VPorAAf/TSsloqGMFA1u9EleLvMosSKTuNnUksdi04zkGoAY17qsa7lRD+njUZtD
HYuyc7Oxq+ESlQhSkGyxL6KYXzmSZVfBwSt4t1PewidC2DEi69NOPwE5SFG5PvPk
1gKjC+Jxhjo7R+fJH8HT0wrLc0C/CJqziZl/+0nE5WFLN5j3DA/8+kSMtWEB60fl
JDzHBwGrnB1braD5c1VCPxH25N0epxer0VfjsCnq7i2dh/WkU421mdZQY4KtE4mC
UrHIZEYs6W1lD8X2O4ul4VyWIPjWTwctEs2sizTn+UOEEdO6UEUEAMHkoTvBLfqW
Jbedq7GgwTQAq0F9S96CiR2ERAhftA==
=xZm6
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#27071: [PATCH 2/3] gnu: Add python-flask-migrate.
87inkovk0q.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-flask-migrate,
> python2-flask-migrate): New variables.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlknKeYACgkQoqBt8qM6
VPruKQgAgSnPIT7eHFWDnD6/UiJK0uwFNtcjE5dHjCmPzB8FNx8wn4G5JOSHNHIO
P3fc2dwxRHhovDB/Ba0jNoVq4hIj5NkobKYJWxPrJvwqWQVTqjkbFG+Lg2JxrBKK
aai8j/AsL0oRytxTB/ePsxOiTcoH1FxfO4tKmOl1WVa/S8goHMOta/95PqViaoJj
u9Zusb5tJmsnBUEsp5tgdLZghqSQjIqe3PAe3J5cPEG6kw1HZ/+N1Z2DF++nJw4u
RykaJOJh6ooViYYAb6kR+ykKhBzMiGHDNtAAvI+/JJYWYaUifk457XfTfhOQWayY
JFCVVs7BazzhVTFqdysxEfvi/cKbuw==
=G6+H
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#27071: [PATCH 3/3] gnu: Add python-flasgger.
87fufsvjyi.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-flasgger,
> python2-flasgger): New variables.

[...]

Toggle quote (4 lines)
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f))

Please add a comment about why tests are disabled. Especially since
pytest is a native-input. Should it be? The rest LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlknKjUACgkQoqBt8qM6
VPr+0wgAgOhi6qt/B9N8tlUQBQ4TYl73BkN55F2byBR3zdOO5+4IWswlXZcL9o+n
V5REKFfyqHH7Yrmq1Ig1ydd4Qg8HIXtwQKhVymrZI+BoLe1UHb8Fen1oYsD/DU+h
J43XxsyG8uafi44iYC5lViSyYsAt2AVaKlGbVIC7fq84BeTS5xjcbYt/CK+IKmLb
t1NelO/8MkH3+MxTG0qxy+l7FYPGJ4EWv/d+IvnU6xC1GOmNOUWeXnUAPYFF3iFK
duaXP/MHszxhi3maQIOUl+QcoR+BPWqfAVOdGcgYiOeMRK6O1t9G9wBq3DxWjur2
yT8Yib4Dqz7E6Rw3vhK5KEvSHd5Cyw==
=xpFw
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 27071@debbugs.gnu.org)
20170527155446.1b8c0f14@scratchpost.org
Hi Marius,

thanks for the review.

On Thu, 25 May 2017 21:02:13 +0200
Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (13 lines)
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
> > * gnu/packages/python.scm (python-flasgger,
> > python2-flasgger): New variables.
>
> [...]
>
> > + (build-system python-build-system)
> > + (arguments
> > + `(#:tests? #f))
>
> Please add a comment about why tests are disabled.

Because they don't work. I've reported it upstream at https://github.com/rochacbruno/flasgger/issues/105.

Toggle quote (3 lines)
> Especially since
> pytest is a native-input. Should it be?

I guess not with tests disabled.

I'll keep trying to get it to work including the tests, but so far that requires the following new packages we didn't have:
- python-jsonpointer
- python-rfc3987
- python-validate-email
- python-flex

It also requires new native-inputs, finally ending up with:

(define-public python-flasgger
(package
(name "python-flasgger")
(version "0.6.3")
(source
(origin
(method url-fetch)
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"1gqzlm0rb55fdpsy5ipkganlx9cnpi454fqyycr03jm22zql14ay"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "Makefile"
(("flake8 flasgger --ignore=F403")
"flake8 flasgger --ignore=E731,F403"))
(setenv "PYTHONPATH" (string-append (getcwd)
":"
(getenv "PYTHONPATH")))
;(zero? (system* "py.test"))
(zero? (system* "make" "test"))
;#t
)))))
(propagated-inputs
`(("python-flask" ,python-flask)
("python-pyyaml" ,python-pyyaml)
("python-jsonschema" ,python-jsonschema)
("python-mistune" ,python-mistune)
("python-six" ,python-six)))
(native-inputs
`(("python-decorator" ,python-decorator)
("python-flake8" ,python-flake8)
("python-flask-restful" ,python-flask-restful)
("python-flex" ,python-flex)
("python-pytest-3.0" ,python-pytest-3.0)
("python-pytest-cov" ,python-pytest-cov)))
(synopsis "Extract Swagger specs from your Flask project")
(description "This package allows extracting Swagger specs from your Flask
project. It is a fork of Flask-Swagger.")
(license license:expat)))

And then the tests finally run and fail.

Let's wait for a few days whether there's an easy fix from upstream. If not, we can still commit it with the tests disabled (ugh).
Danny Milosavljevic wrote 8 years ago
[PATCH v2 0/8] Add python-flasgger and its dependencies.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-1-dannym@scratchpost.org
Danny Milosavljevic (8):
gnu: Add python-jsonpointer.
gnu: Add python-rfc3987.
gnu: Add python-validate-email.
gnu: Add python-flex.
gnu: Add python-marshmallow.
gnu: Add python-bottle.
gnu: Add python-apispec.
gnu: Add python-flasgger.

gnu/packages/python.scm | 221 ++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 221 insertions(+)
Danny Milosavljevic wrote 8 years ago
[PATCH v2 1/8] gnu: Add python-jsonpointer.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-2-dannym@scratchpost.org
* gnu/packages/python.scm (python-jsonpointer, python2-jsonpointer):
New variables.
---
gnu/packages/python.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7617490bd..621443e2f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14926,3 +14926,24 @@ Supported metrics are:
(define-public python2-radon
(package-with-python2 python-radon))
+
+(define-public python-jsonpointer
+ (package
+ (name "python-jsonpointer")
+ (version "1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonpointer" version))
+ (sha256
+ (base32
+ "1cg0gvgqjysydv6p45v4jywg1jb3v48c7m3cbpi57zgf6nndr9cz"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/stefankoegl/python-json-pointer")
+ (synopsis "Identify specific nodes in a JSON document")
+ (description "@code{jsonpointer} allows you to access specific nodes
+by path in a JSON document (see RFC 6901).")
+ (license license:bsd-3)))
+
+(define-public python2-jsonpointer
+ (package-with-python2 python-jsonpointer))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 2/8] gnu: Add python-rfc3987.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-3-dannym@scratchpost.org
* gnu/packages/python.scm (python-rfc3987, python2-rfc3987): New variables.
---
gnu/packages/python.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 621443e2f..98d114301 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14947,3 +14947,24 @@ by path in a JSON document (see RFC 6901).")
(define-public python2-jsonpointer
(package-with-python2 python-jsonpointer))
+
+(define-public python-rfc3987
+ (package
+ (name "python-rfc3987")
+ (version "1.3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rfc3987" version))
+ (sha256
+ (base32
+ "192pclzs2y0yaywqkrlvd0x73740q310kvqvm6jldhi619mq59wi"))))
+ (build-system python-build-system)
+ (home-page "http://pypi.python.org/pypi/rfc3987")
+ (synopsis "Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)")
+ (description "@code{rfc3987} provides routines for parsing and
+validation of URIs (see RFC 3986) and IRIs (see RFC 3987).")
+ (license license:gpl3+)))
+
+(define-public python2-rfc3987
+ (package-with-python2 python-rfc3987))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 3/8] gnu: Add python-validate-email.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-4-dannym@scratchpost.org
* gnu/packages/python.scm (python-validate-email, python2-validate-email):
New variables.
---
gnu/packages/python.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 98d114301..acd579791 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14968,3 +14968,24 @@ validation of URIs (see RFC 3986) and IRIs (see RFC 3987).")
(define-public python2-rfc3987
(package-with-python2 python-rfc3987))
+
+(define-public python-validate-email
+ (package
+ (name "python-validate-email")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "validate_email" version))
+ (sha256
+ (base32
+ "1bxffaf5yz2cph8ki55vdvdypbwkvn2xr1firlcy62vqbzf1jivq"))))
+ (build-system python-build-system)
+ (home-page "http://github.com/syrusakbary/validate_email")
+ (synopsis "Verifies if an email address is valid and really exists")
+ (description "@code{validate_email} can be used to verify if an email
+address is valid and really exists.")
+ (license license:lgpl3+)))
+
+(define-public python2-validate-email
+ (package-with-python2 python-validate-email))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 4/8] gnu: Add python-flex.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-5-dannym@scratchpost.org
* gnu/packages/python.scm (python-flex, python2-flex): New variables.
---
gnu/packages/python.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index acd579791..be4ca2dd6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14989,3 +14989,32 @@ address is valid and really exists.")
(define-public python2-validate-email
(package-with-python2 python-validate-email))
+
+(define-public python-flex
+ (package
+ (name "python-flex")
+ (version "6.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flex" version))
+ (sha256
+ (base32
+ "00pamnwla3khk8nyla7y28dq9jnh69swd7f4jfsl7sn1izs8n8zk"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-iso8601" ,python-iso8601)
+ ("python-jsonpointer" ,python-jsonpointer)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-rfc3987" ,python-rfc3987)
+ ("python-six" ,python-six)
+ ("python-validate-email" ,python-validate-email)))
+ (home-page "https://github.com/pipermerriam/flex")
+ (synopsis "Validates Swagger schemata")
+ (description "@code{flex} can be used to validate Swagger schemata.")
+ (license license:bsd-3)))
+
+(define-public python2-flex
+ (package-with-python2 python-flex))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 5/8] gnu: Add python-marshmallow.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-6-dannym@scratchpost.org
* gnu/packages/python.scm (python-marshmallow, python2-marshmallow):
New variables.
---
gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index be4ca2dd6..7b82a301a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15018,3 +15018,31 @@ address is valid and really exists.")
(define-public python2-flex
(package-with-python2 python-flex))
+
+(define-public python-marshmallow
+ (package
+ (name "python-marshmallow")
+ (version "3.0.0b2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow" version))
+ (sha256
+ (base32
+ "11bnpvfdbczr74177p295zbkdrax2cahvbj5bqhhlprgz2xxi5d9"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-simplejson" ,python-simplejson)))
+ (native-inputs
+ `(("python-pytest-3.0" ,python-pytest-3.0)
+ ("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/marshmallow-code/marshmallow")
+ (synopsis "Convert complex datatypes to and from native
+Python datatypes.")
+ (description "@code{marshmallow} provides a library for converting
+complex datatypes to and from native Python datatypes.")
+ (license license:expat)))
+
+(define-public python2-marshmallow
+ (package-with-python2 python-marshmallow))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 6/8] gnu: Add python-bottle.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-7-dannym@scratchpost.org
* gnu/packages/python.scm (python-bottle, python2-bottle): New variables.
---
gnu/packages/python.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7b82a301a..cbc8650b4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15046,3 +15046,23 @@ complex datatypes to and from native Python datatypes.")
(define-public python2-marshmallow
(package-with-python2 python-marshmallow))
+
+(define-public python-bottle
+ (package
+ (name "python-bottle")
+ (version "0.12.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bottle" version))
+ (sha256
+ (base32
+ "0m9k2a7yxvggc4kw8fsvj381vgsvfcdshg5nzy6vwrxiw2p53drr"))))
+ (build-system python-build-system)
+ (home-page "http://bottlepy.org/")
+ (synopsis "WSGI framework for small web-applications.")
+ (description "@code{python-bottle} is a WSGI framework for small web-applications.")
+ (license license:expat)))
+
+(define-public python2-bottle
+ (package-with-python2 python-bottle))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 7/8] gnu: Add python-apispec.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-8-dannym@scratchpost.org
* gnu/packages/python.scm (python-apispec, python2-apispec): New variables.
---
gnu/packages/python.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cbc8650b4..243637881 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15066,3 +15066,34 @@ complex datatypes to and from native Python datatypes.")
(define-public python2-bottle
(package-with-python2 python-bottle))
+
+(define-public python-apispec
+ (package
+ (name "python-apispec")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "apispec" version))
+ (sha256
+ (base32
+ "0y3jxmgp2d24am3hxl40f5rw9abb0r8037sagax3dv64h4n1azwq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyyaml" ,python-pyyaml)))
+ (native-inputs
+ `(("python-pytest-3.0" ,python-pytest-3.0)
+ ("python-flask" ,python-flask)
+ ("python-marshmallow" ,python-marshmallow)
+ ("python-tornado" ,python-tornado)
+ ("python-bottle" ,python-bottle)
+ ("python-mock" ,python-mock)))
+ (home-page "https://github.com/marshmallow-code/apispec")
+ (synopsis "Swagger 2.0 API specification generator")
+ (description "@code{python-apispec} is a pluggable API specification
+generator. Currently supports the OpenAPI specification (f.k.a.
+Swagger 2.0).")
+ (license license:expat)))
+
+(define-public python2-apispec
+ (package-with-python2 python-apispec))
Danny Milosavljevic wrote 8 years ago
[PATCH v2 8/8] gnu: Add python-flasgger.
(address . 27071@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170603062216.13375-9-dannym@scratchpost.org
* gnu/packages/python.scm (python-flasgger, python2-flasgger): New variables.
---
gnu/packages/python.scm | 50 +++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 243637881..20d223f77 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15097,3 +15097,53 @@ Swagger 2.0).")
(define-public python2-apispec
(package-with-python2 python-apispec))
+
+(define-public python-flasgger
+ (package
+ (name "python-flasgger")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rochacbruno/flasgger/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gqzlm0rb55fdpsy5ipkganlx9cnpi454fqyycr03jm22zql14ay"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("flake8 flasgger --ignore=F403")
+ "flake8 flasgger --ignore=E731,F403"))
+ (setenv "PYTHONPATH" (string-append (getcwd)
+ ":"
+ (getenv "PYTHONPATH")))
+ (zero? (system* "py.test")))))))
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-mistune" ,python-mistune)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-decorator" ,python-decorator)
+ ("python-flake8" ,python-flake8)
+ ("python-flask-restful" ,python-flask-restful)
+ ("python-flex" ,python-flex)
+ ("python-pytest-3.0" ,python-pytest-3.0)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-marshmallow" ,python-marshmallow)
+ ("python-apispec" ,python-apispec)))
+ (home-page "https://github.com/rochacbruno/flasgger/")
+ (synopsis "Extract Swagger specs from your Flask project")
+ (description "@code{python-flasgger} allows extracting Swagger specs
+from your Flask project. It is a fork of Flask-Swagger.")
+ (license license:expat)))
+
+(define-public python2-flasgger
+ (package-with-python2 python-flasgger))
Marius Bakke wrote 8 years ago
Re: bug#27071: [PATCH v2 0/8] Add python-flasgger and its dependencies.
87h8zwymxk.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (10 lines)
> Danny Milosavljevic (8):
> gnu: Add python-jsonpointer.
> gnu: Add python-rfc3987.
> gnu: Add python-validate-email.
> gnu: Add python-flex.
> gnu: Add python-marshmallow.
> gnu: Add python-bottle.
> gnu: Add python-apispec.
> gnu: Add python-flasgger.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkz+GcACgkQoqBt8qM6
VPob0Qf+OUj+/WZloGJRukMHGkepnlSzs2bdkSrvUEv/WYzz2xhyRxDiKsSaJ7Ra
G+dHRhv3QNa3ZNibD5AqlLH3Eh+hmJ6DDtU6k86GFfgqEspvm8un0e26g3ipDepj
SjlrcJ+6s0sACd2tPEmXxitjbnw8TpQo6uMpKS8GTCbn8HVrUDVPEKtBg+1Gf+VY
EOgJrTSbRLeHVb5LJ3u0euyQo3Ve8aVJH9jQ8y9g89uqVNbrsQO6yKJ/lK63iJvA
6Vf/F+hI31e/Iy2+wkttnlc2qu6PgvaW5NWA3EYB9WJaMJB11rmxyMDXJ5FztdSh
aaUdaXB1VImjKgBSYjeDNfLQora4mA==
=krX0
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170604154336.03c6b5c0@scratchpost.org
close 27071
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27071@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27071
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help