[PATCH] gnu: gjs: Update to 1.48.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170524155511.16621-1-kei@openmailbox.org
* gnu/packages/gnome.scm (gjs): Update to 1.48.3.
[source]: Remove snippet.
[arguments]: Disable failing tests.
[propagated-inputs]: Use mozjs-38 instead of mozjs-24; add cairo.
---
gnu/packages/gnome.scm | 22 ++++++++++------------
1 file changed, 10 insertions(+), 12 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d53d15894..2cf6f4e3f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4174,7 +4174,7 @@ configuration program to choose applications starting on login.")
(define-public gjs
(package
(name "gjs")
- (version "1.46.0")
+ (version "1.48.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4182,10 +4182,7 @@ configuration program to choose applications starting on login.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1m2ssa6qsipbp8lz4xbhf0nhadhv0xkdpmz1jcvl9187lwgmk0r2"))
- (modules '((guix build utils)))
- (snippet '(substitute* "test/run-with-dbus"
- (("/bin/rm") "rm")))))
+ "0cqgv460wfhwkw6j1h46v6bg29bycg6dfl7c5rv0lfcqmmw7v6v6"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -4200,11 +4197,11 @@ configuration program to choose applications starting on login.")
;; For the missing /etc/machine-id.
(setenv "DBUS_FATAL_WARNINGS" "0")
- ;; XXX: fails with:
- ;; Failed to convert UTF-8 string to JS string: ...
- ;; TODO: actually fix it.
- (substitute* "installed-tests/js/testEverythingBasic.js"
- ((".*test_utf8_inout.*") ""))
+ ;; Our mozjs-38 package does not compile the required Intl API
+ ;; support for these failing tests.
+ (substitute* "installed-tests/js/testLocale.js"
+ ((".*toBeDefined.*") "")
+ ((".*expect\\(datestr\\).*") ""))
#t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-resources
@@ -4216,8 +4213,9 @@ configuration program to choose applications starting on login.")
("xvfb" ,xorg-server)))
(propagated-inputs
;; These are all in the Requires.private field of gjs-1.0.pc.
- `(("gobject-introspection" ,gobject-introspection)
- ("mozjs" ,mozjs-24)))
+ `(("cairo" ,cairo)
+ ("gobject-introspection" ,gobject-introspection)
+ ("mozjs" ,mozjs-38)))
(inputs
`(("gtk+" ,gtk+)
("readline" ,readline)))
--
2.13.0
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87vaoqw8c2.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (5 lines)
> * gnu/packages/gnome.scm (gjs): Update to 1.48.3.
> [source]: Remove snippet.
> [arguments]: Disable failing tests.
> [propagated-inputs]: Use mozjs-38 instead of mozjs-24; add cairo.

Great, LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlklrs0ACgkQoqBt8qM6
VPpbKQgAr/AP4KGGXIr+l2MZlwKCIkgPW45p5NYGKoFNDCStekZIaYm+LsPo30ix
0YYWR4AZHQqm+lRPNomGAdqHoq/wZHmMy4PbGVinXWKuyge0fVFvLj/32xaoG/jm
CwX5lphApF6A4obNQvqRZOf7C/iStrL8iRqFOzOU77uR1g3AvFHjODKZaT7RdoNN
LaP5kLCXHbPuwKbuVZeMbtVZzGvcxGiecTQIizfchf9/b8zkTk64TemmqMUWfM2L
NG0P+WUecISzCra+K0idDhRxVZw6K3BrWpnwLH7YP39D957oq1qUSs22xMsuLL9E
sYUBnU2tmm4DUzounezTlfUmR7pkUg==
=ADds
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 27058-done@debbugs.gnu.org)
8760gqmbj0.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (9 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/gnome.scm (gjs): Update to 1.48.3.
>> [source]: Remove snippet.
>> [arguments]: Disable failing tests.
>> [propagated-inputs]: Use mozjs-38 instead of mozjs-24; add cairo.
>
> Great, LGTM!

Thanks! Pushed as 144f94d0a212f1cecd28be59b99e867fbd58aa93.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlklvSMACgkQ5qXuPBlG
eg17MhAAsWI1sN03msraNM0tsOE0md9jotoIIu7c/LGyATOCOpuwbliax87CGZts
noVDI1LM+izgaZ09myy5mVDOhd6ZJoKTNEuQ+DRBWrf9PCUkSI1z3UVrRoLwAG8U
Myx2pNf6jLwM9rZ2kBVNSgZEmvCA1Hv7p5N2R2yiLNAju0J/YkNfweo4rwVanGYE
Cg986iLQwBoo1INUK7z6yErjyW4vMUpwgdC+DazE7F8N0+h+oDvku/1YrEweC2fG
1pTLAmlrZ8QeT56hQhMi5ueFxuJKRUWljMR6OE9QxTjZsGw/rlX/+hpamPLPi2vm
JlUpNQLVRzU/ki3ATiBFF6ySJF6X/gk3NC/gsLRjrj1S62OQ0hLBAA5Vt/dBdmLo
uoQ9Vir/bt1n4Kza1V6oPoUZzFZlqV5qVrA4DkUlg6qmVxR6xWbxz65dYPQdHWKD
n9K0kiXNvosnjNq2OBarsc4K1PWgbVlE2YjyxfludWLrhuMJiuH8rxP8aPzW7kTE
3Hzcu2q+dozNHBSYEr6RmaENT++4nJnuKJful66LeJlYrBm971/waIH5zNbgigNU
dzZaYUqbsZ/Yrw0/+UraFtyObMv+novGqUsLCBZ4oMr9e+S5L+5EEAa7ht+0rW6Y
UVV4tiNKmLl1opDE99ac9XpHj0MG+flgHycQVXElHtlw3/wuNlg=
=luXh
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27058@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27058
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help