Toggle diff (659 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 37258efe5..76b345cd8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2111,3 +2111,57 @@ MPEG-2, MPEG-4, DVD (VOB)...
@end itemize \n")
(license license:bsd-2)))
+;; TODO also have a GUI version available
+(define-public mediainfo
+ (package
+ (name "mediainfo")
+ (version "0.7.95")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://mediaarea.net/download/source/"
+ name "/" version "/"
+ name "_" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0dy51a3i79jppmg1gi4f6h7jx4hcgnkmfim4d7d3gmnlbkjh8anv"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)
+ ("libmediainfo", libmediainfo)
+ ("libzen" ,libzen)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; lacks tests
+ #:phases
+ ;; build scripts not in root of archive
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ (chdir "Project/GNU/CLI")))
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://mediaarea.net/en/MediaInfo")
+ (synopsis "Utility for reading media metadata")
+ (description "MediaInfo is a utility used for retrieving technical
+information and other metadata about audio or video files.
+A non-exhaustive list of the information MediaInfo can retrieve from media files include:
+@itemize
+@item General: title, author, director, album, track number, date, duration...
+@item Video: codec, aspect, fps, bitrate...
+@item Audio: codec, sample rate, channels, language, bitrate...
+@item Text: language of subtitle
+@item Chapters: number of chapters, list of chapters
+@end itemize\n
+MediaInfo supports the following formats:
+@itemize
+@item Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
+MPEG-2, MPEG-4, DVD (VOB)...
+@item Video Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
+@item Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF...
+@item Subtitles: SRT, SSA, ASS, SAMI...
+@end itemize \n")
+ (license license:bsd-2)))
diff --git a/po/guix/pl.po b/po/guix/pl.po
index 74d1f82ac..3a644bedf 100644
--- a/po/guix/pl.po
+++ b/po/guix/pl.po
@@ -7,7 +7,7 @@ msgid ""
msgstr ""
"Project-Id-Version: guix 0.11.0\n"
"Report-Msgid-Bugs-To: ludo@gnu.org\n"
-"POT-Creation-Date: 2016-07-29 10:16+0200\n"
+"POT-Creation-Date: 2017-05-25 12:14-0400\n"
"PO-Revision-Date: 2016-08-11 03:21+0200\n"
"Last-Translator: Daniel Koć <daniel@xn--ko-wla.pl>\n"
"Language-Team: Polish <translation-team-pl@lists.sourceforge.net>\n"
@@ -15,457 +15,515 @@ msgstr ""
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=(n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
+"Plural-Forms: nplurals=3; plural=(n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 "
+"|| n%100>=20) ? 1 : 2);\n"
"X-Generator: Poedit 1.8.7.1\n"
-#: gnu/packages.scm:79
+#: gnu/packages.scm:90
#, scheme-format
msgid "~a: patch not found"
msgstr "~a: nie znaleziono łatki"
-#: gnu/packages.scm:95
+#: gnu/packages.scm:106
#, scheme-format
msgid "could not find bootstrap binary '~a' for system '~a'"
msgstr ""
-#: gnu/packages.scm:147
-#, scheme-format
-msgid "cannot access `~a': ~a~%"
-msgstr "brak dostępu do `~a': ~a~%"
-
-#: gnu/packages.scm:301
+#: gnu/packages.scm:236
#, scheme-format
msgid "ambiguous package specification `~a'~%"
msgstr "niejasna specyfikacja pakietu `~a'~%"
-#: gnu/packages.scm:302
-#, scheme-format
-msgid "choosing ~a from ~a~%"
+#: gnu/packages.scm:237
+#, fuzzy, scheme-format
+msgid "choosing ~a@~a from ~a~%"
msgstr "wybieranie ~a z ~a~%"
-#: gnu/packages.scm:306
+#: gnu/packages.scm:242 guix/scripts/package.scm:272
#, scheme-format
-msgid "deprecated NAME-VERSION syntax; use NAME@VERSION instead~%"
+msgid "package '~a' has been superseded by '~a'~%"
msgstr ""
-#: gnu/packages.scm:311
+#: gnu/packages.scm:249
#, scheme-format
msgid "~A: package not found for version ~a~%"
msgstr "~A: nie znalezino pakietu w wersji ~a~%"
-#: gnu/packages.scm:321
+#: gnu/packages.scm:250
#, scheme-format
msgid "~A: unknown package~%"
msgstr "~A: nieznany pakiet~%"
-#: gnu/packages.scm:349
+#: gnu/packages.scm:278
#, scheme-format
msgid "package `~a' lacks output `~a'~%"
msgstr ""
-#: gnu/services.scm:540
+#: gnu/services.scm:186
+#, scheme-format
+msgid "~a: no value specified for service of type '~a'"
+msgstr ""
+
+#: gnu/services.scm:627
#, scheme-format
msgid "no target of type '~a' for service ~s"
msgstr ""
-#: gnu/services.scm:551 gnu/services.scm:612
+#: gnu/services.scm:638 gnu/services.scm:699
#, scheme-format
msgid "more than one target service of type '~a'"
msgstr ""
-#: gnu/services.scm:602
+#: gnu/services.scm:689
#, scheme-format
msgid "service of type '~a' not found"
msgstr ""
-#: gnu/system.scm:500
+#: gnu/system.scm:279
#, scheme-format
-msgid "using a string for file '~a' is deprecated; use 'plain-file' instead~%"
+msgid "unrecognized boot parameters for '~a'~%"
msgstr ""
-#: gnu/system.scm:516
+#: gnu/system.scm:642
#, scheme-format
-msgid "using a monadic value for '~a' is deprecated; use 'plain-file' instead~%"
+msgid "using a string for file '~a' is deprecated; use 'plain-file' instead~%"
msgstr ""
-#: gnu/system.scm:650
+#: gnu/system.scm:658
#, scheme-format
-msgid "~a: invalid locale name"
+msgid ""
+"using a monadic value for '~a' is deprecated; use 'plain-file' instead~%"
msgstr ""
-#: gnu/system.scm:770
+#: gnu/system.scm:800
#, scheme-format
-msgid "unrecognized boot parameters for '~a'~%"
+msgid "~a: invalid locale name"
msgstr ""
-#: gnu/services/shepherd.scm:162
+#: gnu/services/shepherd.scm:166
#, scheme-format
msgid "service '~a' provided more than once"
msgstr ""
-#: gnu/services/shepherd.scm:177
+#: gnu/services/shepherd.scm:181
#, scheme-format
msgid "service '~a' requires '~a', which is not provided by any service"
msgstr ""
-#: gnu/system/shadow.scm:240
+#: gnu/system/shadow.scm:223
#, scheme-format
msgid "supplementary group '~a' of user '~a' is undeclared"
msgstr ""
-#: gnu/system/shadow.scm:250
+#: gnu/system/shadow.scm:233
#, scheme-format
msgid "primary group '~a' of user '~a' is undeclared"
msgstr "podstawowa grupa '~a' użytkownika '~a' nie została określona"
-#: guix/scripts.scm:52
+#: guix/scripts.scm:56
#, scheme-format
msgid "invalid argument: ~a~%"
msgstr "nieprawidłowy argument: ~a~%"
-#: guix/scripts.scm:78 guix/scripts/download.scm:99 guix/scripts/gc.scm:164
-#: guix/scripts/import/cran.scm:78 guix/scripts/import/elpa.scm:77
-#: guix/scripts/pull.scm:219 guix/scripts/lint.scm:916
-#: guix/scripts/publish.scm:549 guix/scripts/graph.scm:383
+#: guix/scripts.scm:82 guix/scripts/download.scm:133 guix/scripts/gc.scm:164
+#: guix/scripts/import/cran.scm:82 guix/scripts/import/elpa.scm:77
+#: guix/scripts/lint.scm:1061 guix/scripts/publish.scm:821
+#: guix/scripts/edit.scm:81 guix/scripts/graph.scm:456
#, scheme-format
msgid "~A: unrecognized option~%"
msgstr "~A: nieznana opcja~%"
-#: guix/scripts/build.scm:121
+#: guix/scripts.scm:175
+#, scheme-format
+msgid "Your Guix installation is ~a day old.\n"
+msgid_plural "Your Guix installation is ~a days old.\n"
+msgstr[0] ""
+msgstr[1] ""
+msgstr[2] ""
+
+#: guix/scripts.scm:180
+#, scheme-format
+msgid ""
+"Consider running 'guix pull' followed by\n"
+"'~a' to get up-to-date packages and security updates.\n"
+msgstr ""
+
+#: guix/scripts/build.scm:124
#, scheme-format
msgid "failed to create GC root `~a': ~a~%"
msgstr ""
-#: guix/scripts/build.scm:198
+#: guix/scripts/build.scm:206
#, scheme-format
msgid "invalid replacement specification: ~s~%"
msgstr ""
-#: guix/scripts/build.scm:246
+#: guix/scripts/build.scm:263
msgid ""
"\n"
" --with-source=SOURCE\n"
" use SOURCE when building the corresponding package"
msgstr ""
-#: guix/scripts/build.scm:249
+#: guix/scripts/build.scm:266
msgid ""
"\n"
" --with-input=PACKAGE=REPLACEMENT\n"
" replace dependency PACKAGE by REPLACEMENT"
msgstr ""
-#: guix/scripts/build.scm:274
+#: guix/scripts/build.scm:269
+msgid ""
+"\n"
+" --with-graft=PACKAGE=REPLACEMENT\n"
+" graft REPLACEMENT on packages that refer to PACKAGE"
+msgstr ""
+
+#: guix/scripts/build.scm:294
#, scheme-format
msgid "transformation '~a' had no effect on ~a~%"
msgstr ""
-#: guix/scripts/build.scm:292
+#: guix/scripts/build.scm:312
msgid ""
"\n"
" -L, --load-path=DIR prepend DIR to the package module search path"
msgstr ""
-#: guix/scripts/build.scm:294
+#: guix/scripts/build.scm:314
msgid ""
"\n"
" -K, --keep-failed keep build tree of failed builds"
msgstr ""
-#: guix/scripts/build.scm:296
+#: guix/scripts/build.scm:316
msgid ""
"\n"
" -k, --keep-going keep going when some of the derivations fail"
msgstr ""
-#: guix/scripts/build.scm:298
+#: guix/scripts/build.scm:318
msgid ""
"\n"
" -n, --dry-run do not build the derivations"
msgstr ""
-#: guix/scripts/build.scm:300
+#: guix/scripts/build.scm:320
msgid ""
"\n"
" --fallback fall back to building when the substituter fails"
msgstr ""
-#: guix/scripts/build.scm:302
+#: guix/scripts/build.scm:322
msgid ""
"\n"
" --no-substitutes build instead of resorting to pre-built substitutes"
msgstr ""
-#: guix/scripts/build.scm:304 guix/scripts/size.scm:217
+#: guix/scripts/build.scm:324 guix/scripts/size.scm:222
msgid ""
"\n"
" --substitute-urls=URLS\n"
" fetch substitute from URLS if they are authorized"
msgstr ""
-#: guix/scripts/build.scm:307
+#: guix/scripts/build.scm:327
msgid ""
"\n"
" --no-grafts do not graft packages"
msgstr ""
-#: guix/scripts/build.scm:309
+#: guix/scripts/build.scm:329
msgid ""
"\n"
" --no-build-hook do not attempt to offload builds via the build hook"
msgstr ""
-#: guix/scripts/build.scm:311
+#: guix/scripts/build.scm:331
msgid ""
"\n"
" --max-silent-time=SECONDS\n"
" mark the build as failed after SECONDS of silence"
msgstr ""
-#: guix/scripts/build.scm:314
+#: guix/scripts/build.scm:334
msgid ""
"\n"
" --timeout=SECONDS mark the build as failed after SECONDS of activity"
msgstr ""
-#: guix/scripts/build.scm:316
+#: guix/scripts/build.scm:336
msgid ""
"\n"
" --verbosity=LEVEL use the given verbosity LEVEL"
msgstr ""
-#: guix/scripts/build.scm:318
+#: guix/scripts/build.scm:338
msgid ""
"\n"
" --rounds=N build N times in a row to detect non-determinism"
msgstr ""
-#: guix/scripts/build.scm:320
+#: guix/scripts/build.scm:340
msgid ""
"\n"
" -c, --cores=N allow the use of up to N CPU cores for the build"
msgstr ""
-#: guix/scripts/build.scm:322
+#: guix/scripts/build.scm:342
msgid ""
"\n"
" -M, --max-jobs=N allow at most N build jobs"
msgstr ""
-#: guix/scripts/build.scm:428 guix/scripts/build.scm:435
+#: guix/scripts/build.scm:448 guix/scripts/build.scm:455
#, scheme-format
msgid "not a number: '~a' option argument: ~a~%"
msgstr ""
-#: guix/scripts/build.scm:455
+#: guix/scripts/build.scm:474
msgid ""
"Usage: guix build [OPTION]... PACKAGE-OR-DERIVATION...\n"
"Build the given PACKAGE-OR-DERIVATION and return their output paths.\n"
msgstr ""
-#: guix/scripts/build.scm:457
+#: guix/scripts/build.scm:476
msgid ""
"\n"
" -e, --expression=EXPR build the package or derivation EXPR evaluates to"
msgstr ""
-#: guix/scripts/build.scm:459
+#: guix/scripts/build.scm:478
msgid ""
"\n"
-" -f, --file=FILE build the package or derivation that the code within\n"
+" -f, --file=FILE build the package or derivation that the code "
+"within\n"
" FILE evaluates to"
msgstr ""
-#: guix/scripts/build.scm:462
+#: guix/scripts/build.scm:481
msgid ""
"\n"
" -S, --source build the packages' source derivations"
msgstr ""
-#: guix/scripts/build.scm:464
+#: guix/scripts/build.scm:483
msgid ""
"\n"
-" --sources[=TYPE] build source derivations; TYPE may optionally be one\n"
+" --sources[=TYPE] build source derivations; TYPE may optionally be "
+"one\n"
" of \"package\", \"all\" (default), or \"transitive\""
msgstr ""
-#: guix/scripts/build.scm:467
+#: guix/scripts/build.scm:486 guix/scripts/pack.scm:337
msgid ""
"\n"
" -s, --system=SYSTEM attempt to build for SYSTEM--e.g., \"i686-linux\""
msgstr ""
-#: guix/scripts/build.scm:469
+#: guix/scripts/build.scm:488 guix/scripts/pack.scm:339
msgid ""
"\n"
" --target=TRIPLET cross-build for TRIPLET--e.g., \"armel-linux-gnu\""
msgstr ""
-#: guix/scripts/build.scm:471
+#: guix/scripts/build.scm:490
msgid ""
"\n"
" -d, --derivations return the derivation paths of the given packages"
msgstr ""
-#: guix/scripts/build.scm:473
+#: guix/scripts/build.scm:492
msgid ""
"\n"
" --check rebuild items to check for non-determinism issues"
msgstr ""
-#: guix/scripts/build.scm:475
+#: guix/scripts/build.scm:494
+msgid ""
+"\n"
+" --repair repair the specified items"
+msgstr ""
+
+#: guix/scripts/build.scm:496
msgid ""
"\n"
" -r, --root=FILE make FILE a symlink to the result, and register it\n"
" as a garbage collector root"
msgstr ""
-#: guix/scripts/build.scm:478
+#: guix/scripts/build.scm:499
msgid ""
"\n"
" -q, --quiet do not show the build log"
msgstr ""
-#: guix/scripts/build.scm:480
+#: guix/scripts/build.scm:501
msgid ""
"\n"
" --log-file return the log file names for the given derivations"
msgstr ""
-#: guix/scripts/build.scm:487 guix/scripts/download.scm:56
-#: guix/scripts/package.scm:388 guix/scripts/gc.scm:74
-#: guix/scripts/hash.scm:56 guix/scripts/import.scm:91
-#: guix/scripts/import/cran.scm:46 guix/scripts/pull.scm:83
-#: guix/scripts/substitute.scm:827 guix/scripts/system.scm:695
-#: guix/scripts/lint.scm:865 guix/scripts/publish.scm:73
-#: guix/scripts/edit.scm:44 guix/scripts/size.scm:225
-#: guix/scripts/graph.scm:364 guix/scripts/challenge.scm:182
-#: guix/scripts/container.scm:33 guix/scripts/container/exec.scm:43
+#: guix/scripts/build.scm:508 guix/scripts/download.scm:81
+#: guix/scripts/package.scm:419 guix/scripts/gc.scm:74 guix/scripts/hash.scm:59
+#: guix/scripts/import.scm:92 guix/scripts/import/cran.scm:47
+#: guix/scripts/pull.scm:94 guix/scripts/substitute.scm:810
+#: guix/scripts/system.scm:792 guix/scripts/lint.scm:1010
+#: guix/scripts/publish.scm:93 guix/scripts/edit.scm:44
+#: guix/scripts/size.scm:230 guix/scripts/graph.scm:436
+#: guix/scripts/challenge.scm:227 guix/scripts/copy.scm:121
+#: guix/scripts/pack.scm:348 guix/scripts/container.scm:33
+#: guix/scripts/container/exec.scm:43
msgid ""
"\n"
" -h, --help display this help and exit"
msgstr ""
-#: guix/scripts/build.scm:489 guix/scripts/download.scm:58
-#: guix/scripts/package.scm:390 guix/scripts/gc.scm:76
-#: guix/scripts/hash.scm:58 guix/scripts/import.scm:93
-#: guix/scripts/import/cran.scm:48 guix/scripts/pull.scm:85
-#: guix/scripts/substitute.scm:829 guix/scripts/system.scm:697
-#: guix/scripts/lint.scm:869 guix/scripts/publish.scm:75
-#: guix/scripts/edit.scm:46 guix/scripts/size.scm:227
-#: guix/scripts/graph.scm:366 guix/scripts/challenge.scm:184
-#: guix/scripts/container.scm:35 guix/scripts/container/exec.scm:45
+#: guix/scripts/build.scm:510 guix/scripts/download.scm:83
+#: guix/scripts/package.scm:421 guix/scripts/gc.scm:76 guix/scripts/hash.scm:61
+#: guix/scripts/import.scm:94 guix/scripts/import/cran.scm:49
+#: guix/scripts/pull.scm:96 guix/scripts/substitute.scm:812
+#: guix/scripts/system.scm:794 guix/scripts/lint.scm:1014
+#: guix/scripts/publish.scm:95 guix/scripts/edit.scm:46
+#: guix/scripts/size.scm:232 guix/scripts/graph.scm:438
+#: guix/scripts/challenge.scm:229 guix/scripts/copy.scm:123
+#: guix/scripts/pack.scm:350 guix/scripts/container.scm:35
+#: guix/scripts/container/exec.scm:45
msgid ""
"\n"
" -V, --version display version information and exit"
msgstr ""
-#: guix/scripts/build.scm:516
+#: guix/scripts/build.scm:537
#, scheme-format
msgid ""
"invalid argument: '~a' option argument: ~a, ~\n"
"must be one of 'package', 'all', or 'transitive'~%"
msgstr ""
-#: guix/scripts/build.scm:563
+#: guix/scripts/build.scm:590
#, scheme-format
msgid "~s: not something we can build~%"
msgstr ""
-#: guix/scripts/build.scm:643
+#: guix/scripts/build.scm:644
+#, scheme-format
+msgid "~a: warning: package '~a' has no source~%"
+msgstr ""
+
+#: guix/scripts/build.scm:678
#, scheme-format
msgid "no build log for '~a'~%"
msgstr ""
-#: guix/scripts/download.scm:47
+#: guix/discovery.scm:56
+#, scheme-format
+msgid "cannot access `~a': ~a~%"
+msgstr "brak dostępu do `~a': ~a~%"
+
+#: guix/scripts/download.scm:67
msgid ""
"Usage: guix download [OPTION] URL\n"
-"Download the file at URL, add it to the store, and print its store path\n"
-"and the hash of its contents.\n"
+"Download the file at URL to the store or to the given file, and print its\n"
+"file name and the hash of its contents.\n"
"\n"
"Supported formats: 'nix-base32' (default), 'base32', and 'base16'\n"
"('hex' and 'hexadecimal' can be used as well).\n"
msgstr ""
-#: guix/scripts/download.scm:53 guix/scripts/hash.scm:51
+#: guix/scripts/download.scm:73 guix/scripts/hash.scm:54
msgid ""
"\n"
" -f, --format=FMT write the hash in the given format"
msgstr ""
-#: guix/scripts/download.scm:76 guix/scripts/hash.scm:76
+#: guix/scripts/download.scm:75
+msgid ""
+"\n"
+" --no-check-certificate\n"
+" do not validate the certificate of HTTPS servers "
+msgstr ""
+
+#: guix/scripts/download.scm:78
+msgid ""
+"\n"
+" -o, --output=FILE download to FILE"
+msgstr ""
+
+#: guix/scripts/download.scm:101 guix/scripts/hash.scm:82
#, scheme-format
msgid "unsupported hash format: ~a~%"
msgstr ""
-#: guix/scripts/download.scm:102 guix/scripts/package.scm:842
-#: guix/scripts/publish.scm:551
+#: guix/scripts/download.scm:136 guix/scripts/package.scm:884
+#: guix/scripts/publish.scm:823
#, scheme-format
msgid "~A: extraneous argument~%"
msgstr ""
-#: guix/scripts/download.scm:111
+#: guix/scripts/download.scm:144
#, scheme-format
msgid "no download URI was specified~%"
msgstr ""
-#: guix/scripts/download.scm:113
+#: guix/scripts/download.scm:146
#, scheme-format
msgid "~a: failed to parse URI~%"
msgstr ""
-#: guix/scripts/download.scm:126
+#: guix/scripts/download.scm:156
#, scheme-format
msgid "~a: download failed~%"
msgstr "~a: pobieranie nie powiodło się~%"
-#: guix/scripts/package.scm:104
+#: guix/scripts/package.scm:107
#, scheme-format
msgid "Try \"info '(guix) Invoking guix package'\" for more information.~%"
-msgstr "Wpisz \"info '(guix) Invoking guix package'\" aby dowiedzieć się więcej.~%"
+msgstr ""
+"Wpisz \"info '(guix) Invoking guix package'\" aby dowiedzieć się więcej.~%"
-#: guix/scripts/package.scm:126
+#: guix/scripts/package.scm:129
#, scheme-format
msgid "error: while creating directory `~a': ~a~%"
msgstr "błąd: podczas tworzenia katalogu `~a': ~a~%"
-#: guix/scripts/package.scm:130
+#: guix/scripts/package.scm:13