[PATCH 2/2] gnu: node: Use unbundled dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jelle Licht
  • Marius Bakke
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal

Debbugs page

Jelle Licht wrote 8 years ago
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
20170522180321.20388-2-jlicht@fsfe.org
* gnu/packages/node.scm (node)[inputs]: Add c-ares and http-parser.
[arguments]: Add configure flags for using system libraries.
---
gnu/packages/node.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 91f1839b6..b3ecfc843 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -26,6 +26,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages adns)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
@@ -33,7 +34,8 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
- #:use-module (gnu packages tls))
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages web))
(define-public node
(package
@@ -54,6 +56,8 @@
'(#:configure-flags '("--shared-openssl"
"--shared-zlib"
"--shared-libuv"
+ "--shared-cares"
+ "--shared-http-parser"
"--without-snapshot")
#:phases
(modify-phases %standard-phases
@@ -123,7 +127,9 @@
("util-linux" ,util-linux)
("which" ,which)))
(inputs
- `(("libuv" ,libuv)
+ `(("c-ares" ,c-ares)
+ ("http-parser" ,http-parser)
+ ("libuv" ,libuv)
("openssl" ,openssl)
("zlib" ,zlib)))
(synopsis "Evented I/O for V8 JavaScript")
--
2.13.0
Marius Bakke wrote 8 years ago
87a863y1px.fsf@fastmail.com
Jelle Licht <jlicht@fsfe.org> writes:

Toggle quote (5 lines)
> * gnu/packages/node.scm (node): Update to 7.10.0.
> (node)[arguments]: Disabled more tests.
> * gnu/packages/patches/node-9077.patch: Delete incompatible patch file.
> Recreate patch file from node pull request 9077.

[...]

Toggle quote (3 lines)
> * gnu/packages/node.scm (node)[inputs]: Add c-ares and http-parser.
> [arguments]: Add configure flags for using system libraries.

Thanks for these patches! I updated the TODO comment about http-parser
to say "TODO: Purge the bundled copies from the source". I tried to do
that with a source 'snippet', but the Makefile expects to build these
targets, so it will take some work. Would you mind looking into it? :-)

Regardless, I've applied these patches for now. Thanks for maintaining
this package! :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkkY8oACgkQoqBt8qM6
VPoMOggAzP0Jbiycu9KpcieieJ8YiBDFD3ZjyP0rWav+qPADucN9C8MLhHQCq3VD
Q2bkwWnHOJHgB8VtwbSMrZnQg88mUj1AplmlJXvwxuRnu2V/nZ2vW7DQeCZ0CRqs
Dp1m6x3h8+2xDPcBkzQHUHVDI4lGLBVOS2K7ExIDEGLBU3WBwQfNYK6WT0z9psnT
7rzL6Gm0gKUlvAjBBItCQ675A93kiw0t6GACwDdQXkUBAygm+XUflcK++oeiX9fC
AdMmOEqkAEFAZqg4vu9koUxZa5Jgp6oATXLMEgeEd6H3ib9EgWt+PIsxqq3MXyiN
6mTHdNnFqVPGSp8ac5c9y221cNcIrQ==
=Kj1i
-----END PGP SIGNATURE-----

Closed
Jelle Licht wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 27021-done@debbugs.gnu.org)
CAPsKtf+GmJW0Bv=K9Y+y6KGeNUTdsiEkGJa7hprKAHOohnGnDA@mail.gmail.com
No problem, I use this stuff quite often.
I noticed the problem with the bundled copies in the source as well, but
ran into the same issues you mention here.
Maybe I will look into it when the next node version is released.

2017-05-23 18:31 GMT+02:00 Marius Bakke <mbakke@fastmail.com>:

Toggle quote (20 lines)
> Jelle Licht <jlicht@fsfe.org> writes:
>
> > * gnu/packages/node.scm (node): Update to 7.10.0.
> > (node)[arguments]: Disabled more tests.
> > * gnu/packages/patches/node-9077.patch: Delete incompatible patch file.
> > Recreate patch file from node pull request 9077.
>
> [...]
>
> > * gnu/packages/node.scm (node)[inputs]: Add c-ares and http-parser.
> > [arguments]: Add configure flags for using system libraries.
>
> Thanks for these patches! I updated the TODO comment about http-parser
> to say "TODO: Purge the bundled copies from the source". I tried to do
> that with a source 'snippet', but the Makefile expects to build these
> targets, so it will take some work. Would you mind looking into it? :-)
>
> Regardless, I've applied these patches for now. Thanks for maintaining
> this package! :-)
>
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27021@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27021
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help