[PATCH] gnu: gjs: Update to 1.49.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170518215650.25400-1-kei@openmailbox.org
* gnu/packages/gnome.scm (gjs): Update to 1.49.1.
[source]: Remove snippet.
[arguments]: Replace check phase.
[propagated-inputs]: Use mozjs-38 instead of mozjs-24; add cairo.
---
gnu/packages/gnome.scm | 24 ++++++++++--------------
1 file changed, 10 insertions(+), 14 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81c747ce1..671d6a022 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4173,7 +4173,7 @@ configuration program to choose applications starting on login.")
(define-public gjs
(package
(name "gjs")
- (version "1.46.0")
+ (version "1.49.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4181,10 +4181,7 @@ configuration program to choose applications starting on login.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1m2ssa6qsipbp8lz4xbhf0nhadhv0xkdpmz1jcvl9187lwgmk0r2"))
- (modules '((guix build utils)))
- (snippet '(substitute* "test/run-with-dbus"
- (("/bin/rm") "rm")))))
+ "0vp13aw3xnhdvk9l7gxzks2f6lh044faiay57c94v3mfkwqa7cqg"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -4198,13 +4195,11 @@ configuration program to choose applications starting on login.")
;; For the missing /etc/machine-id.
(setenv "DBUS_FATAL_WARNINGS" "0")
-
- ;; XXX: fails with:
- ;; Failed to convert UTF-8 string to JS string: ...
- ;; TODO: actually fix it.
- (substitute* "installed-tests/js/testEverythingBasic.js"
- ((".*test_utf8_inout.*") ""))
- #t)))))
+ #t))
+ (replace 'check
+ (lambda _
+ ;; 17 test failures and 3 errors occur for unknown reasons.
+ (system* "make" "-k" "check"))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-resources
("pkg-config" ,pkg-config)
@@ -4215,8 +4210,9 @@ configuration program to choose applications starting on login.")
("xvfb" ,xorg-server)))
(propagated-inputs
;; These are all in the Requires.private field of gjs-1.0.pc.
- `(("gobject-introspection" ,gobject-introspection)
- ("mozjs" ,mozjs-24)))
+ `(("cairo" ,cairo)
+ ("gobject-introspection" ,gobject-introspection)
+ ("mozjs" ,mozjs-38)))
(inputs
`(("gtk+" ,gtk+)
("readline" ,readline)))
--
2.12.2
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26989@debbugs.gnu.org)
87vaoxi7sy.fsf@gnu.org
Hi Kei,

Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (5 lines)
> * gnu/packages/gnome.scm (gjs): Update to 1.49.1.
> [source]: Remove snippet.
> [arguments]: Replace check phase.
> [propagated-inputs]: Use mozjs-38 instead of mozjs-24; add cairo.

[...]

Toggle quote (12 lines)
> - ;; XXX: fails with:
> - ;; Failed to convert UTF-8 string to JS string: ...
> - ;; TODO: actually fix it.
> - (substitute* "installed-tests/js/testEverythingBasic.js"
> - ((".*test_utf8_inout.*") ""))
> - #t)))))
> + #t))
> + (replace 'check
> + (lambda _
> + ;; 17 test failures and 3 errors occur for unknown reasons.
> + (system* "make" "-k" "check"))))))

Could you try to get more info about the test failures?

It would be good to determine whether these are genuine problems or
problems caused by our build environment. Since gjs is quite central in
GNOME, AIUI, it would be best to have some confidence that it works
correctly.

Thanks,
Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26989@debbugs.gnu.org)
87wp9cg80m.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (33 lines)
> Hi Kei,
>
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * gnu/packages/gnome.scm (gjs): Update to 1.49.1.
>> [source]: Remove snippet.
>> [arguments]: Replace check phase.
>> [propagated-inputs]: Use mozjs-38 instead of mozjs-24; add cairo.
>
> [...]
>
>> - ;; XXX: fails with:
>> - ;; Failed to convert UTF-8 string to JS string: ...
>> - ;; TODO: actually fix it.
>> - (substitute* "installed-tests/js/testEverythingBasic.js"
>> - ((".*test_utf8_inout.*") ""))
>> - #t)))))
>> + #t))
>> + (replace 'check
>> + (lambda _
>> + ;; 17 test failures and 3 errors occur for unknown reasons.
>> + (system* "make" "-k" "check"))))))
>
> Could you try to get more info about the test failures?
>
> It would be good to determine whether these are genuine problems or
> problems caused by our build environment. Since gjs is quite central in
> GNOME, AIUI, it would be best to have some confidence that it works
> correctly.
>
> Thanks,
> Ludo’.

I'll do my best!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkfFGkACgkQ5qXuPBlG
eg2PYg/7BtWPQwhC1kK7kQJBRuHr2Yn6gOIjy12AOIkHkE6NcxL+drVRs8Hpeald
XYOc5liYKRxadeOSuElFvlPJcRs/xNvzC/80SyNy6Epzx5sfSlWLlxVPPCdtcqMt
+mCWbfw7GyNTuVEnrXCrG2n4us31/pUz5m6o8/s0vrfwkbZrOgzxC3vYresVGdRa
8pFxZ22JUuBi4iRvR7Is77guw3keCCe0frxNqp+3oe19Gbnp7pSiLWQspOw6A3XB
XWBTt9IDusymcjDGC0bl9ZM6QRms1Z7sST9UZ9zGF8Cu1KQKoy0tCi8VuSI0eUvI
IIuwZuaGU/LXw044ASj4BxKcgwq/aoyaNgYuLm5/aR56+EW3gOwh9WNBkF+C9W9Y
dGhqdMkvd6AwDaP3+9d5lO9gLud0zpaLm5GEZys82nr3PcF0OZ4datcUYDBMwMCc
pkvhcusUHF0OQVxABZf4M/wVd8gmvczmDASViWD+7mNqUSsY/CwMnBrL0DiCYPk3
gwDZjD+X7qOWRcJBdc84fhFLIZSANepfBzBDc07vsfZqYvYBiaQ08n3SuRy0Fzj6
gubVqvy1rq5TQlOYmdPrSSp4WJbEV5HhmLaV7X+NtT8bV280SwdY08u7HEfgKzZj
XvUgQ11lrjUjmqA57gerVufvd+xSQkR4v4dWN6zt4Sn68w6oYeI=
=hPL4
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
Re: Status: [PATCH] gnu: gjs: Update to 1.49.1.
(name . bug#26989)(address . 26989-done@debbugs.gnu.org)
87tw3wld13.fsf@openmailbox.org
bug#26989 <26989@debbugs.gnu.org> writes:

Toggle quote (8 lines)
> retitle 26989 [PATCH] gnu: gjs: Update to 1.49.1.
> reassign 26989 guix-patches
> submitter 26989 Kei Kebreau <kei@openmailbox.org>
> severity 26989 normal
> tag 26989 patch
>
> thanks

A replacement patch was pushed to staging as
144f94d0a212f1cecd28be59b99e867fbd58aa93.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkza8gACgkQ5qXuPBlG
eg10qA/9F/XPjDH+7UJdPwadGBDV0I5kq5Ef6Fb2Dy5iOYp9WCPEFnWqr4T0tC+e
ynqWtuXcRHoHiWITkvW893dnOp3MH9C46K0gRHpTdTG/6bvPcDyGqFzH4IvMZhjh
5oOEIWjJKufl8l8vnWZTW6jfR068BMV4J3luKClwHL4dQp+g2OhpFUDgY4XvffFZ
l2onH7My89+QQSeSZ6awCFMvoWH+wKLbdcDLN3Pq4FNnk62RkTqCsF1htnZ93j38
8sNg0BHafkQy+Ho63zEXA+kleCf+Wtw2vfs5oQCU6G6WTZoFFLn48TIaIC4mI5Tz
EQduiYTdUJt9GrvaRIk1TgZZQ0khP4yJirp//6o6E+MCGx9kVYdQzOvcXGEPnvcZ
w9dKYpMwK24UTbkkQPi5KbL3eL2TVfzUemhXO0sYOi+mB7UOuLKZP1niImd1BCeS
bp1OAuHELMhNe77KVRikHWvQqWJFgQeEqN8VBWr/9eihbfe70H05BqNOvSpsm4PO
5TVuMIGMVFa4Bt807ZCITZtZ78cr1rdYqxOJHLu0A6D1lvT2JlgG5meWUyKz+UGV
MLHhL7b+v+DKWi/cnCH3ew+LrUJkmEfHW5pTi2tDE+fsSOdizFTiJk2rAFNPxgjb
7QngulU+eSGXhchucy+JwTAmJmvV+mWZH2j8SUSVPG8trE+efw8=
=+Jj9
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26989@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26989
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help