Toggle quote (5 lines)
> Subject: [PATCH] gnu: Add plymouth.
>
> * gnu/packages/freedesktop.scm (plymouth): New variable.
> ---
Toggle quote (15 lines)
> + (arguments
> + `(#:configure-flags (list (string-append "--sbindir="
> + (assoc-ref %outputs "out")
> + "/sbin")
> + (string-append "--bindir="
> + (assoc-ref %outputs "out")
> + "/bin")
> + (string-append "--prefix="
> + (assoc-ref %outputs "out"))
> + (string-append "--exec-prefix="
> + (assoc-ref %outputs "out"))
> + (string-append "--libexecdir="
> + (assoc-ref %outputs "out")
> + "/lib")
Is it really necessary to set *all* of these? Usually it’s sufficient
to just set “--prefix” and that’s done by default.
Toggle quote (3 lines)
> + (string-append "--sysconfdir="
> + "/etc")
You don’t need string-append here. Is it *necessary* to use the global
/etc here, or can it be told (at runtime) to read its configuration
files from elsewhere?
Toggle quote (5 lines)
> + (string-append "--localstatedir="
> + "/var")
> + (string-append "--with-logo="
> + "/etc/plymouth/logo.png")
I would prefer if we didn’t have to use the global /etc here. You don’t
need string-append here.
Toggle quote (7 lines)
> + (string-append "--with-background-color="
> + "0x000000")
> + (string-append "--with-background-start-color-stop="
> + "0x000000")
> + (string-append "--with-background-end-color-stop="
> + "0x000000")
Toggle quote (8 lines)
> + "--without-system-root-install"
> + "--without-rhgb-compat-link"
> + "--enable-tracing"
> + "--disable-systemd-integration"
> + "--enable-pango"
> + "--enable-gdm-transition"
> + "--enable-gtk")
And what about these? Does “disable-systemd-integration” mean that it
won’t work with elogind?
Toggle quote (7 lines)
> + #:make-flags (list (string-append "plymouthd_defaultsdir="
> + (assoc-ref %outputs "out")
> + "/share/plymouth")
> + (string-append "plymouthd_confdir="
> + (assoc-ref %outputs "out")
> + "/etc/plymouth"))
These differ from the configure flags above that say that the global
/etc should be used. Is this on purpose?
Toggle quote (32 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (add-before 'configure 'fix-docbook
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "docs/Makefile.in"
> + (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
> + (string-append (assoc-ref inputs "docbook-xsl")
> + "/xml/xsl/docbook-xsl-"
> + ,(package-version docbook-xsl)
> + "/manpages/docbook.xsl")))
> + (setenv "XML_CATALOG_FILES"
> + (string-append (assoc-ref inputs "docbook-xml")
> + "/xml/dtd/docbook/catalog.xml"))
> + #t)))))
> + (inputs
> + `(("gtk+" ,gtk+)
> + ("glib" ,glib)
> + ("cairo" ,cairo)
> + ("libdrm" ,libdrm)
> + ("pango" ,pango)
> + ("libpng" ,libpng)
> + ("eudev" ,eudev)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("libxslt" ,libxslt)
> + ("docbook-xsl" ,docbook-xsl)
> + ("docbook-xml" ,docbook-xml)))
> + (synopsis "Graphical boot animation (splash) and logger")
> + (home-page "https://www.freedesktop.org/wiki/Software/Plymouth/")
> + (description
> + "Plymouth is an application that runs very early in the boot
> +process (even before the root filesystem is mounted!) that provides
Toggle quote (3 lines)
> +a graphical boot animation while the boot process happens in the
> +background.
I wonder how this will work “before the root filesystem is mounted” when
the store actually sits on the root filesystem. I would prefer to only
add this once it actually works, so I’d very much like to see a proof of
concept for how to use it in a system.
--
Ricardo
GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC