[PATCH 0/4] Update helm and add some friends

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170517191122.2490-1-kyle@kyleam.com
Hello,

This patch series updates Helm (and its dependency async) and adds two
Helm-related packages.

gnu: emacs-async: Update to 1.9.2.
gnu: emacs-helm: Update to 2.7.0.
gnu: Add emacs-helm-swoop.
gnu: Add emacs-helm-projectile.

gnu/packages/emacs.scm | 57 ++++++++++++++++++++++++++++++++++++++++++++++----
1 file changed, 53 insertions(+), 4 deletions(-)

--
2.13.0
Kyle Meyer wrote 8 years ago
[PATCH 1/4] gnu: emacs-async: Update to 1.9.2.
(address . 26968@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170517191432.2639-1-kyle@kyleam.com
* gnu/packages/emacs.scm (emacs-async): Update to 1.9.2.
---
gnu/packages/emacs.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3ed08043b..17d00ddd1 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1156,14 +1156,14 @@ rather than the contents of files.")
(define-public emacs-async
(package
(name "emacs-async")
- (version "1.9")
+ (version "1.9.2")
(source (origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/async-"
version ".tar"))
(sha256
(base32
- "1ip5nc8xyln5szvqwp6wqva9xr84pn8ssn3nnphrszr19y4js2bm"))))
+ "17fnvrj7jww29sav6a6jpizclg4w2962m6h37akpii71gf0vrffw"))))
(build-system emacs-build-system)
(home-page "https://elpa.gnu.org/packages/async.html")
(synopsis "Asynchronous processing in Emacs")
--
2.13.0
Kyle Meyer wrote 8 years ago
[PATCH 2/4] gnu: emacs-helm: Update to 2.7.0.
(address . 26968@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170517191432.2639-2-kyle@kyleam.com
* gnu/packages/emacs.scm (emacs-helm): Update to 2.7.0.
---
gnu/packages/emacs.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 17d00ddd1..7e04bb907 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3361,7 +3361,7 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(define-public emacs-helm
(package
(name "emacs-helm")
- (version "1.9.8")
+ (version "2.7.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3370,7 +3370,7 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "019dpzr6l83k1fgxn40aqxjvrpz4dl5d9vi7fc5wjnifmxaqxia6"))))
+ "1scdirpclgq3pi1j2c90gqaaqg1pgvasp98f4jqw8c5xbqcr7jdw"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-async" ,emacs-async)
--
2.13.0
Kyle Meyer wrote 8 years ago
[PATCH 3/4] gnu: Add emacs-helm-swoop.
(address . 26968@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170517191432.2639-3-kyle@kyleam.com
* gnu/packages/emacs.scm (emacs-helm-swoop): New variable.
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7e04bb907..66eaea518 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3387,6 +3387,30 @@ considered to be its successor. Helm sets out to clean up the legacy code in
not tied in the trap of backward compatibility.")
(license license:gpl3+)))
+(define-public emacs-helm-swoop
+ (package
+ (name "emacs-helm-swoop")
+ (version "1.7.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ShingoFukuyama/helm-swoop/archive/"
+ version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z34pfi0gsk054pxr906ilaalaw0xz3s536163gf9ykkwmc2356d"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/ShingoFukuyama/helm-swoop")
+ (synopsis "Filter and jump to lines in an Emacs buffer using Helm")
+ (description
+ "This package builds on the Helm interface to provide several commands
+for search-based navigation of buffers.")
+ (license license:gpl2+)))
+
(define-public emacs-cider
(package
(name "emacs-cider")
--
2.13.0
Kyle Meyer wrote 8 years ago
[PATCH 4/4] gnu: Add emacs-helm-projectile.
(address . 26968@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170517191432.2639-4-kyle@kyleam.com
* gnu/packages/emacs.scm (emacs-helm-projectile): New variable.
---
gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 66eaea518..4a0d20c9f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3411,6 +3411,31 @@ not tied in the trap of backward compatibility.")
for search-based navigation of buffers.")
(license license:gpl2+)))
+(define-public emacs-helm-projectile
+ (package
+ (name "emacs-helm-projectile")
+ (version "0.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/bbatsov/helm-projectile/archive/v"
+ version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19cfmilqh8kbab3b2hmx6lyrj73q6vfmn3p730x95g23iz16mnd5"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-helm" ,emacs-helm)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/bbatsov/helm-projectile")
+ (synopsis "Helm integration for Projectile")
+ (description
+ "This Emacs library provides a Helm interface for Projectile.")
+ (license license:gpl3+)))
+
(define-public emacs-cider
(package
(name "emacs-cider")
--
2.13.0
Ludovic Courtès wrote 8 years ago
Re: bug#26968: [PATCH 1/4] gnu: emacs-async: Update to 1.9.2.
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 26968@debbugs.gnu.org)
87shk25qdl.fsf@gnu.org
Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-async): Update to 1.9.2.

Applied, thanks!

Ludo’.
Ludovic Courtès wrote 8 years ago
Re: bug#26968: [PATCH 2/4] gnu: emacs-helm: Update to 2.7.0.
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 26968@debbugs.gnu.org)
87o9uq5qco.fsf@gnu.org
Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-helm): Update to 2.7.0.

Applied, thanks!
Ludovic Courtès wrote 8 years ago
Re: bug#26968: [PATCH 3/4] gnu: Add emacs-helm-swoop.
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 26968@debbugs.gnu.org)
87k25e5qat.fsf@gnu.org
Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-helm-swoop): New variable.

Applied, thanks!
Ludovic Courtès wrote 8 years ago
Re: bug#26968: [PATCH 4/4] gnu: Add emacs-helm-projectile.
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 26968-done@debbugs.gnu.org)
87efvm5q9h.fsf@gnu.org
Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-helm-projectile): New variable.

Applied, thanks! :-)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26968@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26968
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help