[PATCH] gnu: emacspeak: Update to 46.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170515192148.15539-1-kei@openmailbox.org
* gnu/packages/emacs.scm (emacspeak): Update to 46.0.
[source]: Add snippet to delete pre-compiled Emacs Lisp files.
[arguments]: Adjust phases for the update.
---
gnu/packages/emacs.scm | 52 ++++++++++++++++++++++++++++++++------------------
1 file changed, 33 insertions(+), 19 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3d9e83713..228b2a47f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4145,7 +4145,7 @@ jQuery and Bootstrap resources included via osscdn.")
(define-public emacspeak
(package
(name "emacspeak")
- (version "45.0")
+ (version "46.0")
(source
(origin
(method url-fetch)
@@ -4154,7 +4154,11 @@ jQuery and Bootstrap resources included via osscdn.")
version "/emacspeak-" version ".tar.bz2"))
(sha256
(base32
- "0npcr867xbbhwa0i7v26hnk4z2d51522jwcfwc594j74kbv3g6ka"))))
+ "15x4yfp3wl2fxm1nkx6pz3clw6zyw3argcsqxgcx6pa28sivlg2n"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Delete the bundled byte-compiled elisp files.
+ '(for-each delete-file (find-files "lisp" "\\.elc$")))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "prefix="
@@ -4162,25 +4166,35 @@ jQuery and Bootstrap resources included via osscdn.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("\\$\\(INSTALL\\) -d \\$\\(libdir\\)/servers/linux-outloud")
- "")
- (("\\$\\(INSTALL\\) -m 755 \\$\\{OUTLOUD\\}.*$") "")
- (("\\*info\\*") "*"))
- (substitute* "etc/emacspeak.sh.def"
- (("<emacspeak-dir>")
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/emacspeak/lisp")))
+ (lambda _
+ ;; Configure Emacspeak according to etc/install.org.
(zero? (system* "make" "config"))))
- (add-after 'install 'install-espeak-server
+ (add-after 'build 'build-espeak
+ (lambda _
+ (zero? (system* "make" "espeak"))))
+ (replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion "servers/linux-espeak"
- (and (zero? (system* "make"))
- (zero? (system* "make" "install"
- (string-append "PREFIX=" out))))))))
- (add-after 'install-espeak-server 'wrap-program
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lisp (string-append out "/share/emacs/site-lisp/emacspeak"))
+ (info (string-append out "/share/info")))
+ ;; According to etc/install.org, the Emacspeak directory should
+ ;; be copied to its installation destination.
+ (for-each
+ (lambda (file)
+ (copy-recursively file (string-append lisp "/" file)))
+ '("etc" "info" "lisp" "media" "servers" "sounds" "stumpwm"
+ "xsl"))
+ ;; Make sure emacspeak is loaded from the correct directory.
+ (substitute* "etc/emacspeak.sh"
+ (("exec emacs.*$")
+ (string-append "exec emacs -l " lisp
+ "/lisp/emacspeak-setup.el $CL_ALL")))
+ ;; Install the convenient startup script.
+ (mkdir-p bin)
+ (copy-file "etc/emacspeak.sh" (string-append bin "/emacspeak")))
+ #t))
+ (add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(emacspeak (string-append out "/bin/emacspeak"))
--
2.12.2
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26944@debbugs.gnu.org)
8737c47f2j.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/emacs.scm (emacspeak): Update to 46.0.
> [source]: Add snippet to delete pre-compiled Emacs Lisp files.
> [arguments]: Adjust phases for the update.

LGTM, thanks!

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26944-done@debbugs.gnu.org)
87efvoh8l3.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (10 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * gnu/packages/emacs.scm (emacspeak): Update to 46.0.
>> [source]: Add snippet to delete pre-compiled Emacs Lisp files.
>> [arguments]: Adjust phases for the update.
>
> LGTM, thanks!
>
> Ludo’.

Okay! Pushed as 231e48d6db692910b1a8c94fdc954f2721329211.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkbW0kACgkQ5qXuPBlG
eg3eUg/9FX9CpBkyxerAyjtOIRAqJcgS5nlD4YA/MkFlfwciCj/hE7+ZZ6RuQD4z
KXhgx+A5F8hON6ZMg1YqWcgQY2/5skhFjWQjbKohST1msz/0aiIviqoKsV3KVks1
IwkkeLZxcSYIGpTloI1/tPPAKHxqYh1Sf9Bak0txS+ERz3an/0jw3OZ7rOeIo86G
4CxJigpfNoR4IDVG6fdIOgrmVdzJIys5UZfDD0ZTGY1lZDIsVNg48FLKYnnJ3POa
NwJy+hGlGJWH7kX3x/PjycqjnJdQxYz2P9ln5uZQUEEpD+/R8gYFJrsFFrR9z1El
s+NZNDKl68CehAZndVL/l/MNOSAX35U9t3FZujvg2mEdZi/VK/Jl/JXxelNu5M56
O+F7U+Y9yX0+3NWZGxHg9UaWjQrhoGETBn926p1S3qZPT2pebd4mHxfg2ClEJ73l
coJBjA1wFgEQI9KzVtYCrGNIuEbXllFE9UU1WN5I8LgdS6+rKZ09Br/yMibWN6q/
MSYry3XQWpzQ/MBhM0G3yN/8d1kAryhqzI5G1OcLpPrpy51NpDSrdoHNHsJjlZP1
VYvobyWJOhZpBnD+vakZ40jj4Jn28gv6M5+XAVbW1HtwsVQH7etXPql88ioB6DkJ
jQZ+5BFRvHf2lxIL7Qe+jkRQGdFgtQ5sLLjbj3hD4TezHGMh6Wc=
=c9TT
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26944@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26944
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help