Add SSSD

  • Done
  • quality assurance status badge
Details
4 participants
  • Leo Famulari
  • Mathieu Othacehe
  • Marius Bakke
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 15 May 2017 15:58
(address . guix-patches@gnu.org)
87fug6w7ba.fsf@elephly.net
Hi Guix,

the following three patches add SSSD, the system security services
daemon.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 15 May 2017 16:01
[PATCH 1/3] gnu: Add http-parser.
(address . 26940@debbugs.gnu.org)(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
20170515140122.26545-1-rekado@elephly.net
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>

* gnu/packages/web.scm (http-parser): New variable.
---
gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index efaa1b574..20cf0ab95 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4552,3 +4552,35 @@ into your tests. It automatically starts up a HTTP server in a separate thread
(define-public python2-pytest-httpbin
(package-with-python2 python-pytest-httpbin))
+
+(define-public http-parser
+ (package
+ (name "http-parser")
+ (version "2.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nodejs/http-parser/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cw6nf8xy4jhib1w0jd2y0gpqjbdasg8b7pkl2k2vpp54k9rlh3h"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags
+ (list (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ "CC=gcc" "library")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/nodejs/http-parser")
+ (synopsis "HTTP request/response parser for C")
+ (description "This is a parser for HTTP messages written in C. It parses
+both requests and responses. The parser is designed to be used in performance
+HTTP applications. It does not make any syscalls nor allocations, it does not
+buffer data, it can be interrupted at anytime. Depending on your architecture,
+it only requires about 40 bytes of data per message stream (in a web server
+that is per connection).")
+ (license l:expat)))
--
2.11.1
R
R
Ricardo Wurmus wrote on 15 May 2017 16:01
[PATCH 3/3] gnu: Add sssd.
(address . 26940@debbugs.gnu.org)(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
20170515140122.26545-3-rekado@elephly.net
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>

* gnu/packages/sssd.scm (sssd): New variable.
---
gnu/packages/sssd.scm | 122 +++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 121 insertions(+), 1 deletion(-)

Toggle diff (139 lines)
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 8166b6dda..f9c547828 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -22,7 +22,30 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages adns)
+ #:use-module (gnu packages augeas)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages dns)
+ #:use-module (gnu packages docbook)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnuzilla)
+ #:use-module (gnu packages libunistring)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages kerberos)
+ #:use-module (gnu packages openldap)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages pcre)
+ #:use-module (gnu packages popt)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages samba)
+ #:use-module (gnu packages selinux)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xml))
(define-public ding-libs
(package
@@ -50,3 +73,100 @@ dynamically-growing, reference-counted array; libbasicobjects, a set of
fundamental object types for C ")
(license license:lgpl3+)))
+;; Note: This package installs modules for ldb and nss. For the former we
+;; need to set LDB_MODULES_PATH. For the latter LD_PRELOAD or LD_LIBRARY_PATH
+;; is needed.
+(define-public sssd
+ (package
+ (name "sssd")
+ (version "1.15.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://releases.pagure.org/SSSD/sssd/"
+ "sssd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r6j28f7vjb1aw65gkw4nz2l3jy605h7wsr1k815hynp2jrzrmac"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "DOCBOOK_XSLT="
+ (assoc-ref %build-inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")
+ ;; Remove "--postvalid" option, because that requires access to
+ ;; online DTDs.
+ "XMLLINT_FLAGS = --catalogs --nonet --noent --xinclude --noout")
+ #:configure-flags
+ (list "--disable-cifs-idmap-plugin"
+ "--without-nfsv4-idmapd-plugin"
+ "--without-python2-bindings"
+ "--without-python3-bindings"
+ (string-append "--with-plugin-path="
+ (assoc-ref %outputs "out")
+ "/lib/sssd")
+ (string-append "--with-krb5-plugin-path="
+ (assoc-ref %outputs "out")
+ "/lib/krb5/plugins/libkrb5")
+ (string-append "--with-cifs-plugin-path="
+ (assoc-ref %outputs "out")
+ "/lib/cifs-utils")
+ (string-append "--with-init-dir="
+ (assoc-ref %outputs "out")
+ "/etc/init.d")
+ (string-append "--with-ldb-lib-dir="
+ (assoc-ref %outputs "out")
+ "/lib/ldb/modules/ldb")
+ (string-append "--with-xml-catalog-path="
+ (assoc-ref %build-inputs "docbook-xml")
+ "/xml/dtd/docbook/catalog.xml"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "src/tests/responder_socket_access-tests.c"
+ (("tcase_add_test\\(tc_utils, resp_str_to_array_test\\);") ""))
+ #t)))))
+ (inputs
+ `(("augeas" ,augeas)
+ ("bind" ,bind "utils")
+ ("c-ares" ,c-ares)
+ ("curl" ,curl)
+ ("cyrus-sasl" ,cyrus-sasl)
+ ("dbus" ,dbus)
+ ("ding-libs" ,ding-libs)
+ ("glib" ,glib)
+ ("gnutls" ,gnutls)
+ ("http-parser" ,http-parser)
+ ("jansson" ,jansson)
+ ("ldb" ,ldb)
+ ("libselinux" ,libselinux)
+ ("libsemanage" ,libsemanage)
+ ("libunistring" ,libunistring)
+ ("linux-pam" ,linux-pam)
+ ("mit-krb5" ,mit-krb5)
+ ("nss" ,nss)
+ ("openldap" ,openldap)
+ ("openssl" ,openssl)
+ ("pcre" ,pcre)
+ ("popt" ,popt)
+ ("samba" ,samba)
+ ("talloc" ,talloc)
+ ("tdb" ,tdb)
+ ("tevent" ,tevent)))
+ (native-inputs
+ `(("check" ,check)
+ ("docbook-xsl" ,docbook-xsl)
+ ("docbook-xml" ,docbook-xml)
+ ("libxslt" ,libxslt)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://pagure.io/SSSD/sssd/")
+ (synopsis "System security services daemon")
+ (description "SSSD is a system daemon. Its primary function is to provide
+access to identity and authentication remote resource through a common
+framework that can provide caching and offline support to the system. It
+provides PAM and NSS modules, and in the future will D-BUS based interfaces
+for extended user information. It also provides a better database to store
+local users as well as extended user data.")
+ (license license:gpl3+)))
--
2.11.1
R
R
Ricardo Wurmus wrote on 15 May 2017 16:01
[PATCH 2/3] gnu: Add ding-libs.
(address . 26940@debbugs.gnu.org)(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
20170515140122.26545-2-rekado@elephly.net
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>

* gnu/packages/sssd.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/sssd.scm | 52 +++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 53 insertions(+)
create mode 100644 gnu/packages/sssd.scm

Toggle diff (72 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 28a283ab7..52fb6f510 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -356,6 +356,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/speech.scm \
%D%/packages/spice.scm \
%D%/packages/ssh.scm \
+ %D%/packages/sssd.scm \
%D%/packages/stalonetray.scm \
%D%/packages/statistics.scm \
%D%/packages/storage.scm \
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
new file mode 100644
index 000000000..8166b6dda
--- /dev/null
+++ b/gnu/packages/sssd.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sssd)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+(define-public ding-libs
+ (package
+ (name "ding-libs")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://releases.pagure.org/SSSD/ding-libs/"
+ "ding-libs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bczkvq7cblp75kqn6r2d7j5x7brfw6wxirzc6d2rkyb80gj2jkn"))))
+ (build-system gnu-build-system)
+ (home-page "https://pagure.io/SSSD/ding-libs/")
+ (synopsis "Libraries for SSSD")
+ (description
+ "DING-LIBS (DING Is Not Glib) are a set of small, useful libraries that
+the @dfn{System Security Services Daemon} (SSSD) uses and makes available to
+other projects. They include: libdhash, an implementation of a dynamic hash
+table which will dynamically resize to achieve optimal storage and access time
+properties; ini_config, a library for parsing and managing @code{INI} files;
+path_utils, a library to manage UNIX paths and subsets of paths; collection, a
+generic, hierarchical grouping mechanism for complex data sets; ref_array, a
+dynamically-growing, reference-counted array; libbasicobjects, a set of
+fundamental object types for C ")
+ (license license:lgpl3+)))
+
--
2.11.1
M
M
Marius Bakke wrote on 15 May 2017 19:41
Re: bug#26940: [PATCH 1/3] gnu: Add http-parser.
(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
87inl2dnlg.fsf@fastmail.com
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (2 lines)
> * gnu/packages/web.scm (http-parser): New variable.

[...]

Toggle quote (7 lines)
> + (description "This is a parser for HTTP messages written in C. It parses
> +both requests and responses. The parser is designed to be used in performance
> +HTTP applications. It does not make any syscalls nor allocations, it does not
> +buffer data, it can be interrupted at anytime. Depending on your architecture,
> +it only requires about 40 bytes of data per message stream (in a web server
> +that is per connection).")

Some missing spaces in the description here. The sentences also read a
bit weird, should it be "high-performance HTTP applications"? Or
performant? Maybe just "fast"? LGTM with cosmetic fix.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkZ6EsACgkQoqBt8qM6
VPq6Zwf+NJThMwl/ph2QBPWSQxRkq2pMN7iWKCqixjUFKZpIX/GqE2rbsZ+9dqdA
L4PbUCt20nlFUb2Z89NwUqVVGs/1XUrBV1NHG4LRkMzwyQLe9YAE7Cv/LMT/Vliy
Wg74dAz6T34PiBbmZfKojSqMc9ZB6ncYNxE4DuACUk8tbtDoRlY8ShCwSbl7vXir
Q2HOmHfnDqlg6ZsQnhKmOiDxgDR9hbGgx0OzyCSFNItUKv+2q4LNtuTlESlPYDxt
AoO6GnqfZyhRNH/eTDbNaWIru6XUSyGHyGmWdAN1RbzA5NIVdpuA+ZCbvL3I/ZCk
A/EDH0PQc35v5mqwoyaWf/4m7eZ4ow==
=Tsoi
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 15 May 2017 19:43
Re: bug#26940: [PATCH 2/3] gnu: Add ding-libs.
(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
87fug6dniz.fsf@fastmail.com
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (78 lines)
> From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
>
> * gnu/packages/sssd.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
> ---
> gnu/local.mk | 1 +
> gnu/packages/sssd.scm | 52 +++++++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 53 insertions(+)
> create mode 100644 gnu/packages/sssd.scm
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 28a283ab7..52fb6f510 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -356,6 +356,7 @@ GNU_SYSTEM_MODULES = \
> %D%/packages/speech.scm \
> %D%/packages/spice.scm \
> %D%/packages/ssh.scm \
> + %D%/packages/sssd.scm \
> %D%/packages/stalonetray.scm \
> %D%/packages/statistics.scm \
> %D%/packages/storage.scm \
> diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
> new file mode 100644
> index 000000000..8166b6dda
> --- /dev/null
> +++ b/gnu/packages/sssd.scm
> @@ -0,0 +1,52 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages sssd)
> + #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix packages)
> + #:use-module (guix download)
> + #:use-module (guix utils)
> + #:use-module (guix build-system gnu)
> + #:use-module (gnu packages))
> +
> +(define-public ding-libs
> + (package
> + (name "ding-libs")
> + (version "0.6.0")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://releases.pagure.org/SSSD/ding-libs/"
> + "ding-libs-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1bczkvq7cblp75kqn6r2d7j5x7brfw6wxirzc6d2rkyb80gj2jkn"))))
> + (build-system gnu-build-system)
> + (home-page "https://pagure.io/SSSD/ding-libs/")
> + (synopsis "Libraries for SSSD")
> + (description
> + "DING-LIBS (DING Is Not Glib) are a set of small, useful libraries that
> +the @dfn{System Security Services Daemon} (SSSD) uses and makes available to
> +other projects. They include: libdhash, an implementation of a dynamic hash
> +table which will dynamically resize to achieve optimal storage and access time
> +properties; ini_config, a library for parsing and managing @code{INI} files;
> +path_utils, a library to manage UNIX paths and subsets of paths; collection, a
> +generic, hierarchical grouping mechanism for complex data sets; ref_array, a
> +dynamically-growing, reference-counted array; libbasicobjects, a set of
> +fundamental object types for C ")
^^^
Missing punctuation? LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkZ6KQACgkQoqBt8qM6
VPo8ewgAiEsTxx3Bp9iFWnKR0I2NKGfhFEtljszMAllSdeB9RD5el79P7BZ93tgU
b5B8ds+ygRd7IHX9U1dsZxnhEqy4dXlULz4dBzD0EZfFeUEsvPZzKYYwGwJE+9XB
vAJKGLazNcv9IlPdC39oJGm4bRJ2RCsUTWYFCCGNS+r1RiVpWiX5YUxnCQnhltwh
xxItU2KSOnLa6+QbQI+vxXuiFsRbEeQB6SV9VJbenBkRs5mZvmDXH4uGNUM45dKF
woW8uydd8KCm09fQZfkj/UO+DwQbKbyWqNipdltN5mF+doBS3ucmivpAvH8+pYmR
wyK626cKnDphHS3zugLVByjQKLWvTA==
=wO/W
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 15 May 2017 19:44
Re: bug#26940: [PATCH 3/3] gnu: Add sssd.
(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
87d1badng4.fsf@fastmail.com
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (2 lines)
> * gnu/packages/sssd.scm (sssd): New variable.

Awesome, LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkZ6QsACgkQoqBt8qM6
VPpjXAf/fOcEORk2fabq7dX8un5yUEtt311Mv4rXKUR1TE8wGenbMasBrYPsxLqC
zYwOoUdBF9KSpJ6SF5NorGIZ4S0hk28XevYExGq16x46iFYgTG54LYn+5Zdcll23
Grw86TDlTFVOimyaImoEG7jFkzwWpjPC0NI2Diy61Z9pn9RlCy3Itq6MbW62xpDq
hk5IRYCanyru3dxe1HsVnfRdQwBoKrNnVOAc798iQThGvq+ijK3NmvDwwtLFQAQh
Q2M2H81SqjoyO2wtEIKDwjIwM24vm09+bCIdAkRiV6HHoCcnOatyEiAa079pJ550
dPo3ks3lWdar46uPXQ6oMK6OneWB1A==
=vtaz
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 15 May 2017 21:26
Re: bug#26940: [PATCH 1/3] gnu: Add http-parser.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26940@debbugs.gnu.org)
87efvp7wha.fsf@elephly.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (17 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> * gnu/packages/web.scm (http-parser): New variable.
>
> [...]
>
>> + (description "This is a parser for HTTP messages written in C. It parses
>> +both requests and responses. The parser is designed to be used in performance
>> +HTTP applications. It does not make any syscalls nor allocations, it does not
>> +buffer data, it can be interrupted at anytime. Depending on your architecture,
>> +it only requires about 40 bytes of data per message stream (in a web server
>> +that is per connection).")
>
> Some missing spaces in the description here. The sentences also read a
> bit weird, should it be "high-performance HTTP applications"? Or
> performant? Maybe just "fast"? LGTM with cosmetic fix.

Thanks for the suggestions!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 15 May 2017 21:33
Re: bug#26940: [PATCH 3/3] gnu: Add sssd.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26940-done@debbugs.gnu.org)
87d1b97w9e.fsf@elephly.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (6 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> * gnu/packages/sssd.scm (sssd): New variable.
>
> Awesome, LGTM!

Thank you for the review! I’ve pushed the patch set after making the
changes you suggested.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
L
L
Leo Famulari wrote on 15 May 2017 22:33
20170515203344.GA5194@jasmine
On Mon, May 15, 2017 at 09:33:04PM +0200, Ricardo Wurmus wrote:
Toggle quote (7 lines)
>
> Marius Bakke <mbakke@fastmail.com> writes:
>
> > Ricardo Wurmus <rekado@elephly.net> writes:
> >
> >> * gnu/packages/sssd.scm (sssd): New variable.

I get this warning now:

WARNING: (gnu packages sssd): imported module (gnu packages dns) overrides core binding `bind'

M
M
Mathieu Othacehe wrote on 15 May 2017 22:42
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87wp9honr5.fsf@gmail.com
Hi Ricardo,

I have the following warning while building sssd.scm :

Toggle snippet (3 lines)
WARNING: (gnu packages sssd): imported module (gnu packages dns) overrides core binding `bind'

Would the attached patch be ok ?

Thanks,

Mathieu
From c565786200e6f48bc59e8202205d7929d3791064 Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <m.othacehe@gmail.com>
Date: Mon, 15 May 2017 22:33:48 +0200
Subject: [PATCH] gnu: sssd: Fix bind redefinition.

* gnu/packages/sssd.scm (sssd): Add a "dns:" prefix to (gnu packages dns), to
prevent "bind" symbol redefinition.
---
gnu/packages/sssd.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 26d034790..a159da2bf 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
- #:use-module (gnu packages dns)
+ #:use-module ((gnu packages dns) #:prefix dns:)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages glib)
@@ -131,7 +132,7 @@ fundamental object types for C.")
#t)))))
(inputs
`(("augeas" ,augeas)
- ("bind" ,bind "utils")
+ ("bind" ,dns:bind "utils")
("c-ares" ,c-ares)
("curl" ,curl)
("cyrus-sasl" ,cyrus-sasl)
--
2.13.0
Closed
R
R
Ricardo Wurmus wrote on 15 May 2017 23:00
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
87lgpx6dla.fsf@elephly.net
Mathieu Othacehe <m.othacehe@gmail.com> writes:

Toggle quote (10 lines)
> Hi Ricardo,
>
> I have the following warning while building sssd.scm :
>
> --8<---------------cut here---------------start------------->8---
> WARNING: (gnu packages sssd): imported module (gnu packages dns) overrides core binding `bind'
> --8<---------------cut here---------------end--------------->8---
>
> Would the attached patch be ok ?

Thank you, this looks good. Please push it!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26940@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26940
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch