[PATCH 1/3] gnu: video: add libzen

  • Done
  • quality assurance status badge
Details
3 participants
  • Ethan R. Jones
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Ethan R. Jones
Severity
normal

Debbugs page

Ethan R. Jones wrote 8 years ago
(address . guix-patches@gnu.org)(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)
20170515025701.2492-1-doubleplusgood23@gmail.com
---
gnu/packages/video.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index dde404144..1eaba0dd5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2059,3 +2060,44 @@ file format that has been used as a multimedia file format in a variety of platf
applications. It is a very powerful and extensible format that can accommodate
practically any type of media.")
(license license:mpl1.1)))
+
+(define-public libzen
+ (package
+ (name "libzen")
+ (version "0.4.35")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://mediaarea.net/download/source/"
+ name
+ "/"
+ version
+ "/"
+ name
+ "_"
+ version
+ ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "12a1icgcffgv503ii2k1453kxg5hfly09mf4zjcc80aq8a6rf8by"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ ;; build scripts not in root of archive
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'pre-configure
+ (lambda _
+ (chdir "Project/GNU/Library")))
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://mediaarea.net/en/MediaInfo")
+ (synopsis "Library for libmediainfo")
+ (description "Shared library for libmediainfo and mediainfo.")
+ (license license:bsd-2)))
+
--
2.13.0
Ludovic Courtès wrote 8 years ago
(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)(address . 26934@debbugs.gnu.org)
87mvabwrg3.fsf@gnu.org
Hello Ethan,

Thanks for the patch set. Overall the patches look good to me modulo
minor issues that I’ll comment on:

"Ethan R. Jones" <doubleplusgood23@gmail.com> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/video.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 42 insertions(+)

Could you provide ChangeLog-style commit logs? See ‘git log’ for

Toggle quote (12 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://mediaarea.net/download/source/"
> + name
> + "/"
> + version
> + "/"
> + name
> + "_"
> + version
> + ".tar.bz2"))

Could you squeeze that on one or two lines?

Toggle quote (5 lines)
> + (native-inputs
> + `(("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("libtool" ,libtool)))

[...]

Toggle quote (4 lines)
> + (add-before 'configure 'autogen
> + (lambda _
> + (zero? (system* "./autogen.sh")))))))

Please double-check that this is needed. Usually, but not always,
projects that use Autoconf & co. provide self-contained tarballs such
that one doesn’t need to run ./autogen.sh.

Toggle quote (4 lines)
> + (synopsis "Library for libmediainfo")
> + (description "Shared library for libmediainfo and mediainfo.")

Could you improve the synopsis and description according to the
guidelines at

Please take a look at
haven’t already.

Could you send updated patches?

Thanks in advance!

Ludo’.
Ethan R. Jones wrote 8 years ago
(address . ludo@gnu.org)(address . 26934@debbugs.gnu.org)
874lwjt598.fsf@gmail.com
<#secure method=pgp mode=sign>
Thanks for the response.
Toggle quote (7 lines)
>> ---
>> gnu/packages/video.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 42 insertions(+)

>Could you provide ChangeLog-style commit logs? See ‘git log’ for
>examples and <https://gnu.org/s/guix/manual/html_node/Submitting-Patches.html>.

So I should independently `git add --patch` each addition, then do a multi-line
`git commit` like so:

gnu: foo: Update to 1.0.
* gnu/packages/foo.scm (foo): Update to 1.0
* gnu/packages/foo.scm (libbar): New shared library.

Toggle quote (2 lines)
>Could you squeeze that on one or two lines?

Is there a style on when to squeeze and when to not?

Toggle quote (2 lines)
>Please double-check that this is needed.

Yup, all packages lack a proper configure script.

Toggle quote (2 lines)
>Could you improve the synopsis and description

Do you have any ideas of what to add? I wasn't sure where to start
myself

Thanks!

dpg
Ludovic Courtès wrote 8 years ago
Re: bug#26934: [PATCH 1/3] gnu: video: add libzen
(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)(address . 26934@debbugs.gnu.org)
87fug2a62s.fsf@gnu.org
Hi Ethan,

doubleplusgood23@gmail.com (Ethan R. Jones) skribis:

Toggle quote (15 lines)
>>> ---
>>> gnu/packages/video.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
>>> 1 file changed, 42 insertions(+)
>
>>Could you provide ChangeLog-style commit logs? See ‘git log’ for
>>examples and <https://gnu.org/s/guix/manual/html_node/Submitting-Patches.html>.
>
> So I should independently `git add --patch` each addition, then do a multi-line
> `git commit` like so:
>
> gnu: foo: Update to 1.0.
>
> * gnu/packages/foo.scm (foo): Update to 1.0
> * gnu/packages/foo.scm (libbar): New shared library.

(“New variable”, not “new shared library”, because technically ‘libbar’
is a variable in foo.scm. :-)) But yes, as noted there, it should
typically be one patch per addition.

Toggle quote (4 lines)
>>Could you squeeze that on one or two lines?
>
> Is there a style on when to squeeze and when to not?

There’s no written guideline for that, but you can check what other
files do. Essentially, if this can fit in two 80-column lines rather
than 5 lines, just choose the former.

Toggle quote (4 lines)
>>Please double-check that this is needed.
>
> Yup, all packages lack a proper configure script.

OK, perfect.

Toggle quote (5 lines)
>>Could you improve the synopsis and description
>
> Do you have any ideas of what to add? I wasn't sure where to start
> myself

I don’t know those pieces of software, but a good start for the
description is typically their Web page or their ‘README’ file.

Thanks in advance!

Ludo’.
Ethan R. Jones wrote 8 years ago
(address . ludo@gnu.org)(address . 26934@debbugs.gnu.org)
87bmqjz46p.fsf@gmail.com
Hello, I resubmitted the patches, you'll probably want to close this bug.
Sorry for the wait.
Marius Bakke wrote 8 years ago
Re: bug#27044: [PATCH 1/3] gnu: video: Add libzen.
(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)(address . 27044@debbugs.gnu.org)(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)(address . 26934-done@debbugs.gnu.org)
87poeyw752.fsf@fastmail.com
"Ethan R. Jones" <doubleplusgood23@gmail.com> writes:

Toggle quote (25 lines)
> * gnu/packages/video.scm (libzen): New variable.
> ---
> gnu/packages/video.scm | 36 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 36 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index b7c26a042..bc3fa48b8 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -2052,3 +2052,39 @@ file format that has been used as a multimedia file format in a variety of platf
> applications. It is a very powerful and extensible format that can accommodate
> practically any type of media.")
> (license license:mpl1.1)))
> +
> +(define-public libzen
> + (package
> + (name "libzen")
> + (version "0.4.35")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://mediaarea.net/download/source/"
> + name "/" version "/"
> + name "_" version ".tar.bz2"))
> + (file-name (string-append name "-" version ".tar.bz2"))

Is it necessary to set a file-name here? IMO $name_$version is fine, but
the linter may have a different opinion.

Toggle quote (26 lines)
> + (sha256
> + (base32
> + "12a1icgcffgv503ii2k1453kxg5hfly09mf4zjcc80aq8a6rf8by"))))
> + (native-inputs
> + `(("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("libtool" ,libtool)))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:phases
> + ;; build scripts not in root of archive
> + (modify-phases %standard-phases
> + (add-before
> + 'configure 'pre-configure
> + (lambda _
> + (chdir "Project/GNU/Library")))
> + (add-before 'configure 'autogen
> + (lambda _
> + (zero? (system* "./autogen.sh")))))))
> + (home-page "https://github.com/MediaArea/ZenLib")
> + (synopsis "C++ utility library")
> + (description "ZenLib is a C++ utility library. It includes classes for handling
> +strings, configuration, bit streams, threading, translation, and cross-platform
> +operating system functions.")
> + (license license:bsd-2)))

I don't think video.scm is a good location for this package definition.
Though I'm not sure which module is most appropriate. Maybe 'code.scm'?
Or perhaps create a "cpp.scm" for these generic C++ libraries?

PS: No need to open separate bugs, you can just send the updated patches
here. Bonus points if you add a subject prefix like "PATCH v2" for the
next batch.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkltNkACgkQoqBt8qM6
VPpj/AgAv5nBjpCaxqqbRKwsMn5RRQbg+KgXY3ygM3B+ihLerBR5Yvk2d0K59tID
atIMYpouxT3LzowptfQzvfBMuYSk+hGLnfaJUfcAz1B4N/SM/TeMVrgf6eTJ5wcI
pu7Kr65N8/8S779i1E+cc2kcFBqJwuzL2UofdyvNJzohYN0usfV9h8FBQocf6t6o
aosRl10f70MYSwz5QNbFYpgeAw1lZQJlJn+PU+4BhhEobCJeax0dkoEHYFj+ypsO
4zR3LPfMS2zJbdJbuv6UDmLL6rPDtgkPC/0yISUDJTJCsfNOofBqrZliwag7ZRCa
euAJN3JT2ceKvIKxKOr3c9YK35k5BA==
=TBOv
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26934@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26934
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help