Ethan R. Jones wrote 8 years ago
(address . guix-patches@gnu.org)(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)
---
gnu/packages/search.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
Toggle diff (34 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 8651b985e..b23d57a60 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -235,6 +236,8 @@ conflict with slocate compatibility.")
;; swish-e to extend its features at runtime, but are not required for
;; building: xpdf, catdoc, MP3::Tag, Spreadsheet::ParseExcel,
;; HTML::Entities.
+ ;; FIXME Currently fails compliation with zlib and fails test with
+ ;; libxml2. See bug 25859
(inputs
`(("libxml" ,libxml2)
("zlib" ,zlib)
@@ -244,7 +247,9 @@ conflict with slocate compatibility.")
("perl-html-tagset" ,perl-html-tagset)
("perl-mime-types" ,perl-mime-types)))
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:configure-flags (list (string-append "--without-zlib")
+ (string-append "--without-libxml2"))
+ #:phases (modify-phases %standard-phases
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
--
2.13.0