[PATCH] gnu: Add python-behave-web-api.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
Blocked by

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170513085212.18768-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-behave-web-api, python2-behave-web-api):
New variables.
---
gnu/packages/python.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dc7adf24e..b6ccd2e95 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14621,3 +14621,35 @@ substitute for redis.")
(define-public python2-fakeredis
(package-with-python2 python-fakeredis))
+
+(define-public python-behave-web-api
+ (package
+ (name "python-behave-web-api")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "behave-web-api" version))
+ (sha256
+ (base32
+ "03kpq2xsy1gab3jy0dccbxlsg7vwfy4lagss0qldwmx3xz6b3i19"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dependencies
+ (lambda _
+ (substitute* "setup.py"
+ (("'wheel'") "") ; We don't use it.
+ (("'ordereddict==1.1'") ""))))))) ; Python >= 2.7 has it built-in.
+ (propagated-inputs
+ `(("behave" ,behave)
+ ("python-requests" ,python-requests)))
+ (home-page "https://github.com/jefersondaniel/behave-web-api")
+ (synopsis "Provides testing for JSON APIs with Behave for Python")
+ (description "This package provides testing utility modules for testing
+JSON APIs with Behave.")
+ (license license:expat)))
+
+(define-public python2-behave-web-api
+ (package-with-python2 python-behave-web-api))
Danny Milosavljevic wrote 8 years ago
python-behave-web-api depends on fixed python-parse-type (bug#26900)
(address . 26906@debbugs.gnu.org)
20170513111529.7ca3e3f7@scratchpost.org
Hi,

no idea how to add a dependency to a debbugs bug report.

So I'll just write it here:

In order for bug#26906 to work, you need bug#26900. Otherwise for python2-web-api you get an error message about "enum34" being missing.
Marius Bakke wrote 8 years ago
Re: bug#26906: python-behave-web-api depends on fixed python-parse-type (bug#26900)
87k25khllr.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (2 lines)
> no idea how to add a dependency to a debbugs bug report.

Send a "block X by Y" email body to control@debbugs.gnu.org :-)

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkXGWEACgkQoqBt8qM6
VPpuDgf+Py7YwmWHRIRfpHgXtEJyzoGIG0PJQJ+F6jY3s9k1KhmnTTd0Lw/hQVr9
JMMf/Nx3YY0w72mWaQEFUZFCPHQF6bVYC1Db1gnoA2dbK18sZfp2jjQZIbg2vyWJ
mglc83+hI8xanrD04APx2yzw8DkA1cKQBm55cfXmgqZe75mW2UoywHv04LkSaCpO
+/2WChQ2wxeDNxYELYGn9nEt/O1B1nqo7oWD0KnckJMiqm+3A9mHCiax4h3GVF7W
r/cnM9bFvNUDuIpdbfTasNx3EP9f32dQvGcCyCxJD3oqwFcyyZtkH+SdiPpWw0Bf
/sqLfDFMHnF4htwokZTHL9MHDej42A==
=3J/C
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170513174607.1d03b436@scratchpost.org
block 26906 by 26900
Danny Milosavljevic wrote 8 years ago
(address . control@debbugs.gnu.org)
20170525130429.537a9197@scratchpost.org
close 26900
close 26906
close 26999
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26906@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26906
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help