[PATCH] gnu: admin: add nnn.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ethan R. Jones
  • Marius Bakke
Owner
unassigned
Submitted by
Ethan R. Jones
Severity
normal

Debbugs page

Ethan R. Jones wrote 8 years ago
(address . guix-patches@gnu.org)(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)
20170513050043.21463-1-doubleplusgood23@gmail.com
---
gnu/packages/admin.scm | 51 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ff0431999..d16ef77df 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2130,3 +2130,54 @@ logo, or any ASCII file of your choice. The main purpose of Neofetch is to be
used in screenshots to show other users what operating system or distribution
you are running, what theme or icon set you are using, etc.")
(license license:expat)))
+
+(define-public nnn
+ (package
+ (name "nnn")
+ (version "v1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/jarun/nnn/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hww4385f81lyy30fx2rb4wchfi79dpgl7yylnfxvf27a4h2mkhm"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)
+ ("readline" ,readline)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases
+ ;; We do not provide `ncurses.h' within an `ncursesw'
+ ;; sub-directory, so patch the source accordingly. See
+ ;; <http://bugs.gnu.org/19018>.
+ ;; Thanks to gtypist maintainer.
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-curses-lib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("-lncursesw")
+ "-lncurses"))
+ (substitute* "nnn.c"
+ (("ncursesw\\/curses.h")
+ "ncurses.h")))
+ #t))
+ (delete 'configure))
+ #:make-flags
+ (list
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "-Wl,-rpath="
+ %output "/lib")
+ "CC=gcc")))
+ (home-page "https://github.com/jarun/nnn")
+ (synopsis "Terminal file browser")
+ (description "nnn is a fork of noice, a blazing-fast lightweight
+terminal file browser with easy keyboard shortcuts for navigation,
+opening files and running tasks. noice is developed considering
+terminal based systems. There is no config file and mime associations
+are hard-coded. However, the incredible user-friendliness and
+speed make it a perfect utility on modern distros.")
+ (license license:bsd-2)))
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)(address . 26903-done@debbugs.gnu.org)(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)
87h90ohhoe.fsf@fastmail.com
Hello Ethan!

Thanks for this patch! I updated the commit message to follow the
ChangeLog-style convention we use, and did some slight editorialisation:

@@ -2134,11 +2134,11 @@ you are running, what theme or icon set you are using, etc.")
(define-public nnn
(package
(name "nnn")
- (version "v1.1")
+ (version "1.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/jarun/nnn/"
- "archive/" version ".tar.gz"))
+ "archive/v" version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
@@ -2174,10 +2174,9 @@ you are running, what theme or icon set you are using, etc.")
"CC=gcc")))
(synopsis "Terminal file browser")
- (description "nnn is a fork of noice, a blazing-fast lightweight
-terminal file browser with easy keyboard shortcuts for navigation,
-opening files and running tasks. noice is developed considering
-terminal based systems. There is no config file and mime associations
-are hard-coded. However, the incredible user-friendliness and
-speed make it a perfect utility on modern distros.")
+ (description "@command{nnn} is a fork of @command{noice}, a blazing-fast
+lightweight terminal file browser with easy keyboard shortcuts for
+navigation, opening files and running tasks. There is no config file and
+mime associations are hard-coded. The incredible user-friendliness and speed
+make it a perfect utility on modern distros.")
(license license:bsd-2)))

Pushed as a76ca052d6e772164586bb1b4b2b8c69af783666 !
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkXLUEACgkQoqBt8qM6
VPq6oggAogmjEPQOZikFD0nsYfu2Gj29W/dd3GABEcItkhPMCRKXkR2VvZFc8aBS
oQjq7iNnruYW4xiWqHeyBN1TqWps6//1MWWZcWq3oEY0bG6jvFI09xOcwrJvrRRf
jUBlT8U6foCBkm0CjshW6iR/YehfO8OVmD8EOEGHWpnPvrdg45uOnxswSXsgZCDn
f/Hlzyog1AtxiZMMSm4oGcKutqrTA7s3imSRSjQHai8KhWRqJ0abWyLYvGhSnnws
jciP6GYKmgv3DisI6qr6SGEhNZu/jX5f/mpS+CjLOG1gMSjdNVpH2SyoZSt3Od0w
7+7Z5VwQjPsnnZXL+JsfRoTLK4Qp0Q==
=OcON
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26903@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26903
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help