[PATCH 01/11] gnu: libdrm: Update to 2.4.80.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)
20170511153021.14972-1-kei@openmailbox.org
From: Marius Bakke <mbakke@fastmail.com>

* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.80.
---
gnu/packages/xdisorg.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 89830a628..8d7f2195c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -277,7 +277,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.79")
+ (version "2.4.80")
(source
(origin
(method url-fetch)
@@ -287,7 +287,7 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "15xiwnicf7vl1l37k8nj0z496p7ln1qp8qws7q13ikiv54cz7an6"))
+ "1wa9cnzf60xwx67zq9ay48xr3j3sn1z80q77jpbzmkg906b52am8"))
(patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system)
(inputs
--
2.13.0
Kei Kebreau wrote 8 years ago
[PATCH 05/11] gnu: cogl: Enable wayland support.
(address . guix-patches@gnu.org)
20170511153021.14972-5-kei@openmailbox.org
* gnu/packages/gnome.scm (cogl)[inputs]: Add wayland.
[arguments]: Add "--enable-wayland-egl-platform" and
"--enable-wayland-egl-server".
---
gnu/packages/gnome.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7f8aa839d..e6a1e3ca5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2920,9 +2920,13 @@ throughout GNOME for API documentation).")
("cairo" ,cairo)
("pango" ,pango)
("gstreamer" ,gstreamer)
- ("gst-plugins-base" ,gst-plugins-base)))
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("wayland" ,wayland)))
(arguments
`(#:configure-flags (list "--enable-cogl-gst"
+ "--enable-wayland-egl-platform"
+ "--enable-wayland-egl-server"
+
;; Arrange to pass an absolute file name to
;; dlopen for libGL.so.
(string-append "--with-gl-libname="
--
2.13.0
Kei Kebreau wrote 8 years ago
[PATCH 06/11] gnu: gnome-desktop: Update to 3.24.1.
(address . guix-patches@gnu.org)
20170511153021.14972-6-kei@openmailbox.org
* gnu/packages/gnome.scm (gnome-desktop): Update to 3.24.1.
---
gnu/packages/gnome.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e6a1e3ca5..4a0274735 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -253,7 +253,7 @@ commonly used macros.")
(define-public gnome-desktop
(package
(name "gnome-desktop")
- (version "3.22.2")
+ (version "3.24.1")
(source
(origin
(method url-fetch)
@@ -262,7 +262,7 @@ commonly used macros.")
name "-" version ".tar.xz"))
(sha256
(base32
- "074yjz4g9gii045v2pl1ad34hcg92ci04ynxqcabwnf3lvvypmsi"))))
+ "1as5ri52n6wphvhqnxa813q15jri0x47hxsjikjcmb2big9vf2fy"))))
(build-system gnu-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
--
2.13.0
Kei Kebreau wrote 8 years ago
[PATCH 02/11] gnu: mesa: Update to 17.0.4.
(address . guix-patches@gnu.org)
20170511153021.14972-2-kei@openmailbox.org
From: Marius Bakke <mbakke@fastmail.com>

* gnu/packages/patches/mesa-skip-disk-cache-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gl.scm (mesa): Update to 17.0.4.
[source]: Adapt URI to new directory structure.
[arguments]: End phases on #t. Remove stray whitespaces.
[home-page]: Use HTTPS.
---
gnu/local.mk | 1 +
gnu/packages/gl.scm | 23 +++++++++++++---------
.../patches/mesa-skip-disk-cache-test.patch | 20 +++++++++++++++++++
3 files changed, 35 insertions(+), 9 deletions(-)
create mode 100644 gnu/packages/patches/mesa-skip-disk-cache-test.patch

Toggle diff (101 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 5822add4c..552dd0549 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -775,6 +775,7 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
+ %D%/packages/patches/mesa-skip-disk-cache-test.patch \
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
%D%/packages/patches/metabat-remove-compilation-date.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index bb2eb768e..f43f46439 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -217,17 +217,20 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "13.0.5")
+ (version "17.0.4")
(source
(origin
(method url-fetch)
- (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- version "/mesa-" version ".tar.xz"))
+ (uri (list (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+ "mesa-" version ".tar.xz")
+ (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+ version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "11zgynii1wz17131ml1mmblpwib8m88zz2jwi5h5llh1r3iagkmz"))
+ "0im3ca1vwwmkjf5w761vh7vabr4vrrdxpckr0wm974x18n2xqs8j"))
(patches
- (search-patches "mesa-wayland-egl-symbols-check-mips.patch"))))
+ (search-patches "mesa-wayland-egl-symbols-check-mips.patch"
+ "mesa-skip-disk-cache-test.patch"))))
(build-system gnu-build-system)
(propagated-inputs
`(("glproto" ,glproto)
@@ -281,7 +284,7 @@ also known as DXTn or DXTC) for Mesa.")
;; Without floating point texture support, drivers such as Nouveau
;; are stuck at OpenGL 2.1 instead of OpenGL 3.0+.
"--enable-texture-float"
-
+
;; Also enable the tests.
"--enable-gallium-tests"
@@ -301,7 +304,8 @@ also known as DXTn or DXTC) for Mesa.")
(substitute* "src/compiler/glsl/tests/lower_jumps/create_test_cases.py"
(("/usr/bin/env bash") (which "bash")))
(substitute* "src/intel/genxml/gen_pack_header.py"
- (("/usr/bin/env python2") (which "python")))))
+ (("/usr/bin/env python2") (which "python")))
+ #t))
(add-before
'build 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -325,8 +329,9 @@ also known as DXTn or DXTC) for Mesa.")
;; it's never installed since Mesa removed its
;; egl_gallium support.
(("\"gbm_dri\\.so")
- (string-append "\"" out "/lib/dri/gbm_dri.so")))))))))
- (home-page "http://mesa3d.org/")
+ (string-append "\"" out "/lib/dri/gbm_dri.so")))
+ #t))))))
+ (home-page "https://mesa3d.org/")
(synopsis "OpenGL implementation")
(description "Mesa is a free implementation of the OpenGL specification -
a system for rendering interactive 3D graphics. A variety of device drivers
diff --git a/gnu/packages/patches/mesa-skip-disk-cache-test.patch b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
new file mode 100644
index 000000000..437711047
--- /dev/null
+++ b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
@@ -0,0 +1,20 @@
+disk_cache_create() here looks up the users home directory from <pwd.h>
+which resolves to "/" in the build environment. I could not find an easy
+way to set the home directory to something else, so we disable this test
+for now.
+
+--- a/src/compiler/glsl/tests/cache_test.c
++++ b/src/compiler/glsl/tests/cache_test.c
+@@ -137,11 +137,6 @@
+ unsetenv("MESA_GLSL_CACHE_DIR");
+ unsetenv("XDG_CACHE_HOME");
+
+- cache = disk_cache_create();
+- expect_non_null(cache, "disk_cache_create with no environment variables");
+-
+- disk_cache_destroy(cache);
+-
+ /* Test with XDG_CACHE_HOME set */
+ setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
+ cache = disk_cache_create();
+
--
2.13.0
Kei Kebreau wrote 8 years ago
Re: bug#26887: [PATCH 01/11] gnu: libdrm: Update to 2.4.80.
(address . 26887@debbugs.gnu.org)
871srvjsh8.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

These patches are intended for gnome-updates. The first three are merged
from master. Also, the mutter patch is not functional yet, as it
probably requires some updated package from master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkUihMACgkQ5qXuPBlG
eg2DLBAAwpr5ziUOZjnWigS7ra0MJPVK9i5DMCxgKtSW7pM5hE5wu7z6ISDJ8qy5
vohqU32aDG9CbNI9CPJ36t+cAnQt095w6D4eEKO980hLdhJoM/DB/scimE+CB97S
nImygAgtyurksHn/54E6O53k+TB8vU0O3mZb2ptaF7hDNlxcnEykYYI7sxRHiz7x
piF1GuPGvTEVvR7WA4OyHhCcWUKz4d5BxE3mOgsgl8CwRMVNMsSwmA55IOr3ZuiT
UqWPGvsPicC4eG9N4pzWownEkdWMnRqsmLXVWFwo2gDjMLbBavl5oWWfaav9XweZ
+7s+VsPCGuhkOQMrjjNFUlaL8uEuB9cLSuPxxkTJd363db2rH2BOM103l9B5OP+4
KEUG5Qb0aLwfupXrmMm5PiHkbUD7WRzKz5T/LgqY14++7rtJZhBcrrmOJ5xLkEkY
2r7qiuHultrj8imw5c+veH9cefFWpDN1TUfNTvcCId+sOSLkSnoD3eqi8vUpn18F
BFWop8Sx1tkqgZv1WicARVv4itRHdaPBByWrxWVaRyejDKlv8pmD8nr7UUBug+WB
vkv+pF+jEgvYJkrfV/ZMa9PcRdORuCOxzXTrFDFkwcQsZ/jrLJhOLa+ixSuEYJJv
2KHw2a+vS+naqQD1nyaVCnV0Tb913aKdgGCyXOdpcCf2nVZKE/I=
=Z/xl
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
87r2zvjh1x.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (6 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
> These patches are intended for gnome-updates. The first three are merged
> from master. Also, the mutter patch is not functional yet, as it
> probably requires some updated package from master.

I think it's better to merge master directly instead of cherry-picking
these patches. We'd want to do that before starting it on Hydra anyway.

Would you like to do it? I think we can start building it shortly, Hydra
seems to have caught up with recent events. Maybe it'll be ready for the
release :)

Do you know if anything else remains after Mutter?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkUw+sACgkQoqBt8qM6
VPonMQgAit4Q1ILgY9czlb5ldvbPynD+EoMzYNyERYnUoo3KUIlk4G7oBDE82i5o
5xzd/2YF5QM4X6mjTCS+N/m3p9mQfYQP4ksWGfg8GStuwmFWYCM+9bl+B8xnzopB
ZtZClfh2MhxTuV4SVTpZbZ4NKdP/QbMzoDhS+GQOna53wrScjVlVzY0CFqSv3hjU
MjK4X+l7UX60vfqvJXkIUmA5YRXUi2N/cgGVVEDy28mrGCK8sYHUX3BkMGUmBI3E
vxr8+Ej+xL25p7oprC1UpK+obWMhm+XbuQR9Sr+oTgaYntDc4gZ+QSlBP02Nk/+2
DVM5WnuEz1Ykx8GgdVX0Qe87ZPN9eA==
=hqQh
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#26887: [PATCH 05/11] gnu: cogl: Enable wayland support.
87lgq3jglt.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (4 lines)
> * gnu/packages/gnome.scm (cogl)[inputs]: Add wayland.
> [arguments]: Add "--enable-wayland-egl-platform" and
> "--enable-wayland-egl-server".

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkUxi4ACgkQoqBt8qM6
VPrv/Qf/XoMGT/5pIbSpePHPeT2Q0GQrjZjFhilNQ1aJziwzfVFjjTmPfeXauyw7
aR+Fob9x/JZWo6lSXn7GQdIfatYJfjv7CggGxdq2Eipdji8zNwtM4Y4YEPf9mh/0
gecmhJ47oukMNT2GDJ+UdXfuSKVIri8zsvevBko9pbPE4QQIBBtKmFrpUG19gerh
X48Kbb6FIumYr9watAhmB789tv1ZpFVkakmHTKxtDMrM76t4dyU1cLZf+Rnmqz4f
5Jf+oorSD94SU4zbNPsaVtg+JgoezNJWQGLTBTNM6GRuEagygAgUVdl7AVSm1yBd
3hluJiPF2nxgUeUVOQEXmhsfOBALOA==
=K0bj
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
Re: bug#26887: [PATCH 01/11] gnu: libdrm: Update to 2.4.80.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26887@debbugs.gnu.org)
87lgq3i0s7.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (15 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>> These patches are intended for gnome-updates. The first three are merged
>> from master. Also, the mutter patch is not functional yet, as it
>> probably requires some updated package from master.
>
> I think it's better to merge master directly instead of cherry-picking
> these patches. We'd want to do that before starting it on Hydra anyway.
>
> Would you like to do it? I think we can start building it shortly, Hydra
> seems to have caught up with recent events. Maybe it'll be ready for the
> release :)
>
I can merge master and put these on top, though I can't test my patches
very quickly (building webkitgtk+ repeatedly on 10-year-old hardware \o/).
If your computer(s) are faster, I'd be more than happy to let you finish
this branch.

Toggle quote (2 lines)
> Do you know if anything else remains after Mutter?

Within the gnome meta-package, everything from gnome-shell down. If all
of those main packages can be upgraded, I'll be satisfied.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkUzIgACgkQ5qXuPBlG
eg0KzQ//fNH3lSV0bqt01NnGBrhk9ww6h6pJy5VDB8sY+QYnd1aSxKtkAfhtPhpJ
rF0GjxWK7ueAbGsxbpqzAeiQqIEmFltFpOz9j/tw2qMagrn1IiyJAjku9c0TMDxt
Ndt4UMynLWnHneEvLRN9EMtOEwBW3Sj4F6OQcAhaT+i7u0KMHqZdn7r84+oPqQ9U
WdZx37MEtLWK8dlm9t4QR1aVbSkbLG7SAFVIcxXBbuOwJIbAssK0ci2r39oqSHrB
Lnc5i1zeWDJKfV75nNiPzG1ukopW6jwxVha9QcEX8h9GdcC5aGob/eJDnfcGgFF8
ik+iFYnFMAjxwUZRZvsZ7Jf4ueRSm6m5BOX844hX3iUd/lhi4AHbhHLoLs2GSMV8
4h218089l+HdckqbMP2LoWn1DwbDxwxLlmhjpGHRsp7xiNGGtQ+Zp49Z/G/1VDmv
WwuudDjQO0KN124iNnvdfDN37Ucb6HtWdduzl43RVm11IhZLuTkj9ladE03rGu7T
TGg/ZPXyDoXc+/auAlhF4FEvmnUuf12sTEq9tisV7/P/ejErmy926PpaftyFu2op
ISEhsbcKZPHW7xgIfmhAKZ3saDA30x56zCyaaitwlH9YK/6yuolbiJ2yH6CERpLv
K1/4UP+YLnUV3WFXs+gCWjkGmRWE9IUIbnu84YByMgtte1bd4hs=
=UMjR
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26887@debbugs.gnu.org)
87fugbjcw2.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (22 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>
>>> These patches are intended for gnome-updates. The first three are merged
>>> from master. Also, the mutter patch is not functional yet, as it
>>> probably requires some updated package from master.
>>
>> I think it's better to merge master directly instead of cherry-picking
>> these patches. We'd want to do that before starting it on Hydra anyway.
>>
>> Would you like to do it? I think we can start building it shortly, Hydra
>> seems to have caught up with recent events. Maybe it'll be ready for the
>> release :)
>>
> I can merge master and put these on top, though I can't test my patches
> very quickly (building webkitgtk+ repeatedly on 10-year-old hardware \o/).
> If your computer(s) are faster, I'd be more than happy to let you finish
> this branch.

I think these patches look fine (see other comments), at least up to
mutter. I'd suggest merging master and adding the patches leading to
it, as long as everyone is fine with adding wayland as a hard dependency
of gtk+.

Then we can start an evaluation on Hydra to get some substitutes before
trying the mutter update :)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkU2P0ACgkQoqBt8qM6
VPo9jwf/bPl2TY2UJn20vSVYh668/jqsxibXJD4T+tvfIlt3iAs5Asxn9g0EkOLQ
Iq33P6bxFpHaXlJeDEKgEXqTcQJBovLEzdm/3+FN0bg9Mf21ocilI0OPjT3Kwhxx
mOMfo/nyIEvtHjk9X4vu9RddFr/SRtuZLhBzJz6QtXc0ybjWTz+j7ehTc4fbSZIy
RKPBsCtrcznE63yE87SkIltCj2j/4+l9UxT8E8bWR5D+lSuCQLk+2eQGdyp6WwlS
jextcNoLcHJDwvEiaquKdVJpqEX3ih45Q4RecXxd7fANi7dgsiFuLsOOoVg1Ta/r
15Z+3ODmg3W4WUUuWP/nCeAQ+6enCw==
=/4TR
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
87pofdhdgr.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (32 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Marius Bakke <mbakke@fastmail.com> writes:
>>
>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>
>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>
>>>> These patches are intended for gnome-updates. The first three are merged
>>>> from master. Also, the mutter patch is not functional yet, as it
>>>> probably requires some updated package from master.
>>>
>>> I think it's better to merge master directly instead of cherry-picking
>>> these patches. We'd want to do that before starting it on Hydra anyway.
>>>
>>> Would you like to do it? I think we can start building it shortly, Hydra
>>> seems to have caught up with recent events. Maybe it'll be ready for the
>>> release :)
>>>
>> I can merge master and put these on top, though I can't test my patches
>> very quickly (building webkitgtk+ repeatedly on 10-year-old hardware \o/).
>> If your computer(s) are faster, I'd be more than happy to let you finish
>> this branch.
>
> I think these patches look fine (see other comments), at least up to
> mutter. I'd suggest merging master and adding the patches leading to
> it, as long as everyone is fine with adding wayland as a hard dependency
> of gtk+.
>
> Then we can start an evaluation on Hydra to get some substitutes before
> trying the mutter update :)

Last call for objections to wayland as a hard dependency of gtk+ on the
gnome-updates branch! This will be committed in approximately 24 hours
otherwise.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkWQpUACgkQ5qXuPBlG
eg2u9w/+I+ytOCCeOTHuiieVoChDxiqaMLLgrVz+xi2058UhTMAkqQ9EVp5toSZ8
DG+LopMjs1wWPa//6/HJNDelbpZ3uJPRdmVWiq15woYD0QfS2wcKR4xKVHrljU7T
16idBlizhNwXaDfm8VUWQNqeYYELqSHGSzoFvkzwkfbjZjdo91y6uNxrjJnPMKvH
UmkgcZHixbDvC+8SImmqXCl3RuMdd3YTPp/KRgDwSVSEngV9St8ZSIjqSJzk9OZA
GO7DFgmPHNPfsM9guHvIP4ub2XQc7m/GlfPz6vMXlOz/RBAOGonkV6oUGwDGF5Xb
qqSL8Orp6WMfv+FkMzvijCIrVTM1R6Pa8698g8ggQpcP+28VEQZB6fCZlGUz+hNF
wI54jdsTFoXAYo5QbqldtOmzQWi5IUYJ0veEaN9cZ47Ih0ZMbJqGZa6bHl8sfVQm
lM6zQnu+fBldKKaarpUqG/yxplii1WEQGQz8xyLfrh+VQTYYeki3QiI9yBfNuzaG
V93A5jMKhW4q4KX4P0+iX4a8/lUjujBaSYGo9LQcl7/Anvxd/1MX0dmlogMFxliL
eTdH4RJCw0kOSsPQV3mH02Bvv78sIqjBWHlIHRbSQUgQMra7AQdGfLeYghN46r98
EOz9XWiqLNTl5O8aHPDfNFfEDpwjOG5jjhhgASbHHvY9ZRd11Zs=
=pfz8
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
87lgq0gwh3.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (38 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>
>>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>>
>>>>> These patches are intended for gnome-updates. The first three are merged
>>>>> from master. Also, the mutter patch is not functional yet, as it
>>>>> probably requires some updated package from master.
>>>>
>>>> I think it's better to merge master directly instead of cherry-picking
>>>> these patches. We'd want to do that before starting it on Hydra anyway.
>>>>
>>>> Would you like to do it? I think we can start building it shortly, Hydra
>>>> seems to have caught up with recent events. Maybe it'll be ready for the
>>>> release :)
>>>>
>>> I can merge master and put these on top, though I can't test my patches
>>> very quickly (building webkitgtk+ repeatedly on 10-year-old hardware \o/).
>>> If your computer(s) are faster, I'd be more than happy to let you finish
>>> this branch.
>>
>> I think these patches look fine (see other comments), at least up to
>> mutter. I'd suggest merging master and adding the patches leading to
>> it, as long as everyone is fine with adding wayland as a hard dependency
>> of gtk+.
>>
>> Then we can start an evaluation on Hydra to get some substitutes before
>> trying the mutter update :)
>
> Last call for objections to wayland as a hard dependency of gtk+ on the
> gnome-updates branch! This will be committed in approximately 24 hours
> otherwise.

The gnome-updates branch has been updated! I'll be closing all of my
related bugs.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkXmJgACgkQ5qXuPBlG
eg09zBAAkVnreF1hoPm/jT39j1X8jyaxKNFJrM4N3xupQ/BCuvOfbdTHL8jmVOpD
uxHrz9n9oa4Kr5LlnbE2XVbHeUz8WvvusiToHc6mqJ72mY/3YF6VZRsSUwvqD3DI
pyy1AGHq7qFAMHXqiqJ/5hWNClk+hoP3CveB4hJE+xpm2EM3PYmXGvaeAwsZc3RQ
jjD8FJ0pOMeZi8DIjY7HgUaDcjQbIhdUBk7Q23cLMHMLZxd4fD4IKSuVbo6R9i3z
ibdwuewfy2385NKjnBxS5AiEQ3lq8QQcuQyXpzv5o/ZCKEabhBWZ/hiefZ5sZJ3C
pRyJBPy4KLcHvTQ5AAqoLKanQK3/0ncXhlR2PKjBLAesNXpfdRIKHOCBWfgUnWwk
UZ7lpKlVns2o6L7U48gt6ygap8p9ebF6AmNRrJsXbGr4PJ61sDLsycZUF0YkKTjf
QOMUArM2IgpSpVf2C2ILlbf5NN3cK3okDF6aVT4V80aSJg38DoIHCiOagK9BRXaq
VVTsI+z1nTQl0Vcc0TWS90V8UCivI/kcGv2GjWLqcCZdXal8Dj9WSMC8IkI6TF7+
a9tJ2Agi2ezCxbGa8IQ3VzkuwmLaipd9FLlSKzxmt7mkwQ61Xf3fFy7i3zVuqaMI
2BQ7g3ZJgp08ZIVq5AXkUCn2jzx6gZpFU16UuqFgjactgwrmaTw=
=BLVL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26887@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26887
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help