[PATCH 11/11] gnu: mutter: Update to 3.24.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)
20170511153021.14972-11-kei@openmailbox.org
* gnu/packages/gnome.scm (mutter): Update to 3.24.1.
[arguments]: Enable wayland and the native backend. Add "use-elogind"
phase.
[propagated-inputs]: Remove wayland and wayland-protocols.
[inputs]: Add elogind and libxtst.
---
gnu/packages/gnome.scm | 45 ++++++++++++++++++++++++---------------------
1 file changed, 24 insertions(+), 21 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f79b5351a..fbb15ba0a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4300,24 +4300,21 @@ to display dialog boxes from the commandline and shell scripts.")
(license license:lgpl2.0+)))
(define-public mutter
- ;; Uses the gnome 3.22 branch that only contains bug fixes.
- (let ((commit "23c315ea7121e9bd108e2837d0b4beeba53c5e18"))
(package
(name "mutter")
- (version (git-version "3.22.2" "1" commit))
+ (version "3.24.1")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.gnome.org/mutter")
- (commit commit)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
(sha256
(base32
- "1v1f9xyzjr1ihmfwpq9kzlv2lyr9qn63ck8zny699mbp5hsi11mb"))))
- ;; NOTE: Since version 3.21.x, mutter now bundles and exports forked
- ;; versions of cogl and clutter. As a result, many of the inputs,
- ;; propagated-inputs, and configure flags used in cogl and clutter are
- ;; needed here as well.
+ "093ax3ng7fv28qfkxpbvcx67mfiizwj5b4s17m5cmijwf3wpgamc"))))
+ ;; NOTE: Since version 3.21.x, mutter now bundles and exports forked
+ ;; versions of cogl and clutter. As a result, many of the inputs,
+ ;; propagated-inputs, and configure flags used in cogl and clutter are
+ ;; needed here as well.
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -4326,8 +4323,7 @@ to display dialog boxes from the commandline and shell scripts.")
;; implicit declaration of function ?roundf?
(list "--enable-compile-warnings=minimum"
- "--disable-wayland" ; TODO enable wayland
- ;; "--enable-native-backend" ; TODO enable the native backend
+ "--enable-native-backend"
;; The following flags are needed for the bundled clutter
"--enable-x11-backend=yes"
@@ -4340,8 +4336,15 @@ to display dialog boxes from the commandline and shell scripts.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi"))))
+ (add-before 'configure 'use-elogind
+ (lambda _
+ (substitute* (list "configure"
+ "src/backends/native/meta-launcher.c"
+ "src/core/main.c")
+ (("systemd") "elogind"))
+ #t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("gobject-introspection" ,gobject-introspection)
@@ -4374,17 +4377,17 @@ to display dialog boxes from the commandline and shell scripts.")
("mesa" ,mesa)
("pango" ,pango)
("udev" ,eudev)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)
("xinput" ,xinput)))
(inputs
- `(("gnome-desktop" ,gnome-desktop)
+ `(("elogind" ,elogind)
+ ("gnome-desktop" ,gnome-desktop)
("libcanberra-gtk" ,libcanberra)
("libgudev" ,libgudev)
("libice" ,libice)
("libsm" ,libsm)
("libxkbfile" ,libxkbfile)
("libxrandr" ,libxrandr)
+ ("libxtst" ,libxtst)
("startup-notification" ,startup-notification)
("upower-glib" ,upower)
("xkeyboard-config" ,xkeyboard-config)
@@ -4396,7 +4399,7 @@ to display dialog boxes from the commandline and shell scripts.")
desktop via OpenGL. Mutter combines a sophisticated display engine using the
Clutter toolkit with solid window-management logic inherited from the Metacity
window manager.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public gnome-online-accounts
(package
--
2.13.0
Marius Bakke wrote 8 years ago
87inl7jg7l.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (6 lines)
> * gnu/packages/gnome.scm (mutter): Update to 3.24.1.
> [arguments]: Enable wayland and the native backend. Add "use-elogind"
> phase.
> [propagated-inputs]: Remove wayland and wayland-protocols.
> [inputs]: Add elogind and libxtst.

This should also mention that the source is now a release download.

[...]

Toggle quote (9 lines)
> @@ -4340,8 +4336,15 @@ to display dialog boxes from the commandline and shell scripts.")
> #:phases
> (modify-phases %standard-phases
> (add-after 'unpack 'autoreconf
> - (lambda _
> - (zero? (system* "autoreconf" "-vfi")))))))
> + (lambda _
> + (zero? (system* "autoreconf" "-vfi"))))

...and this phase can likely be removed since we use a bootstrapped
release.

Toggle quote (7 lines)
> + (add-before 'configure 'use-elogind
> + (lambda _
> + (substitute* (list "configure"
> + "src/backends/native/meta-launcher.c"
> + "src/core/main.c")
> + (("systemd") "elogind"))

This looks like it potentially could cause some trouble, especially in
configure. Could you add a comment about what we are substituting here?

Other than that looks okay to me, thanks a lot for working on it.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkUyC4ACgkQoqBt8qM6
VPpnIwf9HoVpGPDO3OPl7CKgjYSUxG2WXo46K3bITYzO0I34Vt1W8zMlV1uSZImt
y0M35rYQuh0UhkN/H6TmOTuhTgOOZMmEblwtR8vBL9lHOpfTE6tZIyAv1xWUUM3a
JcEKIeyhza7tUgYAaxAQ4N7nGUyBkL6vs5gEImMVhX2wk70jp8Yif3X6P0i4k7Ke
I32A9j02NMSkpp9oWODfjgdg5akrpn2oBLYONfTu1U9z3DXnXBLpRzC5Np4eLvaO
/oMCwDcz81L/ypPQ0b2MLXgtOJ0iiSTret1496mRv8dBfNu/ZkaS6m9BloFVbXfs
dXG+VhZqxDcSpsS6x6msGkmB7Bliog==
=uNB5
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
Re: bug#26887: [PATCH 01/11] gnu: libdrm: Update to 2.4.80.
(name . Marius Bakke)(address . mbakke@fastmail.com)
87lgq0gwh3.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (38 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>
>>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>>
>>>>> These patches are intended for gnome-updates. The first three are merged
>>>>> from master. Also, the mutter patch is not functional yet, as it
>>>>> probably requires some updated package from master.
>>>>
>>>> I think it's better to merge master directly instead of cherry-picking
>>>> these patches. We'd want to do that before starting it on Hydra anyway.
>>>>
>>>> Would you like to do it? I think we can start building it shortly, Hydra
>>>> seems to have caught up with recent events. Maybe it'll be ready for the
>>>> release :)
>>>>
>>> I can merge master and put these on top, though I can't test my patches
>>> very quickly (building webkitgtk+ repeatedly on 10-year-old hardware \o/).
>>> If your computer(s) are faster, I'd be more than happy to let you finish
>>> this branch.
>>
>> I think these patches look fine (see other comments), at least up to
>> mutter. I'd suggest merging master and adding the patches leading to
>> it, as long as everyone is fine with adding wayland as a hard dependency
>> of gtk+.
>>
>> Then we can start an evaluation on Hydra to get some substitutes before
>> trying the mutter update :)
>
> Last call for objections to wayland as a hard dependency of gtk+ on the
> gnome-updates branch! This will be committed in approximately 24 hours
> otherwise.

The gnome-updates branch has been updated! I'll be closing all of my
related bugs.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkXmJgACgkQ5qXuPBlG
eg09zBAAkVnreF1hoPm/jT39j1X8jyaxKNFJrM4N3xupQ/BCuvOfbdTHL8jmVOpD
uxHrz9n9oa4Kr5LlnbE2XVbHeUz8WvvusiToHc6mqJ72mY/3YF6VZRsSUwvqD3DI
pyy1AGHq7qFAMHXqiqJ/5hWNClk+hoP3CveB4hJE+xpm2EM3PYmXGvaeAwsZc3RQ
jjD8FJ0pOMeZi8DIjY7HgUaDcjQbIhdUBk7Q23cLMHMLZxd4fD4IKSuVbo6R9i3z
ibdwuewfy2385NKjnBxS5AiEQ3lq8QQcuQyXpzv5o/ZCKEabhBWZ/hiefZ5sZJ3C
pRyJBPy4KLcHvTQ5AAqoLKanQK3/0ncXhlR2PKjBLAesNXpfdRIKHOCBWfgUnWwk
UZ7lpKlVns2o6L7U48gt6ygap8p9ebF6AmNRrJsXbGr4PJ61sDLsycZUF0YkKTjf
QOMUArM2IgpSpVf2C2ILlbf5NN3cK3okDF6aVT4V80aSJg38DoIHCiOagK9BRXaq
VVTsI+z1nTQl0Vcc0TWS90V8UCivI/kcGv2GjWLqcCZdXal8Dj9WSMC8IkI6TF7+
a9tJ2Agi2ezCxbGa8IQ3VzkuwmLaipd9FLlSKzxmt7mkwQ61Xf3fFy7i3zVuqaMI
2BQ7g3ZJgp08ZIVq5AXkUCn2jzx6gZpFU16UuqFgjactgwrmaTw=
=BLVL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26883@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26883
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help