[PATCH 04/11] gnu: gtk+: Enable wayland backend.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)
20170511153021.14972-4-kei@openmailbox.org
* gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon,
mesa, wayland and wayland-protocols.
[arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend"
to #:configure-flags.
---
gnu/packages/gtk.scm | 14 ++++++++++++--
1 file changed, 12 insertions(+), 2 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 985056b95..9732ee4cc 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages docbook)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -673,8 +674,12 @@ application suites.")
("libxcursor" ,libxcursor)
("libxi" ,libxi)
("libxinerama" ,libxinerama)
+ ("libxkbcommon" ,libxkbcommon)
("libxdamage" ,libxdamage)
- ("pango" ,pango)))
+ ("mesa" ,mesa)
+ ("pango" ,pango)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
(inputs
`(("libxml2" ,libxml2)
;; XXX: colord depends on mozjs (through polkit), which fails on
@@ -700,7 +705,12 @@ application suites.")
;; to "doc".
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
+ "/share/gtk-doc/html")
+ ;; The header file <gdk/gdkwayland.h> is required
+ ;; by gnome-control-center
+ "--enable-wayland-backend"
+ ;; This is necessary to build both backends.
+ "--enable-x11-backend")
#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
(lambda _
--
2.13.0
Marius Bakke wrote 8 years ago
87o9uzjgp5.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (5 lines)
> * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon,
> mesa, wayland and wayland-protocols.
> [arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend"
> to #:configure-flags.

Why do these inputs need to be propagated? Apart from that I think this
looks okay. Would like other opinions though.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkUxbYACgkQoqBt8qM6
VPoWzQgAw9YJleXY8I5u43Oq9jCoeixijT7dI1s56gQrfmXXkqnDouSm8dEfy5I8
WyjpLZuw400CASceNKE335AjW75SdVvSyuTrfKpZJ59+hNlUV9fZCuV/gAqC4khe
/QWIh4SURF+4dlrwu+b5dJe3ChUfknONRneEO7R7SlIuI/vg6XWkR3ESq9CDJQXM
nMchLwhx3XqAGVKFPR4+vObBr79vuqFd08eZHH/eEPJNHMKLGXcl3EC9ceh5tSTF
h6vWGyxmPhgHdTgyUR+6twVpbA6FF51HHPXMx9mmDYmBbytWB+NYiti7sRQJ2MMQ
vbkVwhQZqgZG9Sdht33b6iRPE6UnUA==
=n9uA
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26880@debbugs.gnu.org)
87a86jhz4v.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (10 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon,
>> mesa, wayland and wayland-protocols.
>> [arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend"
>> to #:configure-flags.
>
> Why do these inputs need to be propagated? Apart from that I think this
> looks okay. Would like other opinions though.

Many packages depending on gtk+ ended up needing these inputs. I can
sift through my gtk+ .pc files to see if propagation is absolutely necessary.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkU1OEACgkQ5qXuPBlG
eg0TixAAjCNjd3sjVDidCSA09KkeIeTzNROrOrzplv9wfppjdSnWZw5aZw2NIezu
R0/e0uQSNoBcB3jF4/6hBOERDh6d3x6cFvJbtNbBdJ3KH07bMNjsLNr7yKJwSaQE
q9PBbm/aqxVLLvaHeiNIjYkNjzwicvJP7QWDhw5HCYlZ48akoP9xOR00qEvojLaz
TKSKclL5BPuDZrciXfSiZ3CfvThoJwIEln67ctC5ahAQxy33qYWDA/KvX8aoYPCm
plGEUID6vJVkUE/wSIstSwA6f1KxwSZZ79/FIGVkX7nf071Jsydq548GHFVauH9q
3GhcargA2tttYueTedkySxmFioqK6++SEcbRZZfv1IJ/QDFrpQvvpYrbqK5/GfTu
f8k7OGh2GxTxphPDcJAjMzdCTqjiFAJilY1CCIxaCfSNFgAhhew68zyiFY0gvasV
nslFyuyJha5ZBm8LsYEzTIggZweSiImKmVKxzUk6r2DDl0eAtGv6zrstzWuZwUtN
SA0LQwycFjkx/WMRlKh1E1oL/h6pctqyqb3g8cIrddrnMGi1mwgNgDSJKz6s5bEg
c+5lfcCzfUZ7+sMZJyR+WbYO1DktYkRrj7UhQsPVQ4CVPWrDPnFeCfjG0mlPgvky
v4gdI078It96L37HmwYBTQHbcwPFWeqAWgnDZYta+UixHwxOF2A=
=JSBL
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26880@debbugs.gnu.org)
87d1bfjcsi.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (15 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon,
>>> mesa, wayland and wayland-protocols.
>>> [arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend"
>>> to #:configure-flags.
>>
>> Why do these inputs need to be propagated? Apart from that I think this
>> looks okay. Would like other opinions though.
>
> Many packages depending on gtk+ ended up needing these inputs. I can
> sift through my gtk+ .pc files to see if propagation is absolutely necessary.

That would be great. Maybe some of these should be propagated from
wayland instead.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkU2X0ACgkQoqBt8qM6
VPok4Qf+InUcONXmeHNwiwgJR2XUR73XtDSxwsyFwufv+TkJwu6v3DHMFnhkfsMf
guG+Abeslsk5J9X47zEhZqnsYiTG/3hcHX45jZrkAKtHgIlSeCgyNys7hfnLzQs7
ERkA0SrTCbvsgPkbUBe5cRSZAZIsMyXdHfBK2+kfXBC6aEz6mbd5d09co6giqx06
E+3qPUVXpsT9yhpqaXbO1Y1Xb8RsU21w3RB/QJNzyAcK9qfmwIi3SYDrXafF0MWW
TPW/WiD1d0rMLdXi1Ac+KCCBXGzUqS0OK+yn4UA7URTwSKoZ8Pt2G5snkaQ8ekfM
neOxnUvviSjkvzhE5V9/W9slqcnlmA==
=Vgqe
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26880@debbugs.gnu.org)
8737cbhx5d.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (20 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Marius Bakke <mbakke@fastmail.com> writes:
>>
>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>
>>>> * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon,
>>>> mesa, wayland and wayland-protocols.
>>>> [arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend"
>>>> to #:configure-flags.
>>>
>>> Why do these inputs need to be propagated? Apart from that I think this
>>> looks okay. Would like other opinions though.
>>
>> Many packages depending on gtk+ ended up needing these inputs. I can
>> sift through my gtk+ .pc files to see if propagation is absolutely necessary.
>
> That would be great. Maybe some of these should be propagated from
> wayland instead.

It looks like gtk+ needs them to be propagated. No xkbcommon to be found
in my wayland .pc files.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkU3u8ACgkQ5qXuPBlG
eg2W9w/8Dfow3qizJc7BnE5yETkiXt7FACn1pNpdcE16APtJldzZuRCjy/hVdorp
tn13KSb52VFXnCl1pORSeoByBL28Rdyy/ev+ZiIEgSmguAtTNpGZRSpTRENs/AWW
gl6rNg8YUly+3W3KWdO7pEcIeNkK0oMIK8boC/BeLM5lFimATjq55huCTpwZEj0m
yr/pvOAfWQsrNHsNpcdVPNz3W8LXWHxCi3iBQ+/82yTPfR9SFsXPfGOULiDfrOMH
RvE8JyhXOU4a8cofTLDF17MPDXI0MpkaHan2lK69qPDBVtejnFjVSzBAVAzR3iTW
6zXOKfyje76eGPEAV3JvgHkL4k/Iky7N7PRbgXfNTY7Zly7/JxBnGNqTph479KCs
6+AhGI7EUFsd4vHijO100FRORAtEAq8dP1Q38F2zHPed9FGZVxDArP8WKA9HIT8p
YtPsxh+v0LboKjsDUxgcKJh66BnYhC6pmpQ83ZSh9nhgGwR2pfPTC6g3DZ5kA0w9
L8cd24ujTIrrqLm69HKw2eYy8ToAb3HoToBS3ktKCuHn/qkENpZNsS9KmipJ99wb
sgLCdHF88BlzQooBXfS+K/nRTWmqq+GvIZdYZVu2dZvjtUJZfJ2GNDFqvyQ7QEn0
z291I3rRR0JgPkB+PT9UQ7FDOK1J1R0BgGvMPpR1ZwzfMydrXbo=
=9qRl
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26880@debbugs.gnu.org)
877f1njb7w.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (25 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>
>>>>> * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon,
>>>>> mesa, wayland and wayland-protocols.
>>>>> [arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend"
>>>>> to #:configure-flags.
>>>>
>>>> Why do these inputs need to be propagated? Apart from that I think this
>>>> looks okay. Would like other opinions though.
>>>
>>> Many packages depending on gtk+ ended up needing these inputs. I can
>>> sift through my gtk+ .pc files to see if propagation is absolutely necessary.
>>
>> That would be great. Maybe some of these should be propagated from
>> wayland instead.
>
> It looks like gtk+ needs them to be propagated. No xkbcommon to be found
> in my wayland .pc files.

And they're all in Requires.private of the gtk+ .pc files? LGTM in that
case. Pending other comments I think you can go ahead and push these
tomorrow. Maybe we can have native Wayland support by 1.0! :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkU4XMACgkQoqBt8qM6
VPo+ugf/bTrCCGRGdSUDsSQCtn402tHjwlTO+2kZiKxpzDXbsVoL+s1T1+oGupv7
p1r+oDqF3O9LQLNNr+z27vlaXYlJNtHboXVr5m5JudR9JO4IgBnIEkSDeqAmxGjL
1bSZuSP+Rtvoys97Yf1k0k0UP7MR2198LcXNVAfJx5tsGyi5J/+eP34QqVrT+AG6
zFkhR0tgwnY4hpNI+ntGelPQUmwCfyjPiZ4iJ8zGQVU3xXDgp8JUI380lCdLKa22
YHd0m7sNX328VrA788X5e6TMWAM8IEGIZFCPbmehT5hWtfTl/ifiNFqGKRjq++aJ
4r4knJ8VLovAUCTy3zFPFuicywKE0w==
=ea8T
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26880@debbugs.gnu.org)
87y3u3ge70.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (3 lines)
> And they're all in Requires.private of the gtk+ .pc files? LGTM in that
> case.

Yes they are and thanks for the review.

Toggle quote (3 lines)
> Pending other comments I think you can go ahead and push these
> tomorrow. Maybe we can have native Wayland support by 1.0! :-)

It's definitely worth a shot!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkU9SMACgkQ5qXuPBlG
eg3oTA/9GeZLBwGk2ta8N34T6ZW7fCdIdNHmGIin4twEIpU7IfxIwwfrgKuU1+PL
40FtoPZdxOdWvY0kES+UUmeyouf1VlMUbC1znSND0goOXbz2fMikB9/6tJXSH0mU
PX7HYoT81xzJknkNc7vLFCUNE2Mg1YCnBFNFWkJxO5fYUh01fCF6lKeN0bJW1G4h
+HpOwaNuXn2q9jETjvJsrFg1JC8Dx04hWoUvxxuvWnF5Q3uw1oTw98lepbH7Jkrk
dRBK+TrL19Zd0d5dD/01WZsJrWLhrxzjmSFPbMNUM1JRGIV+smK5gcGy3yDnzZjj
Izs9ci92VUGhskT/Q+kXW9NOmGMpjCbxE2WHJpbi6MXPB1va9TLn1qqDMat3X3FO
y1EkmhuwdMhtEKKjub2abN4YxYd6eSrd6toN4i0Jwon3QI+cEEtKz9JueXJQOuFB
M/hnjQabDk2D6mw2T5Pp8FHvIoBvrkrFqv8P3QzLxXjArh+1lUE345yH9b6NkPCU
ymvKARPn6sQ4Nc/kYeB0V3UeiHuBfiUb+McDE4vCl+gaA3jPws3RWxc3I7zUaidK
UEdk+EgLxs1OHRwiE9STM850o+fP4uKMVvDxCViRBY3mijq9zx/4OyxPLTd9rid7
6hBmP6eB8i0T/3D7FiGehv5LlolojGSfl7xoEoKhaQzhYHFcJ24=
=kCX/
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
Re: bug#26887: [PATCH 01/11] gnu: libdrm: Update to 2.4.80.
(name . Marius Bakke)(address . mbakke@fastmail.com)
87lgq0gwh3.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (38 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>
>>>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>>>
>>>>> These patches are intended for gnome-updates. The first three are merged
>>>>> from master. Also, the mutter patch is not functional yet, as it
>>>>> probably requires some updated package from master.
>>>>
>>>> I think it's better to merge master directly instead of cherry-picking
>>>> these patches. We'd want to do that before starting it on Hydra anyway.
>>>>
>>>> Would you like to do it? I think we can start building it shortly, Hydra
>>>> seems to have caught up with recent events. Maybe it'll be ready for the
>>>> release :)
>>>>
>>> I can merge master and put these on top, though I can't test my patches
>>> very quickly (building webkitgtk+ repeatedly on 10-year-old hardware \o/).
>>> If your computer(s) are faster, I'd be more than happy to let you finish
>>> this branch.
>>
>> I think these patches look fine (see other comments), at least up to
>> mutter. I'd suggest merging master and adding the patches leading to
>> it, as long as everyone is fine with adding wayland as a hard dependency
>> of gtk+.
>>
>> Then we can start an evaluation on Hydra to get some substitutes before
>> trying the mutter update :)
>
> Last call for objections to wayland as a hard dependency of gtk+ on the
> gnome-updates branch! This will be committed in approximately 24 hours
> otherwise.

The gnome-updates branch has been updated! I'll be closing all of my
related bugs.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkXmJgACgkQ5qXuPBlG
eg09zBAAkVnreF1hoPm/jT39j1X8jyaxKNFJrM4N3xupQ/BCuvOfbdTHL8jmVOpD
uxHrz9n9oa4Kr5LlnbE2XVbHeUz8WvvusiToHc6mqJ72mY/3YF6VZRsSUwvqD3DI
pyy1AGHq7qFAMHXqiqJ/5hWNClk+hoP3CveB4hJE+xpm2EM3PYmXGvaeAwsZc3RQ
jjD8FJ0pOMeZi8DIjY7HgUaDcjQbIhdUBk7Q23cLMHMLZxd4fD4IKSuVbo6R9i3z
ibdwuewfy2385NKjnBxS5AiEQ3lq8QQcuQyXpzv5o/ZCKEabhBWZ/hiefZ5sZJ3C
pRyJBPy4KLcHvTQ5AAqoLKanQK3/0ncXhlR2PKjBLAesNXpfdRIKHOCBWfgUnWwk
UZ7lpKlVns2o6L7U48gt6ygap8p9ebF6AmNRrJsXbGr4PJ61sDLsycZUF0YkKTjf
QOMUArM2IgpSpVf2C2ILlbf5NN3cK3okDF6aVT4V80aSJg38DoIHCiOagK9BRXaq
VVTsI+z1nTQl0Vcc0TWS90V8UCivI/kcGv2GjWLqcCZdXal8Dj9WSMC8IkI6TF7+
a9tJ2Agi2ezCxbGa8IQ3VzkuwmLaipd9FLlSKzxmt7mkwQ61Xf3fFy7i3zVuqaMI
2BQ7g3ZJgp08ZIVq5AXkUCn2jzx6gZpFU16UuqFgjactgwrmaTw=
=BLVL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26880@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26880
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help