[PATCH] gnu: Add python-tmx.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170510172040.8889-1-kei@openmailbox.org
* gnu/packages/game-development.scm (python-tmx, python2-tmx): New
variables.
---
gnu/packages/game-development.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index e47b556c0..c95afe231 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -214,6 +214,38 @@ possible, and it also makes the SGE easy to learn.")
(define-public python2-sge-pygame
(package-with-python2 python-sge-pygame))
+(define-public python-tmx
+ (package
+ (name "python-tmx")
+ (version "1.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/python-tmx/tmx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1is107sx3lr09dqjiyn10xqhyv5x54c2ryhys9mb9j3mxjbm227l"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "http://python-tmx.nongnu.org")
+ (synopsis "Python library for the @code{Tiled} TMX format")
+ (description
+ "Python TMX read and writes the @code{Tiled} TMX format in a simple way.
+This is useful for map editors or generic level editors, and it's also useful
+for using a map editor or generic level editor like Tiled to edit your game's
+levels.")
+ (license license:asl2.0)))
+
+(define-public python2-tmx
+ (let ((python2-tmx (package-with-python2 python-tmx)))
+ (package
+ (inherit python2-tmx)
+ (propagated-inputs
+ `(("python2-pathlib" ,python2-pathlib)
+ ,@(package-propagated-inputs python2-tmx))))))
+
(define-public tiled
(package
(name "tiled")
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87d1bglb5p.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (3 lines)
> * gnu/packages/game-development.scm (python-tmx, python2-tmx): New
> variables.

[...]

Toggle quote (2 lines)
> + (license license:asl2.0)))

It looks like the documentation is CC0/public-domain. It should be
listed here if it is part of the installed package (but does not hurt to
mention it here regardless).

LGTM otherwise, thanks for packaging these!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkTdUMACgkQoqBt8qM6
VPrWrAf+KEXjWeXQxT/E/VXqYmmlo9dnt9ol7ICfLGGW6Ta8+IXhWe2wBkQf9sf3
QRo+VV0iBRCwCQ0YwhSS6hBI3qEnKxJEcA+2LvV3IIuoryIpYLuAMlgxC2k2g61n
GiAqrK9zDTuh9PyUFPCn4PYHU79T/Ct9d7BdQnd4aFBQN7s0ganiQddy75KGItHp
PALliTSREj4DL/CTOzDbkl5At7RL8sHG0UP4YeayY3eTmZwsea7yzoDnnyph39Op
SfDvvpzKFmkw2t4sbUp4GvA01biCkb4e/C0CTtXDogZ1oL3oTl/Fkm9i1gpnHySJ
XIFM7S56q+uPvcTfp4j8LFV6Os9/EA==
=ylMx
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26867-done@debbugs.gnu.org)
8760h8jlz5.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (15 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/game-development.scm (python-tmx, python2-tmx): New
>> variables.
>
> [...]
>
>> + (license license:asl2.0)))
>
> It looks like the documentation is CC0/public-domain. It should be
> listed here if it is part of the installed package (but does not hurt to
> mention it here regardless).
>
> LGTM otherwise, thanks for packaging these!

Thanks again for the review! Pushed as
1b775fd1df9e4c4f96e9acdf5485d04a74730153.

P.S. python-sge-pygame hash should have been
45f8e7f75e5401eb05bf98383ee169f6b7f06851.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkTqv8ACgkQ5qXuPBlG
eg0z0hAAhHvkhd1jvaH+OhWR3RsCzSxfJkvcVeG1IbGYWjF2vdgvxmnqDkV+IxK9
z97E2F5HKoMgUZ+a3JlxZkgkFqawmh7NwQiUfD1bMULaOdK8vs2fsKMOe4jHeIkb
hzkSxrF8yjvwWH7i22enPixWJtY6cVFFBGTqcD6Ydjh0zbqORUqQjSKt8wH54LlQ
2mlIadAYFk+h9FBxwEbIgH8UDKCIm7a7iOdGLUMkNJv0uwW+ZteySA1rEuQxhzgd
cVMnjnBVthZMAjZI/9ZxqUvsFGRguQTxwKJjfgCMO9+ygsqfwvxpJRaX/Em+2/vd
j9gLnD/n4Zo5u6lBUacI5RN6GzZyDysqVGcdcZSja8JwEUL9TU9cyKIxg37w+Bxd
r4FM6DGioNim0uLNHX9r1agTIoYWYY/jL/F0mBqSLddqFF5+Oz8hT2REo1TQSChA
o/QnHQDXsZBUGgsKEnfksl5/2iMU8vUg63YRo4AS13wkqJZSkfm4eLX0PwotHnDX
hVEqgjuGr6Ueg6f9tqmsbY8lF68RprVMftxkT0bkXaH6gMLLoNdkgd6NBJzcOQJh
o+SpZd3gupOIPpT4gvdgbSR/HVC06b93RrKQket+1Rq+W8WxlA+wEsqjXhbg065o
8Fg1B2bN584HdTtxQ+V0tj08DIGVfAPzMPQnPiE4t2InoZRGa/M=
=x5KQ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26867@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26867
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help