[PATCH] gnu: Add python-sge-pygame.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170510162949.5856-1-kei@openmailbox.org
* gnu/packages/game-development.scm (python-sge-pygame, python2-sge-pygame):
New variables.
---
gnu/packages/game-development.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 41d85aac8..e47b556c0 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -187,6 +187,33 @@ and network communications. A very thin client library can be embedded to
provide connectivity for client applications written in any language.")
(license license:gpl3+)))
+(define-public python-sge-pygame
+ (package
+ (name "python-sge-pygame")
+ (version "1.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sge-pygame" version))
+ (sha256
+ (base32
+ "1qhrcja1igqkjjn1w425ni5f41mijdq5dpq0ymkhl29xxrf8hnx8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pygame" ,python-pygame)
+ ("python-six" ,python-six)))
+ (home-page "http://stellarengine.nongnu.org")
+ (synopsis "A 2-D game engine for Python")
+ (description
+ "The SGE Game Engine (\"SGE\", pronounced like \"Sage\") is a
+general-purpose 2-D game engine. It takes care of several details fro you so
+you can focus on the game itself. This makes more rapid game development
+possible, and it also makes the SGE easy to learn.")
+ (license license:lgpl3+)))
+
+(define-public python2-sge-pygame
+ (package-with-python2 python-sge-pygame))
+
(define-public tiled
(package
(name "tiled")
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87fugclbl6.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (3 lines)
> * gnu/packages/game-development.scm (python-sge-pygame, python2-sge-pygame):
> New variables.

[...]

Toggle quote (2 lines)
> + (synopsis "A 2-D game engine for Python")

s/A // should make the linter happy. I'd also remove the dash here.

The rest LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkTcxUACgkQoqBt8qM6
VPoF3AgAv+2zxIC8wbTeTOTTodh4moalH0/tteWBhUzWp51soyHrG28QeDDpqrkM
GZeO57+xH7Fzq8cjhLm785MiWw9QXXv63t7Bila8MNA7xR1AV2dPrQIgnypXdIOp
70dv7iF9d7IXKW1+CouKbrnwgKYd+7j3skOtShZc+XcT+VyAZHKKHiCmmXwJBndo
IQ9R0E2SOxZbb8mfiY8gS1kNnXQaNuEj61ORfD9aDHndWulCWR9OTrran4Do5VoH
9heYmu2iYs7U37u17Rvb/M/bb3IQddtTCOUAy3AYwdw2xHw5Oi1cgLCg0XNCf6hq
KzzeKzGQc5pfmzak+Tq5somqf2zBGQ==
=JNUY
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26865-done@debbugs.gnu.org)
87a86kjm2j.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (13 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/game-development.scm (python-sge-pygame, python2-sge-pygame):
>> New variables.
>
> [...]
>
>> + (synopsis "A 2-D game engine for Python")
>
> s/A // should make the linter happy. I'd also remove the dash here.
>
> The rest LGTM!

Thanks! Pushed as 1b775fd1df9e4c4f96e9acdf5485d04a74730153.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkTqoUACgkQ5qXuPBlG
eg0EjA//bpns+ijV8v1/Gi10UkHWzta+QaAhWv1oIBY9F4+ppCa6V9VSAtNglXi9
Ye0vnUs4HYJ+X9RNmCOP3aihlRBj8PaHrtkV1bOs0Skhx04mb3rlEIgkkjzQI8Hr
4+8qxCANGNDWLFJt1+o6ImTqgX/ZM0o6LYf8kfkODf2O6bQHVGEK5ROzCxdv5T9H
QGVsTlJEw0sZ+hZ4KY98OZkt4KcofC+DEDeHR02jhWCEQuX3SfIVgCmCLSUrrCwO
G1d8C/eOEEis7VdDn8NgejJW1nXcSNLRT/6G9919qhgFP+847TQM6J3/+fF0NAfI
EPe2hLgHQay7NJ8p24qpKF0ZjtO7qVzcr/zQIic0FTmRcrcEXsBRFfuQsyfLd0fx
8PywOZ4VCkg1bHtln0Sc5gGL9mWHSm6Y9fRAEQDVpXi6M9+SI2xJqepCZJ2eJ+3w
MBcrh58t5U9HxVgG84I6DMwufaWceeXJs+luMGPvhBKeez/IrASrgr6K/auhoh8p
TkUq3TAI2HOe9Bax3fSdLYpjQ59ge1XpafdefiN7gMIFSRPyvlkS7ySvA9EP0Rry
GiVCAfd3yrkIaL4U/vo7mtcKzwiphCfIQ7iOSpDuetdSIwloGHZjLF0IhmJnp16m
H3Dt5w8bpV0bOOov8KRu3AgzLTYXASnfci9T2y6yQsEvSUDVYIM=
=nA8a
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26865@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26865
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help