[PATCH] gnu: Add libgme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170509020205.11735-1-kei@openmailbox.org
* gnu/packages/music.scm (libgme): New variable.
---
gnu/packages/music.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 850eef35b..3002d27a6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -582,6 +582,50 @@ for path in [path for path in sys.path if 'site-packages' in path]: site.addsite
interface. It is implemented as a frontend to @code{klick}.")
(license license:gpl2+)))
+(define-public libgme
+ (package
+ (name "libgme")
+ (version "0.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
+ "downloads/game-music-emu-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "08fk7zddpn7v93d0fa7fcypx7hvgwx9b5psj9l6m8b87k2hbw4fw"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no check target
+ (home-page "https://bitbucket.org/mpyne/game-music-emu")
+ (synopsis "Video game music file playback library")
+ (description
+ "Game-music-emu is a collection of video game music file emulators that
+support the following formats and systems:
+@table @code
+@item AY
+ZX Spectrum/Asmtrad CPC
+@item GBS
+Nintendo Game Boy
+@item GYM
+Sega Genesis/Mega Drive
+@item HES
+NEC TurboGrafx-16/PC Engine
+@item KSS
+MSX Home Computer/other Z80 systems (doesn't support FM sound)
+@item NSF/NSFE
+Nintendo NES/Famicom (with VRC 6, Namco 106, and FME-7 sound)
+@item SAP
+Atari systems using POKEY sound chip
+@item SPC
+Super Nintendo/Super Famicom
+@item VGM/VGZ
+Sega Master System/Mark III, Sega Genesis/Mega Drive, BBC Micro
+@end table")
+ (license (list license:lgpl2.1+
+ ;; demo and player directories are under the Expat license
+ license:expat))))
+
(define-public lilypond
(package
(name "lilypond")
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87pofiw08z.fsf@fastmail.com
LGTM
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkR17wACgkQoqBt8qM6
VPqk0wgAuaBXXaOFQoG9dcL9bBx/mB3JuMH5NYA4WPkaO6DBtXkIanr1+BLfXgZ1
pqzTQ0hbuWLAiPuRMw27/6/hpP8CjhxwKiL+LLrqbgkVxegn8wqxxnbS98dHsoaF
2O/uIT0gWZaB32jcYJRNmCEn1NC4IASdbaoUIH1wuUn/8zjen1q3/j9A+rrIRs9b
odk+GmWVOk548ryzxbtkYkzdGfZ5yUMaO8agKt5qnF7x1lqOBkvqybtXaSWS2Tjr
G2NxiiZCe3/2oZRcJ7p7r3oL0GaBCX4dKf8TacHugNe2f8gSavB8g9tS/nSQhVi/
gWrBAuI854iEVNczrM04FJtTgMnq1Q==
=YBgv
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26849-done@debbugs.gnu.org)
87o9v2jah9.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (1 lines)
> LGTM
Thanks for checking. Pushed to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkR5TIACgkQ5qXuPBlG
eg1ZAw//S6FzH6QiTYoMn1C51+TkCb9mDDZPmYQ49kK4nlH99Q4OVJKSP6ZJUSdw
BF+lAJhbJbIjV7ndcTINRlIoqG6RjFc4ppStRbiIebR4f4UeFmzPNd0RZ+NLpptN
sV8YrIruYFAzFxEd6OsHF93pwaw/5PM6IpXqPIP1uIp1v6K8XOBbcv4IeV9D0e/L
a2GsmSU/8H/A8C3DrOfJEC6snJxFHi4s+6lGnLS30GBJ/OvuRFXGGsOlT7g9lXMJ
lVVrLUoaOVkmJDcevHvkaQa1guOlg07NJK9ZCvQMuUoYN7CgH4l2crPtJ566V+eK
bzcxFW11dazmKOxBLzdO28U12Xs2w3qNSy+mF1IWCStHulpgQGN34SFUOetIN//+
EfiqULMlflcWoB+qhG3teTf88aNi7b06ObSo4UjVlOD8aXIfkoI9jm+ZVYfC698r
Mf/D06dGTyBJXKMUnvzZIZUknPFScYeCimLZrVKukc5I6XpXXTD6QlfqtdhAq7K2
oNcT36+nGSipKUS1uhttJIpZqk3WeDqes7Vwi2Qj/CXprcgeNGgP7B46T4Dk7QOH
KQLi9q19H/2jL5WydlOJ6BV6uNCW1+DQ8vJUbfNpBaAXV6qDFBMBZFJay9StPcE/
WqrhWdY+xd1Atw10QXqIW5q7Eligzj4ZDSGMvHGAtZpte6hhCXQ=
=N83y
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26849@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26849
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help