[PATCH] gnu: Move lynx to web-browsers.scm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170508192047.16688-1-kei@openmailbox.org
* gnu/packages/lynx.scm: Remove file and move lynx...
* gnu/packages/web-browsers.scm: ...here.
* gnu/packages/man.scm (define-module): Remove unused module import of
(gnu packages lynx).
* gnu/packages/ocaml.scm (define-module): Adjust module import to use
(gnu packages web-browsers).
* gnu/local.mk (GNU_SYSTEM_MODULES): Remove lynx.scm.
---
gnu/local.mk | 1 -
gnu/packages/lynx.scm | 91 -------------------------------------------
gnu/packages/man.scm | 1 -
gnu/packages/ocaml.scm | 2 +-
gnu/packages/web-browsers.scm | 62 +++++++++++++++++++++++++++++
5 files changed, 63 insertions(+), 94 deletions(-)
delete mode 100644 gnu/packages/lynx.scm

Toggle diff (237 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 1922bb46c..af37e6764 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -244,7 +244,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/lua.scm \
%D%/packages/lxde.scm \
%D%/packages/lxqt.scm \
- %D%/packages/lynx.scm \
%D%/packages/m4.scm \
%D%/packages/machine-learning.scm \
%D%/packages/man.scm \
diff --git a/gnu/packages/lynx.scm b/gnu/packages/lynx.scm
deleted file mode 100644
index b212dca38..000000000
--- a/gnu/packages/lynx.scm
+++ /dev/null
@@ -1,91 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages lynx)
- #:use-module ((guix licenses) #:select (gpl2))
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages libidn)
- #:use-module (gnu packages gnupg)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages zip)
- #:use-module (gnu packages compression))
-
-(define-public lynx
- (package
- (name "lynx")
- (version "2.8.9dev.11")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://invisible-mirror.net/archives/lynx/tarballs"
- "/lynx" version ".tar.bz2"))
- (sha256
- (base32
- "1cqm1i7d209brkrpzaqqf2x951ra3l67dw8x9yg10vz7rpr9441a"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("perl" ,perl)))
- (inputs `(("ncurses" ,ncurses)
- ("libidn" ,libidn)
- ("gnutls" ,gnutls)
- ("libgcrypt" ,libgcrypt)
- ("unzip" ,unzip)
- ("zlib" ,zlib)
- ("gzip" ,gzip)
- ("bzip2" ,bzip2)))
- (arguments
- `(#:configure-flags
- (let ((gnutls (assoc-ref %build-inputs "gnutls")))
- `("--with-pkg-config"
- "--with-screen=ncurses"
- "--with-zlib"
- "--with-bzlib"
- ,(string-append "--with-gnutls=" gnutls)
- ;; "--with-socks5" ; XXX TODO
- "--enable-widec"
- "--enable-ascii-ctypes"
- "--enable-local-docs"
- "--enable-htmlized-cfg"
- "--enable-gzip-help"
- "--enable-nls"
- "--enable-ipv6"))
- #:tests? #f ; no check target
- #:phases (alist-replace
- 'install
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (zero? (apply system* "make" "install-full" make-flags)))
- %standard-phases)))
- (synopsis "Text Web Browser")
- (description
- "Lynx is a fully-featured World Wide Web (WWW) client for users running
-cursor-addressable, character-cell display devices. It will display Hypertext
-Markup Language (HTML) documents containing links to files on the local
-system, as well as files on remote systems running http, gopher, ftp, wais,
-nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on
-the WWW, or to build information systems intended primarily for local
-access.")
- (home-page "http://lynx.isc.org/")
- (license gpl2)))
-
-;;; lynx.scm ends here
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 2cc685dee..8319a7e41 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -30,7 +30,6 @@
#:use-module (gnu packages gawk)
#:use-module (gnu packages groff)
#:use-module (gnu packages less)
- #:use-module (gnu packages lynx)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages linux))
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0c21a74da..e5e599358 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -37,7 +37,6 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libevent)
- #:use-module (gnu packages lynx)
#:use-module (gnu packages m4)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -50,6 +49,7 @@
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages web-browsers)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 4cbd5fbe0..a10b1367e 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
@@ -27,7 +28,10 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages libidn)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -35,6 +39,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages tls)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages zip)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
@@ -121,6 +126,63 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
;; linking of the program with openssl.
(license license:gpl1+)))
+(define-public lynx
+ (package
+ (name "lynx")
+ (version "2.8.9dev.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://invisible-mirror.net/archives/lynx/tarballs"
+ "/lynx" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1cqm1i7d209brkrpzaqqf2x951ra3l67dw8x9yg10vz7rpr9441a"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (inputs `(("ncurses" ,ncurses)
+ ("libidn" ,libidn)
+ ("gnutls" ,gnutls)
+ ("libgcrypt" ,libgcrypt)
+ ("unzip" ,unzip)
+ ("zlib" ,zlib)
+ ("gzip" ,gzip)
+ ("bzip2" ,bzip2)))
+ (arguments
+ `(#:configure-flags
+ (let ((gnutls (assoc-ref %build-inputs "gnutls")))
+ `("--with-pkg-config"
+ "--with-screen=ncurses"
+ "--with-zlib"
+ "--with-bzlib"
+ ,(string-append "--with-gnutls=" gnutls)
+ ;; "--with-socks5" ; XXX TODO
+ "--enable-widec"
+ "--enable-ascii-ctypes"
+ "--enable-local-docs"
+ "--enable-htmlized-cfg"
+ "--enable-gzip-help"
+ "--enable-nls"
+ "--enable-ipv6"))
+ #:tests? #f ; no check target
+ #:phases (alist-replace
+ 'install
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (zero? (apply system* "make" "install-full" make-flags)))
+ %standard-phases)))
+ (synopsis "Text Web Browser")
+ (description
+ "Lynx is a fully-featured World Wide Web (WWW) client for users running
+cursor-addressable, character-cell display devices. It will display Hypertext
+Markup Language (HTML) documents containing links to files on the local
+system, as well as files on remote systems running http, gopher, ftp, wais,
+nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on
+the WWW, or to build information systems intended primarily for local
+access.")
+ (home-page "http://lynx.isc.org/")
+ (license license:gpl2)))
+
(define-public qutebrowser
(package
(name "qutebrowser")
--
2.12.2
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26838@debbugs.gnu.org)
20170508194003.GA20971@jasmine
On Mon, May 08, 2017 at 03:20:47PM -0400, Kei Kebreau wrote:
Toggle quote (8 lines)
> * gnu/packages/lynx.scm: Remove file and move lynx...
> * gnu/packages/web-browsers.scm: ...here.
> * gnu/packages/man.scm (define-module): Remove unused module import of
> (gnu packages lynx).
> * gnu/packages/ocaml.scm (define-module): Adjust module import to use
> (gnu packages web-browsers).
> * gnu/local.mk (GNU_SYSTEM_MODULES): Remove lynx.scm.

LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkQyZMACgkQJkb6MLrK
fwjGrQ/9EPtMES0AasJQ2389VdoGSSdAQ1bK+eAsL/FxJXp7UpcQRPm3VK6Us2lz
rjjk7YqeW8bzkDvRn8m4msTTZMbFPk0uchDAxEiMJbSzH/GdG2jbcjtTnRQN6TYD
0n1KXeVb3HQh0cv/uS+Fu/dNu5wG7HFKguFU8sB45XmmxOmOAz2swLmVOgz1g0Ak
WNn8MXxkEAPU6Gq90O5ZXYAuFVkCmJ6eMwiuPrAiPqAXpGO1jolBMdXxeRZZCaxV
e3rxypG92BWY4g/QV+0VDvg4vHEWJMd2bqzLV4HKKXPyvL9QmVlmKy5UvmievuoF
ixqPS0FMB2pJCFUvgrgEoFXqn4FuG/0ayhTO5lZ9zPhoRl0B5D0QZzOgxyWgwaBc
D/2Nz19EcC7tCQNeX56wzGD07u89I3080x96X3Xc4C8mTEd6+Vg0TEqzpRmclJQK
SyZp+CkmokgAQ+rS9uVc/EoyJ1rKoquCQXmM/PtPdRQ7cc4LC4aRuMfmJr3Fk7o5
ra6868E2iY9ShSuaVP5g3xHpavIhrF5QbgQTv08WgdX2hnebPa4CHAPkhVkzdwcs
/PxVMhB1iKc1pRyKJqbVUsmNCrm/I+6jeOcdxoLD548RajanAvbMdTiu0QX+NnU0
ruycwI67wbBIE3vjXXdxzF+1XDMYxzDFdMWbKb5GuQnfz/Dz7rQ=
=/szd
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 26838-done@debbugs.gnu.org)
87fugfkqvq.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (11 lines)
> On Mon, May 08, 2017 at 03:20:47PM -0400, Kei Kebreau wrote:
>> * gnu/packages/lynx.scm: Remove file and move lynx...
>> * gnu/packages/web-browsers.scm: ...here.
>> * gnu/packages/man.scm (define-module): Remove unused module import of
>> (gnu packages lynx).
>> * gnu/packages/ocaml.scm (define-module): Adjust module import to use
>> (gnu packages web-browsers).
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Remove lynx.scm.
>
> LGTM, thanks!

Thanks again! Pushed as c5196ac7ee668a65c0cfda25ce354b826b15435c.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkQ2+kACgkQ5qXuPBlG
eg1D3w/8DCTl+2XcHw8zjhRc8jl1ln/JyRG2/m51+bJp2geqEFR7+NNKfK1d3g63
D6El7anFUWNT+718KNljGQ+9xSjGJL4IKZYY7yz5sEoMtdt/Io2VI3uaooklzhKA
WDn+KdcZGUhphRnGfFGzdreTOkzCh+jWYiFxe837zXZZmLO0BMITed+oRi8HrSxQ
z/fYNa+L5FFFe38trCrO7OZCHNqqXKT/MpZ7Q1masyi60wXs5/e6XSuezIIl9QIy
uAOyh6BeAzTCfYAsPFWkxcye1+E3J4MUDVpk1EcZJkfPWMaVMN6nu+Di4QR1X4m/
I0GqV7x5iqHIqOAhvOI3pV5OjIXFQ6cIYNLCf0h2i3uRHoLgNTe4Sj/c5gz4yyw1
IwVgGJEuS7VLAfq6s6bSDfSmIRay+rF+3vu62IgijN/eTQ/WumBqyX8Z3z1ygMvR
LEcnsPko/8ZaPqigyaQDgOnSR8kxwXF6SKDbAXVhRixuRgNydOTUv+BPYo79q2fV
Ny5PBSBH13qnNjRRcqsxKH9dFSy/5aEM3bqRw5A/pAy4SiAxsEE2oOTFfjd4Phr6
CWdIS0NBjhqN8wlCLOSf9seNaUU07ggkESQ7legF6khVYN+TeYi8PdSd3jyfFRIU
47rj116PshV21hR7IRdhwjWPQaKocNRS7vSTLLYNNGLZrjbkZmg=
=X0lY
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26838@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26838
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help