[PATCH] gnu: Move links to web-browsers.scm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170508162540.5374-1-kei@openmailbox.org
* gnu/packages/links.scm: Remove file and move links...
* gnu/packages/web-browsers.scm: ...here.
* gnu/local.mk (GNU_SYSTEM_MODULES): Remove links.scm.
---
gnu/local.mk | 1 -
gnu/packages/links.scm | 81 -------------------------------------------
gnu/packages/web-browsers.scm | 54 +++++++++++++++++++++++++++++
3 files changed, 54 insertions(+), 82 deletions(-)
delete mode 100644 gnu/packages/links.scm

Toggle diff (178 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 55abf5c88..4c415cc8c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -233,7 +233,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/libunwind.scm \
%D%/packages/libupnp.scm \
%D%/packages/lighting.scm \
- %D%/packages/links.scm \
%D%/packages/linux.scm \
%D%/packages/lirc.scm \
%D%/packages/lisp.scm \
diff --git a/gnu/packages/links.scm b/gnu/packages/links.scm
deleted file mode 100644
index 145ed761e..000000000
--- a/gnu/packages/links.scm
+++ /dev/null
@@ -1,81 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages links)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages image)
- #:use-module (gnu packages libevent)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages xorg)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public links
- (package
- (name "links")
- (version "2.14")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://links.twibright.com/download/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32 "1f24y83wa1vzzjq5kp857gjqdpnmf8pb29yw7fam0m8wxxw0c3gp"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The tarball uses a very old version of autconf. It doesn't
- ;; understand extra flags like `--enable-fast-install', so
- ;; we need to invoke it with just what it understands.
- (let ((out (assoc-ref outputs "out")))
- ;; 'configure' doesn't understand '--host'.
- ,@(if (%current-target-system)
- `((setenv "CHOST" ,(%current-target-system)))
- '())
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- "--enable-graphics"))))))))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("zlib" ,zlib)
- ("openssl" ,openssl)
- ("libjpeg" ,libjpeg)
- ("libtiff" ,libtiff)
- ("libevent" ,libevent)
- ("libpng" ,libpng)
- ("libxt" ,libxt)))
- (synopsis "Text and graphics mode web browser")
- (description "Links is a graphics and text mode web browser, with many
-features including, tables, builtin image display, bookmarks, SSL and more.")
- (home-page "http://links.twibright.com")
- ;; The distribution contains a copy of GPLv2
- ;; However, the copyright notices simply say:
- ;; "This file is a part of the Links program, released under GPL."
- ;; Therefore, under the provisions of Section 9, we can choose
- ;; any version ever published by the FSF.
- ;; One file (https.c) contains an exception permitting
- ;; linking of the program with openssl.
- (license license:gpl1+)))
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 07b61dd25..4cbd5fbe0 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
@@ -25,6 +27,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -67,6 +70,57 @@ older or slower computers and embedded systems.")
(home-page "http://www.dillo.org")
(license license:gpl3+)))
+(define-public links
+ (package
+ (name "links")
+ (version "2.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://links.twibright.com/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1f24y83wa1vzzjq5kp857gjqdpnmf8pb29yw7fam0m8wxxw0c3gp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The tarball uses a very old version of autconf. It doesn't
+ ;; understand extra flags like `--enable-fast-install', so
+ ;; we need to invoke it with just what it understands.
+ (let ((out (assoc-ref outputs "out")))
+ ;; 'configure' doesn't understand '--host'.
+ ,@(if (%current-target-system)
+ `((setenv "CHOST" ,(%current-target-system)))
+ '())
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ "--enable-graphics"))))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("zlib" ,zlib)
+ ("openssl" ,openssl)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("libevent" ,libevent)
+ ("libpng" ,libpng)
+ ("libxt" ,libxt)))
+ (synopsis "Text and graphics mode web browser")
+ (description "Links is a graphics and text mode web browser, with many
+features including, tables, builtin image display, bookmarks, SSL and more.")
+ (home-page "http://links.twibright.com")
+ ;; The distribution contains a copy of GPLv2
+ ;; However, the copyright notices simply say:
+ ;; "This file is a part of the Links program, released under GPL."
+ ;; Therefore, under the provisions of Section 9, we can choose
+ ;; any version ever published by the FSF.
+ ;; One file (https.c) contains an exception permitting
+ ;; linking of the program with openssl.
+ (license license:gpl1+)))
+
(define-public qutebrowser
(package
(name "qutebrowser")
--
2.12.2
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26834@debbugs.gnu.org)
20170508181445.GA8814@jasmine
On Mon, May 08, 2017 at 12:25:40PM -0400, Kei Kebreau wrote:
Toggle quote (4 lines)
> * gnu/packages/links.scm: Remove file and move links...
> * gnu/packages/web-browsers.scm: ...here.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Remove links.scm.

LGTM, thanks!
Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 26834-done@debbugs.gnu.org)
87k25rkvyn.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (7 lines)
> On Mon, May 08, 2017 at 12:25:40PM -0400, Kei Kebreau wrote:
>> * gnu/packages/links.scm: Remove file and move links...
>> * gnu/packages/web-browsers.scm: ...here.
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Remove links.scm.
>
> LGTM, thanks!

Okay! Pushed to master as 8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkQwjAACgkQ5qXuPBlG
eg2bDhAAihUZ+eqf3cHrVcvOalVHIiK7zJeTo6mJiXcYOAy3hlk3UunRLmG8kSUt
n/jMgclSEO1c+/lo3/VLr72wKrom2U06eQenwmRsVS1+nRQl7azie/jc3NlNdyns
cfk16v8gb5m6n/VKtn+7QrV73TNGYF8w2QKBa2layRl0s62iNaA9bdfdrpd62DOC
QX5UHxh9lITnZzc2RfZWkJVyS+fzuEWCq3HUiQXcNU2L9SbYC2T3Iv/8cSZWB9bc
II1yDNMMxaOt2aG7Ci5EzoiT1/fsza8oXpktIF6uPUeb3v9c+B8/yjVbvrrEj466
u/SOKwcKfoeoTJvzvpmTQNle0TqjcrLBVDmsvzOT0VekOn+X7U1+qauJA6k4hHQ/
aS9dFv/2GQ9M48WAPubIA+pmebnus+9HCE9AGGqJjnm2NnnqBdXrOLELXSwQ0dRX
LqPRU0ZYqT6bpceElWUo71UtaZLzawBjj86A9e7UXx0VxCOEVUx6X3Q1hFYfACol
dOAbiEQB2a77WoGtLrRJt+p8ZIpxKXjSe3FFkoi4VqCdwRLWDFNLm8TQN+XhhIMX
PZiK7wHpntTxHVRae3R3eyf8kodgGNH6oTLF4BqQgotz4oHOJUXPSEKC6Dphufg4
OI1N+KAT8yZb1U9rivXsYd89Q7+JBBSyYGaWUHne6FFrFgHbFQ0=
=iTcA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26834@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26834
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help