[PATCH] gnu: Add emacs-key-chord.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Kyle Meyer
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170506044144.21717-1-kyle@kyleam.com
* gnu/packages/emacs.scm (emacs-key-chord): New variable.
---
gnu/packages/emacs.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9028ed0ed..a096b4f45 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4561,3 +4561,22 @@ built on top of XELB.")
(description "@code{emacs-gnuplot} is an emacs major mode for interacting
with gnuplot.")
(license license:gpl2+)))
+
+(define-public emacs-key-chord
+ (package
+ (name "emacs-key-chord")
+ (version "0.6")
+ (source (origin
+ (method url-fetch)
+ (uri "https://www.emacswiki.org/emacs/download/key-chord.el")
+ (sha256
+ (base32
+ "03m44pqggfrd53nh9dvpdjgm0rvca34qxmd30hr33hzprzjambxg"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/key-chord.el")
+ (synopsis "Map pairs of simultaneously pressed keys to Emacs commands")
+ (description
+ "This Emacs package provides @code{key-chord-mode}, a mode for binding
+key chords to commands. A key chord is defined as two keys pressed
+simultaneously or a single key quickly pressed twice.")
+ (license license:gpl2+)))
--
2.12.2
Arun Isaac wrote 8 years ago
(address . 26793-done@debbugs.gnu.org)
a84aa328.ADsAAHeqKiUAAAAAAAAAAAO8BNEAAAACwQwAAAAAAAW9WABZDaoM@mailjet.com
Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26793@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26793
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help