[PATCH] gnu: Add python-mwclient.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Leo Famulari
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170502081849.1496-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-mwclient, python2-mwclient): New variables.
---
gnu/packages/python.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5df679935..407a2c3a3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14106,3 +14106,37 @@ library for Python")
(description "@code{python-flask-oidc} provides an OpenID Connect extension
for Flask.")
(license license:bsd-2)))
+
+(define-public python-mwclient
+ (package
+ (name "python-mwclient")
+ (version "0.8.4")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The PyPI version wouldn't contain tests.
+ (uri (string-append "https://github.com/mwclient/mwclient/archive/"
+ "v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jj0yhilkjir00719fc7w133x7hdyhkxhk6xblla4asig45klsfv"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)
+ ("python-requests-oauthlib"
+ ,python-requests-oauthlib)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-pep8" ,python-pytest-pep8)
+ ("python-pytest-cache" ,python-pytest-cache)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-responses" ,python-responses)))
+ (home-page "https://github.com/btongminh/mwclient")
+ (synopsis "MediaWiki API client")
+ (description "This package provides a MediaWiki API client.")
+ (license license:expat)))
+
+(define-public python2-mwclient
+ (package-with-python2 python-mwclient))
Leo Famulari wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 26744@debbugs.gnu.org)
20170502144326.GB13895@jasmine
On Tue, May 02, 2017 at 10:18:49AM +0200, Danny Milosavljevic wrote:
Toggle quote (2 lines)
> * gnu/packages/python.scm (python-mwclient, python2-mwclient): New variables.

LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkImw0ACgkQJkb6MLrK
fwijtBAA4tn2GrTmBEsBuZxgejswa1qgsJQJ8lvy57e6n9nblUaBYnmtgWVhVVa2
r8qLWSQEXCpn3+Keb19h9tl55r8vr/HuTKoMYA+OS7+xT14OCSmS8b9saDe4EEGL
xj9yI90fL1YBNeBlgsAtm9Dd1LjBRuiYF7+KpWPDUuB45LdfKr2XwxZdV+aTq2oV
5ld2NT9e725sK1rxpOpjyQ/IXAGPRemwRi9oOAsa/ISFiHaXxkJZH4QRefexgdwV
MOzLFkRlO/7JkYL3odm5b8fMhTAzM/SUg5/v3reycGNgfwbbryw4wWazYRHNtcfl
zowXVQ/XDPX+bOGUh/fe4b+W1tMMdlBla7tsDuC+GEIt+VGOOouyZGQ3TOUUKEMl
PtzwlUJ1EcmOWtUwAvAr4/jbSGGuX6QLHW+4w1VaOHAaYL/+yJgfz629vcrD+IRA
5V9fsMiE5CCC1FJLe1PpWKTV5u/+kWu+mXEJb5oK0t0DVk1A91tI92nNxZhP7Uex
rkYWgb8j91f7y2JYSCIKaM7n99+Y0TLhqVcVjDa/6Kc0D4H5XWqRtijd9NqFOdQG
8gezvggQonE8M1Hr0JXFv9pXvHasl84EpErIidGjkLpgOd80DAWZpApYE64AexbD
z3WWdpiFGDmv7XYVYAAJq0Uj2crdZcy9b4IL/DzcYDQZSHQ/+I4=
=tIck
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170507212106.7b1c20b4@scratchpost.org
close 26166
close 26541
close 26614
close 26751
close 26692
close 26731
close 26743
close 26744
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26744@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26744
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help