[Patch 0/2] Add python-flask-oidc and dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170501100015.25657-1-dannym@scratchpost.org
Danny Milosavljevic (2):
gnu: Add python-oauth2client.
gnu: Add python-flask-oidc.

gnu/packages/python.scm | 54 +++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)
Danny Milosavljevic wrote 8 years ago
[PATCH 1/2] gnu: Add python-oauth2client.
(address . 26731@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170501100143.30374-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-oauth2client): New variable.
---
gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 164c1f49b..dd83f2dd7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14011,3 +14011,30 @@ exception message with a traceback that points to the culprit.")
(define-public python2-fudge
(package-with-python2 python-fudge))
+
+(define-public python-oauth2client
+ (package
+ (name "python-oauth2client")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "oauth2client" version))
+ (sha256
+ (base32
+ "1irqqap2zibysf8dba8sklfqikia579srd0phm5n754ni0h59gl0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; Django not found.
+ (propagated-inputs
+ `(("python-httplib2" ,python-httplib2)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pyasn1-modules" ,python-pyasn1-modules)
+ ("python-rsa" ,python-rsa)
+ ("python-six" ,python-six)))
+ (home-page
+ "http://github.com/google/oauth2client/")
+ (synopsis "OAuth 2.0 client library")
+ (description "@code{python-oauth2client} provides an OAuth 2.0 client
+library for Python")
+ (license license:asl2.0)))
Danny Milosavljevic wrote 8 years ago
[PATCH 2/2] gnu: Add python-flask-oidc.
(address . 26731@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170501100143.30374-2-dannym@scratchpost.org
* gnu/packages/python.scm (python-flask-oidc): New variable.
---
gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dd83f2dd7..1ea2db622 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14038,3 +14038,30 @@ exception message with a traceback that points to the culprit.")
(description "@code{python-oauth2client} provides an OAuth 2.0 client
library for Python")
(license license:asl2.0)))
+
+(define-public python-flask-oidc
+ (package
+ (name "python-flask-oidc")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask-oidc" version))
+ (sha256
+ (base32
+ "1ay5j0mf174bix7i67hclr95gv16z81fpx0dijvi0gydvdj3ddy2"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-itsdangerous" ,python-itsdangerous)
+ ("python-oauth2client" ,python-oauth2client)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-mock" ,python-mock)))
+ (home-page
+ "https://github.com/puiterwijk/flask-oidc")
+ (synopsis "OpenID Connect extension for Flask")
+ (description "@code{python-flask-oidc} provides an OpenID Connect extension
+for Flask.")
+ (license license:bsd-2)))
Marius Bakke wrote 8 years ago
Re: bug#26731: [PATCH 1/2] gnu: Add python-oauth2client.
877f20hbf3.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (29 lines)
> * gnu/packages/python.scm (python-oauth2client): New variable.
> ---
> gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 164c1f49b..dd83f2dd7 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -14011,3 +14011,30 @@ exception message with a traceback that points to the culprit.")
>
> (define-public python2-fudge
> (package-with-python2 python-fudge))
> +
> +(define-public python-oauth2client
> + (package
> + (name "python-oauth2client")
> + (version "4.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "oauth2client" version))
> + (sha256
> + (base32
> + "1irqqap2zibysf8dba8sklfqikia579srd0phm5n754ni0h59gl0"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f)) ; Django not found.

Please add a TODO here, maybe including the error message.

Toggle quote (9 lines)
> + (propagated-inputs
> + `(("python-httplib2" ,python-httplib2)
> + ("python-pyasn1" ,python-pyasn1)
> + ("python-pyasn1-modules" ,python-pyasn1-modules)
> + ("python-rsa" ,python-rsa)
> + ("python-six" ,python-six)))
> + (home-page
> + "http://github.com/google/oauth2client/")

The line break here is unnecessary.

Toggle quote (4 lines)
> + (synopsis "OAuth 2.0 client library")
> + (description "@code{python-oauth2client} provides an OAuth 2.0 client
> +library for Python")

...and this misses a punctuation

Toggle quote (1 lines)
> + (license license:asl2.0)))
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHTPAACgkQoqBt8qM6
VPoNuAf/Z1+7trKbeTwpie3VqOTsdrKGTzWNo3QLbwgQDi1VY2lusysjBj5fw4Pt
JcZaAeooRIiW4ClsLmgFpQRNLUnnuv/EewYo0JuM6u01xf7JuJsWm0KgOyCoF4QD
C10NV81YzBITvunr78VAqraJg+64n0ie9tCwZ0K27UiwlSP5Mwy1zcpCD+7+go+q
K69LYUiMgl6nb00Cuk/kGndvI+26nO4laJW0AaEGR1nXMsAu7uoX6GEY9JEp9xcb
1LnbUJvuzhQHhq0zVYHcPyFMyU48gmRTyZkS150Rx+eV4eF8Jvkzevzxei8++7YO
HbPlDn4eRyZnTorVlC2rELVsfdNXAw==
=5yJC
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#26731: [PATCH 2/2] gnu: Add python-flask-oidc.
874lx4hbd5.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (37 lines)
> * gnu/packages/python.scm (python-flask-oidc): New variable.
> ---
> gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index dd83f2dd7..1ea2db622 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -14038,3 +14038,30 @@ exception message with a traceback that points to the culprit.")
> (description "@code{python-oauth2client} provides an OAuth 2.0 client
> library for Python")
> (license license:asl2.0)))
> +
> +(define-public python-flask-oidc
> + (package
> + (name "python-flask-oidc")
> + (version "1.1.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "flask-oidc" version))
> + (sha256
> + (base32
> + "1ay5j0mf174bix7i67hclr95gv16z81fpx0dijvi0gydvdj3ddy2"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + `(("python-flask" ,python-flask)
> + ("python-itsdangerous" ,python-itsdangerous)
> + ("python-oauth2client" ,python-oauth2client)
> + ("python-six" ,python-six)))
> + (native-inputs
> + `(("python-nose" ,python-nose)
> + ("python-mock" ,python-mock)))
> + (home-page
> + "https://github.com/puiterwijk/flask-oidc")

Why these line breaks? Looks good otherwise!

Toggle quote (4 lines)
> + (synopsis "OpenID Connect extension for Flask")
> + (description "@code{python-flask-oidc} provides an OpenID Connect extension
> +for Flask.")
> + (license license:bsd-2)))
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHTTYACgkQoqBt8qM6
VPpfNggAtnwm1MguCzd1hoUEZvIyHPGrr1/ZUdgMs1j4G/ZIPCbxvJ8eHE7PmV7k
q+RcKGE2gz2cDSq8uQwGvkfgNTcihBVgc3MJlev4qS/+u5xc4byj+jkKyZ8boYgv
OdaioldkAVszCVtJcCqgm1k7hokAUd0QSyEFk83bQyKMmjIDrz9FppA0jUX0Jbwm
krGkYONXKpvCk3VqMBnjmtkbgNSAoaNfgTyFHvqWXWkHDDk0pICe8TLBweQK1mqH
iHuN+5JZFGNvE27VtvLUONBwqrqoNAdhfwMBFoGFSOfmrC9e6nY7RVJCXi9YPhMC
qffbGCahpJ6wrIGkFYZQBtRgT/eSkw==
=V4Q4
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170507212106.7b1c20b4@scratchpost.org
close 26166
close 26541
close 26614
close 26751
close 26692
close 26731
close 26743
close 26744
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26731@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26731
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help