[PATCH] Add tailon.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Marius Bakke
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
a006eadf-13ae-148d-4a1f-28d170ac2037@cbaines.net

Christopher Baines wrote 8 years ago
[PATCH 2/3] gnu: python-tornado: Update to 4.5.1.
(address . 26722@debbugs.gnu.org)
20170430214415.3029-2-mail@cbaines.net
* gnu/packages/python.scm (python-tornado): Update to 4.5.1.
---
gnu/packages/python.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5fbc012b7..d01aa2f56 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6135,13 +6135,13 @@ It is written entirely in Python.")
(define-public python-tornado
(package
(name "python-tornado")
- (version "4.3")
+ (version "4.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tornado" version))
(sha256
- (base32 "1gzgwayl6hmc9jfcl88bni4jcsk2jcca9dn1rvrfsvnijcjx7hn9"))))
+ (base32 "1zbkgcdfq81k298awrm8p0xwbwwn2p3nbizdglzfbkskhai082fv"))))
(build-system python-build-system)
(arguments
'(;; FIXME: Two tests error out with:
--
2.12.2
Christopher Baines wrote 8 years ago
[PATCH 1/3] gnu: Add python-sockjs-tornado.
(address . 26722@debbugs.gnu.org)
20170430214415.3029-1-mail@cbaines.net
* gnu/packages/python.scm (python-sockjs-tornado): New variable.
---
gnu/packages/python.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 22fadea27..5fbc012b7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4217,6 +4217,36 @@ routines such as routines for numerical integration and optimization.")
(package-with-python2
(strip-python2-variant python-scipy)))
+(define-public python-sockjs-tornado
+ (package
+ (name "python-sockjs-tornado")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/"
+ "s/sockjs-tornado/sockjs-tornado-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-tornado" ,python-tornado)))
+ (home-page "http://github.com/mrjoes/sockjs-tornado/")
+ (synopsis
+ "SockJS python server implementation on top of Tornado framework")
+ (description
+ "SockJS-tornado provides the server side counterpart to a SockJS client
+library, through the Tornado framework.
+
+SockJS provides a low latency, full duplex, cross-domain communication channel
+between a web browser and web server.")
+ (license license:expat)))
+
+(define-public python2-sockjs-tornado
+ (package-with-python2 python-sockjs-tornado))
+
(define-public python-socksipy-branch
(package
(name "python-socksipy-branch")
--
2.12.2
Christopher Baines wrote 8 years ago
[PATCH 3/3] gnu: Add tailon.
(address . 26722@debbugs.gnu.org)
20170430214415.3029-3-mail@cbaines.net
* gnu/packages/logging.scm (tailon): New variable.
---
gnu/packages/logging.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index d28094c3a..b441d455a 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -24,8 +24,10 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages autotools))
(define-public log4cpp
@@ -90,3 +92,30 @@ helper macros. You can log a message by simply streaming things to log at a
particular severity level. It allows logging to be controlled from the
command line.")
(license license:bsd-3)))
+
+(define-public tailon
+ (package
+ (name "tailon")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/97/83/"
+ "0591b4f2befe795dcea1f03d437afafa13e6637de78d7c68ec2c1af7d1c0/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08clrwpfdxcv2z2b5ardpmim4alahbw4l7631dhw62xhbcf6wjzz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-pyyaml" ,python-pyyaml)
+ ("python-sockjs-tornado" ,python-sockjs-tornado)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://tailon.readthedocs.io/")
+ (synopsis
+ "Webapp for looking at and searching through log files")
+ (description
+ "Tailon provides a web interface around the tail, grep, awk and sed
+commands, displaying the results via a web interface.")
+ (license license:bsd-3)))
--
2.12.2
Marius Bakke wrote 8 years ago
Re: bug#26722: [PATCH 1/3] gnu: Add python-sockjs-tornado.
87inlkhby9.fsf@fastmail.com
Hello Chris!

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/python.scm (python-sockjs-tornado): New variable.

[...]

Toggle quote (11 lines)
> +(define-public python-sockjs-tornado
> + (package
> + (name "python-sockjs-tornado")
> + (version "1.0.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://pypi.python.org/packages/source/"
> + "s/sockjs-tornado/sockjs-tornado-" version ".tar.gz"))

Please use 'pypi-uri' here.

Toggle quote (7 lines)
> + (sha256
> + (base32
> + "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
> + (build-system python-build-system)
> + (inputs
> + `(("python-tornado" ,python-tornado)))

Python does not have a good mechanism for specifying exact versions of
runtime dependencies, so they should normally be propagated. If the
package does not import this at runtime (e.g. only needed for tests) it
should be a 'native-input'.

LGTM with those changes.

Toggle quote (19 lines)
> + (synopsis
> + "SockJS python server implementation on top of Tornado framework")
> + (description
> + "SockJS-tornado provides the server side counterpart to a SockJS client
> +library, through the Tornado framework.
> +
> +SockJS provides a low latency, full duplex, cross-domain communication channel
> +between a web browser and web server.")
> + (license license:expat)))
> +
> +(define-public python2-sockjs-tornado
> + (package-with-python2 python-sockjs-tornado))
> +
> (define-public python-socksipy-branch
> (package
> (name "python-socksipy-branch")
> --
> 2.12.2
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHSj4ACgkQoqBt8qM6
VPrUQwf+IJf216rTagr/QBdVoMdMaNwa/9kbzMVgbXWLM0tm+msIybcTg7ZFGP4S
Xb2B6sW48Spj9s9yr/9F3TZBicwgT6hRldUKm906VzKTh3h50GyCQmWB01Kgzj3A
c/QUIOjxydk0dzukXA8Jr42rLpwvm37MJR7btVE7nltwAqmahGcDsm4m/rH4VPej
3gmvwLoUf7g3pGsPDGb310HysvFjgMMCN+KBXHALl4t6HjZG5HYLIVB0hAviHGtD
R7wEmy34xCAqlXjH3c9UbP8eZ+UESzI8ntyAMbronHjN1Z/kI7LTghVfDw71k3pC
gkBgGOPVj0BgsaQEQpje9l7j3D9f2Q==
=F/Xv
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#26722: [PATCH 2/3] gnu: python-tornado: Update to 4.5.1.
87fugohbtn.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (23 lines)
> * gnu/packages/python.scm (python-tornado): Update to 4.5.1.
> ---
> gnu/packages/python.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 5fbc012b7..d01aa2f56 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -6135,13 +6135,13 @@ It is written entirely in Python.")
> (define-public python-tornado
> (package
> (name "python-tornado")
> - (version "4.3")
> + (version "4.5.1")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "tornado" version))
> (sha256
> - (base32 "1gzgwayl6hmc9jfcl88bni4jcsk2jcca9dn1rvrfsvnijcjx7hn9"))))
> + (base32 "1zbkgcdfq81k298awrm8p0xwbwwn2p3nbizdglzfbkskhai082fv"))))

LGTM, assuming the few dependent packages (from `guix refresh -l
python{,2}-tornado`) still builds.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHSuQACgkQoqBt8qM6
VPru2wf8DpzOv3XCLs1x2X15B1LVf6q950muPirFFkqM2fSXvPmQ0ldrXRcNAQC1
KcYNi9nDQC5PceZYLMNW0q5caCP6GkP7PMSXj8aVxktfLmpglhPUbObpHyxV+0dT
szeQaTt7zv8UF2/JtMnyhfDkTlK+892zc7l2e8uklm3wDJUI4g4+TQltBn15SVFj
onI4qewxlNvGcO8tl11+xwcF3yD/EtwBvhUZzQGOrJwQDiCq9eUDulaPvUN6z/p8
IQswCE3IeuH1nnfuj36ptDRB6xkniEFK4/VTviaFkYxP1NQHAZkfzy6vGm8ivm3D
TDLH9yqX2v8bxqTpJY30X6hG75kRRg==
=zZPI
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#26722: [PATCH 3/3] gnu: Add tailon.
87d1bshbqd.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/logging.scm (tailon): New variable.

Same comment about 'pypi-uri' and native vs propagated inputs, other
than that looks good. Can you send updated patches? Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHS1oACgkQoqBt8qM6
VPrCAQf/esF352NSqXBRlix0Gr8qqlUJgpIOXaE0Z/+f1Wpj/GcruF6uoXIVLdvA
fam4EJ0zhKV9a1iY0xa2KAiiPQOZSJi67cmsnI2wTmWxW8MUKd57AKPfzGRDAVeE
eEBdqlr/H9cg35k9Z0ZTiPMRIUCFgGg0X+0SUEPfequaEK0CRD3mZw2Wb4LXWjoX
KNcc05MC7leHXsI8Hnf8kZnLZy057CYaR3OsXU5cFFHc1eKfvgXrhcz4csBoviaG
IJ0A3ppQTND3tViZ4mEByVGk/0z8d06vWEAi9nTb+hvFK9+Xf/0oJ+pALe1Q6vxe
cYrIkODkm6pko9Bk5vGwtCmEVgOBpA==
=hd5O
-----END PGP SIGNATURE-----

Christopher Baines wrote 8 years ago
[PATCH 3/3] gnu: Add tailon.
(address . 26722@debbugs.gnu.org)
20170501192215.6678-3-mail@cbaines.net
* gnu/packages/logging.scm (tailon): New variable.
---
gnu/packages/logging.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index d28094c3a..2523d65f6 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -24,8 +24,10 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages autotools))
(define-public log4cpp
@@ -90,3 +92,27 @@ helper macros. You can log a message by simply streaming things to log at a
particular severity level. It allows logging to be controlled from the
command line.")
(license license:bsd-3)))
+
+(define-public tailon
+ (package
+ (name "tailon")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "08clrwpfdxcv2z2b5ardpmim4alahbw4l7631dhw62xhbcf6wjzz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-pyyaml" ,python-pyyaml)
+ ("python-sockjs-tornado" ,python-sockjs-tornado)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://tailon.readthedocs.io/")
+ (synopsis
+ "Webapp for looking at and searching through log files")
+ (description
+ "Tailon provides a web interface around the tail, grep, awk and sed
+commands, displaying the results via a web interface.")
+ (license license:bsd-3)))
--
2.12.2
Christopher Baines wrote 8 years ago
[PATCH 2/3] gnu: python-tornado: Update to 4.5.1.
(address . 26722@debbugs.gnu.org)
20170501192215.6678-2-mail@cbaines.net
* gnu/packages/python.scm (python-tornado): Update to 4.5.1.
---
gnu/packages/python.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 85967ba45..6139287db 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6137,13 +6137,13 @@ It is written entirely in Python.")
(define-public python-tornado
(package
(name "python-tornado")
- (version "4.3")
+ (version "4.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tornado" version))
(sha256
- (base32 "1gzgwayl6hmc9jfcl88bni4jcsk2jcca9dn1rvrfsvnijcjx7hn9"))))
+ (base32 "1zbkgcdfq81k298awrm8p0xwbwwn2p3nbizdglzfbkskhai082fv"))))
(build-system python-build-system)
(arguments
'(;; FIXME: Two tests error out with:
--
2.12.2
Christopher Baines wrote 8 years ago
[PATCH 1/3] gnu: Add python-sockjs-tornado.
(address . 26722@debbugs.gnu.org)
20170501192215.6678-1-mail@cbaines.net
* gnu/packages/python.scm (python-sockjs-tornado): New variable.
---
gnu/packages/python.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 22fadea27..85967ba45 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4217,6 +4217,38 @@ routines such as routines for numerical integration and optimization.")
(package-with-python2
(strip-python2-variant python-scipy)))
+(define-public python-sockjs-tornado
+ (package
+ (name "python-sockjs-tornado")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sockjs-tornado" version))
+ (sha256
+ (base32
+ "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; There are no tests, and running the test phase requires missing
+ ;; dependencies
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-tornado" ,python-tornado)))
+ (home-page "http://github.com/mrjoes/sockjs-tornado/")
+ (synopsis
+ "SockJS python server implementation on top of Tornado framework")
+ (description
+ "SockJS-tornado provides the server side counterpart to a SockJS client
+library, through the Tornado framework.
+
+SockJS provides a low latency, full duplex, cross-domain communication channel
+between a web browser and web server.")
+ (license license:expat)))
+
+(define-public python2-sockjs-tornado
+ (package-with-python2 python-sockjs-tornado))
+
(define-public python-socksipy-branch
(package
(name "python-socksipy-branch")
--
2.12.2
Christopher Baines wrote 8 years ago
e9ec0ce1-04c8-ef66-c64c-5deb0a560180@cbaines.net
On 01/05/17 15:46, Marius Bakke wrote:
Toggle quote (35 lines)
> Hello Chris!
>
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/python.scm (python-sockjs-tornado): New variable.
>
> [...]
>
>> +(define-public python-sockjs-tornado
>> + (package
>> + (name "python-sockjs-tornado")
>> + (version "1.0.3")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://pypi.python.org/packages/source/"
>> + "s/sockjs-tornado/sockjs-tornado-" version ".tar.gz"))
>
> Please use 'pypi-uri' here.
>
>> + (sha256
>> + (base32
>> + "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
>> + (build-system python-build-system)
>> + (inputs
>> + `(("python-tornado" ,python-tornado)))
>
> Python does not have a good mechanism for specifying exact versions of
> runtime dependencies, so they should normally be propagated. If the
> package does not import this at runtime (e.g. only needed for tests) it
> should be a 'native-input'.
>
> LGTM with those changes.

Thanks for the review Marius, I've now sent some updated patches.
Attachment: signature.asc
Christopher Baines wrote 8 years ago
Re: bug#26722: [PATCH 2/3] gnu: python-tornado: Update to 4.5.1.
20a9db5e-e010-d774-6439-b7952f65bdb4@cbaines.net
On 01/05/17 15:49, Marius Bakke wrote:
Toggle quote (28 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/python.scm (python-tornado): Update to 4.5.1.
>> ---
>> gnu/packages/python.scm | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
>> index 5fbc012b7..d01aa2f56 100644
>> --- a/gnu/packages/python.scm
>> +++ b/gnu/packages/python.scm
>> @@ -6135,13 +6135,13 @@ It is written entirely in Python.")
>> (define-public python-tornado
>> (package
>> (name "python-tornado")
>> - (version "4.3")
>> + (version "4.5.1")
>> (source
>> (origin
>> (method url-fetch)
>> (uri (pypi-uri "tornado" version))
>> (sha256
>> - (base32 "1gzgwayl6hmc9jfcl88bni4jcsk2jcca9dn1rvrfsvnijcjx7hn9"))))
>> + (base32 "1zbkgcdfq81k298awrm8p0xwbwwn2p3nbizdglzfbkskhai082fv"))))
>
> LGTM, assuming the few dependent packages (from `guix refresh -l
> python{,2}-tornado`) still builds.

Thanks for pointing this out. I didn't spot any problems in existing
packages, although I did spot that the python2-sockjs-tornado failed to
build regardless of the version of python2-tornado. I think the issue
was the setup.py test command being run and pulling in some random
packages, which can be resolved by disabling the tests, as there are no
tests to run.
Attachment: signature.asc
Christopher Baines wrote 8 years ago
Re: bug#26722: [PATCH 3/3] gnu: Add tailon.
aed40d1a-9dfc-85a1-d299-1939ee580ff5@cbaines.net
On 01/05/17 15:51, Marius Bakke wrote:
Toggle quote (7 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/logging.scm (tailon): New variable.
>
> Same comment about 'pypi-uri' and native vs propagated inputs, other
> than that looks good. Can you send updated patches? Thanks!

I've switched the pypi-uri here, but left the inputs as just inputs. I
view the tailon package as an application, and not a library, and the
inputs paths are included in the wrapped bin/tailon script, which means
that it works without propagating them.
Attachment: signature.asc
Marius Bakke wrote 8 years ago
87shkofdfy.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (13 lines)
> On 01/05/17 15:51, Marius Bakke wrote:
>> Christopher Baines <mail@cbaines.net> writes:
>>
>>> * gnu/packages/logging.scm (tailon): New variable.
>>
>> Same comment about 'pypi-uri' and native vs propagated inputs, other
>> than that looks good. Can you send updated patches? Thanks!
>
> I've switched the pypi-uri here, but left the inputs as just inputs. I
> view the tailon package as an application, and not a library, and the
> inputs paths are included in the wrapped bin/tailon script, which means
> that it works without propagating them.

Oops, you're right. Good catch!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHrzEACgkQoqBt8qM6
VPpQpggAjl5+Nh23hTg3hpc3xt88KqsmrWc4eL2B8mcKC1HZUbgkkMvob9kySOlX
dHL1bbCX8SoREhrMrK0eBReBcEH/IjxN2pAfXxLF1WLfxULdn18/nrEYkYUuJ+J/
fxl8qAA/p9TASvdwVUiFwFbgYFByAQhtnD0mauuP+3h6wGAWHMEwV494nH742J6G
Tc3QZkYTWKpeTl4GCkt1qgEgTtxa+J/kgn5VyjHcDvd+dE5h5SGmu83qB5iqwNTU
0p+8+m0Lxl2+J7lNNGS2Q9sxmtp91W0Y+5VWEqpogqlGZPI4aPxO06NJz9gnJean
cnnxJFjkUtNSa+um0MKZHEkLWmZkeA==
=K2gg
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#26722: [PATCH 1/3] gnu: Add python-sockjs-tornado.
87pofsfcy3.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (38 lines)
> On 01/05/17 15:46, Marius Bakke wrote:
>> Hello Chris!
>>
>> Christopher Baines <mail@cbaines.net> writes:
>>
>>> * gnu/packages/python.scm (python-sockjs-tornado): New variable.
>>
>> [...]
>>
>>> +(define-public python-sockjs-tornado
>>> + (package
>>> + (name "python-sockjs-tornado")
>>> + (version "1.0.3")
>>> + (source
>>> + (origin
>>> + (method url-fetch)
>>> + (uri (string-append
>>> + "https://pypi.python.org/packages/source/"
>>> + "s/sockjs-tornado/sockjs-tornado-" version ".tar.gz"))
>>
>> Please use 'pypi-uri' here.
>>
>>> + (sha256
>>> + (base32
>>> + "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
>>> + (build-system python-build-system)
>>> + (inputs
>>> + `(("python-tornado" ,python-tornado)))
>>
>> Python does not have a good mechanism for specifying exact versions of
>> runtime dependencies, so they should normally be propagated. If the
>> package does not import this at runtime (e.g. only needed for tests) it
>> should be a 'native-input'.
>>
>> LGTM with those changes.
>
> Thanks for the review Marius, I've now sent some updated patches.

Cheers! Pushed as 99aa2dce5d376b6612aab0971985f6320c03ecd2 :)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHsbQACgkQoqBt8qM6
VPrqwAgAmPvPylXffO3QRqsUCcaxretr0MqGdASzNVLpjvaZMcMDFzBIbosmjKCf
rlnwCbEd37uKUxEuDPbCcwUyQtbG+Vrd//us6IvL1NdLSk3fd+grOvPGHFyH16uT
nZS/XzG7/bUcmce6RlNatQQT4zxyOIASpSnQ5nwgb+iGPQ6843yLuSUQI0zY/c1e
9tpkfLt5BU4KQJGugTEYvEJDa4T8t1uUBQ9TIPpUL2lVmX2+e8QN5GdxCDBePTso
dO6mPvppoMCzHIDD2M2StIVy0uT6Q3+YQLZXvHsMRfc8MpfZ4AkPGttORncGh2sq
mn/p6ZtpqIm4Cc8GvGoSLpaLY6WXLw==
=L7fD
-----END PGP SIGNATURE-----

Closed
Christopher Baines wrote 8 years ago
565ef392-5f03-ac11-aac2-45ed713e732e@cbaines.net
On 01/05/17 23:07, Marius Bakke wrote:
Toggle quote (42 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> On 01/05/17 15:46, Marius Bakke wrote:
>>> Hello Chris!
>>>
>>> Christopher Baines <mail@cbaines.net> writes:
>>>
>>>> * gnu/packages/python.scm (python-sockjs-tornado): New variable.
>>>
>>> [...]
>>>
>>>> +(define-public python-sockjs-tornado
>>>> + (package
>>>> + (name "python-sockjs-tornado")
>>>> + (version "1.0.3")
>>>> + (source
>>>> + (origin
>>>> + (method url-fetch)
>>>> + (uri (string-append
>>>> + "https://pypi.python.org/packages/source/"
>>>> + "s/sockjs-tornado/sockjs-tornado-" version ".tar.gz"))
>>>
>>> Please use 'pypi-uri' here.
>>>
>>>> + (sha256
>>>> + (base32
>>>> + "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
>>>> + (build-system python-build-system)
>>>> + (inputs
>>>> + `(("python-tornado" ,python-tornado)))
>>>
>>> Python does not have a good mechanism for specifying exact versions of
>>> runtime dependencies, so they should normally be propagated. If the
>>> package does not import this at runtime (e.g. only needed for tests) it
>>> should be a 'native-input'.
>>>
>>> LGTM with those changes.
>>
>> Thanks for the review Marius, I've now sent some updated patches.
>
> Cheers! Pushed as 99aa2dce5d376b6612aab0971985f6320c03ecd2 :)

Awesome, thanks Marius :)
Attachment: signature.asc
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26722@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26722
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help