[PATCH] gnu: Move qutebrowser to web-browsers.scm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170430195141.30265-1-kei@openmailbox.org
* gnu/packages/web.scm: Move qutebrowser...
* gnu/packages/web-browsers.scm: ...here.
---
gnu/packages/web-browsers.scm | 69 ++++++++++++++++++++++++++++++++++++++++++-
gnu/packages/web.scm | 62 --------------------------------------
2 files changed, 68 insertions(+), 63 deletions(-)

Toggle diff (183 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index fe971de91..ad6461c57 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gtk)
@@ -31,13 +33,17 @@
#:use-module (gnu packages libidn)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages image)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages xorg)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system python))
(define-public dillo
(package
@@ -183,3 +189,64 @@ older or slower computers and embedded systems.")
rendering engine entirely written from scratch. It is small and capable of
handling many of the web standards in use today.")
(license license:gpl2+)))
+
+(define-public qutebrowser
+ (package
+ (name "qutebrowser")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/The-Compiler/"
+ "qutebrowser/releases/download/v" version "/"
+ "qutebrowser-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05qryn56w2pbqhir4pl99idx7apx2xqw9f8wmbrhj59b1xgr3x2p"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("asciidoc" ,asciidoc)))
+ (inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-cssutils" ,python-cssutils)
+ ("python-jinja2" ,python-jinja2)
+ ("python-markupsafe" ,python-markupsafe)
+ ("python-pygments" ,python-pygments)
+ ("python-pypeg2" ,python-pypeg2)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-pyqt" ,python-pyqt)
+ ("qtwebkit" ,qtwebkit)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-more
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (app (string-append out "/share/applications"))
+ (hicolor (string-append out "/share/icons/hicolor")))
+ (system* "a2x" "-f" "manpage" "doc/qutebrowser.1.asciidoc")
+ (install-file "doc/qutebrowser.1"
+ (string-append out "/share/man/man1"))
+
+ (for-each
+ (lambda (i)
+ (let ((src (format #f "icons/qutebrowser-~dx~d.png" i i))
+ (dest (format #f "~a/~dx~d/apps/qutebrowser.png"
+ hicolor i i)))
+ (mkdir-p (dirname dest))
+ (copy-file src dest)))
+ '(16 24 32 48 64 128 256 512))
+ (install-file "icons/qutebrowser.svg"
+ (string-append hicolor "/scalable/apps"))
+
+ (substitute* "qutebrowser.desktop"
+ (("Exec=qutebrowser")
+ (string-append "Exec=" out "/bin/qutebrowser")))
+ (install-file "qutebrowser.desktop" app)
+ #t))))))
+ (home-page "https://qutebrowser.org/")
+ (synopsis "Minimal, keyboard-focused, vim-like web browser")
+ (description "qutebrowser is a keyboard-focused browser with a minimal
+GUI. It is based on PyQt5 and QtWebKit.")
+ (license license:gpl3+)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6a4489508..c122077ba 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -78,7 +78,6 @@
#:use-module (gnu packages python)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages qt)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages xml)
#:use-module (gnu packages curl)
@@ -4376,64 +4375,3 @@ functions of Tidy.")
Features include the ability to stop SQL injections, XSS and CSRF attacks and
exploit attempts.")
(license l:gpl2)))
-
-(define-public qutebrowser
- (package
- (name "qutebrowser")
- (version "0.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/The-Compiler/"
- "qutebrowser/releases/download/v" version "/"
- "qutebrowser-" version ".tar.gz"))
- (sha256
- (base32
- "05qryn56w2pbqhir4pl99idx7apx2xqw9f8wmbrhj59b1xgr3x2p"))))
- (build-system python-build-system)
- (native-inputs
- `(("asciidoc" ,asciidoc)))
- (inputs
- `(("python-colorama" ,python-colorama)
- ("python-cssutils" ,python-cssutils)
- ("python-jinja2" ,python-jinja2)
- ("python-markupsafe" ,python-markupsafe)
- ("python-pygments" ,python-pygments)
- ("python-pypeg2" ,python-pypeg2)
- ("python-pyyaml" ,python-pyyaml)
- ("python-pyqt" ,python-pyqt)
- ("qtwebkit" ,qtwebkit)))
- (arguments
- `(#:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-more
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (app (string-append out "/share/applications"))
- (hicolor (string-append out "/share/icons/hicolor")))
- (system* "a2x" "-f" "manpage" "doc/qutebrowser.1.asciidoc")
- (install-file "doc/qutebrowser.1"
- (string-append out "/share/man/man1"))
-
- (for-each
- (lambda (i)
- (let ((src (format #f "icons/qutebrowser-~dx~d.png" i i))
- (dest (format #f "~a/~dx~d/apps/qutebrowser.png"
- hicolor i i)))
- (mkdir-p (dirname dest))
- (copy-file src dest)))
- '(16 24 32 48 64 128 256 512))
- (install-file "icons/qutebrowser.svg"
- (string-append hicolor "/scalable/apps"))
-
- (substitute* "qutebrowser.desktop"
- (("Exec=qutebrowser")
- (string-append "Exec=" out "/bin/qutebrowser")))
- (install-file "qutebrowser.desktop" app)
- #t))))))
- (home-page "https://qutebrowser.org/")
- (synopsis "Minimal, keyboard-focused, vim-like web browser")
- (description "qutebrowser is a keyboard-focused browser with a minimal
-GUI. It is based on PyQt5 and QtWebKit.")
- (license l:gpl3+)))
--
2.12.2
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26719@debbugs.gnu.org)
87r307yma2.fsf@gnu.org
Hi,

Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/web.scm: Move qutebrowser...
> * gnu/packages/web-browsers.scm: ...here.

Sounds reasonable to me, go for it!

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26719-done@debbugs.gnu.org)
87efw2gc5j.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (11 lines)
> Hi,
>
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * gnu/packages/web.scm: Move qutebrowser...
>> * gnu/packages/web-browsers.scm: ...here.
>
> Sounds reasonable to me, go for it!
>
> Ludo’.

Thanks! Pushed as 7610c3ca5540a7d0946e15a765b35f8bf068316e.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkN/3kACgkQ5qXuPBlG
eg0L7g/+M2M2sDYIGA5WZtVm8OQ0ns+KYPTv/tv6YERmNjr8ApXVimbp7H9TEARa
/5YSgzidcSBXiDjo+io5ujMptw68YLHfiq9TvejikowwNlGQaSBrzhK7MkTt9W78
FpcjG6C0p0albpUSoxVfcYY+vT+qrUdk+FNrqZu4srjkwUaPa4JmCCirjXzMtF/e
bCWAl++AnVvAh5wYs98rkrLGtteeE8ER1l9iAsDAidm2sLGByz9lNoR/mdsdkqtF
FudA7v2O0L3Pts4w84pth/g+LDPEgjzyPI0ydvkc20uA+MFVoP8mIFKpvIt6K/+j
5oRJofSwbJ7dVp0ZTELh/WDSK7fuWzCuACdZ2ZFxD9XghqI46836cBgkn0RQ46lR
J4AntIdZqwiBuJNWULeZ63b25Kxj8kRxeC+rb3PWtKNZ7Lxj4euyAlUaJ4Mx0l37
qNJqVoFPDYC5uPUpnrstVjq1FcGgurrpoTLKnMF0nerz6bss5+pFuxZpL0SOQmDU
ISnDRpS0rWAaQgh7Iws4+bmXsvn4dr0fdUWpniv1rJHuZenOForpenxaZfyxtqAX
La2uE+vJL8SVmW1lXdCG0l3qK+DQFfzVO4+dBoLOXaH6KdvBxEB/vQbjJpgqyjwS
pzmbW1cWzpwJeunps9+vIPUwWvITOYcAg08svTzmvmmTQ9aMNX8=
=nPg7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26719@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26719
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help