[PATCH] gnu: Move netsurf to web-browsers.scm.

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Allan Webber
  • Kei Kebreau
  • Leo Famulari
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 30 Apr 2017 00:09
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170429220942.26880-1-kei@openmailbox.org
* gnu/packages/web.scm: Move netsurf...
* gnu/packages/web-browsers.scm: ...here.
---
gnu/packages/web-browsers.scm | 122 ++++++++++++++++++++++++++++++++++++++++++
gnu/packages/web.scm | 116 ---------------------------------------
2 files changed, 122 insertions(+), 116 deletions(-)

Toggle diff (287 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 3ff69611b..fe971de91 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
@@ -20,13 +21,20 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages libidn)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages image)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -61,3 +69,117 @@
older or slower computers and embedded systems.")
(home-page "http://www.dillo.org")
(license license:gpl3+)))
+
+(define-public netsurf
+ (package
+ (name "netsurf")
+ (version "3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.netsurf-browser.org/netsurf/"
+ "releases/source/netsurf-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "174sjx0566agckwmlj4w2cip5qbxdiafyhlp185a1qprxx84pbjr"))
+ (patches (search-patches "netsurf-system-utf8proc.patch"
+ "netsurf-y2038-tests.patch"
+ "netsurf-longer-test-timeout.patch"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("netsurf-buildsystem" ,netsurf-buildsystem)
+ ("nsgenbind" ,nsgenbind)
+ ("libidn" ,libidn) ;only for tests
+ ("check" ,check)
+ ("perl" ,perl)
+ ("perl-html-parser" ,perl-html-parser)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("gtk+" ,gtk+-2)
+ ("openssl" ,openssl)
+ ("utf8proc" ,utf8proc)
+ ("libpng" ,libpng)
+ ("libjpeg" ,libjpeg)
+ ("libcss" ,libcss)
+ ("libdom" ,libdom)
+ ("libnsbmp" ,libnsbmp)
+ ("libnsgif" ,libnsgif)
+ ("libnspsl" ,libnspsl)
+ ("libnsutils" ,libnsutils)
+ ("libsvgtiny" ,libsvgtiny)
+ ("miscfiles" ,miscfiles)))
+ (arguments
+ `(#:make-flags `("CC=gcc" "BUILD_CC=gcc"
+ ,(string-append "PREFIX=" %output)
+ ,(string-append "NSSHARED="
+ (assoc-ref %build-inputs
+ "netsurf-buildsystem")
+ "/share/netsurf-buildsystem"))
+ #:test-target "test"
+ #:modules ((ice-9 rdelim)
+ (ice-9 match)
+ (srfi srfi-1)
+ (sxml simple)
+ ,@%glib-or-gtk-build-system-modules)
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'build 'adjust-welcome
+ (lambda _
+ ;; First, fix some unended tags and simple substitutions
+ (substitute* "frontends/gtk/res/welcome.html"
+ (("<(img|input)([^>]*)>" _ tag contents)
+ (string-append "<" tag contents " />"))
+ (("Licence") "License") ;prefer GNU spelling
+ ((" open source") ", free software")
+ (("web&nbsp;site") "website")
+ ;; Prefer privacy-respecting default search engine
+ (("www.google.co.uk") "www.duckduckgo.com/html")
+ (("Google Search") "DuckDuckGo Search")
+ (("name=\"btnG\"") ""))
+ ;; Remove default links so it doesn't seem we're endorsing them
+ (with-atomic-file-replacement "frontends/gtk/res/welcome.html"
+ (lambda (in out)
+ ;; Leave the DOCTYPE header as is
+ (display (read-line in 'concat) out)
+ (sxml->xml
+ (let rec ((sxml (xml->sxml in)))
+ ;; We'd like to use sxml-match here, but it can't
+ ;; match against generic tag symbols...
+ (match sxml
+ (`(div (@ (class "links")) . ,rest)
+ '())
+ ((x ...)
+ (map rec x))
+ (x x)))
+ out)))
+ #t))
+ (add-before 'check 'patch-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("test/bloom.c" "test/hashtable.c")
+ (("/usr/share/dict/words")
+ (string-append (assoc-ref inputs "miscfiles") "/share/web2")))
+ #t))
+ (add-after 'install 'install-more
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (desktop (string-append out "/share/applications/"
+ "netsurf.desktop")))
+ (mkdir-p (dirname desktop))
+ (copy-file "frontends/gtk/res/netsurf-gtk.desktop"
+ desktop)
+ (substitute* desktop
+ (("netsurf-gtk") (string-append out "/bin/netsurf"))
+ (("netsurf.png") (string-append out "/share/netsurf/"
+ "netsurf.xpm")))
+ (install-file "Docs/netsurf-gtk.1"
+ (string-append out "/share/man/man1/"))
+ #t))))))
+ (home-page "http://www.netsurf-browser.org")
+ (synopsis "Web browser")
+ (description
+ "NetSurf is a lightweight web browser that has its own layout and
+rendering engine entirely written from scratch. It is small and capable of
+handling many of the web standards in use today.")
+ (license license:gpl2+)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 487366b4a..6a4489508 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -69,10 +69,8 @@
#:use-module (gnu packages gnu-doc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
- #:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
- #:use-module (gnu packages libidn)
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages base)
@@ -4101,120 +4099,6 @@ Public Suffix List. It is developed as part of the NetSurf project.")
w3c webidl files and a binding configuration file.")
(license l:expat)))
-(define-public netsurf
- (package
- (name "netsurf")
- (version "3.6")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://download.netsurf-browser.org/netsurf/"
- "releases/source/netsurf-" version "-src.tar.gz"))
- (sha256
- (base32
- "174sjx0566agckwmlj4w2cip5qbxdiafyhlp185a1qprxx84pbjr"))
- (patches (search-patches "netsurf-system-utf8proc.patch"
- "netsurf-y2038-tests.patch"
- "netsurf-longer-test-timeout.patch"))))
- (build-system glib-or-gtk-build-system)
- (native-inputs
- `(("netsurf-buildsystem" ,netsurf-buildsystem)
- ("nsgenbind" ,nsgenbind)
- ("libidn" ,libidn) ;only for tests
- ("check" ,check)
- ("perl" ,perl)
- ("perl-html-parser" ,perl-html-parser)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("curl" ,curl)
- ("gtk+" ,gtk+-2)
- ("openssl" ,openssl)
- ("utf8proc" ,utf8proc)
- ("libpng" ,libpng)
- ("libjpeg" ,libjpeg)
- ("libcss" ,libcss)
- ("libdom" ,libdom)
- ("libnsbmp" ,libnsbmp)
- ("libnsgif" ,libnsgif)
- ("libnspsl" ,libnspsl)
- ("libnsutils" ,libnsutils)
- ("libsvgtiny" ,libsvgtiny)
- ("miscfiles" ,miscfiles)))
- (arguments
- `(#:make-flags `("CC=gcc" "BUILD_CC=gcc"
- ,(string-append "PREFIX=" %output)
- ,(string-append "NSSHARED="
- (assoc-ref %build-inputs
- "netsurf-buildsystem")
- "/share/netsurf-buildsystem"))
- #:test-target "test"
- #:modules ((ice-9 rdelim)
- (ice-9 match)
- (srfi srfi-1)
- (sxml simple)
- ,@%glib-or-gtk-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'build 'adjust-welcome
- (lambda _
- ;; First, fix some unended tags and simple substitutions
- (substitute* "frontends/gtk/res/welcome.html"
- (("<(img|input)([^>]*)>" _ tag contents)
- (string-append "<" tag contents " />"))
- (("Licence") "License") ;prefer GNU spelling
- ((" open source") ", free software")
- (("web&nbsp;site") "website")
- ;; Prefer privacy-respecting default search engine
- (("www.google.co.uk") "www.duckduckgo.com/html")
- (("Google Search") "DuckDuckGo Search")
- (("name=\"btnG\"") ""))
- ;; Remove default links so it doesn't seem we're endorsing them
- (with-atomic-file-replacement "frontends/gtk/res/welcome.html"
- (lambda (in out)
- ;; Leave the DOCTYPE header as is
- (display (read-line in 'concat) out)
- (sxml->xml
- (let rec ((sxml (xml->sxml in)))
- ;; We'd like to use sxml-match here, but it can't
- ;; match against generic tag symbols...
- (match sxml
- (`(div (@ (class "links")) . ,rest)
- '())
- ((x ...)
- (map rec x))
- (x x)))
- out)))
- #t))
- (add-before 'check 'patch-check
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("test/bloom.c" "test/hashtable.c")
- (("/usr/share/dict/words")
- (string-append (assoc-ref inputs "miscfiles") "/share/web2")))
- #t))
- (add-after 'install 'install-more
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (desktop (string-append out "/share/applications/"
- "netsurf.desktop")))
- (mkdir-p (dirname desktop))
- (copy-file "frontends/gtk/res/netsurf-gtk.desktop"
- desktop)
- (substitute* desktop
- (("netsurf-gtk") (string-append out "/bin/netsurf"))
- (("netsurf.png") (string-append out "/share/netsurf/"
- "netsurf.xpm")))
- (install-file "Docs/netsurf-gtk.1"
- (string-append out "/share/man/man1/"))
- #t))))))
- (home-page "http://www.netsurf-browser.org")
- (synopsis "Web browser")
- (description
- "NetSurf is a lightweight web browser that has its own layout and
-rendering engine entirely written from scratch. It is small and capable of
-handling many of the web standards in use today.")
- (license l:gpl2+)))
-
(define-public surfraw
(package
(name "surfraw")
--
2.12.2
C
C
Christopher Allan Webber wrote on 30 Apr 2017 17:31
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26713@debbugs.gnu.org)
87mvaxdi9i.fsf@dustycloud.org
Good call... lgtm!
K
K
Kei Kebreau wrote on 30 Apr 2017 20:12
(name . Christopher Allan Webber)(address . cwebber@dustycloud.org)(address . 26713-done@debbugs.gnu.org)
87wpa1ojby.fsf@openmailbox.org
Christopher Allan Webber <cwebber@dustycloud.org> writes:

Toggle quote (2 lines)
> Good call... lgtm!

Pushed! Thanks for the review.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkGKSIACgkQ5qXuPBlG
eg0AKBAAviFUCkUQF2S6I8FgV+UnPDv+y+R+2f6BtXnr2rQAU6LZPTaPuzdHa9ah
tyIQbzj5vDatH8epiTyuedULrWskAcXmhH85zxM93eQlX0dGduZys+F29zKNFoj5
5o7uYVYMUC55hsyjWHWzuxK/JACdqbOg8CJIOY0P1miE6lhCY8fivaVerFPkVbNR
sNssCfW8bjkiArWTVL9GB0CgG1nEQzizhZ5cTJ6T4jQMH7TcfHhQPIcpvANsEmAc
QXpkUz6lQpJ2i8VZNQ4P935MXmSalkWYVjUb6nnwn+b7axyzwNTUAIICUAvxjL6f
b9u+Z7Z80jtykCuR7FbKhvCqzmPbG+WtMgLNr+U9Ak5RE5z/w9ZN6QzLt40hF7p7
CEB0WbfkFYen8ERWJ0zG9zhfJkywuyt6dDoKe8qhxABQ63DUHOynifZPGWHrO0Eq
RYiL38jEwwd6IHEbLhShXTZ6lnPKmY9WxF1KGH95lFJtBZPE8pfHFx/DJD5Y0ecr
1xMYUcHpvDQVdoNzy7fWPUZXlPjBtyypgFuBdA/iszLyWx89fy+fJSHSoH/Ll++3
aA2JlMaF1OBchN542YDUXq3Nx2a+dFB0OQ0TrvPmnr7hhjbyuVCEpC2pjiYGbqfr
SFP5fp7dINJDwUzHNlWd3lcBulVx6ki4HcwhBWpZNDtww5arwes=
=e5Gq
-----END PGP SIGNATURE-----

Closed
L
L
Leo Famulari wrote on 30 Apr 2017 21:13
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26713@debbugs.gnu.org)
20170430191306.GA26169@jasmine
On Sat, Apr 29, 2017 at 06:09:42PM -0400, Kei Kebreau wrote:
Toggle quote (3 lines)
> * gnu/packages/web.scm: Move netsurf...
> * gnu/packages/web-browsers.scm: ...here.

This caused building Guix to fail because the glib-or-gtk build-system
module was not imported in (gnu packages web-browsers).

I planned to add that module in a followup commit, but I realized that
several other variables from (gnu packages web) need to be imported in
(gnu packages web-browsers) along with this change, and I decided to
revert the change for now.

Can you take another look at moving this package?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkGN0EACgkQJkb6MLrK
fwhpiA//bX2D77bPJ6gGejbk/a7g2kp7o7SeQS9UGtLOxlwQejR9C6YDmLNVqZKJ
lMg8FwXkrEm7vDgjZ1cx/Tfkte3MwbpnfcadXk/JgPTiSQw1wiEUUUvNR+VgUyxC
v0y61wh+sGMgAcaRMHOm7B3GjOEfU7DyPDVEzYjdjaxYzzyIw6yMiIIo6y/f0Dqg
JSGkcXoJ0xYRkmBOHe8SqbmaNINqb2mlTHnTr8P8icQ+9DB1kgaFkmCiVfyWD5Wd
Zu+vBzM3FIon0A5ms6AjI39kYeZdWHkSP/BD0Qu59AAWhJvAiNJbVy5nTjUpl7vz
KvFegV7OawvWqpqo6hexECFV6N0WX4hQjQQHlOHyVfbmZ2B39UcDvbWhWuWKDmuD
3DTCzhkUSfr25sH4AjU6d7ejasYp8yNsfw1mBCaQr5sD1bThBAjLtTvMaA/55kp1
UArFCjviEuATrjYHpcySny7wjSeXAOnUkQFeRxm759G8YTewL2uPv/g6VzBwA+nV
KEYEjHGnQphKpn3OAVCITeYCpt8cHPbe5z47yx4dIhz+0TsrGWYEkO+PwvJiB4bi
YCs9jwgu2JMdnOzEbzNY8SXyO0yJBjbm5jQPTtLMJuvC9Km66DD3ZxFDJI1Oj7Cj
FwzApUWVwVdkRmstiJIaYVumFhfh1LxtSPqpcjQCHOMBSI3qims=
=SwyE
-----END PGP SIGNATURE-----


K
K
Kei Kebreau wrote on 30 Apr 2017 21:57
(name . Leo Famulari)(address . leo@famulari.name)(address . 26713@debbugs.gnu.org)
87shkpoehf.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (8 lines)
> On Sat, Apr 29, 2017 at 06:09:42PM -0400, Kei Kebreau wrote:
>> * gnu/packages/web.scm: Move netsurf...
>> * gnu/packages/web-browsers.scm: ...here.
>
> This caused building Guix to fail because the glib-or-gtk build-system
> module was not imported in (gnu packages web-browsers).
>

Oh no! :(

Toggle quote (7 lines)
> I planned to add that module in a followup commit, but I realized that
> several other variables from (gnu packages web) need to be imported in
> (gnu packages web-browsers) along with this change, and I decided to
> revert the change for now.
>
> Can you take another look at moving this package?

Will do. I'll have to adjust the qutebrowser patch for corrections to
this one.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkGQawACgkQ5qXuPBlG
eg35+xAAkd7lVBw+djEOV+qdO3jk4rTPkuyKrjNFcaXxS/+w6uFwMa7k5yGrE7nk
H41/5bGzZu9ilnbU2IFm/OaLu9nZfneY+hPG+K832EyUEc1B6dPLuxe+YlZVZ56t
GU4YTsZJv827pg/SmGyHZcI3pxra6ghEZUO2A3Mv84G21dSAcFUab93eq2QV8Vg/
5Jq5mRxvB7hKKo2lA1aXNL8XyljqXySJZXfabaLEgLu2wR2//TxdOtqWenRqoWqp
AUvjrvuYOmw7/v5ED4Gol97489ieIS9NatvBiErbpdgTAMhs9I68/LoWZSd1ZBFw
UZimeWlT6nPgkegmYzX6AJqvcF2f7uXmnkUvnJ0TF3iwzy1doMEPPPFLXK0K+3hi
bbFr/p8GAe/oCGMLbHzuM/s305g4NjvRiXhK7d4Mba8I/5xuAnWbgNFAQcFaRnRl
KLZkiUrmzwVZfAiIa2eic5q5Bljs6BbePlTDmwkjFcG850/B4X+uCokRTMtgcd6I
FDyy6ASNgdCN9FoOlJfizxwEhR52Wy9XyTwa03Ytw/UaI3isH8UoPiLNy7GGA4o6
Ltq2x+SSZECuuIqs4tJshbW4V7Bn6/VfvsAn+lTPOVlENYNiJRBeSHXtPXE3UqYb
NG6HcgrSS/k6YaF/hS7xpekMNy9VmukyxEjpNSwGxWEiOmcwSMw=
=BHai
-----END PGP SIGNATURE-----

K
K
Kei Kebreau wrote on 1 May 2017 00:17
(name . Leo Famulari)(address . leo@famulari.name)(address . 26713@debbugs.gnu.org)
87o9vdo805.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (22 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Sat, Apr 29, 2017 at 06:09:42PM -0400, Kei Kebreau wrote:
>>> * gnu/packages/web.scm: Move netsurf...
>>> * gnu/packages/web-browsers.scm: ...here.
>>
>> This caused building Guix to fail because the glib-or-gtk build-system
>> module was not imported in (gnu packages web-browsers).
>>
>
> Oh no! :(
>
>> I planned to add that module in a followup commit, but I realized that
>> several other variables from (gnu packages web) need to be imported in
>> (gnu packages web-browsers) along with this change, and I decided to
>> revert the change for now.
>>
>> Can you take another look at moving this package?
>
> Will do. I'll have to adjust the qutebrowser patch for corrections to
> this one.

Try the attached patch. I'm not sure that copying the definition of
netsurf-buildsystem is the best way to handle the move, but I'm not sure
this is worth making netsurf-buildsystem a publicly-defined package.

Thoughts?
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkGYnoACgkQ5qXuPBlG
eg1IBg/+J1dGH/FdsNWrSf2696KMsvrsDoby864uILZBqcF9A/VqQKpKw9bRX3ZE
wpR+ouUxqGHs1XF3Jua38GRJf0OlZSw6URNBcxkkcIg3TSHSUGc6PV5rprxH9Qi2
p041lyFS0c7eVM1K617bhcVT/VG/V4BAlpZZKEv+93Ev1/zIQYDAkviRxi1BDRRi
lIw7Yd2XhzJ+zoL6nwJVlx1eYriwxtww7ehS+lOB3/CtvBZH5G/3wbTMGKFfA7Q8
0ab73Pee96D3RL3QVdk0vzCBxPWd3l830BVfqy8HFiHmjXxv4WTK+fHpzbmXViIX
DR9jhDFwfuqsdo897qXBRP7VVJ3TmqZF+VO9X3iNJXbLDYIlunipH3db4atUBpUt
tgvoFdf8aluNRfLCNc5HfGMXEJ3PZSLieQLveo4Zkc6j2uOCgg+x3L3HDRlJPAUU
3VXqiqWC1gT28N0hIlaLsi+Ynja+FMk/EfipihvE97zhFLf2KO3Ax8sfQXE5vvUh
cgIpbSBjHmYv05RMTmEJQbsWckkLzXOpbnJUV8qvhXo29pgyx5UCOBhAreMBvv4d
3Q/rWnGzehvijoOs3PToONBJ+C9p9MHhselT4UgADAGXPn3miZbJmign+2zOUq+I
egcvmDxpQM1bkrJwKweXZ+CooBK1jMie/q8NYUuUP+R3AYDnaXU=
=CLu+
-----END PGP SIGNATURE-----

K
K
Kei Kebreau wrote on 6 May 2017 16:51
(name . Leo Famulari)(address . leo@famulari.name)(address . 26713@debbugs.gnu.org)
87lgqaghsh.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (30 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Leo Famulari <leo@famulari.name> writes:
>>
>>> On Sat, Apr 29, 2017 at 06:09:42PM -0400, Kei Kebreau wrote:
>>>> * gnu/packages/web.scm: Move netsurf...
>>>> * gnu/packages/web-browsers.scm: ...here.
>>>
>>> This caused building Guix to fail because the glib-or-gtk build-system
>>> module was not imported in (gnu packages web-browsers).
>>>
>>
>> Oh no! :(
>>
>>> I planned to add that module in a followup commit, but I realized that
>>> several other variables from (gnu packages web) need to be imported in
>>> (gnu packages web-browsers) along with this change, and I decided to
>>> revert the change for now.
>>>
>>> Can you take another look at moving this package?
>>
>> Will do. I'll have to adjust the qutebrowser patch for corrections to
>> this one.
>
> Try the attached patch. I'm not sure that copying the definition of
> netsurf-buildsystem is the best way to handle the move, but I'm not sure
> this is worth making netsurf-buildsystem a publicly-defined package.
>
> Thoughts?

If you have no objections, I'd like to push this.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkN4u4ACgkQ5qXuPBlG
eg3dPg//VW7p48qBqUkuOVpuJtto8gbaZWeVqf8/cYAesPwdKEhNW0Cse6X3TsAi
6wXbObQ56eVdBcKcQaQbDwfZBZabaLNin0WJwJYWwBc0in8w0zcOfdXouS2ChCcA
URaXJXQQeWzcFoY54DLaXfgPruDxmQm3eYTnDeArRjO/HfV483jkxIv/MJDJfr31
abQoI3MpQh/gG5Ze6yPjvHUJHdjl3ld8ejtuukSal6dDk6BhuBV9+6+Qz/+nI28a
uc1MOJXuPUf9kuvi+l1Lqdp26sjbexrv4uSPHI3bA4CCicXqoEyB1/Gswecpz+gn
vFG+LeoTVT/BNM8DydJRrXyuxK9O9VQu4bUJSjhNOaf/UJfHOJ/RNp04kPeg9o2R
cckedtVS32YaIeo2MMT7zwkhqzzIVL5td96RQur7QmsTt5drcfkUEW6SMcmAjq9k
S+mnHU4yXia9b99bGjf/Q0OuyaS6aKbS0yIItIHKhiScpbAsQOaCaVeAH0MCjGdH
I2oUzvoIqDkoS3TPa9mr2XWBx+K05sb5fFujZhU0tCAwqwzH7jYjKqoE7/qeZwmG
jx85KFQV6YvoLfq+ZuvY7ZSzt895llNJf969OgWvRMlQ16JzWHjpQYGxkeZGDn7s
nQybNSG4+fuLp/U2J9BruZrlLKNGKrR+VajbCde+OqMIKakN0GQ=
=r1n/
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 May 2017 17:24
(address . 26713@debbugs.gnu.org)
87pofmypni.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (34 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> Leo Famulari <leo@famulari.name> writes:
>>>
>>>> On Sat, Apr 29, 2017 at 06:09:42PM -0400, Kei Kebreau wrote:
>>>>> * gnu/packages/web.scm: Move netsurf...
>>>>> * gnu/packages/web-browsers.scm: ...here.
>>>>
>>>> This caused building Guix to fail because the glib-or-gtk build-system
>>>> module was not imported in (gnu packages web-browsers).
>>>>
>>>
>>> Oh no! :(
>>>
>>>> I planned to add that module in a followup commit, but I realized that
>>>> several other variables from (gnu packages web) need to be imported in
>>>> (gnu packages web-browsers) along with this change, and I decided to
>>>> revert the change for now.
>>>>
>>>> Can you take another look at moving this package?
>>>
>>> Will do. I'll have to adjust the qutebrowser patch for corrections to
>>> this one.
>>
>> Try the attached patch. I'm not sure that copying the definition of
>> netsurf-buildsystem is the best way to handle the move, but I'm not sure
>> this is worth making netsurf-buildsystem a publicly-defined package.
>>
>> Thoughts?
>
> If you have no objections, I'd like to push this.

AFAICT, the latest patch (id:87o9vdo805.fsf@openmailbox.org) does not
actually move netsurf-build-system. Am I missing something?

There are other things using netsurf-build-system as well, so I would
just leave it for now. Also some copyright information is missing in the
patch.

As a side note, make sure to run `make` after moving code around like
this. And `make clean-go` when deleting modules. I've been bitten before
by Guix picking up code from stale .go files.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkN6qEACgkQoqBt8qM6
VPovYAgAwG3dlUagjrz3qy/T22Cc/kzvjpSMkE7gbUSqen6j23o0D6UImy3xv7Px
7b1O6EjMdvQPtJ8eBocgfskvqxgm75wol0AgJMm6qhZvH/Tk/TJu/9LkmSkIoJ+G
TfE0GwBk9+CMCSlobVjvsOjQI6ZnXB8fDbibQdfM2fdQ3W957kaUVg2FNHFsgPah
fsMUW3jzCLfzZGElZC3dpx9ZroPVBw+MaCpqDaqap9PzsISYrJ6HSl36sNj+H280
jor3BRt3XTHfgGtcfbuKPvZAyjb3+nEn/s4ZpZeDHZLujPYW5EaOipo7OHGPcDzE
OcgZ5oePAuTpKXJ5Hbr4PFJiJVxwZA==
=FjDl
-----END PGP SIGNATURE-----

K
K
Kei Kebreau wrote on 6 May 2017 18:34
(name . Marius Bakke)(address . mbakke@fastmail.com)
87h90ygd0j.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (6 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>
> AFAICT, the latest patch (id:87o9vdo805.fsf@openmailbox.org) does not
> actually move netsurf-build-system. Am I missing something?

No, I somehow posted an old patch. Please try the one attached.

Toggle quote (4 lines)
>
> There are other things using netsurf-build-system as well, so I would
> just leave it for now.

I intend to copy, not move, netsurf-build-system into web-browsers.scm
so that NetSurf can build.

Toggle quote (3 lines)
> Also some copyright information is missing in the patch.
>

What information in particular?

Toggle quote (4 lines)
> As a side note, make sure to run `make` after moving code around like
> this. And `make clean-go` when deleting modules. I've been bitten before
> by Guix picking up code from stale .go files.

Noted.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkN+x0ACgkQ5qXuPBlG
eg07vQ/+OM9uadLHIZrjXR050cwkDj31Ww6i+gtf8+i5LsiecuY11Cx7nScTG+cy
oH8v/9xLsxJitO9xLChlszScNcK0upDDcK1NiAWIYdl8BXJm6x1xavwoDo+adWFZ
3WmjAfrYhn5h0b6CNS++CnI29ef2/97jQkdddQtHWsUDkZvwQFy6lN7b/MP/VhxP
u7rwFeHsftrcJDP4uNmapvJSuKrOC4pdusU1ty6n01KsQC8uCDedRj/V/wZ2hCTf
fJqXHfvWMNwfDY+uE5UTUd79BUr9oOGS2JBy/0cWa6Qxm6F+CUklP/CEbRbg7Nv9
C2TGPXHHd1+i8PdH3CIQ4nehJxWDAuyq8QOHajAsY01BeSlJmhmHkPCbCh4EPdkX
x50XfdMf9qdXAPrfrcRyGtDH4WUBu6PR7W1Cn3al1bqLk3v9+CiClMGNmExqO+ju
LDRI/iLFMY55t8N1rtz9CSjFUILz9IHMalbySMYb8zm0jjuPObEn0CToF2Kh2W5x
zDkx7HALammEQ4LyiSe3elviBt3shf+h8vv3A1GRs/BLkxfXK1CQsoDghQl4cOXp
qqroh56vWpvNxAgbu+slfkCHiWT6X7TEIx3men7keeRIBANAUCfXT0tpsxmFkwd4
nByJu9cmgLLISCNdIlI5i/wH7yuycR0Aa3ILO/SB/MJuzDX8kys=
=jRLy
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 May 2017 19:38
(name . Kei Kebreau)(address . kei@openmailbox.org)
87k25tzy07.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (8 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>>
>> There are other things using netsurf-build-system as well, so I would
>> just leave it for now.
>
> I intend to copy, not move, netsurf-build-system into web-browsers.scm
> so that NetSurf can build.

There are many other packages in web.scm using netsurf-build-system. IMO
it would be "cleaner" to have all that in a "netsurf" module, but I'm not
sure if it's worth the hassle.

The current patch duplicates netsurf-build-system, which means we have
to maintain it two different places. I think we should avoid that.

Toggle quote (4 lines)
>> Also some copyright information is missing in the patch.
>
> What information in particular?

Netsurf was added in 2016, but web-browsers.scm only includes 2017.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkOChgACgkQoqBt8qM6
VPrkrQf/SZeYLbdXm8J43XuJUtkcJV/CAcx1ph2mmQk1jnovFIQkZHDq2ntvUUd+
7b1O8emHhtZPZ1oPttumooqGf/eN3cDygInzoXVTTNvR9Nue+3pl+/QvcITxGwu8
UUbe8T6T1ociDKuWPQ93Qx7aDb4scCOY/vRhru9pqMD3ZJOL++Rc9gf+BRmQbMcQ
3ZCaUIxV6dwOZpAlscV3OVEC08/xdVwEfD6YA3tSvAIofD7Q9wkxAs8zNJVVtA2K
gdydhImcKvv8JFQAyRqg4mUcStsYmPZlE7KlF/hwWcQgTfNbFZRxGaM92s6ZtZJO
Oa67wkq90wyfwFXJWrLZsR0y+nqlPA==
=7QQ8
-----END PGP SIGNATURE-----

K
K
Kei Kebreau wrote on 8 May 2017 17:17
(name . Marius Bakke)(address . mbakke@fastmail.com)
8737cfxtrg.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (18 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>> There are other things using netsurf-build-system as well, so I would
>>> just leave it for now.
>>
>> I intend to copy, not move, netsurf-build-system into web-browsers.scm
>> so that NetSurf can build.
>
> There are many other packages in web.scm using netsurf-build-system. IMO
> it would be "cleaner" to have all that in a "netsurf" module, but I'm not
> sure if it's worth the hassle.
>
> The current patch duplicates netsurf-build-system, which means we have
> to maintain it two different places. I think we should avoid that.
>

Another option is moving all of the "NetSurf components" into
web-browsers.scm. None of them are depended on by anything but NetSurf
and each other.

Toggle quote (6 lines)
>>> Also some copyright information is missing in the patch.
>>
>> What information in particular?
>
> Netsurf was added in 2016, but web-browsers.scm only includes 2017.

Okay, this was fixed in the patch I just submitted.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJZEIwTAAoJEOal7jwZRnoNyssP/iW6pVsvL2Teec1W1QarDsKS
2kwXNu4V2xER0h0NkpZvR8d+ptyazLZjJRazqoJJg8Cov+dTQBSDnElZnvln2HIv
D4LWUjvaRqg4PngnvTs84HjamsQtEzMWC4+LVqZH+acXgBCD5TDXhOinPQxuFJ/6
R3pA/FNwB4MzJhKTSbyZ06TTzeuvt1ytUQIvN4sYuBLyAx9sKQbKe/8Rag+uSx62
qk65M80vSxGEmUQJA84ErQNRNe/ftS/XLsMh+vzu9/112Gvs6o/WOKi+gsZCieqD
YgFZgFJ9Q6sm1GFptQeVIvlCE8oDcj09qntKqQHxkSdZJXi8cfAspzRMTnyTqVnH
zMxP7IuiYlDUJ8x4vxO/Gt/Q0ZQq+M2/RCV1apdFJR9a3KHirT3gEGg+ZYqVS28L
mmAXkneCBtXDoFe52OfsTF/juPysicUL27lgZi4oTrzQX0/fMn+1etfKN2ZbRrd/
xTJWJO+2lZwR4WSb390HYPZbZICLMQx5SK8WdsaZ34Qw7iIeZ8Riq7fDBLFjZKBl
MEe3Y9Av0c2bq20jvblpI4Fq1s+oQ2UBKOleGKvydNgL+XW29wPYjuzTg2eYrFxi
gZO3u3qV45Ih7XK+TsZ4rpu+bxvmUf5kl5Zh3MbinZOrErjdHhkUNz/l7/hC1Yyd
DrK7+y5AIrHQ3ygyehqn
=dNSQ
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 26713@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26713
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch