Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/python.scm (python-openid)[arguments]: Replace 'check phase.
[native-inputs]: Add python-defusedxml, python-psycopg2.
---
gnu/packages/python.scm | 11 +++++++++++
1 file changed, 11 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e51405bd9..bee656318 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5523,6 +5523,17 @@ features useful for text console applications.")
(base32
"1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (substitute* "admin/runtests"
+ (("django_failures = django_tests..") "print('Disabled Django tests')"))
+ (zero? (system* "./admin/runtests")))))))
+ (native-inputs
+ `(("python-defusedxml" ,python-defusedxml)
+ ("python-psycopg2" ,python-psycopg2)))
(home-page "https://github.com/necaris/python3-openid")
(synopsis "OpenID support for servers and consumers")
(description "This library provides OpenID authentication for Python, both