[PATCH] gnu: python-openid: Fix tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170428124219.9609-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-openid)[arguments]: Replace 'check phase.
[native-inputs]: Add python-defusedxml, python-psycopg2.
---
gnu/packages/python.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e51405bd9..bee656318 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5523,6 +5523,17 @@ features useful for text console applications.")
(base32
"1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (substitute* "admin/runtests"
+ (("django_failures = django_tests..") "print('Disabled Django tests')"))
+ (zero? (system* "./admin/runtests")))))))
+ (native-inputs
+ `(("python-defusedxml" ,python-defusedxml)
+ ("python-psycopg2" ,python-psycopg2)))
(home-page "https://github.com/necaris/python3-openid")
(synopsis "OpenID support for servers and consumers")
(description "This library provides OpenID authentication for Python, both
Danny Milosavljevic wrote 8 years ago
[PATCH v2] gnu: python-openid: Fix package.
(address . 26692@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170428125216.11070-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-openid)[arguments]: Replace 'check phase.
[propagated-inputs]: Add python-defusedxml.
[native-inputs]: Add python-psycopg2.
---
gnu/packages/python.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e51405bd9..313e69975 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5523,6 +5523,19 @@ features useful for text console applications.")
(base32
"1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (substitute* "admin/runtests"
+ (("django_failures = django_tests..")
+ "print('Disabled Django tests')"))
+ (zero? (system* "./admin/runtests")))))))
+ (propagated-inputs
+ `(("python-defusedxml" ,python-defusedxml)))
+ (native-inputs
+ `(("python-psycopg2" ,python-psycopg2)))
(home-page "https://github.com/necaris/python3-openid")
(synopsis "OpenID support for servers and consumers")
(description "This library provides OpenID authentication for Python, both
Marius Bakke wrote 8 years ago
87k264bo5w.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (24 lines)
> * gnu/packages/python.scm (python-openid)[arguments]: Replace 'check phase.
> [propagated-inputs]: Add python-defusedxml.
> [native-inputs]: Add python-psycopg2.
> ---
> gnu/packages/python.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index e51405bd9..313e69975 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -5523,6 +5523,19 @@ features useful for text console applications.")
> (base32
> "1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
> (build-system python-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda _
> + (substitute* "admin/runtests"
> + (("django_failures = django_tests..")
> + "print('Disabled Django tests')"))

Can you add a comment/TODO/FIXME here about why Django tests needs to be
disabled? Other than that looks OK.

Toggle quote (8 lines)
> + (zero? (system* "./admin/runtests")))))))
> + (propagated-inputs
> + `(("python-defusedxml" ,python-defusedxml)))
> + (native-inputs
> + `(("python-psycopg2" ,python-psycopg2)))
> (home-page "https://github.com/necaris/python3-openid")
> (synopsis "OpenID support for servers and consumers")
> (description "This library provides OpenID authentication for Python, both
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkDUewACgkQoqBt8qM6
VPrRxQgAqpIRiw4EIf6YJw9vBxSGP3/Q0vOXJKca8RcqDh4kCBYbjJdKovTi+pOv
TENXuHOR+VCeIl6gHz0a1SVdXUif8n+gVrEqnzeAWxOwXMZFtALjScCnF6V99qnf
9NjN+0I96s8k5aFLgCTgT3jTCyE+B0e7AbOg7dfYZJLzTc0mswFHYTn8VODumc4V
ie5AZ8qsnTDjIFhrDZGQJHep+v6vc38lTILbYFTKfj99ryc5BojoYo2b2N4vob3M
fgG0ZJvUc4SfH7kufRo3i3ynaYelLdNdNjo8/ZopGsPBEQnIw1zRhoBi7GrklQe9
RS7ZqMon1idaHsp1cfVQprDx9AisvA==
=4x8B
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170507212106.7b1c20b4@scratchpost.org
close 26166
close 26541
close 26614
close 26751
close 26692
close 26731
close 26743
close 26744
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26692@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26692
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help