gnu: Add guile-sjson.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Allan Webber
  • Kei Kebreau
Owner
unassigned
Submitted by
Christopher Allan Webber
Severity
normal

Debbugs page

Christopher Allan Webber wrote 8 years ago
(address . guix-patches@gnu.org)
874lxcvase.fsf@dustycloud.org
It looks like somehow I didn't send this last night as I thought I did.

Anyway, here's guile-sjson!
From a62ba605afe6c994fe0c6dc8b544789fdefe4561 Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Tue, 25 Apr 2017 00:18:29 -0500
Subject: [PATCH] gnu: Add guile-sjson.

* gnu/packages/guile.scm (guile-sjson): Add guile-sjson.
---
gnu/packages/guile.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9dd524e4b..ad2a488f6 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1768,4 +1768,33 @@ HTML (via SXML) or any other format for rendering.")
(home-page "http://dthompson.us/software/guile-syntax-highlight")
(license license:lgpl3+))))
+(define-public guile-sjson
+ (package
+ (name "guile-sjson")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dustycloud.org/misc/sjson-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09hnh2brc7ihh8dv4g5hdmdj8rs8p9l3pmlgafkx145grdg7wprx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _ (zero? (system* "sh" "bootstrap.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "https://gitlab.com/dustyweb/guile-sjson")
+ (synopsis "s-expression based json reader/writer for Guile")
+ (description "guile-sjson is a json reader/writer for Guile.
+It has a nice, simple s-expression based syntax.")
+ (license license:lgpl3+)))
+
;;; guile.scm ends here
--
2.12.2
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAlj/WKEACgkQS8Alkl/4
9NO13hAAw55LRm+BsnYxbtHSjoayhgulX0PTbEzWn8gEc7e1+QYNixUFvi4kgEpD
fOQUgUKwVGaiay8MAhshWkVCHOW5HGoKZgqmsmF3zy+4HOWu1+u+NnZNns3E48+m
tJP9ojdB7Q6Q/yMaPIIGoecauYAWigpeteo7h+eKs+KwogISRgtcnXjFoVgjbtYP
CLZWGISnphuobuM9xwr9tUwY0+Nu3mcKsxLFOdNhWx8xkk8MGow6EKqwHOp5VCty
pM898wCzGsyTqjHH6a7ubaKXRfFZ3bR628eoCrq9Mmk47qUWJR/oHs89rMxm16Q1
KwuaTTYAsj8rNUKF/pAdDxIH6gRg67r9SFa+JYBkddj3epNvMzkoiTfsjCMMBXLI
BLWTOitsuY5tt7T+dOIBx9590xznkztE3NRd3aeuk0sQdlAH3QE9RVc0O5J9o/nP
qC+VQz//m+WQOUsddSSEYa/5vOPNzGlyYswvFc51WQu0pjoK8XqUdQtk9W3h1kUO
RxrqdOozzN9tGfH/7BDscVMfPzQWuAMJXZXKeOcgkOod8L0Jq84BBdip78NC+i9Z
fBVnFrg5xbc/QunHUJGGI8IW377JSyxwi8eqzLq1t/2Zv75m8HkHD3DGXGQ6VR77
trnpqpn8imVPhgTueFMFJxWAuUj+F0ri1fwDba2w/zUQFvdztpI=
=r7vJ
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Christopher Allan Webber)(address . cwebber@dustycloud.org)(address . 26653@debbugs.gnu.org)
87d1c0nn99.fsf@openmailbox.org
Christopher Allan Webber <cwebber@dustycloud.org> writes:

Toggle quote (48 lines)
> It looks like somehow I didn't send this last night as I thought I did.
>
> Anyway, here's guile-sjson!
>
> From a62ba605afe6c994fe0c6dc8b544789fdefe4561 Mon Sep 17 00:00:00 2001
> From: Christopher Allan Webber <cwebber@dustycloud.org>
> Date: Tue, 25 Apr 2017 00:18:29 -0500
> Subject: [PATCH] gnu: Add guile-sjson.
>
> * gnu/packages/guile.scm (guile-sjson): Add guile-sjson.
> ---
> gnu/packages/guile.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
> index 9dd524e4b..ad2a488f6 100644
> --- a/gnu/packages/guile.scm
> +++ b/gnu/packages/guile.scm
> @@ -1768,4 +1768,33 @@ HTML (via SXML) or any other format for rendering.")
> (home-page "http://dthompson.us/software/guile-syntax-highlight")
> (license license:lgpl3+))))
>
> +(define-public guile-sjson
> + (package
> + (name "guile-sjson")
> + (version "0.2")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://dustycloud.org/misc/sjson-" version
> + ".tar.gz"))
> + (sha256
> + (base32
> + "09hnh2brc7ihh8dv4g5hdmdj8rs8p9l3pmlgafkx145grdg7wprx"))))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'bootstrap
> + (lambda _ (zero? (system* "sh" "bootstrap.sh")))))))
> + (native-inputs
> + `(("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("pkg-config" ,pkg-config)))
> + (inputs
> + `(("guile" ,guile-2.2)))
> + (home-page "https://gitlab.com/dustyweb/guile-sjson")
> + (synopsis "s-expression based json reader/writer for Guile")

The linter wants a capital letter for the first letter in the synopsis.

Toggle quote (6 lines)
> + (description "guile-sjson is a json reader/writer for Guile.
> +It has a nice, simple s-expression based syntax.")
> + (license license:lgpl3+)))
> +
> ;;; guile.scm ends here

The rest looks good.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlj/y4IACgkQ5qXuPBlG
eg09qA//SyAMIWmeALeVzYC1y7VtwJq6xjEJoqSQd7h19ak8m8g9giZnXzim0aKL
cJDjFw3RhRgivuNSlYFyEVDXle+AyOKwntMi/JyUXOwPI2DRWGEIKvp4aLoFZxCy
VLubbPR8wbeH9JK1vM/le+OQ2+ZUB/r4YhgaPLqEakgnIW/jPKwVbUpZrlB0Wsiw
sTzYzcOU85r1KWb+o+8XOjzh2/d0fj+vS9iaYdEuBPwysFwmN/6lPVNya9dKwsbP
XRrjq+WC7ykufkfJo4A0d9rL1SFTA8+m0sG7Vztm8nB3Jow6iNZZWR+62byjPlLZ
GO7oaBwuKO/WGmRwnpjCXEYrIozeiBh6AYATM3xvS3BH04mi5Kp52wqcR91uFloe
5+hJAkQ18FuCdyeHQntahQ04WGkn+7aOc0/Bg85Ob6aRI6WChWNDYJj+hIoVMR8P
3u1Gd6LVKKD2y8oLxygdob5+2YiJHOr0KstHmDZZxRt4InF/SxlPSc5dPUc+MNyf
5qd/9/QU4ggzCOxNnqDRnyiPdITP6yx/opG/Sh/pvTcjzV3Mby/eYOnBKJ3DMwXC
fMb3sdpjp+SELi2V9nPtsarrSmpPkUcOLjO5EwkO8bM5XBFJ4I6mwa5FuGFwFcb3
nIojK1Sk8bgfllnqYWwe3GNl34ORFjTEhWfbjKVZ2Li5YyxvB8Q=
=XdBj
-----END PGP SIGNATURE-----

Christopher Allan Webber wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26653-done@debbugs.gnu.org)
87tw5bu8xj.fsf@dustycloud.org
Toggle quote (4 lines)
>> + (synopsis "s-expression based json reader/writer for Guile")
>
> The linter wants a capital letter for the first letter in the synopsis.

Fixed.

Toggle quote (8 lines)
>> + (description "guile-sjson is a json reader/writer for Guile.
>> +It has a nice, simple s-expression based syntax.")
>> + (license license:lgpl3+)))
>> +
>> ;;; guile.scm ends here
>
> The rest looks good.

Woo woo! Pushed up!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26653@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26653
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help