[PATCH] gnu: Add gnustep-make.

  • Done
  • quality assurance status badge
Details
3 participants
  • Kei Kebreau
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170423003805.32488-1-kei@openmailbox.org
* gnu/packages/gnustep.scm (gnustep-make): New variable.
---
gnu/packages/gnustep.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 6e729165c..b55b0ea29 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -22,7 +22,9 @@
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
+ #:use-module (gnu packages base)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages libffcall)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages texinfo)
@@ -30,7 +32,33 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages image)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xml))
+
+(define-public gnustep-make
+ (package
+ (name "gnustep-make")
+ (version "2.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f)) ; no check target
+ (native-inputs
+ `(("which" ,which)))
+ (home-page "http://gnustep.org")
+ (synopsis "GNUstep make package")
+ (description "The makefile package is a simple, powerful and extensible way
+to write makefiles for a GNUstep-based project. It allows the user to write a
+project without having to deal with the complex issues associated with
+configuration, building, installation, and packaging. It also allows the user
+to easily create cross-compiled binaries.")
+ (license gpl3+)))
(define-public windowmaker
(package
--
2.12.2
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26617@debbugs.gnu.org)
20170423004817.GE10153@jasmine
On Sat, Apr 22, 2017 at 08:38:05PM -0400, Kei Kebreau wrote:
Toggle quote (2 lines)
> * gnu/packages/gnustep.scm (gnustep-make): New variable.

Cool!

Toggle quote (20 lines)
> --- a/gnu/packages/gnustep.scm
> +++ b/gnu/packages/gnustep.scm
> @@ -22,7 +22,9 @@
> #:use-module (guix packages)
> #:use-module (guix build-system gnu)
> #:use-module (guix licenses)
> + #:use-module (gnu packages base)
> #:use-module (gnu packages xorg)
> + #:use-module (gnu packages libffcall)
> #:use-module (gnu packages gnome)
> #:use-module (gnu packages gtk)
> #:use-module (gnu packages texinfo)
> @@ -30,7 +32,33 @@
> #:use-module (gnu packages glib)
> #:use-module (gnu packages fontutils)
> #:use-module (gnu packages image)
> - #:use-module (gnu packages pkg-config))
> + #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages xml))

Are all of these new modules used?

Toggle quote (2 lines)
> + (home-page "http://gnustep.org")

Is there a package-specific home-page?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlj7+dEACgkQJkb6MLrK
fwhqYQ//Zf6z37UdjkdLB2S/7+ycH8Nu3n5ypRScLqqAIGtnP8X5Be3AGnB0Jv94
8H7HnLXmaHQJtYkCgWNp7DKxP5MxatDg8k5ldsI/Jj6hAosJNwGYVkJ2ZkgwPwif
DGrhryO+6rkJnx02p7EvFfUwxyPbhMiPdpND0wz/71RgN4DwrEQHlpbzcuFoE0TE
ctfpf0QqqDlt1gY23Iy8wk3d1JADCph2Fx+qD5jYnA7b3jE9itWcNFv6M1945end
hEUM6THiB/4hcIHnYYDhm2omraJOtv5zzS3J+tfis2k7KW0HQQgm3caCD4ZTMMLG
qtx/wySJLBFuA6x1sh+EjIGxz7Vjc+t3YSe1Y3mtJqc1n52QV4So8Sbl3vpvBP7r
ZE0dKkr6GvHRn5NlsXkgnOrakwuj5WmvUZyR5DI/QExEuLqG8VxsFfyhog+XmUw6
1RbQtRNOm9WIYvYx4LvTdHZiNLXprkQaLM/oFzZGKj4BnHaOxFa1PxI6d84rq+Od
A/8VFGdJR4A9e9w+Q4bQk1EmeLbDh9eTWL6i6vUYdNiRI4BoBE9ZWL6efyqdXb8A
EZsanQGJ1Y7nslwDM9iJVsjPBBToywXt9RxQKtVwro4Td2gEcz5d6hm6Yzhtrz36
VGaKz2ZqP+sCD+nfw0P5eVJrB4arZzxQ7y7jBYzG+GnOIAUC7ds=
=FW+I
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 26617@debbugs.gnu.org)
87zif7jfuq.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (28 lines)
> On Sat, Apr 22, 2017 at 08:38:05PM -0400, Kei Kebreau wrote:
>> * gnu/packages/gnustep.scm (gnustep-make): New variable.
>
> Cool!
>
>> --- a/gnu/packages/gnustep.scm
>> +++ b/gnu/packages/gnustep.scm
>> @@ -22,7 +22,9 @@
>> #:use-module (guix packages)
>> #:use-module (guix build-system gnu)
>> #:use-module (guix licenses)
>> + #:use-module (gnu packages base)
>> #:use-module (gnu packages xorg)
>> + #:use-module (gnu packages libffcall)
>> #:use-module (gnu packages gnome)
>> #:use-module (gnu packages gtk)
>> #:use-module (gnu packages texinfo)
>> @@ -30,7 +32,33 @@
>> #:use-module (gnu packages glib)
>> #:use-module (gnu packages fontutils)
>> #:use-module (gnu packages image)
>> - #:use-module (gnu packages pkg-config))
>> + #:use-module (gnu packages pkg-config)
>> + #:use-module (gnu packages xml))
>
> Are all of these new modules used?
>

No. I accidentally "polluted" this patch with changes from the next one
to come. Only the base, tex, and texinfo modules are needed for this
patch*.

Toggle quote (4 lines)
>> + (home-page "http://gnustep.org")
>
> Is there a package-specific home-page?

It doesn't appear so.

* I've also realized that documentation is installed separately from the
main GNU building process, so I've added an appropriate phase now. The
only problem is that there's a PostScript file with a line that varies
depending on the build time. Is there a way to eliminate this variance
that you know of?
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlj8yf4ACgkQ5qXuPBlG
eg33dRAAs4TWZ4KVTlprOIT1s9lice7FIga1k4v5BIlrF2choLw7OXarh6dKFWNG
TtLIJfagxJ3G5wKSj4LB3Mhmho6qre6sgPFVd820mwTbSlG/oRTTjg3gnpt68NKD
CYMxfnp8nxexjNkk1eiYaSBYOEuJGnUdzGw/9B2xtQTRtb6CpDldniFz4lX+lQEj
ySXq2ejjxsLUwga1rCzHpRNftvmED3Oqt6x1kTUs5HE2JgnRRcnMHB47EKyufzTE
RNnlEOIHLQ1FBG54AVN3o/n1FDStw38ClIYf0vHuYqdIVgauoz9jx+ZS+Zg1Nuov
5cn7ndX2c6fS1Dfl3+6c/pTUSOtgYpVYVWC8Z8T9XvioDoC/b3scJlTAqVw2izQt
wjh/ai6jgCiW2vz90xEaxiXYuuJT3+uzKdT8qmURlOJDcRxON5XzWG5o/EJ5bhWD
UC47k+siov0JTFUOpqIinNtf3124nIPDoSi8VZo37O31UX851ZiI23MOZ+lGs4XS
GzsDfUDVaumsPNh46rjIL5AuLPpmCMqsVUOGZOnE5mcHj9p5G785+JsBfOFwLMDl
WxwW7LoSFnb/hTLN6TJUGXXQfgnjlEjnTbCPyB6nbmFZjRhmxPR6jKK1k4JuIl53
knP2uskEYXaGrZ/aTEETwPT/gqUtE5xLIlHhC8ESmslKpFlmNFw=
=hXc2
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87inlbjeg4.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (6 lines)
> * I've also realized that documentation is installed separately from the
> main GNU building process, so I've added an appropriate phase now. The
> only problem is that there's a PostScript file with a line that varies
> depending on the build time. Is there a way to eliminate this variance
> that you know of?

It may be that this line is added by a separate tool, perhaps pdflatex
or whatever is used. It’s this tool that we should fix.

If you could fine which tool that is and file a bug for this to
bug-guix, that would be great.

In the meantime you can happily commit gnustep-make. :-)

Thanks,
Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87vapakieh.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (19 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * I've also realized that documentation is installed separately from the
>> main GNU building process, so I've added an appropriate phase now. The
>> only problem is that there's a PostScript file with a line that varies
>> depending on the build time. Is there a way to eliminate this variance
>> that you know of?
>
> It may be that this line is added by a separate tool, perhaps pdflatex
> or whatever is used. It’s this tool that we should fix.
>
> If you could fine which tool that is and file a bug for this to
> bug-guix, that would be great.
>
> In the meantime you can happily commit gnustep-make. :-)
>
> Thanks,
> Ludo’.

Commited (both to master and to finding that bug)!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkRBtYACgkQ5qXuPBlG
eg1yLQ/+PB+ap5y3KB9C+Q+2knKoUbsiGufxA4mb5ogWvaJwCVQchu0m0L/9cb2a
NkWj8liGBXYhifzkAFuVVWZJbbfFEnlgqLsyu7Xnkc+mb4Qkn/qfT3EaeHC73PSZ
BbF/lQemumcPAInQSyM5ge5dGmEF53rIAHaGPn035smNpP7LlOjO806wbxGA3VWf
PwV6jEgryBS+8FAMLMgBbGPv/LI4Vz44UAibEsTNqxxA8Sbxx8WpA+yaY/R6gcmH
4qFVR0K58xSipkhN7CcKOuyfykJPaevQOWbaS4mor9W7qIwAi1RZzr0s89dQWPTA
e7IhktBJYv0idA6B4HOt6jXtN0pPKlYTrcaqdI4SjeFSg7XRp0G0khV661ch4p25
TJY4lFs7liuTWsJ9XAc10ybeSGBwnQltwXLCWv+3hOXk5bYAqs+xpbu1aXAyzG/e
WOQlNz7YP790RYhTMEACQchuIW3RGnKtWSgXihW+jKI8DrlDm1jN68TsuUOCwXz6
+zURfWeoFAhf3uO7D+GKJh8sViKt7U0fe06YCRL+HS80PyFXKCZ7w9gm91BqK7Mp
3dKGZEIKj5O+k9ZcSfRKNo7oxaTpEwelZJJcoSUTICiRW5wisKIyyX4BxXMKfx7A
4f/VyN1SGInT1R6LBZVmm8q+PpUphCG2yFWVC8XSt5okSv34dj8=
=/td0
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26617@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26617
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help