[PATCH] gnu: Add volk.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Leo Famulari
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170422213547.6460-1-dannym@scratchpost.org
* gnu/packages/engineering.scm (volk): New variable.
---
gnu/packages/engineering.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index dd56af99d..69937146b 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -774,3 +774,30 @@ render model libraries.")
educational use. As such, there is an emphasis on capabilities that improve
the 'showing the effect of'-style of operation.")
(license license:gpl2+)))
+
+(define-public volk
+ (package
+ (name "volk")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://libvolk.org/releases/volk-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)))
+ (native-inputs
+ `(("python-2", python-2)
+ ("python2-cheetah" ,python2-cheetah)))
+ (home-page "http://libvolk.org/")
+ (synopsis "Vector-Optimized Library of Kernels")
+ (description
+ "@code{volk} contains procedures with machine-specific optimizations
+for mathematical functions. It also provides an machine-independent
+interface to select the best such procedures to use on a given system.")
+ (license license:gpl3+)))
Leo Famulari wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 26614@debbugs.gnu.org)
20170423003707.GB10153@jasmine
On Sat, Apr 22, 2017 at 11:35:47PM +0200, Danny Milosavljevic wrote:
Toggle quote (2 lines)
> * gnu/packages/engineering.scm (volk): New variable.

LGTM overall!

Toggle quote (4 lines)
> + (uri (string-append "http://libvolk.org/releases/volk-"
> + version
> + ".tar.gz"))

We can combine these last two lines, right?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlj79zMACgkQJkb6MLrK
fwh+xhAA7ZQpnWZpc/IiB7sz6ShEGYGCRV2Oc2ddE5GPuHyiDHPLrP7EbdD7MBZv
L08oop7d9CS81KrCYDtVFrYyeKvDvrEl14VN5yFbSI3eCC1I1cJ6oCZLOAjwzMLj
0d6bdSFVYfFYaRbS3N/SJEfm5wfFVDsMjWIezwMTtU7YXS6vEp8NIkCoJUhkoiyu
7pjEHpcg9PfIn0DoFmsdTsFe3Sj/LL5docQQCDAKQmn75gC8d06inwj0UZV+tlO7
JcPSc+DJEZbvs7u/NhKR3X+LWAAJXni3yT45Dpc7dGnO7/vevBxJSWbzs2Yoy54I
UFcZNIaKbaHdCgaplUKBBQf06+s4KgLzSxSM8jj9Yq/qtyCvI/8gZ2mj3MhVT1Np
nJgR0kCTnJRtyOgDZnIOrSjgsZn42g2AqD384suElSNNSdwcd+qW4jLqW88g1FD1
wKB0HkBtyII2GBK99COzkvNOu1L5US+CsJHNHflYi49BouUKJWnedEhKLEXNWCFn
OSHBleVvLyMCpEGiUDxCDab28U9jgXc/IaRA2+p7ggEvdpqT4StrOg7rz5VkT7I8
v4T0KsquPoghFGCaTOaemXzjBa3jyKamlvmlC8NBaddjX8o+tf/8JYU5t6GgsfpL
DeE79GbXXukjdPEGKo3+D0ClDS0brpQFLG5UGa3n4sgrBCRFyLg=
=T/LF
-----END PGP SIGNATURE-----


Marius Bakke wrote 8 years ago
8760ht283f.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (2 lines)
> * gnu/packages/engineering.scm (volk): New variable.

[...]

Toggle quote (10 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "http://libvolk.org/releases/volk-"
> + version
> + ".tar.gz"))
> + (sha256
> + (base32
> + "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))

Indentation is off in this section.

Toggle quote (10 lines)
> + (build-system cmake-build-system)
> + (inputs
> + `(("boost" ,boost)))
> + (native-inputs
> + `(("python-2", python-2)
> + ("python2-cheetah" ,python2-cheetah)))
> + (home-page "http://libvolk.org/")
> + (synopsis "Vector-Optimized Library of Kernels")
> + (description
> + "@code{volk} contains procedures with machine-specific optimizations
^^^
...and here (should align with the d).

Sorry! :D
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlj+C4QACgkQoqBt8qM6
VPpVQggAzDSZEGORhxJBzbCFHt3R3MvIsuZYPonUJJvF1/zN3TvwqJFVRR0XN65t
/50jjwWYiMWtzOUKYO0CBMtPPAoCDs3k/yTpZHGRT/lKAtpaUcz2jDGIReoAoNY7
BOa1aZ//zSfp1JBUn/jaELxOMpIgPXEAkMADJD1DlA8wzjh4ezAK7n/lYLq0GZmt
KmwoCaV81Wedj4MZkUTCo4iblCG12RCWxZzVHzbCQMoNdZjtDyppC9pWpcaulgUo
IavYI/UK99X5LgWcXtllHzjKNE3AySytcxX2H0oBbc4O+5LYRgAo4Au0SUyaeBpH
PX7M2SshdIZsrADEi7/cbGn1QFztuQ==
=8EGu
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
[PATCH v2] gnu: Add volk.
(address . 26614@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170424182149.19302-1-dannym@scratchpost.org
* gnu/packages/engineering.scm (volk): New variable.
---
gnu/packages/engineering.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index dd56af99d..20efe11a2 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -774,3 +774,29 @@ render model libraries.")
educational use. As such, there is an emphasis on capabilities that improve
the 'showing the effect of'-style of operation.")
(license license:gpl2+)))
+
+(define-public volk
+ (package
+ (name "volk")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://libvolk.org/releases/volk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)))
+ (native-inputs
+ `(("python-2", python-2)
+ ("python2-cheetah" ,python2-cheetah)))
+ (home-page "http://libvolk.org/")
+ (synopsis "Vector-Optimized Library of Kernels")
+ (description
+ "@code{volk} contains procedures with machine-specific optimizations
+for mathematical functions. It also provides an machine-independent
+interface to select the best such procedures to use on a given system.")
+ (license license:gpl3+)))
Leo Famulari wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 26614@debbugs.gnu.org)
20170424204534.GA17268@jasmine
On Mon, Apr 24, 2017 at 08:21:49PM +0200, Danny Milosavljevic wrote:
Toggle quote (2 lines)
> * gnu/packages/engineering.scm (volk): New variable.

LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlj+Y+sACgkQJkb6MLrK
fwg08w/+JwZe7oVMwJqrCerm5eC67oKADebWqXeC1JQntEAw0YIWYhHSYylDicqO
gMjf0cZk2wZ3Hkd+uIQAIDoJB3H5VNYJW0CUHXpny2kRfgiGpiA1/MaqghPZ2mkf
RiZ2VEghjug/ngIUlWVgUqdQqEtuFxIC7H84RYh13glgoXXIg5DGsrfAIQWhmI8z
hugDm7ZS+nz4TSktAIsOnVVI7ETAfB+EhdN2xeJTo9RWT8/+H84d0+VELxOXtjO+
X7yuLQJpajDqVEJUIdKmVYEbHqbxrWT5tFjaEcuXM4ko3BdEnE/I1v7t6SCgSbtF
igrquySYcL2uCxJ2OGLGHANBuCrici58NQ7oadqQrT97RPv/kDWaHZ35AoHSSR1C
DLMB8zDa/okj3o43bi+frnc+IEWF84jIdFFFNWMLqTVujA+Yw6MwnV73TN0Viyei
b9Oql33HNMcN6j4i+wYV3CGkiX74cZvsxnk+UgpKd/inssHd2oMbtCaWBMN8guy7
yYFNSiNEnUBRXXD4oumfzSRSER3H8iYJlcxmBEz/1JP4T1TUKGRJvPPcFust3zWc
WzuK4hoMFOhis0uJWObLM/nczPKeQHMZ2q593lzuRgtogmTc/gS2iQ0El/jlQl5p
fvUu5rFhZfwovesKPHnc3nP5biqjDDoWDd2rIX14LGNiiW30me8=
=qSls
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170507212106.7b1c20b4@scratchpost.org
close 26166
close 26541
close 26614
close 26751
close 26692
close 26731
close 26743
close 26744
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26614@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26614
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help