python-gpg broke; python-gpg 1.9.0 does not exist

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Allan Webber
  • Ivan Vilata i Balaguer
  • Leo Famulari
Owner
unassigned
Submitted by
Christopher Allan Webber
Severity
normal

Debbugs page

Christopher Allan Webber wrote 8 years ago
8737d0761f.fsf@dustycloud.org
Commit 8439c9c05e upgraded gpgme to 1.9.0.

Unfortunately, python-gpg's version is tied to gpgme:

(define-public python-gpg
(package
(name "python-gpg")
(version (package-version gpgme))
;; [...]

This is a problem, because upgrading gpgme "automatically" upgraded
python-gpg, and there is no python-gpg release of 1.9.0. The latest
release is 1.8.0:


I'm not sure it makes sense to tie the package version to python-gpg's
package version anyway... if upgrading gpgme does trigger the upgrade of
python-gpg "automatically", then that would mean that even if there was
a pythong-gpg available with the new version, the hash would be
incorrect.
Leo Famulari wrote 8 years ago
(address . 26610@debbugs.gnu.org)
20170422224307.GA6373@jasmine
On Sat, Apr 22, 2017 at 11:37:00AM -0500, Christopher Allan Webber wrote:
Toggle quote (16 lines)
> Commit 8439c9c05e upgraded gpgme to 1.9.0.
>
> Unfortunately, python-gpg's version is tied to gpgme:
>
> (define-public python-gpg
> (package
> (name "python-gpg")
> (version (package-version gpgme))
> ;; [...]
>
> This is a problem, because upgrading gpgme "automatically" upgraded
> python-gpg, and there is no python-gpg release of 1.9.0. The latest
> release is 1.8.0:
>
> https://pypi.python.org/pypi/gpg/1.8.0

I'd hoped the GPGME maintainers would release new versions of python-gpg
in tandem with GPGME, but since that's not the case, we should not use
gpgme's package-version in python-gpg.

Can you try it? I'm not an assword user, so I can't adequately test the
combination of gpgme-1.9.0 and python-gpg-1.8.0.

Toggle quote (6 lines)
> I'm not sure it makes sense to tie the package version to python-gpg's
> package version anyway... if upgrading gpgme does trigger the upgrade of
> python-gpg "automatically", then that would mean that even if there was
> a pythong-gpg available with the new version, the hash would be
> incorrect.

Right, this technique doesn't work if one forgets to update the other
packages... as I forgot to do in this case :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlj73HsACgkQJkb6MLrK
fwiPXQ//eK2uiGfNAxs9Rw2B5IkzhnS9PATEg/LoURQ0yjIrsT8zj0Q92WJwsLr9
kNe1jAMovKccMDRRZSJCvzsthv1qbmz60Nzm9sSlVEFI7heXLPAzVCA+zHxsB7SY
kOBL+CD+K7g7ewVMXVXh9TDwE1ankp2F7f2tJF55Mj1W+CfX3bWU2LxhuuM6n3JB
5ZH8C/9NMUb6k0z4W2zvqrfMYgcKCuuL4plAJUjSpKI0xnVtGgiVqua25nf7PGA7
lS453Q9CCRmTFbKGcbWDmpamtTk/SRkg9PwSkK4qVQeIs6s2YykVLD41Hm+Yzx0T
fVvExxRPwMnG49acNQB/liSwFaSTqhG80zNGOyaC5eokBfVNu2aT0gruXClxUMzR
x62YXy2WWyMgxuHlRHkfTWn88he3wLtlAFYuY5SQgZ6F3SPSXqs77w0IgZrNXn0Q
ImNkfMrQJLOwubHOKLUHTRp483RSKepsTkXnTMo7/khuOkhxkIax98hLw+8974Ei
cBrBFFMvw/k8ZnzpTPd6jbAKnPcODe+ZE6f2xXHdVs7XkcQmbYqhrBF/bFgTDKcH
iHbIVMbdqn5glJv5XDx+o4RTOroCTpBtvvlzL9FOnV+kV4czZay4KCtwBUzRRYL5
1HU3XUki6VRNWpjQOYMPw9kFr9ncXJalAazv6xwDRWO/toKyvgo=
=UKgV
-----END PGP SIGNATURE-----


Ivan Vilata i Balaguer wrote 8 years ago
python-gpg broke; python-gpg 1.9.0 does not exist
(address . 26610@debbugs.gnu.org)
20170526195147.GC7831@sax.terramar.selidor.net
I think I also got bitten by this:

```
$ guix package --fallback -u
warning: failed to install locale: Invalid argument

Starting download of /gnu/store/8anrjg1qj2sqij6883v057l86wac2vln-gpg-1.9.0.tar.gz

Starting download of /gnu/store/8anrjg1qj2sqij6883v057l86wac2vln-gpg-1.9.0.tar.gz

Starting download of /gnu/store/8anrjg1qj2sqij6883v057l86wac2vln-gpg-1.9.0.tar.gz
failed to download "/gnu/store/8anrjg1qj2sqij6883v057l86wac2vln-gpg-1.9.0.tar.gz" from "https://pypi.io/packages/source/g/gpg/gpg-1.9.0.tar.gz"
builder for `/gnu/store/16rsli2x9sh4fr9fa0yy4mn5pkmqwy3h-gpg-1.9.0.tar.gz.drv' failed to produce output path `/gnu/store/8anrjg1qj2sqij6883v057l86wac2vln-gpg-1.9.0.tar.gz'
cannot build derivation `/gnu/store/gvji20dwv204p39ii010sx267kkpjd15-python-gpg-1.9.0.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/8m8whiqpxy5b45x18rvskq523nl7237d-assword-0.10.drv': 1 dependencies couldn't be built
guix package: error: build failed: build of `/gnu/store/8m8whiqpxy5b45x18rvskq523nl7237d-assword-0.10.drv' failed
```

I am a user of ``assword``, but pretty much a Guix newbie. Is there any
way I can help fix this issue?

Thanks,

--
Ivan Vilata i Balaguer -- https://elvil.net/
Leo Famulari wrote 8 years ago
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)(address . 26610@debbugs.gnu.org)
20170527141146.GG1387@jasmine
On Fri, May 26, 2017 at 09:51:47PM +0200, Ivan Vilata i Balaguer wrote:
Toggle quote (9 lines)
> $ guix package --fallback -u
> warning: failed to install locale: Invalid argument
>
> Starting download of /gnu/store/8anrjg1qj2sqij6883v057l86wac2vln-gpg-1.9.0.tar.gz
> From https://pypi.io/packages/source/g/gpg/gpg-1.9.0.tar.gz...
> following redirection to `https://pypi.org/packages/source/g/gpg/gpg-1.9.0.tar.gz'...
> following redirection to `https://files.pythonhosted.org/packages/source/g/gpg/gpg-1.9.0.tar.gz'...
> ERROR: download failed "https://files.pythonhosted.org/packages/source/g/gpg/gpg-1.9.0.tar.gz" 404 "Not Found"

[...]

Toggle quote (5 lines)
> guix package: error: build failed: build of `/gnu/store/8m8whiqpxy5b45x18rvskq523nl7237d-assword-0.10.drv' failed

> I am a user of ``assword``, but pretty much a Guix newbie. Is there any
> way I can help fix this issue?

You can try changing the python-gpg package's version to the last
available upstream version. On PyPi, that's 1.8.0.

Then, try rebuilding the packages that depend on python-gpg (`guix
refresh -l python-gpg python2-gpg`).

Hopefully it all works. Then, you can send a patch with your fix :)

Let us know if you need help!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkpiSIACgkQJkb6MLrK
fwjQIhAAhkLvvPHYfMfL7m7TFQ//sgv12jr/4+Iwsk7r8PO2ywnep2566QAYRodv
OaHTtETtRz2ZeFg/EEXVmK/kP+iH4PnbIGYJRCJtPigJOTuMWoS1SeSh7OP2t/2o
WWnD3W1lHTNpAZpQyR1U4wIfWu/MDLeGk2v5ykCm9OvG8Nc4S04OZqWYW/gYiVoi
airRPxXKbSVRi5XdUb7Q1m52AGb1NBQZjplVkokn7Q5ErpYZt0e5BRtQT7vHz34e
+C4gnvE0FyFEXW8A10C/D9NgMiwlpcLWVZFQukVQvvVXCm1N7ZLRkqL9nL/ewRnm
ikfyd0Uj4FOyXNfAju8omw7EIsVAODJTzocxc9Xiq7jK0yWW41xUchVntjrj73v9
A3Ufmxk6RV0941PRA1Kl/QjHDMpr25EDG6Du+DFO5VAAn1Zsk9SnVWmx4peZ9cFR
/pGK/VEnFMpZ7mGfy7gB14ETUoPr80Kh3mZO2VGi6GxQ6ykc2irCn/zPK67YTJ3D
61rqLpePngZRTWA65kZcgbUy9KK4ZR8SKCnWeUupeH4XBjBkMyOm6ukfp6HrOTNg
Nne8IsgLdn1vHZvMFlP30dp1JsWJs8ajQMMWS8nvQrI4hyVikm6vxG9nm6h/A7E2
ALqpfJFgQvdj4353/fVFYsXpqf8ioN8QleWGWDrFTQDLt/niIM0=
=78te
-----END PGP SIGNATURE-----


Ivan Vilata i Balaguer wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)
20170601084333.GQ7831@sax.terramar.selidor.net
Leo Famulari (2017-05-27 10:11:46 -0400) wrote:

Toggle quote (10 lines)
> You can try changing the python-gpg package's version to the last
> available upstream version. On PyPi, that's 1.8.0.
>
> Then, try rebuilding the packages that depend on python-gpg (`guix
> refresh -l python-gpg python2-gpg`).
>
> Hopefully it all works. Then, you can send a patch with your fix :)
>
> Let us know if you need help!

Ok, attaching the patch. These are the steps I followed to test it:

0. Apply the patch.

1. Add ``python-gpg`` at the end of ``gnu/packages/gnupg.scm`` (sorry
for my poor Scheme habilities).

2. Run ``guix environment --ad-hoc -l gnu/packages/gnupg.scm python
assword coreutils``.

3. Import ``gpg`` in Python and check ``gpg.version.versionstr``, dump
``assword`` program to verify that it uses the same build of
``python-gnupg``.

4. Run ``assword`` and check that everything works.

Probably many steps can be done better/more easily, but my knowledge is
very limited. Links for improving that are welcome.`;)`

Thanks and cheers,

--
Ivan Vilata i Balaguer -- https://elvil.net/
From bef8ccca58150ad4714cfa65472d5f2e9ae7b283 Mon Sep 17 00:00:00 2001
From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
Date: Thu, 1 Jun 2017 10:33:09 +0200
Subject: [PATCH] gnu: python-gpg: Use explicit version 1.8.0 instead of
GPGME's.

GPGME defines version 1.9.0, which isn't yet available for python-gnupg, whose
latest version is 1.8.0, so we use that explicitly instead. Fixes #26610.

* gnu/packages/gnupg.scm (python-gpg): Use explicit version 1.8.0 instead of GPGME's.
---
gnu/packages/gnupg.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 440e7d550..c2b02789b 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -410,7 +410,7 @@ and every application benefits from this.")
(define-public python-gpg
(package
(name "python-gpg")
- (version (package-version gpgme))
+ (version "1.8.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gpg" version))
--
2.12.2
Leo Famulari wrote 8 years ago
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)(address . 26610-done@debbugs.gnu.org)
20170602032242.GA19312@jasmine
On Thu, Jun 01, 2017 at 10:43:33AM +0200, Ivan Vilata i Balaguer wrote:
Toggle quote (17 lines)
> 0. Apply the patch.
>
> 1. Add ``python-gpg`` at the end of ``gnu/packages/gnupg.scm`` (sorry
> for my poor Scheme habilities).
>
> 2. Run ``guix environment --ad-hoc -l gnu/packages/gnupg.scm python
> assword coreutils``.
>
> 3. Import ``gpg`` in Python and check ``gpg.version.versionstr``, dump
> ``assword`` program to verify that it uses the same build of
> ``python-gnupg``.
>
> 4. Run ``assword`` and check that everything works.
>
> Probably many steps can be done better/more easily, but my knowledge is
> very limited. Links for improving that are welcome.`;)`

Sounds like a good test :)


Toggle quote (11 lines)
> From bef8ccca58150ad4714cfa65472d5f2e9ae7b283 Mon Sep 17 00:00:00 2001
> From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
> Date: Thu, 1 Jun 2017 10:33:09 +0200
> Subject: [PATCH] gnu: python-gpg: Use explicit version 1.8.0 instead of
> GPGME's.
>
> GPGME defines version 1.9.0, which isn't yet available for python-gnupg, whose
> latest version is 1.8.0, so we use that explicitly instead. Fixes #26610.
>
> * gnu/packages/gnupg.scm (python-gpg): Use explicit version 1.8.0 instead of GPGME's.

Thank you! Pushed as 99c63f3f072e73540a65d4a7b5dac9aaeb3ed50d.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlkw2gIACgkQJkb6MLrK
fwh9xg//ZFQeO9AEaGYZICxVyNY7+63yYybHDkN3GWITYAolVWbGWHViSquzSgRG
FQekivaQKd6czwJs7dBzzE6TBaKXKQTSoOoq1OKvYse/nMcFhB2Qze/0t0nEffbZ
auBcgUfbrikGC9cTW0ZVC3TlFBWTQc6at8pqh68RZmddpkSRrP1afX5PYgbKpRL+
rVSTc8fQUHXxIoZeJ4SKQS3V6kj0wSpKKqGf95MVtgHOp9xHoz+svDNAJEX2IBen
ObTQb7sgRLm+GyLUAIJNczTUiLz5r02LFZfT9TM1ggxKCt1qmj9oflWMpJg+8pWL
Hd3fP+C1ZCs+KaH855JEy1ulKody10+lCJae1+xh+zp1DE4kd2akz1kEJEDPgTtK
PzD99sp+g37Rq4XYnN5GZK4575hDS2k1oq0CoLX9UjFWBYC/UnGqD9NL9TGaQR4h
cJ4E3WPyRo3KI+FJyavlvtQWNpKWYernSFsCbS6LLUhkw3GvkqUJT38nZBSJK7bd
9yrxcLtqcAhjISHGVVAHHm5khAOP633nsVuQp35SGyOENZmN7qRcfwK1aT0FjLHy
iDTKYZqF/J0JlZM23cuQzOkbNBrWcV1JTuXfpGC94gu4BolaYwqaeCnbnh8EWqOT
OpGNVCeeWQL5eKsHAuPT828NWOi0XdtEci0Ca/Gw/zUdO9y9dr0=
=23ib
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26610@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26610
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help