(address . guix-patches@gnu.org)(name . Marius Bakke)(address . mbakke@fastmail.com)
Hi Guix! This patch adds an SSH server to the installation image
to aid remote installations as requested in
lsh-service depends on networking, so I pulled in a DHCP client too.
It increases the image size by about 29MiB.
* gnu/system/install.scm (%installation-services): Add DHCP-CLIENT-SERVICE
and LSH-SERVICE.
---
gnu/system/install.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 191ccf168..95904f151 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -24,7 +24,9 @@
#:use-module (guix store)
#:use-module (guix monads)
#:use-module ((guix store) #:select (%store-prefix))
+ #:use-module (gnu services networking)
#:use-module (gnu services shepherd)
+ #:use-module (gnu services ssh)
#:use-module (gnu packages admin)
#:use-module (gnu packages bash)
#:use-module (gnu packages bootloaders)
@@ -262,6 +264,17 @@ You have been warned. Thanks for being so brave.
;; To facilitate copy/paste.
(gpm-service)
+ ;; Add a DHCP client for networking.
+ (dhcp-client-service)
+
+ ;; Add an SSH server to facilitate remote installs.
+ (lsh-service #:port-number 22
+ #:root-login? #t
+ #:password-authentication? #t
+ ;; The root account is passwordless, so make sure
+ ;; a password is set before allowing logins.
+ #:allow-empty-passwords? #f)
+
;; Since this is running on a USB stick with a unionfs as the root
;; file system, use an appropriate cache configuration.
(nscd-service (nscd-configuration
--
2.12.2