Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/embedded.scm (gcc-vc4): New variable.
---
gnu/packages/embedded.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (29 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 36f872cdf..84697023a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -773,3 +773,24 @@ simulator.")
the Raspberry Pi chip.")
(license license:gpl3+)
(home-page "https://github.com/puppeh/vc4-toolchain/"))))
+
+(define-public gcc-vc4
+ (let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2")
+ (xgcc (cross-gcc "vc4-elf" binutils-vc4)))
+ (package (inherit xgcc)
+ (name "gcc-vc4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/puppeh/gcc-vc4.git")
+ (commit commit)))
+ (file-name (string-append name "-" "version" "-checkout"))
+ (sha256
+ (base32
+ "13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2"))))
+ (native-inputs
+ `(("flex" ,flex)
+ ,@(package-native-inputs xgcc)))
+ (synopsis "GCC for VC4")
+ (description "This package provides @code{gcc} for VideoCore IV,
+the Raspberry Pi chip."))))