[PATCH] gnu: Add gcc-vc4.

  • Done
  • quality assurance status badge
Details
One participant
  • Danny Milosavljevic
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170417150102.12742-1-dannym@scratchpost.org
* gnu/packages/embedded.scm (gcc-vc4): New variable.
---
gnu/packages/embedded.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 36f872cdf..84697023a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -773,3 +773,24 @@ simulator.")
the Raspberry Pi chip.")
(license license:gpl3+)
(home-page "https://github.com/puppeh/vc4-toolchain/"))))
+
+(define-public gcc-vc4
+ (let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2")
+ (xgcc (cross-gcc "vc4-elf" binutils-vc4)))
+ (package (inherit xgcc)
+ (name "gcc-vc4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/puppeh/gcc-vc4.git")
+ (commit commit)))
+ (file-name (string-append name "-" "version" "-checkout"))
+ (sha256
+ (base32
+ "13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2"))))
+ (native-inputs
+ `(("flex" ,flex)
+ ,@(package-native-inputs xgcc)))
+ (synopsis "GCC for VC4")
+ (description "This package provides @code{gcc} for VideoCore IV,
+the Raspberry Pi chip."))))
Danny Milosavljevic wrote 8 years ago
[PATCH v2] gnu: Add gcc-vc4.
(address . 26541@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170417151756.16323-1-dannym@scratchpost.org
* gnu/packages/embedded.scm (gcc-vc4): New variable.
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add vc4-elf.
---
gnu/packages/bootstrap.scm | 1 +
gnu/packages/embedded.scm | 21 +++++++++++++++++++++
2 files changed, 22 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 048fe26f1..f43decc96 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -179,6 +179,7 @@ successful, or false to signal an error."
((string=? system "avr") "no-ld.so")
((string=? system "propeller-elf") "no-ld.so")
((string=? system "i686-mingw") "no-ld.so")
+ ((string=? system "vc4-elf") "no-ld.so")
(else (error "dynamic linker name not known for this system"
system))))
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 36f872cdf..84697023a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -773,3 +773,24 @@ simulator.")
the Raspberry Pi chip.")
(license license:gpl3+)
(home-page "https://github.com/puppeh/vc4-toolchain/"))))
+
+(define-public gcc-vc4
+ (let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2")
+ (xgcc (cross-gcc "vc4-elf" binutils-vc4)))
+ (package (inherit xgcc)
+ (name "gcc-vc4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/puppeh/gcc-vc4.git")
+ (commit commit)))
+ (file-name (string-append name "-" "version" "-checkout"))
+ (sha256
+ (base32
+ "13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2"))))
+ (native-inputs
+ `(("flex" ,flex)
+ ,@(package-native-inputs xgcc)))
+ (synopsis "GCC for VC4")
+ (description "This package provides @code{gcc} for VideoCore IV,
+the Raspberry Pi chip."))))
Danny Milosavljevic wrote 8 years ago
[PATCH v3] gnu: Add gcc-vc4.
(address . 26541@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170418174219.4888-1-dannym@scratchpost.org
* gnu/packages/embedded.scm (gcc-vc4): New variable.
---
gnu/packages/embedded.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 36f872cdf..b919bdf6c 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -773,3 +773,27 @@ simulator.")
the Raspberry Pi chip.")
(license license:gpl3+)
(home-page "https://github.com/puppeh/vc4-toolchain/"))))
+
+(define-public gcc-vc4
+ (let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2")
+ (xgcc (cross-gcc "vc4-elf" binutils-vc4)))
+ (package (inherit xgcc)
+ (name "gcc-vc4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/puppeh/gcc-vc4.git")
+ (commit commit)))
+ (file-name (string-append name
+ "-"
+ (package-version xgcc)
+ "-checkout"))
+ (sha256
+ (base32
+ "13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2"))))
+ (native-inputs
+ `(("flex" ,flex)
+ ,@(package-native-inputs xgcc)))
+ (synopsis "GCC for VC4")
+ (description "This package provides @code{gcc} for VideoCore IV,
+the Raspberry Pi chip."))))
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170507212106.7b1c20b4@scratchpost.org
close 26166
close 26541
close 26614
close 26751
close 26692
close 26731
close 26743
close 26744
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26541@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26541
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help