[PATCH 1/3] gnu: speech-dispatcher: Add more inputs.

  • Done
  • quality assurance status badge
Details
One participant
  • ???
Owner
unassigned
Submitted by
???
Severity
normal
?
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
20170409094942.20144-1-iyzsong@member.fsf.org
* gnu/packages/speech.scm (speech-dispatcher)[inputs]: Add espeak,
pulseaudio and python.
---
gnu/packages/speech.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 1d903520e..53303d28d 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -24,11 +24,13 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages python)
#:use-module (gnu packages textutils))
(define-public mitlm
@@ -75,9 +77,12 @@ efficiency through the use of a compact vector representation of n-grams.")
("pkg-config" ,pkg-config)))
(inputs
`(("dotconf" ,dotconf)
+ ("espeak" ,espeak)
("glib" ,glib)
("libltdl" ,libltdl)
- ("libsndfile" ,libsndfile)))
+ ("libsndfile" ,libsndfile)
+ ("pulseaudio" ,pulseaudio)
+ ("python" ,python)))
(synopsis "Common interface to speech synthesizers")
(description "The Speech Dispatcher project provides a high-level
device independent layer for access to speech synthesis through a simple,
--
2.12.2
?
control message for bug #26413
(address . control@debbugs.gnu.org)
87lgr2qlfn.fsf@member.fsf.org
tags 26413 fixed
close 26413
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26413@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26413
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch