[PATCH] gnu: Add tclx.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170405191433.32405-1-kei@openmailbox.org
* gnu/packages/tcl.scm (tclx): New variable.
---
gnu/packages/tcl.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 4cd94299d..e6b01fcd4 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -290,3 +291,35 @@ callback is evaluated.")
(license (non-copyleft
"file://LICENCE"
"See LICENCE in the distribution."))))
+
+(define-public tclx
+ (package
+ (name "tclx")
+ (version "8.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/tclx/TclX/"
+ version "/tclx" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1v2qwzzidz0is58fd1p7wfdbscxm3ip2wlbqkj5jdhf6drh1zd59"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; a test named profile.test segfaults
+ #:configure-flags (list (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl")
+ "/lib")
+ (string-append "--libdir="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (inputs
+ `(("tcl" ,tcl)
+ ("tk" ,tk)))
+ (home-page "http://tclx.sourceforge.net/")
+ (synopsis "System programming extensions for Tcl")
+ (description
+ "Extended Tcl is oriented towards system programming tasks and large
+application development. TclX provides additional interfaces to the operating
+system, and adds many new programming constructs, text manipulation tools, and
+debugging tools.")
+ (license tcl/tk)))
--
2.11.1
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26375@debbugs.gnu.org)
878tn8fv9i.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/tcl.scm (tclx): New variable.

LGTM, thanks!

Ludo'.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26375-done@debbugs.gnu.org)
874lxw54sq.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (8 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * gnu/packages/tcl.scm (tclx): New variable.
>
> LGTM, thanks!
>
> Ludo'.

Pushed to master. Thanks for the review.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljr+XUACgkQ5qXuPBlG
eg1RDxAAllh9FDLNWa1ybVG1C3R1p6uXKW/9X2yhEFq44+Mxz9oJuBheLJStDitM
XzEeX1HOr1Z6noOIB/g7oD/6OTlgBN5rhJg9/Jh+WmFrnTITZFa091JcB4VP9cE/
XFw+1E9CGAaCWSdmW5F03F0pSExTwhZmlPuL9/JYKRBVGzkIdbPsHe9Qdfv+8Rwb
QtDYa3d5kK8ld4JGodg/nMAaj8Vj+ITciiwfQawnif1GNzyInlVqHD00NCOa+6gD
FGuSPGBv5e+2+1W5SnHGhXFcuayCEW+jHdz6nwg7KUP3MEepPyxjHXdCRzYIAZot
Kc8dqazpfH+eU6qYk+EiW85FPj7RO5w5u+GGUhnh/83JAcvI6iA//Vmy7jvYBJv8
lj/WM4KQkFpWQO9sapPstO2GBqN3WumBJPVRlfmvfRcs6jSfoE2dNTpWdnFuqP6q
A+/hrBDc3rzr6jumBCL3KClwwfE9RafzVZqSEIqqcpshT9fDr0at58mAsZX8W2OD
9KG58qrXZXcAzLrZTenWCTeKjPw1Ft8Enxz7fkgxTPwehgBb4xK9bhmqGCyvwLuh
W62KxONGqpXD8XvPJkv8FUFgDQfa5yJK4ygjVh4pOVNYG7jtTqFicfBbS6TS7kps
XLQfpogpc4X2svh6fDhiXphHtP1YioreebTv/C95uTgot+N+XUI=
=tNdy
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26375@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26375
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help