[PATCH] gnu: Move dillo to web.scm.

  • Done
  • quality assurance status badge
Details
3 participants
  • Kei Kebreau
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170405191411.32328-1-kei@openmailbox.org
* gnu/packages/dillo.scm: Remove file and move dillo...
* gnu/packages/web.scm: ...here.
* gnu/local.mk: Remove reference to removed file.
---
gnu/local.mk | 1 -
gnu/packages/dillo.scm | 63 --------------------------------------------------
gnu/packages/web.scm | 35 ++++++++++++++++++++++++++++
3 files changed, 35 insertions(+), 64 deletions(-)
delete mode 100644 gnu/packages/dillo.scm

Toggle diff (147 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index f54ab2a45..8128cd078 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -105,7 +105,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/dejagnu.scm \
%D%/packages/dico.scm \
%D%/packages/dictionaries.scm \
- %D%/packages/dillo.scm \
%D%/packages/disk.scm \
%D%/packages/display-managers.scm \
%D%/packages/django.scm \
diff --git a/gnu/packages/dillo.scm b/gnu/packages/dillo.scm
deleted file mode 100644
index 6e0c4d17a..000000000
--- a/gnu/packages/dillo.scm
+++ /dev/null
@@ -1,63 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages dillo)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages fltk)
- #:use-module (gnu packages fontutils)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages image)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages xorg)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public dillo
- (package
- (name "dillo")
- (version "3.0.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.dillo.org/download/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32
- "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
- (build-system gnu-build-system)
- (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("fltk" ,fltk)
- ("fontconfig" ,fontconfig)
- ("libjpeg" ,libjpeg)
- ("libpng" ,libpng)
- ("libxcursor" ,libxcursor)
- ("libxft" ,libxft)
- ("libxi" ,libxi)
- ("libxinerama" ,libxinerama)
- ("openssl" ,openssl)
- ("perl" ,perl)
- ("zlib" ,zlib)))
- (synopsis "Very small and fast graphical web browser")
- (description "Dillo is a minimalistic web browser particularly intended for
-older or slower computers and embedded systems.")
- (home-page "http://www.dillo.org")
- (license license:gpl3+)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7215dcbed..92e262f79 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
@@ -60,6 +61,8 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages fltk)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
@@ -82,6 +85,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages curl)
#:use-module (gnu packages perl)
#:use-module (gnu packages texinfo)
@@ -4531,3 +4535,34 @@ exploit attempts.")
(description "qutebrowser is a keyboard-focused browser with a minimal
GUI. It is based on PyQt5 and QtWebKit.")
(license l:gpl3+)))
+
+(define-public dillo
+ (package
+ (name "dillo")
+ (version "3.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.dillo.org/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
+ (build-system gnu-build-system)
+ (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("fltk" ,fltk)
+ ("fontconfig" ,fontconfig)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libxcursor" ,libxcursor)
+ ("libxft" ,libxft)
+ ("libxi" ,libxi)
+ ("libxinerama" ,libxinerama)
+ ("openssl" ,openssl)
+ ("perl" ,perl)
+ ("zlib" ,zlib)))
+ (synopsis "Very small and fast graphical web browser")
+ (description "Dillo is a minimalistic web browser particularly intended for
+older or slower computers and embedded systems.")
+ (home-page "http://www.dillo.org")
+ (license license:gpl3+)))
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87lgreabjk.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (4 lines)
> * gnu/packages/dillo.scm: Remove file and move dillo...
> * gnu/packages/web.scm: ...here.
> * gnu/local.mk: Remove reference to removed file.

I think it would be good to have a "web-browsers.scm" to try and keep
things organized; web.scm is already a kind of "kitchen sink" for
anything web related. What do others think?

There are a few other modules that could be moved into a
web-browsers.scm as well.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljlSA8ACgkQoqBt8qM6
VPqO9AgAqBPE66RdxtkmIcmxBjzWwufCLoKEWi5LxA9c1GKXGH61t29J26v+qB/f
25AdRTb657nnnSe3cVdfH7lf7107FcAFQjUHt15ua4zLaLlbjFyFC3hyt42UZ9ui
UjQsLiGpR0g814m++UxhnmtU6UifAsZ3v0ROaOfXXqZHMDJeqN6u5/4TuBv0Nctf
X5m/MmwZH9A76IKoq3G0yZGLMlwc58n5kB8dl1ktu/zsRvs7cSXb55F+cKG98w9V
iU13I7kiD99b0mpE8XsG7YSsUVek/BuL+X/PwBGdgUblSd5R6ld6XdHgbQTJtKHC
cQaQBL11n/PscNw3C5HCq95UkxnTRA==
=9hJy
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26374@debbugs.gnu.org)
87zifu2z34.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (13 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/dillo.scm: Remove file and move dillo...
>> * gnu/packages/web.scm: ...here.
>> * gnu/local.mk: Remove reference to removed file.
>
> I think it would be good to have a "web-browsers.scm" to try and keep
> things organized; web.scm is already a kind of "kitchen sink" for
> anything web related. What do others think?
>
> There are a few other modules that could be moved into a
> web-browsers.scm as well.

Splitting web.scm into more specific parts could be useful IMO.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljlgt8ACgkQ5qXuPBlG
eg3wjBAAvZMJkbk/xiVqIJjyxL0VNAD9gFVL51f4XvRLr6k6Zz4vxjWwuvKmc6XK
XAqwBQ1+5uxdb5fmSExUJluyAwm68bBbzLpdTbcHhi5+7ertKKhpFy9erKc6gYfG
2HtsvR38gZU5rBZ2PJVsnZFE3+EhUZUGZYgknjXkDQl1TlfFKJVfO1/9AJoAMw+T
GCCGgihroEcyXuSWiK35DfkVMUT+TNtvj58TY1hH9cnXyzXM/lXXXhpB9sy+fxux
AzeLFjDxWX1qz+uO1o7XmlU8uVNm4AwW+cJiYY8raqDM22F/e7R+7kuB/HnIxQml
NKTG50pbjdGpYhK9Dhe1yyAiCOi7cwQ7KaNxT4xMDyyDeK8MU3v++TyTYyxm2Xk0
ikXLZEhovdadnJVqMuZZFlLQYRwh88MAYbg7D8y5v+VkslONaZld1sYBeAhUUi2+
PNO7ByiahS5sxtjdRvxt/CiMdfhCtkzZftaBhnN4qaI5A33BNOdgVuc+rTwnRXBy
KmOqSOsFH+fKEF6aFHJg0tQQyIr4iXbD0myp026STppXqUmhiagbEk7ku4LJ2xFM
z81ZmW90HixFaoIwshinQZjgdSmyYzryNK7d+PUBrx5pwnItoatA71qX3r70yzJi
3AU2G2ivTTbfm1tGtaE2Fa9LmO5WLAOUp5vKaDuuuM1rRgZzOcM=
=rrlX
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
874lxwfv6x.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (17 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> * gnu/packages/dillo.scm: Remove file and move dillo...
>>> * gnu/packages/web.scm: ...here.
>>> * gnu/local.mk: Remove reference to removed file.
>>
>> I think it would be good to have a "web-browsers.scm" to try and keep
>> things organized; web.scm is already a kind of "kitchen sink" for
>> anything web related. What do others think?
>>
>> There are a few other modules that could be moved into a
>> web-browsers.scm as well.
>
> Splitting web.scm into more specific parts could be useful IMO.

Introducing web-browsers.scm for a start sounds good to me.

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87zifo3oyd.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (23 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> Marius Bakke <mbakke@fastmail.com> writes:
>>
>>> Kei Kebreau <kei@openmailbox.org> writes:
>>>
>>>> * gnu/packages/dillo.scm: Remove file and move dillo...
>>>> * gnu/packages/web.scm: ...here.
>>>> * gnu/local.mk: Remove reference to removed file.
>>>
>>> I think it would be good to have a "web-browsers.scm" to try and keep
>>> things organized; web.scm is already a kind of "kitchen sink" for
>>> anything web related. What do others think?
>>>
>>> There are a few other modules that could be moved into a
>>> web-browsers.scm as well.
>>
>> Splitting web.scm into more specific parts could be useful IMO.
>
> Introducing web-browsers.scm for a start sounds good to me.
>
> Ludo’.

I've opened a new bug (maybe I should have just submitted the new one
here...), so if this can be re-examined that would be great. :-)
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljr/+sACgkQ5qXuPBlG
eg3eWxAAva+Y3/k5renl66uKkzlB53AcpkYP0md4xWxV0oggRITEdKe73xNA2RmV
Wv3j6LseYJK4uEuyoELrFTITZpYIegRLJVrq+pSYM+G+i1MblBbfwYlCc/hdEwwl
jyBddyJF+c+Zvof+g6ZC8dp8YJbCgLLiOX64wXu5f47dA3eGdtSaNYHwuoN0ckyI
Wgoh82fBc0Fn+oKpY+LnHbMeUI8/90mI3yYBBwnaVVV+S1/+rc2ce9G5w9DH61cp
3RcCdo09f4TCLnx2EE7u++KVDLFBAB1lfp0FPaJDmp+aBaYSY6T1AXJqJoH2+qnV
EDPkm7dOxC53wbO5Zu01Mh7qEou7RmspLackO0d6wPT1mMvU3mic87Az1qYJvPT2
vrk/3ApRDW9ndq5oFBZ7wj6G5VDyBG5NiUyyQp1O7440MbPH/NFfRTxZSdjHv6mS
CguJWk2QpHUsXvyO4vr5ut4j/tvpc2zl8cbEygkEzPx3yKOqDqL177GIKy4lhxoC
VVeKPxsveimMrtz8xoGK8yqhn3NmxvDyA2tUN5i0+EL1ywBUNV/6nPNslCoVUBjB
6Dh1JankdF5BsV6tj9ae9hoRlfiM3qA9WvDbZxe/SXO/cftdPAZxAjWjkwmr4qGD
GlRwyn8LILs4y7N/BrRibBeZtrFOEvabOhz/0RqxdebqFBNK4gs=
=pTfH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26374@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26374
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help