[PATCH] gnu: Move audacity to audio.scm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170404214649.12074-1-kei@openmailbox.org
* gnu/packages/audacity.scm: Remove file and move audacity...
* gnu/packages/audio.scm: ...here.
* gnu/local.mk: Remove reference to removed file.
---
gnu/local.mk | 1 -
gnu/packages/audacity.scm | 112 ----------------------------------------------
gnu/packages/audio.scm | 75 +++++++++++++++++++++++++++++++
3 files changed, 75 insertions(+), 113 deletions(-)
delete mode 100644 gnu/packages/audacity.scm

Toggle diff (225 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 969bcefeb..f54ab2a45 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -53,7 +53,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/assembly.scm \
%D%/packages/astronomy.scm \
%D%/packages/attr.scm \
- %D%/packages/audacity.scm \
%D%/packages/audio.scm \
%D%/packages/augeas.scm \
%D%/packages/autogen.scm \
diff --git a/gnu/packages/audacity.scm b/gnu/packages/audacity.scm
deleted file mode 100644
index 1ef5048f9..000000000
--- a/gnu/packages/audacity.scm
+++ /dev/null
@@ -1,112 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages audacity)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages audio)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages base)
- #:use-module (gnu packages gettext)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages linux)
- #:use-module (gnu packages mp3)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages pulseaudio)
- #:use-module (gnu packages python)
- #:use-module (gnu packages xiph)
- #:use-module (gnu packages xml)
- #:use-module (gnu packages video)
- #:use-module (gnu packages wxwidgets))
-
-(define-public audacity
- (package
- (name "audacity")
- (version "2.1.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/audacity/audacity/archive"
- "/Audacity-" version ".tar.gz"))
- (sha256
- (base32 "11mx7gb4dbqrgfp7hm0154x3m76ddnmhf2675q5zkxn7jc5qfc6b"))))
- (build-system gnu-build-system)
- (inputs
- ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
- ;; versions shipping with Audacity are used for now.
- `(("wxwidgets" ,wxwidgets-gtk2)
- ("gtk" ,gtk+-2)
- ("alsa-lib" ,alsa-lib)
- ("jack" ,jack-1)
- ("expat" ,expat)
- ("ffmpeg" ,ffmpeg)
- ("lame" ,lame)
- ("flac" ,flac)
- ("libid3tag" ,libid3tag)
- ("libmad" ,libmad)
- ("libsbsms" ,libsbsms)
- ("libsndfile" ,libsndfile)
- ("soundtouch" ,soundtouch)
- ("soxr" ,soxr) ;replaces libsamplerate
- ("twolame" ,twolame)
- ("vamp" ,vamp)
- ("libvorbis" ,libvorbis)
- ("lv2" ,lv2)
- ("lilv" ,lilv)
- ("portaudio" ,portaudio)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal) ;for msgfmt
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python" ,python-2)
- ("which" ,which)))
- (arguments
- '(#:configure-flags
- (let ((libid3tag (assoc-ref %build-inputs "libid3tag"))
- (libmad (assoc-ref %build-inputs "libmad")))
- (list
- ;; Loading FFmpeg dynamically is problematic.
- "--disable-dynamic-loading"
- ;; libid3tag and libmad provide no .pc files, so pkg-config fails to
- ;; find them. Force their inclusion.
- (string-append "ID3TAG_CFLAGS=-I" libid3tag "/include")
- (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
- (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
- (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
- #:phases
- (modify-phases %standard-phases
- ;; FFmpeg is only detected if autoreconf runs.
- (add-before 'configure 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))
- ;; The test suite is not "well exercised" according to the developers,
- ;; and fails with various errors. See
- ;; <http://sourceforge.net/p/audacity/mailman/message/33524292/>.
- #:tests? #f))
- (home-page "http://audacity.sourceforge.net/")
- (synopsis "Software for recording and editing sounds")
- (description
- "Audacity is a multi-track audio editor designed for recording, playing
-and editing digital audio. It features digital effects and spectrum analysis
-tools.")
- (license license:gpl2+)))
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d9fdd6c6b..9dc679734 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -269,6 +270,80 @@ record, edit, mix and master audio and MIDI projects. It is targeted at audio
engineers, musicians, soundtrack editors and composers.")
(license license:gpl2+)))
+(define-public audacity
+ (package
+ (name "audacity")
+ (version "2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/audacity/audacity/archive"
+ "/Audacity-" version ".tar.gz"))
+ (sha256
+ (base32 "11mx7gb4dbqrgfp7hm0154x3m76ddnmhf2675q5zkxn7jc5qfc6b"))))
+ (build-system gnu-build-system)
+ (inputs
+ ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
+ ;; versions shipping with Audacity are used for now.
+ `(("wxwidgets" ,wxwidgets-gtk2)
+ ("gtk" ,gtk+-2)
+ ("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("expat" ,expat)
+ ("ffmpeg" ,ffmpeg)
+ ("lame" ,lame)
+ ("flac" ,flac)
+ ("libid3tag" ,libid3tag)
+ ("libmad" ,libmad)
+ ("libsbsms" ,libsbsms)
+ ("libsndfile" ,libsndfile)
+ ("soundtouch" ,soundtouch)
+ ("soxr" ,soxr) ;replaces libsamplerate
+ ("twolame" ,twolame)
+ ("vamp" ,vamp)
+ ("libvorbis" ,libvorbis)
+ ("lv2" ,lv2)
+ ("lilv" ,lilv)
+ ("portaudio" ,portaudio)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal) ;for msgfmt
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)
+ ("which" ,which)))
+ (arguments
+ '(#:configure-flags
+ (let ((libid3tag (assoc-ref %build-inputs "libid3tag"))
+ (libmad (assoc-ref %build-inputs "libmad")))
+ (list
+ ;; Loading FFmpeg dynamically is problematic.
+ "--disable-dynamic-loading"
+ ;; libid3tag and libmad provide no .pc files, so pkg-config fails to
+ ;; find them. Force their inclusion.
+ (string-append "ID3TAG_CFLAGS=-I" libid3tag "/include")
+ (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
+ (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
+ (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; FFmpeg is only detected if autoreconf runs.
+ (add-before 'configure 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))
+ ;; The test suite is not "well exercised" according to the developers,
+ ;; and fails with various errors. See
+ ;; <http://sourceforge.net/p/audacity/mailman/message/33524292/>.
+ #:tests? #f))
+ (home-page "http://audacity.sourceforge.net/")
+ (synopsis "Software for recording and editing sounds")
+ (description
+ "Audacity is a multi-track audio editor designed for recording, playing
+and editing digital audio. It features digital effects and spectrum analysis
+tools.")
+ (license license:gpl2+)))
+
(define-public azr3
(package
(name "azr3")
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87tw62aldy.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (4 lines)
> * gnu/packages/audacity.scm: Remove file and move audacity...
> * gnu/packages/audio.scm: ...here.
> * gnu/local.mk: Remove reference to removed file.

LGTM; the copyright header is already present in audio.scm, and
audacity.scm is not referred to from anywhere else.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljlFjkACgkQoqBt8qM6
VPqkgwf8DTqGG2p0jF/RkpO4t+P1OV2wkfwzwOyq1IGCpVM06BITG9WhICL6VJKa
Z5nFhAANTl5hpF1GQrZecbZAa1TPU4sxB+1olvEXIQIFv57hLkBJqrOg8my7AUFL
2k7Oqmt/Fkf/lmN8u1hMue6nThSb5AA9zsn3voGXq7OD0iK6qaqa8bOLb2ODkblz
wso3gtbYsnWu5cf/C/hJFmBRdeHN8qtM26IDd2uSDLMP5BSwFGxqB5BYDyvAk173
6SEtnA2FASjghZYaJlv6lu62Z5L9ocioz6G5JE7Hw/U6BHMdZL45DCxfmKHw0OkS
c1irCGsDw8JIGO9RuexRl0j0XM8adw==
=VuBA
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26365-done@debbugs.gnu.org)
8737dm4qq1.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (9 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/audacity.scm: Remove file and move audacity...
>> * gnu/packages/audio.scm: ...here.
>> * gnu/local.mk: Remove reference to removed file.
>
> LGTM; the copyright header is already present in audio.scm, and
> audacity.scm is not referred to from anywhere else.

Pushed to master. Thanks for the review.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljlQLcACgkQ5qXuPBlG
eg1d9Q//Xn9uylrDUHywmbFoHs+eTZcExZxzwC3RZ8bNkX9N9c3f+wgq9jHIH6xr
jcPVy1tD6KiW9gg9mnGRpbfMjNDtTI34tYu9AKmvuHbBDUH5kJyZM9d1enjm/ksv
nNk9JH2lz9cTzhBBBs+5IRbOcliSe2Y2u775wehBA0I8FdpBkfz0x0EguDiNd0Kp
R7cayznYwBWoxWXTH5KkvYTbndNlXtCN+XiymYROSoF8iiWfjauG7hp9LLGQ35n8
Sl3VbH9t5AO8pABR1XWmbZXr0DPemwDIRmJLJ9YoLWiM1F9cMJJQ1ZO8Dlqp/kCL
WXEXd2ecJv9eyqzLLWukJyAbhHaCx5RvJHepCXA9dV0DSIf2AzEb4I0ChMkjJBfl
zCwY3XZ+5VHXF71EGNU9QTVCgB5BM7oshSoI6pTPdGsLT+fj6gzCenKTX2fhm1gj
PjNI84y3m3tCtqdceSDqDVB83vYkZo8Qxm/BiXLB8aoZktAR0Q7FEe5/w3h/+sWa
lm2sDzYt3Qe0AHikIujOg0w7gZW6Pz8Q+DyO9rS+XkZJNtKFQe8fluv01ZPWNURw
lfgJdNw+z6qHxxHJZgWhaQRcCHaCv/UnZrmQ9AOPVVDrUOX4XPKOP6mmoobXSKSP
8X9tZ7q/MX1AeN9jZQER/qjEyBIH7ZmARSGS1Cr2E9UjsNY/bPA=
=vRi6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26365@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26365
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help