[PATCH] gnu: audacity: Update to 2.1.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170402155211.23494-1-kei@openmailbox.org
* gnu/packages/audacity.scm (audacity): Update to 2.1.3.
[source]: Fetch gzipped tar archive instead of a zip archive; add
snippet to remove time-dependent code; remove unnecessary patch.
[native-inputs]: Add autoconf, automake and libtool.
[arguments]: Add autoreconf phase to detect system libraries.
* gnu/packages/patches/audacity-fix-ffmpeg-binding.patch: Delete patch.
* gnu/local.mk: Remove reference to removed patch.
---
gnu/local.mk | 1 -
gnu/packages/audacity.scm | 25 +++++++++++++----
.../patches/audacity-fix-ffmpeg-binding.patch | 32 ----------------------
3 files changed, 20 insertions(+), 38 deletions(-)
delete mode 100644 gnu/packages/patches/audacity-fix-ffmpeg-binding.patch

Toggle diff (114 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 68f561e95..f03f50855 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -494,7 +494,6 @@ dist_patch_DATA = \
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
- %D%/packages/patches/audacity-fix-ffmpeg-binding.patch \
%D%/packages/patches/automake-skip-amhello-tests.patch \
%D%/packages/patches/automake-regexp-syntax.patch \
%D%/packages/patches/automake-test-gzip-warning.patch \
diff --git a/gnu/packages/audacity.scm b/gnu/packages/audacity.scm
index a70d0e3a6..a4ac2a6ff 100644
--- a/gnu/packages/audacity.scm
+++ b/gnu/packages/audacity.scm
@@ -23,6 +23,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gtk)
@@ -39,15 +40,20 @@
(define-public audacity
(package
(name "audacity")
- (version "2.1.2")
+ (version "2.1.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/audacity/audacity/archive"
- "/Audacity-" version ".zip"))
+ "/Audacity-" version ".tar.gz"))
(sha256
- (base32 "1642i9d5cdmqzj6r0qdl2ldnqsvpb08znnczncysi72x6zpvb5qq"))
- (patches (search-patches "audacity-fix-ffmpeg-binding.patch"))))
+ (base32 "11mx7gb4dbqrgfp7hm0154x3m76ddnmhf2675q5zkxn7jc5qfc6b"))
+ ;; Replace time-dependent strings.
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "src/AboutDialog.cpp"
+ (("__DATE__") "\"2017\"")
+ (("__TIME__") "\"00:00\"")))))
(build-system gnu-build-system)
(inputs
;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
@@ -73,7 +79,10 @@
("lilv" ,lilv)
("portaudio" ,portaudio)))
(native-inputs
- `(("gettext" ,gettext-minimal) ;for msgfmt
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal) ;for msgfmt
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)
("python" ,python-2)
("which" ,which)))
@@ -90,6 +99,12 @@
(string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
(string-append "LIBMAD_CFLAGS=-I" libmad "/include")
(string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; Ensure the usage of system libraries.
+ (add-before 'configure 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))
;; The test suite is not "well exercised" according to the developers,
;; and fails with various errors. See
;; <http://sourceforge.net/p/audacity/mailman/message/33524292/>.
diff --git a/gnu/packages/patches/audacity-fix-ffmpeg-binding.patch b/gnu/packages/patches/audacity-fix-ffmpeg-binding.patch
deleted file mode 100644
index d6d65338d..000000000
--- a/gnu/packages/patches/audacity-fix-ffmpeg-binding.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-This resolves some "declaration of C function conflicts with previous
-declaration" errors during compilation.
-
---- a/src/FFmpeg.h 2015-02-21 00:33:33.853857529 +0100
-+++ b/src/FFmpeg.h 2015-02-21 00:35:09.626497205 +0100
-@@ -688,7 +688,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- AVOutputFormat*,
- av_oformat_next,
-- (AVOutputFormat *f),
-+ (const AVOutputFormat *f),
- (f)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
-@@ -755,7 +755,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- int,
- av_fifo_size,
-- (AVFifoBuffer *f),
-+ (const AVFifoBuffer *f),
- (f)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
-@@ -801,7 +801,7 @@
- FFMPEG_FUNCTION_WITH_RETURN(
- AVDictionaryEntry *,
- av_dict_get,
-- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
-+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
- (m, key, prev, flags)
- );
- FFMPEG_FUNCTION_WITH_RETURN(
--
2.12.2
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87y3viv55d.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (61 lines)
> * gnu/packages/audacity.scm (audacity): Update to 2.1.3.
> [source]: Fetch gzipped tar archive instead of a zip archive; add
> snippet to remove time-dependent code; remove unnecessary patch.
> [native-inputs]: Add autoconf, automake and libtool.
> [arguments]: Add autoreconf phase to detect system libraries.
> * gnu/packages/patches/audacity-fix-ffmpeg-binding.patch: Delete patch.
> * gnu/local.mk: Remove reference to removed patch.
> ---
> gnu/local.mk | 1 -
> gnu/packages/audacity.scm | 25 +++++++++++++----
> .../patches/audacity-fix-ffmpeg-binding.patch | 32 ----------------------
> 3 files changed, 20 insertions(+), 38 deletions(-)
> delete mode 100644 gnu/packages/patches/audacity-fix-ffmpeg-binding.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 68f561e95..f03f50855 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -494,7 +494,6 @@ dist_patch_DATA = \
> %D%/packages/patches/ath9k-htc-firmware-binutils.patch \
> %D%/packages/patches/ath9k-htc-firmware-gcc.patch \
> %D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
> - %D%/packages/patches/audacity-fix-ffmpeg-binding.patch \
> %D%/packages/patches/automake-skip-amhello-tests.patch \
> %D%/packages/patches/automake-regexp-syntax.patch \
> %D%/packages/patches/automake-test-gzip-warning.patch \
> diff --git a/gnu/packages/audacity.scm b/gnu/packages/audacity.scm
> index a70d0e3a6..a4ac2a6ff 100644
> --- a/gnu/packages/audacity.scm
> +++ b/gnu/packages/audacity.scm
> @@ -23,6 +23,7 @@
> #:use-module (guix build-system gnu)
> #:use-module (gnu packages)
> #:use-module (gnu packages audio)
> + #:use-module (gnu packages autotools)
> #:use-module (gnu packages base)
> #:use-module (gnu packages gettext)
> #:use-module (gnu packages gtk)
> @@ -39,15 +40,20 @@
> (define-public audacity
> (package
> (name "audacity")
> - (version "2.1.2")
> + (version "2.1.3")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://github.com/audacity/audacity/archive"
> - "/Audacity-" version ".zip"))
> + "/Audacity-" version ".tar.gz"))
> (sha256
> - (base32 "1642i9d5cdmqzj6r0qdl2ldnqsvpb08znnczncysi72x6zpvb5qq"))
> - (patches (search-patches "audacity-fix-ffmpeg-binding.patch"))))
> + (base32 "11mx7gb4dbqrgfp7hm0154x3m76ddnmhf2675q5zkxn7jc5qfc6b"))
> + ;; Replace time-dependent strings.
> + (modules '((guix build utils)))
> + (snippet
> + '(substitute* "src/AboutDialog.cpp"
> + (("__DATE__") "\"2017\"")
> + (("__TIME__") "\"00:00\"")))))

Now that we're merging core-updates where GCC have been patched to
respect SOURCE_DATE_EPOCH in these macros, this substitution should no
longer be necessary. Can you verify? :)

Toggle quote (26 lines)
> (build-system gnu-build-system)
> (inputs
> ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
> @@ -73,7 +79,10 @@
> ("lilv" ,lilv)
> ("portaudio" ,portaudio)))
> (native-inputs
> - `(("gettext" ,gettext-minimal) ;for msgfmt
> + `(("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("gettext" ,gettext-minimal) ;for msgfmt
> + ("libtool" ,libtool)
> ("pkg-config" ,pkg-config)
> ("python" ,python-2)
> ("which" ,which)))
> @@ -90,6 +99,12 @@
> (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
> (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
> (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
> + #:phases
> + (modify-phases %standard-phases
> + ;; Ensure the usage of system libraries.
> + (add-before 'configure 'autoreconf
> + (lambda _
> + (zero? (system* "autoreconf" "-vfi")))))

Can you clarify how autoreconf ensures usage of system libraries?
Usually it just re-generates configure scripts and Makefiles from
templates, but should not make any functional difference.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljhdS4ACgkQoqBt8qM6
VPohTQf/Q0MjAbU0L4Djgg5JfZPRDKf3pl72xyTCZKrr16KxThzuXd5KDIDsI7Jn
7I0khsMZY5IM7W/jRJklCdLcbYZzlFwuj0JGQuFkMpWsgeLMG5A7lcg9qFWi/AB3
1gryxkqj3y/99VfRcH/c4ZbpZiK6mmAg0GbxrhvKsPXqlthaIuUO/8RPf+bUnRAV
XCjfbLw4gsOVVuhGwL7hSS5mD92CaMfGmQY8ATg8MIFKDvjOmZei0/77EAtMxVO9
RGkRDIZpjxIrdts2fr+ZjUqT28TkWrpGXPwO9ZtzkjLP9iwJuWNFZbHNtut1i8A3
z34bm6kM2RQ+qgrzYDu8wM1miSkTXA==
=s4jq
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87vaqmv4yn.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Toggle quote (30 lines)
>> (build-system gnu-build-system)
>> (inputs
>> ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
>> @@ -73,7 +79,10 @@
>> ("lilv" ,lilv)
>> ("portaudio" ,portaudio)))
>> (native-inputs
>> - `(("gettext" ,gettext-minimal) ;for msgfmt
>> + `(("autoconf" ,autoconf)
>> + ("automake" ,automake)
>> + ("gettext" ,gettext-minimal) ;for msgfmt
>> + ("libtool" ,libtool)
>> ("pkg-config" ,pkg-config)
>> ("python" ,python-2)
>> ("which" ,which)))
>> @@ -90,6 +99,12 @@
>> (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
>> (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
>> (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
>> + #:phases
>> + (modify-phases %standard-phases
>> + ;; Ensure the usage of system libraries.
>> + (add-before 'configure 'autoreconf
>> + (lambda _
>> + (zero? (system* "autoreconf" "-vfi")))))
>
> Can you clarify how autoreconf ensures usage of system libraries?
> Usually it just re-generates configure scripts and Makefiles from
> templates, but should not make any functional difference.

I also noticed they offer yet another download on the home page:


Perhaps this one is properly bootstrapped?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljhdiAACgkQoqBt8qM6
VPpkXwf+PNkrkDidLNgSXgZEq8T8FCo8bfPQt4oeQEPL4/PArQr3C2h2SGJza8V2
I5lJ3lsDFVC5M+fD/7DKpXLDyL5T36+IwE4nxNICbQtVIWPRuHiCyLl1YcvP2BKn
xt8QcFCiFF3Mg5HzGJiR1PY93FC0dUG1Q1n7hjIE7Y/CPxxAOWo/6dkqFvT+KazE
CfSOaOMvvPgaEnUD4Z4u9BffjF59qcrUhaTUgGOjOluefrIPhpu84egcshJxQCLc
Abl3PqijqTSnMXUrZ9TniRyTRriY8mHxf4BUOBoqdxvQUWgBNAyVcWbme/qwVXuN
2ZyRRgt2e+bEVZvbP6k7aH9hAFPOOQ==
=R9UA
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26343@debbugs.gnu.org)
87pogu45y3.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (68 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/audacity.scm (audacity): Update to 2.1.3.
>> [source]: Fetch gzipped tar archive instead of a zip archive; add
>> snippet to remove time-dependent code; remove unnecessary patch.
>> [native-inputs]: Add autoconf, automake and libtool.
>> [arguments]: Add autoreconf phase to detect system libraries.
>> * gnu/packages/patches/audacity-fix-ffmpeg-binding.patch: Delete patch.
>> * gnu/local.mk: Remove reference to removed patch.
>> ---
>> gnu/local.mk | 1 -
>> gnu/packages/audacity.scm | 25 +++++++++++++----
>> .../patches/audacity-fix-ffmpeg-binding.patch | 32 ----------------------
>> 3 files changed, 20 insertions(+), 38 deletions(-)
>> delete mode 100644 gnu/packages/patches/audacity-fix-ffmpeg-binding.patch
>>
>> diff --git a/gnu/local.mk b/gnu/local.mk
>> index 68f561e95..f03f50855 100644
>> --- a/gnu/local.mk
>> +++ b/gnu/local.mk
>> @@ -494,7 +494,6 @@ dist_patch_DATA = \
>> %D%/packages/patches/ath9k-htc-firmware-binutils.patch \
>> %D%/packages/patches/ath9k-htc-firmware-gcc.patch \
>> %D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
>> - %D%/packages/patches/audacity-fix-ffmpeg-binding.patch \
>> %D%/packages/patches/automake-skip-amhello-tests.patch \
>> %D%/packages/patches/automake-regexp-syntax.patch \
>> %D%/packages/patches/automake-test-gzip-warning.patch \
>> diff --git a/gnu/packages/audacity.scm b/gnu/packages/audacity.scm
>> index a70d0e3a6..a4ac2a6ff 100644
>> --- a/gnu/packages/audacity.scm
>> +++ b/gnu/packages/audacity.scm
>> @@ -23,6 +23,7 @@
>> #:use-module (guix build-system gnu)
>> #:use-module (gnu packages)
>> #:use-module (gnu packages audio)
>> + #:use-module (gnu packages autotools)
>> #:use-module (gnu packages base)
>> #:use-module (gnu packages gettext)
>> #:use-module (gnu packages gtk)
>> @@ -39,15 +40,20 @@
>> (define-public audacity
>> (package
>> (name "audacity")
>> - (version "2.1.2")
>> + (version "2.1.3")
>> (source
>> (origin
>> (method url-fetch)
>> (uri (string-append "https://github.com/audacity/audacity/archive"
>> - "/Audacity-" version ".zip"))
>> + "/Audacity-" version ".tar.gz"))
>> (sha256
>> - (base32 "1642i9d5cdmqzj6r0qdl2ldnqsvpb08znnczncysi72x6zpvb5qq"))
>> - (patches (search-patches "audacity-fix-ffmpeg-binding.patch"))))
>> + (base32 "11mx7gb4dbqrgfp7hm0154x3m76ddnmhf2675q5zkxn7jc5qfc6b"))
>> + ;; Replace time-dependent strings.
>> + (modules '((guix build utils)))
>> + (snippet
>> + '(substitute* "src/AboutDialog.cpp"
>> + (("__DATE__") "\"2017\"")
>> + (("__TIME__") "\"00:00\"")))))
>
> Now that we're merging core-updates where GCC have been patched to
> respect SOURCE_DATE_EPOCH in these macros, this substitution should no
> longer be necessary. Can you verify? :)
>

It works! \o/

Toggle quote (32 lines)
>> (build-system gnu-build-system)
>> (inputs
>> ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
>> @@ -73,7 +79,10 @@
>> ("lilv" ,lilv)
>> ("portaudio" ,portaudio)))
>> (native-inputs
>> - `(("gettext" ,gettext-minimal) ;for msgfmt
>> + `(("autoconf" ,autoconf)
>> + ("automake" ,automake)
>> + ("gettext" ,gettext-minimal) ;for msgfmt
>> + ("libtool" ,libtool)
>> ("pkg-config" ,pkg-config)
>> ("python" ,python-2)
>> ("which" ,which)))
>> @@ -90,6 +99,12 @@
>> (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
>> (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
>> (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
>> + #:phases
>> + (modify-phases %standard-phases
>> + ;; Ensure the usage of system libraries.
>> + (add-before 'configure 'autoreconf
>> + (lambda _
>> + (zero? (system* "autoreconf" "-vfi")))))
>
> Can you clarify how autoreconf ensures usage of system libraries?
> Usually it just re-generates configure scripts and Makefiles from
> templates, but should not make any functional difference.
>
> Thanks!

FFmpeg is not detected if autoreconf doesn't run for some reason. With
this phase, everything is detected like normal.

Also, the audacityteam.org URL leads to another webpage with a seemingly
impermanent link to the tarball*. I get the following:


* Take a look at the following thread to see what happened last time
with this topic. I'm not getting the 403 errors that I was getting
before though:
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljhqeQACgkQ5qXuPBlG
eg1E/w//etCe7ee2h/WiciyErjuQEF/7I9uGL3qM0FLgl/FFOq15GM3YSJzHFsLt
cNk8AGdHvIpEGpVmigUv4FMOUDLaL0ZRoLTKjzAssAMMVsRUhR64j1FCN2JbezlT
uZ1yIHIMhBHzEWm2i8xHaUc6C7/kjW6PqarkW80eJxGqir3egMAGmIU7jevJGwNd
QVumgoKQnOr8IJ8v/ilbWl8u2dfjH1Z6J/YsNf/iLjXC56OmHo/56e0kj2tujHNU
QyPccgNO6tcy5oVN9P+uK/kDuM9cGO1WjsabBFWYlkdAsgWUGNSRlymphbffMBuQ
1tz16xAeiWJe2klZ6Hn4ZYr/v7w30Ehej2qvWKtqAKjW1qxPUCjLuKgMSHCERco7
kAfu28Ifs5Z30eVaW6kQwq8JKI4oL0ETHB81bt+IgzvndIk0IPzgcAWf/6VrH+bI
6vy/vOBzG39O2480JTUIWv86ic9aCuu7eov1EEdCMsvtdDLZipdmjZl+JWwEWCFS
FHahz8tDoahIiEECRqHAdci36LfQybB9789xcphcrhlMelQ/gKdHQFMVxNejZ7Zu
r5OJA75NkfKAxNpgytIqNusvb0P+LI6h+LxpSfdgOHNt/M0Xj9FZhKz+6QKuXSkM
wcseHgpdbH1JQs2XYXtoQHiWx5MRgf/7TWxj3DaCZshf0K3TG68=
=ZIUv
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26343@debbugs.gnu.org)
87lgrhbr6d.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (35 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>>> (build-system gnu-build-system)
>>> (inputs
>>> ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
>>> @@ -73,7 +79,10 @@
>>> ("lilv" ,lilv)
>>> ("portaudio" ,portaudio)))
>>> (native-inputs
>>> - `(("gettext" ,gettext-minimal) ;for msgfmt
>>> + `(("autoconf" ,autoconf)
>>> + ("automake" ,automake)
>>> + ("gettext" ,gettext-minimal) ;for msgfmt
>>> + ("libtool" ,libtool)
>>> ("pkg-config" ,pkg-config)
>>> ("python" ,python-2)
>>> ("which" ,which)))
>>> @@ -90,6 +99,12 @@
>>> (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
>>> (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
>>> (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
>>> + #:phases
>>> + (modify-phases %standard-phases
>>> + ;; Ensure the usage of system libraries.
>>> + (add-before 'configure 'autoreconf
>>> + (lambda _
>>> + (zero? (system* "autoreconf" "-vfi")))))
>>
>> Can you clarify how autoreconf ensures usage of system libraries?
>> Usually it just re-generates configure scripts and Makefiles from
>> templates, but should not make any functional difference.
>
> FFmpeg is not detected if autoreconf doesn't run for some reason. With
> this phase, everything is detected like normal.

Oh. Please mention that in the comment then. Thank you! :)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljiQqoACgkQoqBt8qM6
VPrn/wf/UgDYBmx3M0XCGNX9tEhmUe1GUTefhps5vnXCE0BT3Ek+Yb4PIQjTlZzV
ySf73AY80iTLX9VBy3JCCjp5b+dkxmQxbhMcm9BfdLtptHaJARRLbvaydn13DXpk
gjL3GGlvHeFCn8qkpbHredvXb3kL1Plw/L+12uySfVeG1c9QMu+vKc9jhdJRx9DC
OYZQiFRBETPCAy3QPcFfMr4xy+gp997bR/te8FyxAYHWkVGRnyBK5jmoBdiHUEwS
2TBfXK2eMkZY6KrZpPfp5WAwaN1lUBMC8bdm5uWrw6Kac2AFI7QiCJPyX0EaD4rb
+8VZOrCgZVMo8iZptCBm3IqgMM6tgQ==
=kvrD
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26343-done@debbugs.gnu.org)
87efx94hes.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (39 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> Marius Bakke <mbakke@fastmail.com> writes:
>>
>>>> (build-system gnu-build-system)
>>>> (inputs
>>>> ;; TODO: Add portSMF and libwidgetextra once they're packaged. In-tree
>>>> @@ -73,7 +79,10 @@
>>>> ("lilv" ,lilv)
>>>> ("portaudio" ,portaudio)))
>>>> (native-inputs
>>>> - `(("gettext" ,gettext-minimal) ;for msgfmt
>>>> + `(("autoconf" ,autoconf)
>>>> + ("automake" ,automake)
>>>> + ("gettext" ,gettext-minimal) ;for msgfmt
>>>> + ("libtool" ,libtool)
>>>> ("pkg-config" ,pkg-config)
>>>> ("python" ,python-2)
>>>> ("which" ,which)))
>>>> @@ -90,6 +99,12 @@
>>>> (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")
>>>> (string-append "LIBMAD_CFLAGS=-I" libmad "/include")
>>>> (string-append "LIBMAD_LIBS=-L" libmad "/lib -lmad")))
>>>> + #:phases
>>>> + (modify-phases %standard-phases
>>>> + ;; Ensure the usage of system libraries.
>>>> + (add-before 'configure 'autoreconf
>>>> + (lambda _
>>>> + (zero? (system* "autoreconf" "-vfi")))))
>>>
>>> Can you clarify how autoreconf ensures usage of system libraries?
>>> Usually it just re-generates configure scripts and Makefiles from
>>> templates, but should not make any functional difference.
>>
>> FFmpeg is not detected if autoreconf doesn't run for some reason. With
>> this phase, everything is detected like normal.
>
> Oh. Please mention that in the comment then. Thank you! :)

Pushed to master. Thanks for the review!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljib9sACgkQ5qXuPBlG
eg0AMA//ZB+/bsiBs3KDv5EeMXeKt+KpjjNGRmEZmyLOQyDJspHVAfY2hydU5OGf
fT5quqtXykIXWMauZLjsUAHiRenL+F61EZ9FK5NXpilgHIaQlkRCONePbKCNHXN4
5wtpYkQTqVnjXNfphoR0Ei0POrBlWdXCoyOdJVs919WuUx6y9MJbDAgW656B4tYG
2gK1HPUmyI6qTsJgoZDBDTIUV7GKQBYZfnbzmvjY1BlNg7C9RpLnhIp0Zd5YVCvj
YUrjnKHQTv4xeIBegEfD8PvytgSNp1pTvZfA1WIa+4P09TEXVCfZlECoMyFe2uFL
kE063fJxQvz3vy89ti6GFmBwMx2aFaEzCuZ/ppuKn8QDl/4xwGx4zVACumum7y+M
KLoTd3zi2MJCojtiWCqlFQDr6coFOgPu6D96WJjBkHcLKsREhM0IngimFtWt6cdm
8NF/be/hTSHEdD+KNgOKejUJbHro8LoP9Cz69Vpu2S2zuMBjTcW4GYX8UDLXQKP6
mvahZC4Nl+wV9Jx8XDAVDGqOXCH6z6nBje/emKr+ikX1BTZ1V1qLpVgBMkVFrTyA
b3Ya3/8FEOqab5AbRx4Fzki3sXO1dHfBf3AExEY5dqxJ3WLhrMfCIiQ/DYSI89bU
WoUyTHTQV0U0LQAQoTmDRBUBOdlQEQ9O+g+fS3Fv59lzRsIFQPY=
=XWUA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26343@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26343
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help