[PATCH] gnu: milkytracker: Update to 1.0.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • ng0
  • Kei Kebreau
  • Ricardo Wurmus
Owner
Somebody
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 29 Mar 2017 16:52
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170329145250.3913-1-kei@openmailbox.org
* gnu/packages/music.scm (milkytracker): Update to 1.0.0.
[source]: Change uri; add file-name.
[build-system]: Change from gnu-build-system to cmake-build-system.
[arguments]: Remove #:make-flags; disable tests (which are no longer
present).
[inputs]: Change sdl to sdl2.
---
gnu/packages/music.scm | 20 ++++++++++++--------
1 file changed, 12 insertions(+), 8 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f70945c6..f1914fefe 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
@@ -2132,21 +2132,22 @@ of tools for manipulating and accessing your music.")
(define-public milkytracker
(package
(name "milkytracker")
- (version "0.90.86")
+ (version "1.0.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://milkytracker.titandemo.org/files/"
- name "-" version ".tar.bz2"))
+ (uri (string-append "https://github.com/milkytracker/"
+ "MilkyTracker/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1v9vp8vi24lkagfpr92c128whvakwgrm9pq2zf6ijpl5sh7014zb"))))
- (build-system gnu-build-system)
+ "1p1jd4h274jvcvl05l01v9bj19zhq4sjag92v1zawyi93ib85abz"))))
+ (build-system cmake-build-system)
(arguments
- `(#:make-flags '("CXXFLAGS=-lasound")))
+ '(#:tests? #f)) ; no check target
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
- ("sdl" ,sdl)
+ ("sdl" ,sdl2)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -2157,6 +2158,9 @@ the popular DOS program Fasttracker II, with special playback modes available
for improved Amiga ProTracker 2/3 compatibility.")
(home-page "http://milkytracker.titandemo.org/")
;; 'src/milkyplay' is under Modified BSD, the rest is under GPL3 or later.
+ ;; Also, songs installed in share/milkytracker/songs are licensed under the
+ ;; Creative Commons Attribution-Noncommericial-Share Alike 3.0 Unported
+ ;; License.
(license (list license:bsd-3 license:gpl3+))))
(define-public schismtracker
--
2.12.0
N
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26300@debbugs.gnu.org)
20170329150419.ytsjr7hndor7qjiv@abyayala
Kei Kebreau transcribed 2.7K bytes:
Toggle quote (61 lines)
> * gnu/packages/music.scm (milkytracker): Update to 1.0.0.
> [source]: Change uri; add file-name.
> [build-system]: Change from gnu-build-system to cmake-build-system.
> [arguments]: Remove #:make-flags; disable tests (which are no longer
> present).
> [inputs]: Change sdl to sdl2.
> ---
> gnu/packages/music.scm | 20 ++++++++++++--------
> 1 file changed, 12 insertions(+), 8 deletions(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 2f70945c6..f1914fefe 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -5,7 +5,7 @@
> ;;; Copyright © 2016 Al McElrath <hello@yrns.org>
> ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
> -;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
> +;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
> ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
> ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
> ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
> @@ -2132,21 +2132,22 @@ of tools for manipulating and accessing your music.")
> (define-public milkytracker
> (package
> (name "milkytracker")
> - (version "0.90.86")
> + (version "1.0.0")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://milkytracker.titandemo.org/files/"
> - name "-" version ".tar.bz2"))
> + (uri (string-append "https://github.com/milkytracker/"
> + "MilkyTracker/archive/v" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> (sha256
> (base32
> - "1v9vp8vi24lkagfpr92c128whvakwgrm9pq2zf6ijpl5sh7014zb"))))
> - (build-system gnu-build-system)
> + "1p1jd4h274jvcvl05l01v9bj19zhq4sjag92v1zawyi93ib85abz"))))
> + (build-system cmake-build-system)
> (arguments
> - `(#:make-flags '("CXXFLAGS=-lasound")))
> + '(#:tests? #f)) ; no check target
> (inputs
> `(("alsa-lib" ,alsa-lib)
> ("jack" ,jack-1)
> - ("sdl" ,sdl)
> + ("sdl" ,sdl2)
> ("zlib" ,zlib)))
> (native-inputs
> `(("pkg-config" ,pkg-config)))
> @@ -2157,6 +2158,9 @@ the popular DOS program Fasttracker II, with special playback modes available
> for improved Amiga ProTracker 2/3 compatibility.")
> (home-page "http://milkytracker.titandemo.org/")
> ;; 'src/milkyplay' is under Modified BSD, the rest is under GPL3 or later.
> + ;; Also, songs installed in share/milkytracker/songs are licensed under the
> + ;; Creative Commons Attribution-Noncommericial-Share Alike 3.0 Unported
> + ;; License.

Attribution-Noncommericial… doesn't that make them a candidate for
exclusion in systems like Guix?

Toggle quote (9 lines)
> (license (list license:bsd-3 license:gpl3+))))
>
> (define-public schismtracker
> --
> 2.12.0
>
>
>
>
K
K
Kei Kebreau wrote on 29 Mar 2017 18:01
(address . 26300@debbugs.gnu.org)
871stgoyw1.fsf@openmailbox.org
ng0 <contact.ng0@cryptolab.net> writes:

Toggle quote (5 lines)
>
> Attribution-Noncommericial… doesn't that make them a candidate for
> exclusion in systems like Guix?
>

Considering that the songs are data files and non-executable, the
software is still free. If the sample songs turn out to be a problem, I
can attempt to remove them in a snippet.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJY29peAAoJEOal7jwZRnoNXlIP/jFCuD7RZy9WqWEOqw07jZJa
fqmNP9rCBKAM5cMt7KfRGoDHcuJyjT/Obw32I/4ip5hHDSRzf2CSTWnzTRuXd7Cc
i5QbeX2L+P4rDd5yEKH0u0HA6KkyApT2+tlWVVxrt4VswPeN1hu8IBGntk5+fF22
tznRgc7pjmrVIsmQWeYJwb8nGfDNxOSpKf/1qcRlDFaOcGHgfZeEzlPWgcIQxnxy
M9LH2+IBt8lHui/sGcc0sVMykmeIrrj+v71q9XT+/ZlvuB4NtTD+myDH2BJJg/M9
JAWQpShrjRGMYIKdhihjqlxGMZhTECgczdLb58G9AdTCfqCoSwiwVLHfRCgxPS/2
CbSP+TJVTNwfZS5pc9SomLBjCO1GvBEThikuKKwHrDGIa5/D84GekqwS4Ryjl5ee
Lbf8qr6UB7hJIGkjAAGVmgMFjMWltAt7tLWuzrOqUQxf3flDl4e4qpo++PANDDRn
3TBpGg0QFbG1fXY1SVQpFIKRy0X1HUTo6QqM+ZHvDTR9EEkavT/dF7yXJNjEvQbz
7K4Bsb0hd5pWP1TVwFuOHZRBiZbkynsMc7NcblbFoU6TPMlgWtUHBerr5llffxUe
D9wH141Y/mpZroM6+/RXKDCmkNiAoVf5p2GM6u7sP45RPGkBXM5jxAuFYZTZqso4
Rzp9Y52hwCcQgO76Zh+/
=8o0J
-----END PGP SIGNATURE-----

N
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26300@debbugs.gnu.org)
20170329160821.3hdsx2pdevub6wtg@abyayala
Kei Kebreau transcribed 1.3K bytes:
Toggle quote (11 lines)
> ng0 <contact.ng0@cryptolab.net> writes:
>
> >
> > Attribution-Noncommericial… doesn't that make them a candidate for
> > exclusion in systems like Guix?
> >
>
> Considering that the songs are data files and non-executable, the
> software is still free. If the sample songs turn out to be a problem, I
> can attempt to remove them in a snippet.

It would help if we could document this. I don't think everyone will review
upstream material (FSDG and similar) for data files (music, images).
I would exclude CC licensed material which says "Noncommercial", but I'm
not a lawyer.
K
K
Kei Kebreau wrote on 29 Mar 2017 18:23
(address . 26300@debbugs.gnu.org)
87y3vonjbj.fsf@openmailbox.org
ng0 <contact.ng0@cryptolab.net> writes:

Toggle quote (17 lines)
> Kei Kebreau transcribed 1.3K bytes:
>> ng0 <contact.ng0@cryptolab.net> writes:
>>
>> >
>> > Attribution-Noncommericial… doesn't that make them a candidate for
>> > exclusion in systems like Guix?
>> >
>>
>> Considering that the songs are data files and non-executable, the
>> software is still free. If the sample songs turn out to be a problem, I
>> can attempt to remove them in a snippet.
>
> It would help if we could document this. I don't think everyone will review
> upstream material (FSDG and similar) for data files (music, images).
> I would exclude CC licensed material which says "Noncommercial", but I'm
> not a lawyer.

It may also cause problems upstream as well. The software is under licenses
with no commerical restrictions and the sample songs are under a
noncommericial restriction, but they are shared in one tarball. That
would constitute a conflict, right?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJY299xAAoJEOal7jwZRnoNR7UQAJf1rPLOa/dn5FLvSDsSbMPh
RzKa1Bk6Owi652da92/LqgMkwMfrZN4HBoTqg6cbBPvpL5X9KjE7Qc5Q++qsOMen
auhKwfe2Bpi0+Vqgpw4Y8ept1yqvo0gwrFCIRWvpPvQxlnfBN6QQsPxfUXZw3GFa
DELAL0vJNX7phgXaKuOVos5JzvU2Tb6KHX164N9hAw/70pvUyGg5Wo3ari2KOrqO
yKdDCtOgHzGNV0tjqcBK23mjqV3gt+QHREZ2mJz5ALLFEJ+7IUD7I66W6Rud68RY
dxOtG27nDeHwMwL0OdB2IHMvV8Qp9AxiekSRU1NlDVmejvuZpp8qnfsj2Lly8YOc
hxXOPsmiTm3CE6zmvCEEYXd1za+Gkzy7y7sbqKdsyc6eagch2UQUsjIs2cwrgN8g
aoojzKO/X/K/+wRMHR3sXOGA4fLMzA6CnscRSyBqkmFaX7HH4Xb0XtpGSXJRLj0r
15o5QqV5lgyqu8LjM1ARKU1sFuQqfQXS39GzSAPG3CpRjUj7bxg6bfqGMCrexMg5
wSObiLpXYJNUwn5jFWfMwpQROTMNgrf7x8DfbiG89doGScVXtQLFV3eARZTYEYqm
+t10hW2la/fH26DAPPWqc1g1szzCRgPUUdDJoxs3IgDkHXBEpGu4C9QpujgHIYN6
TilV2EbgojqmLI+CcQuR
=pOsK
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 30 Mar 2017 15:37
(name . Kei Kebreau)(address . kei@openmailbox.org)
87efxe51j2.fsf@elephly.net
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (24 lines)
> ng0 <contact.ng0@cryptolab.net> writes:
>
>> Kei Kebreau transcribed 1.3K bytes:
>>> ng0 <contact.ng0@cryptolab.net> writes:
>>>
>>> >
>>> > Attribution-Noncommericial… doesn't that make them a candidate for
>>> > exclusion in systems like Guix?
>>> >
>>>
>>> Considering that the songs are data files and non-executable, the
>>> software is still free. If the sample songs turn out to be a problem, I
>>> can attempt to remove them in a snippet.
>>
>> It would help if we could document this. I don't think everyone will review
>> upstream material (FSDG and similar) for data files (music, images).
>> I would exclude CC licensed material which says "Noncommercial", but I'm
>> not a lawyer.
>
> It may also cause problems upstream as well. The software is under licenses
> with no commerical restrictions and the sample songs are under a
> noncommericial restriction, but they are shared in one tarball. That
> would constitute a conflict, right?

If my understanding of the FSDG is correct we cannot distribute these
files. The FSDG says this about non-functional data:

Non-functional Data

Data that isn't functional, that doesn't do a practical job, is more
of an adornment to the system's software than a part of it. Thus, we
don't insist on the free license criteria for non-functional
data. It can be included in a free system distribution as long as
its license gives you permission to copy and redistribute, both for
commercial and non-commercial purposes.

In this case the commercial restriction means that we cannot distribute
it. You can remove these files in a snippet. Could you send an updated
patch please?

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 30 Mar 2017 15:37
control message for bug #26300
(address . control@debbugs.gnu.org)
E1ctZm8-0000Mp-3a@debbugs.gnu.org
owner 26300 !
R
R
Ricardo Wurmus wrote on 30 Mar 2017 15:37
(address . control@debbugs.gnu.org)
E1ctZmE-0000N7-A9@debbugs.gnu.org
tags 26300 moreinfo
K
K
Kei Kebreau wrote on 30 Mar 2017 16:20
[PATCH] gnu: milkytracker: Update to 1.0.0.
(address . 26300@debbugs.gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170330142012.17391-1-kei@openmailbox.org
* gnu/packages/music.scm (milkytracker): Update to 1.0.0.
[source]: Change uri; add file-name; add snippet to remove non-FSDG
compliant data.
[build-system]: Change from gnu-build-system to cmake-build-system.
[arguments]: Remove #:make-flags; disable tests (which are no longer
present).
[inputs]: Change sdl to sdl2.
---
gnu/packages/music.scm | 24 ++++++++++++++++--------
1 file changed, 16 insertions(+), 8 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0ad4a2a6c..3ac5be5c8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
@@ -2131,21 +2131,29 @@ of tools for manipulating and accessing your music.")
(define-public milkytracker
(package
(name "milkytracker")
- (version "0.90.86")
+ (version "1.0.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://milkytracker.titandemo.org/files/"
- name "-" version ".tar.bz2"))
+ (uri (string-append "https://github.com/milkytracker/"
+ "MilkyTracker/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1v9vp8vi24lkagfpr92c128whvakwgrm9pq2zf6ijpl5sh7014zb"))))
- (build-system gnu-build-system)
+ "1p1jd4h274jvcvl05l01v9bj19zhq4sjag92v1zawyi93ib85abz"))
+ (modules '((guix build utils)))
+ ;; Remove non-FSDG compliant sample songs.
+ (snippet
+ '(begin
+ (delete-file-recursively "resources/music")
+ (substitute* "CMakeLists.txt"
+ (("add_subdirectory\\(resources/music\\)") ""))))))
+ (build-system cmake-build-system)
(arguments
- `(#:make-flags '("CXXFLAGS=-lasound")))
+ '(#:tests? #f)) ; no check target
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
- ("sdl" ,sdl)
+ ("sdl" ,sdl2)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)))
--
2.12.0
K
K
Kei Kebreau wrote on 30 Mar 2017 16:20
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87vaqqu9qa.fsf@openmailbox.org
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (48 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> ng0 <contact.ng0@cryptolab.net> writes:
>>
>>> Kei Kebreau transcribed 1.3K bytes:
>>>> ng0 <contact.ng0@cryptolab.net> writes:
>>>>
>>>> >
>>>> > Attribution-Noncommericial… doesn't that make them a candidate for
>>>> > exclusion in systems like Guix?
>>>> >
>>>>
>>>> Considering that the songs are data files and non-executable, the
>>>> software is still free. If the sample songs turn out to be a problem, I
>>>> can attempt to remove them in a snippet.
>>>
>>> It would help if we could document this. I don't think everyone will review
>>> upstream material (FSDG and similar) for data files (music, images).
>>> I would exclude CC licensed material which says "Noncommercial", but I'm
>>> not a lawyer.
>>
>> It may also cause problems upstream as well. The software is under licenses
>> with no commerical restrictions and the sample songs are under a
>> noncommericial restriction, but they are shared in one tarball. That
>> would constitute a conflict, right?
>
> If my understanding of the FSDG is correct we cannot distribute these
> files. The FSDG says this about non-functional data:
>
> Non-functional Data
>
> Data that isn't functional, that doesn't do a practical job, is more
> of an adornment to the system's software than a part of it. Thus, we
> don't insist on the free license criteria for non-functional
> data. It can be included in a free system distribution as long as
> its license gives you permission to copy and redistribute, both for
> commercial and non-commercial purposes.
>
> In this case the commercial restriction means that we cannot distribute
> it. You can remove these files in a snippet. Could you send an updated
> patch please?
>
> --
> Ricardo
>
> GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
> https://elephly.net

A new patch has been sent.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljdFD0ACgkQ5qXuPBlG
eg03FA//fh5ngWv8rPFcB+jh8HgjWrqO8R86g6vlOtS7ysIr9qAC099akU0GVRyW
IBseeYgaCIQzlA8bwzvRJbDGpDxRl1S4uQwkI3ixBlBWcl0uuNt0/RxIZqOz2Gmd
vYjfXIaKv8+XHd1yq6QX3j5jQgX3iOvrJzRJbuK2QNSB7jhb7JFNYxte7bovUnn7
K+aVBsaq4GfQ30y/mwERQWnebEmoUt4gUfwehMYSPItp7w5xfw/+BMCJPrMzqNPa
6ZznDG9xQgwSxDwhl4WRRHn4wY8+Tb8Xn4JwUesIFr1rZ+rfZzr0Im6haMIPhzY4
tT5Bx78RYDWkbODMM7jNpxlHTAX1MQHlrCHTaoinQa0LxNzK613lOnAOagWEAxdz
nsGdU/LT6C+WZXOPSN0WzxrWTy/6GtPflA6WpUloq8z7YVaTfKrXYPknQr+liasL
12Z7nuU6Qx2l7kRTjXBubMDOSOTUcpW+nttxGf0GNO274M7jiRD7tgibxe/qeq9c
Jao7f0PEAF3+lIh3bxToXu+2ZoctQZTGsvFieY05rSl1aCy/puHh1F/J7bBw67W9
CPxHS83j81jf9glRKcSpCQIPNBPXfufU0oVfigfR1ii4aAghO+tKyGQwXL/gDj5I
sy+GYvwVnL5U52csYy6KNigUO7YmIe3CNxniErx3vpzpIEDTpv8=
=qas2
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 30 Mar 2017 16:58
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26300@debbugs.gnu.org)
87d1cy4xqn.fsf@elephly.net
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (9 lines)
> * gnu/packages/music.scm (milkytracker): Update to 1.0.0.
> [source]: Change uri; add file-name; add snippet to remove non-FSDG
> compliant data.
> [build-system]: Change from gnu-build-system to cmake-build-system.
> [arguments]: Remove #:make-flags; disable tests (which are no longer
> present).
> [inputs]: Change sdl to sdl2.
> ---

Excellent. Please push!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
K
K
Kei Kebreau wrote on 30 Mar 2017 18:02
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 26300-done@debbugs.gnu.org)
87r31eu50w.fsf@openmailbox.org
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (13 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/music.scm (milkytracker): Update to 1.0.0.
>> [source]: Change uri; add file-name; add snippet to remove non-FSDG
>> compliant data.
>> [build-system]: Change from gnu-build-system to cmake-build-system.
>> [arguments]: Remove #:make-flags; disable tests (which are no longer
>> present).
>> [inputs]: Change sdl to sdl2.
>> ---
>
> Excellent. Please push!

Pushed as e3b2e943b871b26f178cc97a16c9f0cbf595a22a. Thanks for clearing
up the licensing issue.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljdLA8ACgkQ5qXuPBlG
eg3RmxAApOCowz6S2MUZtPZHaajpuF3/9O5znnFGveF39DQctRVTNZECJ+RfFnLX
LL/VwsfwsegfltiRYjZkoTRoW8dIymgDZ1zHEbIJIJWBQn2pXL5e6IuqzJqNxEtr
zZbdGaPz7eOw3Ym6Tfz7Bag1Tut16lLjSqvVh4x1acIV2CB2yxTyh4uQZX5yMpBK
CWe/zXGsZ9xVi0gNKMbOmVKI6xJp2msMJPp1rwOhyc52hGmIH4g5Ynk4jhqEmZh9
2gwVecX8YrcsiEVE7YVDUa5Iazvss7sxuQhJSrGA1kt6O55+44wQRE+1FOQ3bVfJ
hXUgpdWhfULrQC8Qcm7Gi9fvgZ/IBEiGTYszvRYoJ8Lk71aPgiXy6PLT/Lr2VAjj
1gNlCOsy2yu8zu1SXkjIf+ABlXVjgqqMTQG7vncQIaAXSS30Tmlk41xEcse9fb2N
vkWxkJ4NIvQp2otdaTck8cRCF9Z9reYFTaGie80R0We7LQJNVgOD1pIPwykS9sca
RhexTa5Ru9EKL0JZ9DP30s+cDuHmwk5l7hQ26H5Dlo4VPFnrcBYsB4fnw4lOApHa
koq2OpwLavlIjvZSV6+pjw+bcWltRv9IM4GjQSnOp6J+hMUKkBbaIyJg3WFeQmdK
fwsvPXPdyB1eqy+lBw8hpvYxK51QgILiQlmWS//oqJDnTh3kslU=
=Rrde
-----END PGP SIGNATURE-----

Closed
?