[PATCH] gnu: Add grafx2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alex Kost
  • Thompson, David
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Thompson, David
Severity
normal

Debbugs page

Thompson, David wrote 8 years ago
(address . guix-patches@gnu.org)
CAJ=RwfapFwEVu8gytOSAHp25JqLfKccD_QVf2HfWkXV3UXCp1w@mail.gmail.com
Haven't contributed in awhile. Here's a package recipe for a cool
little pixel art editor.

- Dave
From 1a3c396908e2010938501a707badd5c098a0c41c Mon Sep 17 00:00:00 2001
From: David Thompson <dthompson2@worcester.edu>
Date: Sun, 26 Mar 2017 20:00:42 -0400
Subject: [PATCH] gnu: Add grafx2.

* gnu/packages/game-development.scm (grafx2): New variable.
---
gnu/packages/game-development.scm | 45 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 44 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6525f94..482389f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
+;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -676,3 +676,46 @@ to create fully featured games and multimedia programs in the python language.")
(define-public python2-pygame
(package-with-python2 python-pygame))
+
+(define-public grafx2
+ (package
+ (name "grafx2")
+ (version "2.4")
+ (source (origin
+ (method url-fetch)
+ ;; XXX: There is no URL that contains the version. :(
+ (uri "http://pulkomandy.tk/projects/GrafX2/downloads/21")
+ (sha256
+ (base32
+ "0svsy6rqmdj11b400c242i2ixihyz0hds0dgicqz6g6dcgmcl62q"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-before 'build 'change-to-src-directory
+ (lambda _
+ (chdir "src")
+ #t)))
+ #:make-flags
+ ;; SDL header files are referenced without the preceeding "SDL/".
+ (list (string-append "CFLAGS=-I"
+ (assoc-ref %build-inputs "sdl-union")
+ "/include/SDL")
+ (string-append "prefix="
+ (assoc-ref %outputs "out")))
+ #:tests? #f)) ; no check target
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libpng" ,libpng)
+ ("lua" ,lua-5.1)
+ ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-ttf)))))
+ (synopsis "Bitmap paint program")
+ (description "GrafX2 is a bitmap paint program inspired by the Amiga
+programs ​Deluxe Paint and Brilliance. Specializing in 256-color drawing, it
+includes a very large number of tools and effects that make it particularly
+suitable for pixel art, game graphics, and generally any detailed graphics
+painted with a mouse. ")
+ (home-page "http://pulkomandy.tk/projects/GrafX2")
+ (license license:gpl2))) ; GPLv2 only
--
2.10.0
Alex Kost wrote 8 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)(address . 26269@debbugs.gnu.org)
877f3bhz6u.fsf@gmail.com
Thompson, David (2017-03-26 20:34 -0400) wrote:

[...]
Toggle quote (6 lines)
> + (synopsis "Bitmap paint program")
> + (description "GrafX2 is a bitmap paint program inspired by the Amiga
> +programs ​Deluxe Paint and Brilliance. Specializing in 256-color drawing, it
> +includes a very large number of tools and effects that make it particularly
> +suitable for pixel art, game graphics, and generally any detailed graphics
> +painted with a mouse. ")
^
Trailing space ;-)

Toggle quote (3 lines)
> + (license license:gpl2))) ; GPLv2 only

--
Alex
Tobias Geerinckx-Rice wrote 8 years ago
(address . dthompson2@worcester.edu)(address . 26269-done@debbugs.gnu.org)
30cbb48d-c3c2-02f0-76f4-11ff1d714a14@tobias.gr
David,

Thanks!

On 27/03/17 11:00, Alex Kost wrote:
Toggle quote (12 lines)
> Thompson, David (2017-03-26 20:34 -0400) wrote:
>
> [...]
>> + (synopsis "Bitmap paint program")
>> + (description "GrafX2 is a bitmap paint program inspired by the Amiga
>> +programs ​Deluxe Paint and Brilliance. Specializing in 256-color drawing, it
>> +includes a very large number of tools and effects that make it particularly
>> +suitable for pixel art, game graphics, and generally any detailed graphics
>> +painted with a mouse. ")
> ^
> Trailing space ;-)

There was also an invisible ‘zero-width space’ before ‘Deluxe’. Exotic.

In case you, like me, are pretty new to this whole debbugs thing: you
can close bugs after pushing by e-mailing <###>-done@debbugs.gnu.org.
I'll do that now.

Kind regards,

T G-R
Attachment: signature.asc
Closed
Tobias Geerinckx-Rice wrote 8 years ago
(address . dthompson2@worcester.edu)(address . 26269-done@debbugs.gnu.org)
2a74f440-ca47-c255-120f-003888d80d04@tobias.gr
/That/ David,

On 28/03/17 01:32, Tobias Geerinckx-Rice wrote:
Toggle quote (2 lines)
> In case you, like me, are pretty new to this whole debbugs thing:

Ahem. You're probably not. Never mind :-)

Kind regards,

T G-R
Attachment: signature.asc
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26269@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26269
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help