[PATCH] gnu: rustc: Update to 1.16.0. gnu: cargo: Update to 0.17.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 24 Mar 2017 01:20
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170324002033.24810-1-dannym@scratchpost.org
* gnu/packages/rust.scm (rustc): Update to 1.16.0.
(cargo): Update to 0.17.0.
---
gnu/packages/rust.scm | 66 ++++++++++++++++++++++++++++++++++++++-------------
1 file changed, 49 insertions(+), 17 deletions(-)

Toggle diff (169 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 9a56b1ffe..aa2617a04 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -44,7 +44,7 @@
#:use-module (srfi srfi-26))
;; Should be one less than the current released version.
-(define %rust-bootstrap-binaries-version "1.14.0")
+(define %rust-bootstrap-binaries-version "1.15.0")
(define %rust-bootstrap-binaries
(origin
@@ -55,7 +55,7 @@
"-i686-unknown-linux-gnu.tar.gz"))
(sha256
(base32
- "0h384prpabcl08mxs1bilyb0dbk0knpdylcnz4b84ij4idr7ap4d"))))
+ "0wmkfx8pxmkkw021mrq9s3xhra8f0daqdl6j56pxyn4w39i0rzrw"))))
(define (increment-rust-version rust-version major patch)
(match (string-split rust-version #\.)
@@ -205,13 +205,14 @@ rustc-bootstrap and cargo-bootstrap packages.")
"rustc-" version "-src.tar.gz"))
(sha256
(base32
- "0wvn8m1nfg664b95qrdpfh72q1a6ir09rqkrnlzbkay2r7xf8mgn"))))
+ "1d78jq7mc34n265by68amr9r4nzbiqrilfbwh7gx56ydn4gb6rpr"))))
(build-system gnu-build-system)
(native-inputs
`(("cmake" ,cmake)
("git" ,git)
("python-2" ,python-2)
("rust-bootstrap" ,rust-bootstrap)
+ ("cargo-bootstrap" ,cargo-bootstrap)
("which" ,which)))
(inputs
`(("jemalloc" ,jemalloc)
@@ -226,7 +227,16 @@ rustc-bootstrap and cargo-bootstrap packages.")
(lambda _
(substitute* "configure"
(("/usr/bin/env") (which "env")) ; Detect target CPU correctly.
- (("probe_need CFG_CURL curl") "")) ; Avoid curl as a build dependency.
+ (("probe_need CFG_CURL curl") "") ; Avoid curl build dependency.
+ ;; See <https://github.com/rust-lang/rust/issues/40698>
+ (("-DLLVM_TARGETS_TO_BUILD='")
+ "-DLLVM_TARGETS_TO_BUILD='NVPTX;")) ; Make LLVM >= 3.8.1 work.
+ (substitute* "src/tools/compiletest/src/util.rs"
+ (("(\"amd64\", \"x86_64\"),") "(\"amd64\", \"x86_64\"),
+(\"nvptx\", \"nvptx\"),")) ; Make LLVM >= 3.8.1 work.
+ (substitute* "mk/main.mk"
+ (("LLVM_OPTIONAL_COMPONENTS=")
+ "LLVM_OPTIONAL_COMPONENTS=nvptx ")) ; Make LLVM >= 3.8.1 work.
#t))
(add-after 'unpack 'set-env
(lambda _
@@ -264,7 +274,8 @@ rustc-bootstrap and cargo-bootstrap packages.")
"--enable-rpath"
"--enable-local-rust"
"--disable-rustbuild" ; use Makefiles
- "--disable-manage-submodules")))
+ "--disable-manage-submodules"
+ "--enable-llvm-link-shared")))
;; Rust uses a custom configure script (no autoconf).
(zero? (apply system* "./configure" flags)))))
(add-after 'install 'wrap-rustc
@@ -297,7 +308,7 @@ safety and thread safety guarantees.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "194i06y9nql0p93gahh0vm4qwv6c1kpd9rprpf22w5gav9lpcyjz"))))
+ "1y0zy8gk1ly0wh57y78fisk7cdd92qk0x7z664f6l7lzl2krqs7w"))))
(build-system cargo-build-system)
(propagated-inputs
`(("cmake" ,cmake)
@@ -313,10 +324,10 @@ safety and thread safety guarantees.")
`(("rust-openssl"
,(origin
(method url-fetch)
- (uri (crate-uri "openssl" "0.9.1"))
+ (uri (crate-uri "openssl" "0.9.6"))
(sha256
(base32
- "1m2mhiar87qnw4gxci286q9g85ljafbc41salbj2hmcgh8aagchy"))))
+ "0g28g692gby6izp9qmnwnyxyhf9b0870yhd500p18j9l69lxl00c"))))
("rust-strsim"
,(origin
(method url-fetch)
@@ -411,17 +422,17 @@ safety and thread safety guarantees.")
("rust-libssh2-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "libssh2-sys" "0.2.4"))
+ (uri (crate-uri "libssh2-sys" "0.2.5"))
(sha256
(base32
- "1pmmh0hcx14856wg9bp740yf618qfl2765vhf67sfs5lmf39227d"))))
+ "0d2r36hrh9vc1821r0v4kywv30svpf37d31calwql69fbij3bqci"))))
("rust-libz-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "libz-sys" "1.0.10"))
+ (uri (crate-uri "libz-sys" "1.0.13"))
(sha256
(base32
- "1rl85x045sk5d345hgcahx99plpbdg2a3bx5vjfxig30qah74p4h"))))
+ "034pgvxzgsv37iafgs0lmvd1ifm0bg0zm1xcsn9x71nn8lm93vp5"))))
("rust-curl-sys"
,(origin
(method url-fetch)
@@ -429,13 +440,27 @@ safety and thread safety guarantees.")
(sha256
(base32
"0fi8kjz3f8m8vfazycs3ddm0h6j3x78hw78gwbvybx71129192i1"))))
+ ("rust-error-chain"
+ ,(origin
+ (method url-fetch)
+ (uri (crate-uri "error-chain" "0.7.2"))
+ (sha256
+ (base32
+ "03qjh6l2a9fkiyg0428p7q3dcpi47cbmrqf9zmlymkg43v3v731i"))))
+ ("rust-metadeps"
+ ,(origin
+ (method url-fetch)
+ (uri (crate-uri "metadeps" "1.1.1"))
+ (sha256
+ (base32
+ "0l818461bslb7nrs7r1amkqv45n53fcp5sabyqipwx0xxbkzz7w2"))))
("rust-openssl-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "openssl-sys" "0.9.1"))
+ (uri (crate-uri "openssl-sys" "0.9.6"))
(sha256
(base32
- "1sdhgalfm2zdqf144xhdnxdha7ifjgsfbmlrqbx0j9f3mh4gpscm"))))
+ "1hzpyf9z8xg1yn5r9g17bl5j20nifd6s2zp10xh90v7m0sd2yj5i"))))
("rust-fs2"
,(origin
(method url-fetch)
@@ -635,10 +660,10 @@ safety and thread safety guarantees.")
("rust-libgit2-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "libgit2-sys" "0.6.5"))
+ (uri (crate-uri "libgit2-sys" "0.6.6"))
(sha256
(base32
- "0yl80n12ih4jh1halpbj3zqlqvw5zxdr6m6xdcvdz67svjy50bjh"))))
+ "074h9q4p60xh6canb0sj4vrc801wqv6p53l9lp0q724bkwzf7967"))))
("rust-env_logger"
,(origin
(method url-fetch)
@@ -785,7 +810,14 @@ safety and thread safety guarantees.")
(uri (crate-uri "num-complex" "0.1.35"))
(sha256
(base32
- "0bzrjfppnnzf9vmkpklhp2dw9sb1lqzydb8r6k83z76i9l2qxizh"))))))
+ "0bzrjfppnnzf9vmkpklhp2dw9sb1lqzydb8r6k83z76i9l2qxizh"))))
+ ("rust-shell-escape"
+ ,(origin
+ (method url-fetch)
+ (uri (crate-uri "shell-escape" "0.1.3"))
+ (sha256
+ (base32
+ "1y2fp2brv639icv4a0fdqs1zhlrxq8qbz27ygfa86ifmh5jcjp6x"))))))
(arguments
`(#:cargo ,cargo-bootstrap
#:tests? #f ; FIXME
M
M
Marius Bakke wrote on 24 Mar 2017 18:15
Re: bug#26232: [PATCH] gnu: rustc: Update to 1.16.0. gnu: cargo: Update to 0.17.0.
87d1d6y4t0.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (3 lines)
> * gnu/packages/rust.scm (rustc): Update to 1.16.0.
> (cargo): Update to 0.17.0.

Do these have to be updated together? I would prefer them as separate
patches. Also, the changes to the various [arguments] and
[native-inputs] should be mentioned here.

Toggle quote (58 lines)
> ---
> gnu/packages/rust.scm | 66 ++++++++++++++++++++++++++++++++++++++-------------
> 1 file changed, 49 insertions(+), 17 deletions(-)
>
> diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
> index 9a56b1ffe..aa2617a04 100644
> --- a/gnu/packages/rust.scm
> +++ b/gnu/packages/rust.scm
> @@ -44,7 +44,7 @@
> #:use-module (srfi srfi-26))
>
> ;; Should be one less than the current released version.
> -(define %rust-bootstrap-binaries-version "1.14.0")
> +(define %rust-bootstrap-binaries-version "1.15.0")
>
> (define %rust-bootstrap-binaries
> (origin
> @@ -55,7 +55,7 @@
> "-i686-unknown-linux-gnu.tar.gz"))
> (sha256
> (base32
> - "0h384prpabcl08mxs1bilyb0dbk0knpdylcnz4b84ij4idr7ap4d"))))
> + "0wmkfx8pxmkkw021mrq9s3xhra8f0daqdl6j56pxyn4w39i0rzrw"))))
>
> (define (increment-rust-version rust-version major patch)
> (match (string-split rust-version #\.)
> @@ -205,13 +205,14 @@ rustc-bootstrap and cargo-bootstrap packages.")
> "rustc-" version "-src.tar.gz"))
> (sha256
> (base32
> - "0wvn8m1nfg664b95qrdpfh72q1a6ir09rqkrnlzbkay2r7xf8mgn"))))
> + "1d78jq7mc34n265by68amr9r4nzbiqrilfbwh7gx56ydn4gb6rpr"))))
> (build-system gnu-build-system)
> (native-inputs
> `(("cmake" ,cmake)
> ("git" ,git)
> ("python-2" ,python-2)
> ("rust-bootstrap" ,rust-bootstrap)
> + ("cargo-bootstrap" ,cargo-bootstrap)
> ("which" ,which)))
> (inputs
> `(("jemalloc" ,jemalloc)
> @@ -226,7 +227,16 @@ rustc-bootstrap and cargo-bootstrap packages.")
> (lambda _
> (substitute* "configure"
> (("/usr/bin/env") (which "env")) ; Detect target CPU correctly.
> - (("probe_need CFG_CURL curl") "")) ; Avoid curl as a build dependency.
> + (("probe_need CFG_CURL curl") "") ; Avoid curl build dependency.
> + ;; See <https://github.com/rust-lang/rust/issues/40698>
> + (("-DLLVM_TARGETS_TO_BUILD='")
> + "-DLLVM_TARGETS_TO_BUILD='NVPTX;")) ; Make LLVM >= 3.8.1 work.
> + (substitute* "src/tools/compiletest/src/util.rs"
> + (("(\"amd64\", \"x86_64\"),") "(\"amd64\", \"x86_64\"),
> +(\"nvptx\", \"nvptx\"),")) ; Make LLVM >= 3.8.1 work.
> + (substitute* "mk/main.mk"
> + (("LLVM_OPTIONAL_COMPONENTS=")
> + "LLVM_OPTIONAL_COMPONENTS=nvptx ")) ; Make LLVM >= 3.8.1 work.

Phew! I think a sentence or two above the github URL stating the problem
and mentioning that the following three substitutions resolves a flob
with the gnord would be nice here, since it's not obvious that the
substitutions have anything to do with LLVM (even with the comments).

Reading the github issue, it should probably also be mentioned that these
workarounds will be obsolete in the next release.

Toggle quote (116 lines)
> #t))
> (add-after 'unpack 'set-env
> (lambda _
> @@ -264,7 +274,8 @@ rustc-bootstrap and cargo-bootstrap packages.")
> "--enable-rpath"
> "--enable-local-rust"
> "--disable-rustbuild" ; use Makefiles
> - "--disable-manage-submodules")))
> + "--disable-manage-submodules"
> + "--enable-llvm-link-shared")))
> ;; Rust uses a custom configure script (no autoconf).
> (zero? (apply system* "./configure" flags)))))
> (add-after 'install 'wrap-rustc
> @@ -297,7 +308,7 @@ safety and thread safety guarantees.")
> (file-name (string-append name "-" version ".tar.gz"))
> (sha256
> (base32
> - "194i06y9nql0p93gahh0vm4qwv6c1kpd9rprpf22w5gav9lpcyjz"))))
> + "1y0zy8gk1ly0wh57y78fisk7cdd92qk0x7z664f6l7lzl2krqs7w"))))
> (build-system cargo-build-system)
> (propagated-inputs
> `(("cmake" ,cmake)
> @@ -313,10 +324,10 @@ safety and thread safety guarantees.")
> `(("rust-openssl"
> ,(origin
> (method url-fetch)
> - (uri (crate-uri "openssl" "0.9.1"))
> + (uri (crate-uri "openssl" "0.9.6"))
> (sha256
> (base32
> - "1m2mhiar87qnw4gxci286q9g85ljafbc41salbj2hmcgh8aagchy"))))
> + "0g28g692gby6izp9qmnwnyxyhf9b0870yhd500p18j9l69lxl00c"))))
> ("rust-strsim"
> ,(origin
> (method url-fetch)
> @@ -411,17 +422,17 @@ safety and thread safety guarantees.")
> ("rust-libssh2-sys"
> ,(origin
> (method url-fetch)
> - (uri (crate-uri "libssh2-sys" "0.2.4"))
> + (uri (crate-uri "libssh2-sys" "0.2.5"))
> (sha256
> (base32
> - "1pmmh0hcx14856wg9bp740yf618qfl2765vhf67sfs5lmf39227d"))))
> + "0d2r36hrh9vc1821r0v4kywv30svpf37d31calwql69fbij3bqci"))))
> ("rust-libz-sys"
> ,(origin
> (method url-fetch)
> - (uri (crate-uri "libz-sys" "1.0.10"))
> + (uri (crate-uri "libz-sys" "1.0.13"))
> (sha256
> (base32
> - "1rl85x045sk5d345hgcahx99plpbdg2a3bx5vjfxig30qah74p4h"))))
> + "034pgvxzgsv37iafgs0lmvd1ifm0bg0zm1xcsn9x71nn8lm93vp5"))))
> ("rust-curl-sys"
> ,(origin
> (method url-fetch)
> @@ -429,13 +440,27 @@ safety and thread safety guarantees.")
> (sha256
> (base32
> "0fi8kjz3f8m8vfazycs3ddm0h6j3x78hw78gwbvybx71129192i1"))))
> + ("rust-error-chain"
> + ,(origin
> + (method url-fetch)
> + (uri (crate-uri "error-chain" "0.7.2"))
> + (sha256
> + (base32
> + "03qjh6l2a9fkiyg0428p7q3dcpi47cbmrqf9zmlymkg43v3v731i"))))
> + ("rust-metadeps"
> + ,(origin
> + (method url-fetch)
> + (uri (crate-uri "metadeps" "1.1.1"))
> + (sha256
> + (base32
> + "0l818461bslb7nrs7r1amkqv45n53fcp5sabyqipwx0xxbkzz7w2"))))
> ("rust-openssl-sys"
> ,(origin
> (method url-fetch)
> - (uri (crate-uri "openssl-sys" "0.9.1"))
> + (uri (crate-uri "openssl-sys" "0.9.6"))
> (sha256
> (base32
> - "1sdhgalfm2zdqf144xhdnxdha7ifjgsfbmlrqbx0j9f3mh4gpscm"))))
> + "1hzpyf9z8xg1yn5r9g17bl5j20nifd6s2zp10xh90v7m0sd2yj5i"))))
> ("rust-fs2"
> ,(origin
> (method url-fetch)
> @@ -635,10 +660,10 @@ safety and thread safety guarantees.")
> ("rust-libgit2-sys"
> ,(origin
> (method url-fetch)
> - (uri (crate-uri "libgit2-sys" "0.6.5"))
> + (uri (crate-uri "libgit2-sys" "0.6.6"))
> (sha256
> (base32
> - "0yl80n12ih4jh1halpbj3zqlqvw5zxdr6m6xdcvdz67svjy50bjh"))))
> + "074h9q4p60xh6canb0sj4vrc801wqv6p53l9lp0q724bkwzf7967"))))
> ("rust-env_logger"
> ,(origin
> (method url-fetch)
> @@ -785,7 +810,14 @@ safety and thread safety guarantees.")
> (uri (crate-uri "num-complex" "0.1.35"))
> (sha256
> (base32
> - "0bzrjfppnnzf9vmkpklhp2dw9sb1lqzydb8r6k83z76i9l2qxizh"))))))
> + "0bzrjfppnnzf9vmkpklhp2dw9sb1lqzydb8r6k83z76i9l2qxizh"))))
> + ("rust-shell-escape"
> + ,(origin
> + (method url-fetch)
> + (uri (crate-uri "shell-escape" "0.1.3"))
> + (sha256
> + (base32
> + "1y2fp2brv639icv4a0fdqs1zhlrxq8qbz27ygfa86ifmh5jcjp6x"))))))
> (arguments
> `(#:cargo ,cargo-bootstrap
> #:tests? #f ; FIXME
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljVVCsACgkQoqBt8qM6
VPo9qwf/TiRNUqjq8Se/FD8SCfii/YYE/nqvwrST3jJ2uY3D+OhzPt1peNEYekb1
cFe2CvLeqCe3aRdUoGk5jlQj96+WvXmqR2kXNcnEYkDJTj1HqbX7JWEG+2LwFbmc
1Qi1eYf1WdhIJg6EX7WI7KvZvEq0zQEY4kAWzaUfrXx/OnD9YqHIN93D8nA7ngNP
EuedkJ3CvzCXdSI0trkRapri3YE9XG/67246mMHls5eePQEveiKoVhF06L2dazVJ
GN3vxMZG+F/OJ/h3/7hdlwhemTUPTUPpgmCTMOlcG8Xzt8AP8QpVhXrkB+xionyQ
4HJQMhggwMSGCO0sldil4ckw+bdkJQ==
=w2Cg
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 24 Mar 2017 21:53
[PATCH v2] gnu: rustc: Update to 1.16.0. gnu: cargo: Update to 0.17.0.
(address . 26232@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170324205314.6090-1-dannym@scratchpost.org
* gnu/packages/rust.scm (rustc): Update to 1.16.0.
patch-configure: Patch LLVM references.
(cargo): Update to 0.17.0.
[native-inputs]: Update rust-openssl to 0.9.6.
Update rust-libssh2-sys 0.2.5.
Update rust-libz-sys 1.0.13.
Add rust-error-chain 0.7.2.
Add rust-metadeps 1.1.1.
Update rust-openssl-sys 0.9.6.
Update rust-libgit2-sys to 0.6.6.
Add rust-shell-escape 0.1.3.
---
gnu/packages/rust.scm | 70 ++++++++++++++++++++++++++++++++++++++-------------
1 file changed, 53 insertions(+), 17 deletions(-)

Toggle diff (167 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 9a56b1ffe..a9710ba4d 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -44,7 +44,7 @@
#:use-module (srfi srfi-26))
;; Should be one less than the current released version.
-(define %rust-bootstrap-binaries-version "1.14.0")
+(define %rust-bootstrap-binaries-version "1.15.0")
(define %rust-bootstrap-binaries
(origin
@@ -55,7 +55,7 @@
"-i686-unknown-linux-gnu.tar.gz"))
(sha256
(base32
- "0h384prpabcl08mxs1bilyb0dbk0knpdylcnz4b84ij4idr7ap4d"))))
+ "0wmkfx8pxmkkw021mrq9s3xhra8f0daqdl6j56pxyn4w39i0rzrw"))))
(define (increment-rust-version rust-version major patch)
(match (string-split rust-version #\.)
@@ -205,7 +205,7 @@ rustc-bootstrap and cargo-bootstrap packages.")
"rustc-" version "-src.tar.gz"))
(sha256
(base32
- "0wvn8m1nfg664b95qrdpfh72q1a6ir09rqkrnlzbkay2r7xf8mgn"))))
+ "1d78jq7mc34n265by68amr9r4nzbiqrilfbwh7gx56ydn4gb6rpr"))))
(build-system gnu-build-system)
(native-inputs
`(("cmake" ,cmake)
@@ -226,7 +226,22 @@ rustc-bootstrap and cargo-bootstrap packages.")
(lambda _
(substitute* "configure"
(("/usr/bin/env") (which "env")) ; Detect target CPU correctly.
- (("probe_need CFG_CURL curl") "")) ; Avoid curl as a build dependency.
+ (("probe_need CFG_CURL curl") "") ; Avoid curl build dependency.
+ ;; Newer LLVM has a NVPTX (NVIDIA) backend which the Rust
+ ;; Makefiles don't know about, causing a linker failure
+ ;; if we don't intervene.
+ ;; Therefore, we add NVPTX here.
+ ;; See <https://github.com/rust-lang/rust/issues/40698>.
+ ;; For the next release, we will have to use rustbuild.
+ ;; Right now, rustbuild doesn't work yet.
+ (("-DLLVM_TARGETS_TO_BUILD='")
+ "-DLLVM_TARGETS_TO_BUILD='NVPTX;")) ; Make LLVM >= 3.8.1 work.
+ (substitute* "src/tools/compiletest/src/util.rs"
+ (("(\"amd64\", \"x86_64\"),") "(\"amd64\", \"x86_64\"),
+(\"nvptx\", \"nvptx\"),")) ; Make LLVM >= 3.8.1 work.
+ (substitute* "mk/main.mk"
+ (("LLVM_OPTIONAL_COMPONENTS=")
+ "LLVM_OPTIONAL_COMPONENTS=nvptx ")) ; Make LLVM >= 3.8.1 work.
#t))
(add-after 'unpack 'set-env
(lambda _
@@ -263,7 +278,7 @@ rustc-bootstrap and cargo-bootstrap packages.")
"--release-channel=stable"
"--enable-rpath"
"--enable-local-rust"
- "--disable-rustbuild" ; use Makefiles
+ "--disable-rustbuild" ; rustbuild doesn't work yet.
"--disable-manage-submodules")))
;; Rust uses a custom configure script (no autoconf).
(zero? (apply system* "./configure" flags)))))
@@ -297,7 +312,7 @@ safety and thread safety guarantees.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "194i06y9nql0p93gahh0vm4qwv6c1kpd9rprpf22w5gav9lpcyjz"))))
+ "1y0zy8gk1ly0wh57y78fisk7cdd92qk0x7z664f6l7lzl2krqs7w"))))
(build-system cargo-build-system)
(propagated-inputs
`(("cmake" ,cmake)
@@ -313,10 +328,10 @@ safety and thread safety guarantees.")
`(("rust-openssl"
,(origin
(method url-fetch)
- (uri (crate-uri "openssl" "0.9.1"))
+ (uri (crate-uri "openssl" "0.9.6"))
(sha256
(base32
- "1m2mhiar87qnw4gxci286q9g85ljafbc41salbj2hmcgh8aagchy"))))
+ "0g28g692gby6izp9qmnwnyxyhf9b0870yhd500p18j9l69lxl00c"))))
("rust-strsim"
,(origin
(method url-fetch)
@@ -411,17 +426,17 @@ safety and thread safety guarantees.")
("rust-libssh2-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "libssh2-sys" "0.2.4"))
+ (uri (crate-uri "libssh2-sys" "0.2.5"))
(sha256
(base32
- "1pmmh0hcx14856wg9bp740yf618qfl2765vhf67sfs5lmf39227d"))))
+ "0d2r36hrh9vc1821r0v4kywv30svpf37d31calwql69fbij3bqci"))))
("rust-libz-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "libz-sys" "1.0.10"))
+ (uri (crate-uri "libz-sys" "1.0.13"))
(sha256
(base32
- "1rl85x045sk5d345hgcahx99plpbdg2a3bx5vjfxig30qah74p4h"))))
+ "034pgvxzgsv37iafgs0lmvd1ifm0bg0zm1xcsn9x71nn8lm93vp5"))))
("rust-curl-sys"
,(origin
(method url-fetch)
@@ -429,13 +444,27 @@ safety and thread safety guarantees.")
(sha256
(base32
"0fi8kjz3f8m8vfazycs3ddm0h6j3x78hw78gwbvybx71129192i1"))))
+ ("rust-error-chain"
+ ,(origin
+ (method url-fetch)
+ (uri (crate-uri "error-chain" "0.7.2"))
+ (sha256
+ (base32
+ "03qjh6l2a9fkiyg0428p7q3dcpi47cbmrqf9zmlymkg43v3v731i"))))
+ ("rust-metadeps"
+ ,(origin
+ (method url-fetch)
+ (uri (crate-uri "metadeps" "1.1.1"))
+ (sha256
+ (base32
+ "0l818461bslb7nrs7r1amkqv45n53fcp5sabyqipwx0xxbkzz7w2"))))
("rust-openssl-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "openssl-sys" "0.9.1"))
+ (uri (crate-uri "openssl-sys" "0.9.6"))
(sha256
(base32
- "1sdhgalfm2zdqf144xhdnxdha7ifjgsfbmlrqbx0j9f3mh4gpscm"))))
+ "1hzpyf9z8xg1yn5r9g17bl5j20nifd6s2zp10xh90v7m0sd2yj5i"))))
("rust-fs2"
,(origin
(method url-fetch)
@@ -635,10 +664,10 @@ safety and thread safety guarantees.")
("rust-libgit2-sys"
,(origin
(method url-fetch)
- (uri (crate-uri "libgit2-sys" "0.6.5"))
+ (uri (crate-uri "libgit2-sys" "0.6.6"))
(sha256
(base32
- "0yl80n12ih4jh1halpbj3zqlqvw5zxdr6m6xdcvdz67svjy50bjh"))))
+ "074h9q4p60xh6canb0sj4vrc801wqv6p53l9lp0q724bkwzf7967"))))
("rust-env_logger"
,(origin
(method url-fetch)
@@ -785,7 +814,14 @@ safety and thread safety guarantees.")
(uri (crate-uri "num-complex" "0.1.35"))
(sha256
(base32
- "0bzrjfppnnzf9vmkpklhp2dw9sb1lqzydb8r6k83z76i9l2qxizh"))))))
+ "0bzrjfppnnzf9vmkpklhp2dw9sb1lqzydb8r6k83z76i9l2qxizh"))))
+ ("rust-shell-escape"
+ ,(origin
+ (method url-fetch)
+ (uri (crate-uri "shell-escape" "0.1.3"))
+ (sha256
+ (base32
+ "1y2fp2brv639icv4a0fdqs1zhlrxq8qbz27ygfa86ifmh5jcjp6x"))))))
(arguments
`(#:cargo ,cargo-bootstrap
#:tests? #f ; FIXME
D
D
Danny Milosavljevic wrote on 24 Mar 2017 21:57
Re: bug#26232: [PATCH] gnu: rustc: Update to 1.16.0. gnu: cargo: Update to 0.17.0.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26232@debbugs.gnu.org)
20170324215722.3f47acc3@scratchpost.org
Hi Marius,

On Fri, 24 Mar 2017 18:15:23 +0100
Marius Bakke <mbakke@fastmail.com> wrote:
Toggle quote (2 lines)
> Do these have to be updated together?

Right now yes. David chained them together using (cargo-version ...).

Until I find out how to disentangle them I'd like to update them in tandem.

A larger change will be necessary on the next Rust release anyway because of rustbuild. So I'd suggest to disentange it (slowly) then.

Toggle quote (2 lines)
>I would prefer them as separate patches.

Yeah, it just doesn't work right now.

I've posted a v2 now.
L
L
Ludovic Courtès wrote on 7 Apr 2017 23:01
Re: bug#26232: [PATCH v2] gnu: rustc: Update to 1.16.0. gnu: cargo: Update to 0.17.0.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 26232@debbugs.gnu.org)
87k26wszit.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (12 lines)
> * gnu/packages/rust.scm (rustc): Update to 1.16.0.
> patch-configure: Patch LLVM references.
> (cargo): Update to 0.17.0.
> [native-inputs]: Update rust-openssl to 0.9.6.
> Update rust-libssh2-sys 0.2.5.
> Update rust-libz-sys 1.0.13.
> Add rust-error-chain 0.7.2.
> Add rust-metadeps 1.1.1.
> Update rust-openssl-sys 0.9.6.
> Update rust-libgit2-sys to 0.6.6.
> Add rust-shell-escape 0.1.3.

LGTM, thanks!

Ludo'.
D
D
Danny Milosavljevic wrote on 10 Apr 2017 09:06
Re: [PATCH v2] gnu: rustc: Update to 1.16.0. gnu: cargo: Update to 0.17.0.
(address . 26232-done@debbugs.gnu.org)
20170410090631.2e131316@scratchpost.org
Pushed the Rust update to master as 9ea0cdaf7f60823c861868e210add3d1b3af11fd. Closing bug report.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26232@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26232
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch