[PATCH] gnu: Add deutex.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170318202448.22008-1-kei@openmailbox.org
gnu/packages/game-development.scm (deutex): New variable.
---
gnu/packages/game-development.scm | 48 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 47 insertions(+), 1 deletion(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 908ce4834..74cac0be9 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Julian Graham <joolean@gmail.com>
;;;
@@ -95,6 +95,52 @@
is used in some video games and movies.")
(license license:zlib)))
+(define-public deutex
+ (package
+ (name "deutex")
+ (version "4.4.902")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Doom-Utils/" name
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rwz1yzgd539x4h25kzhar4q02xyxjwfrcpz4m8ixi312a82p7cn"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; The provided configure script takes a restricted number of arguments.
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "./configure" "--prefix"
+ (assoc-ref %outputs "out")))))
+ ;; "make install" is broken for this package.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin"))
+ (share (string-append out "/share")))
+ (mkdir-p bin)
+ (install-file "deusf" bin)
+ (install-file "deutex" bin)
+ (install-file "deutex.6" (string-append share "/man/man6")))
+ #t)))))
+ (home-page "https://github.com/Doom-Utils/deutex")
+ (synopsis "WAD file composer for Doom and related games")
+ (description
+ "DeuTex is a wad composer for Doom, Heretic, Hexen and Strife. It can be
+used to extract the lumps of a wad and save them as individual files.
+Conversely, it can also build a wad from separate files. When extracting a
+lump to a file, it does not just copy the raw data, it converts it to an
+appropriate format (such as PPM for graphics, Sun audio for samples, etc.).
+Conversely, when it reads files for inclusion in pwads, it does the necessary
+conversions (for example, from PPM to Doom picture format). In addition,
+DeuTex has functions such as merging wads, etc.")
+ (license license:gpl2+)))
+
(define-public gzochi
(package
(name "gzochi")
--
2.12.0
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26160@debbugs.gnu.org)
20170319223922.GB26441@jasmine
On Sat, Mar 18, 2017 at 04:24:48PM -0400, Kei Kebreau wrote:
Toggle quote (4 lines)
> gnu/packages/game-development.scm (deutex): New variable.

> + ;; "make install" is broken for this package.

It's helpful to say how it's broken. That will make it easier to know
if `make install` is fixed in future versions of DeuTex.

Toggle quote (7 lines)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref %outputs "out"))
> + (bin (string-append out "/bin"))
> + (share (string-append out "/share")))
> + (mkdir-p bin)

This procedure is redundant; (install-file) will create the directory.

Otherwise, LGTM.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljPCJoACgkQJkb6MLrK
fwhs1g//XGaaN/tbQ+bgXZTxdB/DgqXdBbLW7EK/O3GQhtR90ryAUn89viPl2VLr
hYmqforbzGsW4z+oxSUcwNa3lT/5iLBXJ8I9fbyHWTN6hfq089GFDtYH8qa4roo/
DVIyDLiWwH3rFX8oDtKpOeizMEPAYfPOJQsRDeXFXw7n/z4TQg7Dx7S1Ym6LRpHq
qgycJLsGwWZsVP6Yle2eRyFinDMKKdI5yZVhzTf15DgQHG4ljDlZ60B4yBqRZdBT
N+YiuHn6qaubEL+PQMkxr3Gik1+oDcAyYRRzBpxyYLbvBC+CauAxDqcR/h2ev/7H
/Me9PSCNCkg7TDR/2SBv9ak/Nndy2Hr7KH2NpV3v5khYzj/Uxx7v1tVuhvhzIwCt
wnDkLM3fkXD6SzzKBdjtFbmGoXUbTuJ98BDpg4eb4szAxyKVoxjaekNK8bZyeiGG
s0owCdfPVWFEqQLBo2xS5T6T9ORRoZFsbGOpXqD4pf01zif7l5QnABV8HaM/v6fm
F2zulSeqEPbCZQ3gZ7vVjiM6qWKmAPr6ESS8SR6esWnjfpleSF/UavPbf85Zs1rM
B8L0wp61vU+mnitHkphEO4QXRxV8kZ8uixu54BOrtFQqfptqE9Je4u61pfZP8eYf
bzBccPIRjjnfwtLF9cTq5noj7PlVekVLLo+P4N77KHeftoJwNNA=
=0a6z
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 26160-done@debbugs.gnu.org)
878to067lz.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (9 lines)
> On Sat, Mar 18, 2017 at 04:24:48PM -0400, Kei Kebreau wrote:
>> gnu/packages/game-development.scm (deutex): New variable.
>
>> + ;; "make install" is broken for this package.
>
> It's helpful to say how it's broken. That will make it easier to know
> if `make install` is fixed in future versions of DeuTex.
>

A copy of the updated explanation:

"make install" is broken for this package.
Notably, the binaries overrwrite one another upon installation as
they are all installed to the "bin" file in the output directory,
and the manual page fails to install because the directory for the
manual page is not created.

Toggle quote (10 lines)
>> + (replace 'install
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (let* ((out (assoc-ref %outputs "out"))
>> + (bin (string-append out "/bin"))
>> + (share (string-append out "/share")))
>> + (mkdir-p bin)
>
> This procedure is redundant; (install-file) will create the directory.
>

Redundant procedure removed.

Toggle quote (2 lines)
> Otherwise, LGTM.

Pushed to master as 1a0c4437abbe3a1dd9622cc8a7926b9add74bf79. Thanks for
the review.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljPNPgACgkQ5qXuPBlG
eg2LnBAAp1fJWGKi+MUBJ10p9p2yTRUjp9HCzaACbPykr0tw32g42JSU4iOeoSEQ
KnFb0X2J6s84ORjlH0pZliAjm69gBRTPGnJ6B3c78K6SqNsVxdnnKqN2LNniCNZc
Z0aXqIjge+XTBvyxOnNkwdzH7wSiGZI5o6rzP4rgHQCRRMhXVslKyfwdFvrQhfh/
77W1/bo6G70ref82Qyj4gZKSN++JbHES72QwyD6eEND0p85xnLD3wV9OwjMWl546
l6kudt0Ib5uK5t5MIv8+0+HVE+JQYaWmtSByURBya3QuVI2YOv5l+D1asoaAwr/y
3Y1opclx036J/8x5yOgl0f4IrhBEue+cjytUVw4fksU+8/C3pcpT/7/JqD9f6kIy
mD5V+L9MoxsQfcbhDDuJlxJbiWQOlNMAYrZ1clPMhcEFmO4POUe0yEpqrd/5ipgK
3u/WyRQlQKq3GEfIPIkO3F0x55p0lmZ2miAsq/V1O/UA5VT48t+QrTE6gpIoBBc6
DmZccNG9nypDEdIblQzIy9VcR78pi5apBx6Ugse8obMbT7cyh3vl7slzY8YCJgHD
JPQy8JQKp+zud7+07tGjqwMs8p4zChCSOb00DGjgWSHnNjdFroJjd2avZuoUSnx6
4HUyQ+9JY+gY0PLyNBgj7g/DsLKvHKYrP9JybR42WNlVLJleAoc=
=9sW3
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26160@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26160
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help