[PATCH] gnu: Adjust asciidoc-related build options.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170318201321.20566-1-kei@openmailbox.org
Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and
3078821d1380c26c738be6b5d430c595327d401f make many package inputs and
build configurations related to asciidoc obsolete.

* gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml,
libxml2 and libxslt.
* gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt.
* gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml.
(perf)[inputs]: Remove docbook-xml and libxslt.
* gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt.
* gnu/packages/version-control.scm (cgit)[native-inputs]: Remove
docbook-xml, docbook-xsl, libxml2 and libxslt.
(cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl,
libxml2 and libxslt.
* gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml,
docbook-xsl, libxml2, and libxslt.
(tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and
libxslt.
* gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag.
(i3-wm)[inputs]: Remove docbook-xml.
[native-inputs]: Add libxml2.
---
gnu/packages/compton.scm | 3 ---
gnu/packages/linux.scm | 3 ---
gnu/packages/mail.scm | 3 +--
gnu/packages/text-editors.scm | 1 -
gnu/packages/version-control.scm | 10 +---------
gnu/packages/web.scm | 12 ++----------
gnu/packages/wm.scm | 28 +++++++---------------------
7 files changed, 11 insertions(+), 49 deletions(-)

Toggle diff (183 lines)
diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
index a0a644db7..323807091 100644
--- a/gnu/packages/compton.scm
+++ b/gnu/packages/compton.scm
@@ -50,7 +50,6 @@
(build-system gnu-build-system)
(inputs
`(("dbus" ,dbus)
- ("docbook-xml" ,docbook-xml)
("libconfig" ,libconfig)
("libx11" ,libx11)
("libxcomposite" ,libxcomposite)
@@ -58,10 +57,8 @@
("libxext" ,libxext)
("libxfixes" ,libxfixes)
("libxinerama" ,libxinerama)
- ("libxml2" ,libxml2)
("libxrandr" ,libxrandr)
("libxrender" ,libxrender)
- ("libxslt" ,libxslt)
("mesa" ,mesa)
("xprop" ,xprop)
("xwininfo" ,xwininfo)))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c7225dac3..4d7231986 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2224,8 +2224,6 @@ in a digital read-out.")
;; Documentation.
("libxml2" ,libxml2) ;for $XML_CATALOG_FILES
- ("libxslt" ,libxslt)
- ("docbook-xml" ,docbook-xml)
("docbook-xsl" ,docbook-xsl)
("xmlto" ,xmlto)
("asciidoc" ,asciidoc)))
@@ -2803,7 +2801,6 @@ and copy/paste text in the console and in xterm.")
("xmlto" ,xmlto)
;; For building documentation.
("libxml2" ,libxml2)
- ("docbook-xml" ,docbook-xml)
("docbook-xsl" ,docbook-xsl)
;; For tests.
("which" ,which)))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3bf0e6647..322b7e7f9 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -423,8 +423,7 @@ and corrections. It is based on a Bayesian filter.")
"0i5dvygps1ai2qwgamab8kngrp0c5m3bgaw0jk34l8ypsk54wj8r"))))
(build-system python-build-system)
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("libxslt" ,libxslt))) ; for xsltproc
+ `(("asciidoc" ,asciidoc)))
(inputs `(("python2-pysqlite" ,python2-pysqlite)
("python2-six" ,python2-six)))
(arguments
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 4b6aa07ee..a093baa3b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -137,7 +137,6 @@ based command language.")
;; without them the tests fail.
(zero? (system* "chmod" "-R" "u+w" "../test")))))))
(native-inputs `(("gcc" ,gcc-5)
- ("libxslt" ,libxslt)
("asciidoc" ,asciidoc)
("ruby" ,ruby)))
(inputs `(("gcc:lib" ,gcc-5 "lib")
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 1076c1890..4abd28db8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -450,11 +450,7 @@ to lock down your entire repository.")
#t)))))))
(native-inputs
;; For building manpage.
- `(("asciidoc" ,asciidoc)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("xmllint" ,libxml2)
- ("xsltprot" ,libxslt)))
+ `(("asciidoc" ,asciidoc)))
(inputs
`(("git:src" ,(package-source git@2.9))
("openssl" ,openssl)
@@ -856,10 +852,6 @@ RCS, PRCS, and Aegis packages.")
(list "CC=gcc" (string-append "prefix?=" (assoc-ref %outputs "out")))))
(inputs `(("git" ,git)))
(native-inputs `(("asciidoc" ,asciidoc)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("xmllint" ,libxml2)
- ("xsltproc" ,libxslt)
;; These are needed for the tests.
("cvs" ,cvs)
("python" ,python-2)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a0e76d52c..7fb94005e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -626,11 +626,7 @@ used to validate and fix HTML data.")
%standard-phases)))
;; All of the below are used to generate the documentation
;; (Should they be propagated inputs of asciidoc ??)
- (native-inputs `(("asciidoc" ,asciidoc)
- ("libxml2" ,libxml2)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("libxslt" ,libxslt)))
+ (native-inputs `(("asciidoc" ,asciidoc)))
(home-page "https://tinyproxy.github.io/")
(synopsis "Light-weight HTTP/HTTPS proxy daemon")
(description "Tinyproxy is a light-weight HTTP/HTTPS proxy
@@ -4479,11 +4475,7 @@ exploit attempts.")
"0pf91nc0xcykahc3x7ww525c9czm8zpg80nxl8n2mrzc4ilgvass"))))
(build-system python-build-system)
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml)
- ("libxml2" ,libxml2) ;for xmllint
- ("libxslt" ,libxslt))) ;for xsltproc
+ `(("asciidoc" ,asciidoc)))
(inputs
`(("python-colorama" ,python-colorama)
("python-cssutils" ,python-cssutils)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7d76a2d20..b95f2e7a6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -177,26 +177,12 @@ commands would.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (let* ((docbook-xsl-name-version ,(string-append
- (package-name docbook-xsl) "-"
- (package-version docbook-xsl)))
- (docbook-xsl-catalog-file (string-append
- (assoc-ref %build-inputs "docbook-xsl")
- "/xml/xsl/"
- docbook-xsl-name-version
- "/catalog.xml"))
- (docbook-xml-catalog-file (string-append
- (assoc-ref %build-inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml")))
- ;; Reference the catalog files required to build the manpages.
- (list (string-append "XML_CATALOG_FILES=" docbook-xsl-catalog-file " "
- docbook-xml-catalog-file)
- "CC=gcc"
- (string-append "PREFIX=" %output)
- ;; This works around the following error:
- ;; 'error: ‘for’ loop initial declarations are only allowed in C99
- ;; or C11 mode'
- "CFLAGS=-std=c11"))
+ (list "CC=gcc"
+ (string-append "PREFIX=" %output)
+ ;; This works around the following error:
+ ;; 'error: ‘for’ loop initial declarations are only allowed in C99
+ ;; or C11 mode'
+ "CFLAGS=-std=c11")
;; The build system tries to build in a separate directory, but that
;; seems to be unnecessary.
#:configure-flags '("--disable-builddir")
@@ -215,7 +201,6 @@ commands would.")
("asciidoc" ,asciidoc)
("xmlto" ,xmlto)
("perl-pod-simple" ,perl-pod-simple)
- ("docbook-xml" ,docbook-xml)
("libx11" ,libx11)
("pcre" ,pcre)
("startup-notification" ,startup-notification)
@@ -226,6 +211,7 @@ commands would.")
("perl" ,perl)
("pkg-config" ,pkg-config)
;; For building the documentation.
+ ("libxml2" ,libxml2)
("docbook-xsl" ,docbook-xsl)))
(home-page "https://i3wm.org/")
(synopsis "Improved tiling window manager")
--
2.12.0
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26159@debbugs.gnu.org)
87efxq1zi0.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (30 lines)
> Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and
> 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and
> build configurations related to asciidoc obsolete.
>
> * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml,
> libxml2 and libxslt.
> * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt.
> * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml.
> (perf)[inputs]: Remove docbook-xml and libxslt.
> * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt.
> * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove
> docbook-xml, docbook-xsl, libxml2 and libxslt.
> (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl,
> libxml2 and libxslt.
> * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml,
> docbook-xsl, libxml2, and libxslt.
> (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and
> libxslt.
> * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag.
> (i3-wm)[inputs]: Remove docbook-xml.
> [native-inputs]: Add libxml2.
> ---
> gnu/packages/compton.scm | 3 ---
> gnu/packages/linux.scm | 3 ---
> gnu/packages/mail.scm | 3 +--
> gnu/packages/text-editors.scm | 1 -
> gnu/packages/version-control.scm | 10 +---------
> gnu/packages/web.scm | 12 ++----------
> gnu/packages/wm.scm | 28 +++++++---------------------
> 7 files changed, 11 insertions(+), 49 deletions(-)
^^^^^^^^^^^^
I like these stats. :-)

Please go ahead if you’ve confirmed that these packages still build and
that this is not a mass-rebuild per ‘guix refresh -l’ (at first sight
it’s not a mass rebuild).

Thanks!

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26159@debbugs.gnu.org)
87mvce4pkl.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (40 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and
>> 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and
>> build configurations related to asciidoc obsolete.
>>
>> * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml,
>> libxml2 and libxslt.
>> * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt.
>> * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml.
>> (perf)[inputs]: Remove docbook-xml and libxslt.
>> * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt.
>> * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove
>> docbook-xml, docbook-xsl, libxml2 and libxslt.
>> (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl,
>> libxml2 and libxslt.
>> * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml,
>> docbook-xsl, libxml2, and libxslt.
>> (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and
>> libxslt.
>> * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag.
>> (i3-wm)[inputs]: Remove docbook-xml.
>> [native-inputs]: Add libxml2.
>> ---
>> gnu/packages/compton.scm | 3 ---
>> gnu/packages/linux.scm | 3 ---
>> gnu/packages/mail.scm | 3 +--
>> gnu/packages/text-editors.scm | 1 -
>> gnu/packages/version-control.scm | 10 +---------
>> gnu/packages/web.scm | 12 ++----------
>> gnu/packages/wm.scm | 28 +++++++---------------------
>> 7 files changed, 11 insertions(+), 49 deletions(-)
> ^^^^^^^^^^^^
> I like these stats. :-)
>
> Please go ahead if you’ve confirmed that these packages still build and
> that this is not a mass-rebuild per ‘guix refresh -l’ (at first sight
> it’s not a mass rebuild).
>

No mass-rebuilds here! Pushed to master as
4b0e63670119971864289d67fc1e11a438f58ea6.

Toggle quote (4 lines)
> Thanks!
>
> Ludo’.

My pleasure. :-)
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljRRosACgkQ5qXuPBlG
eg08eRAAu4+xihO2PgZjvfkSY0NbmyyzurVJeBy1NTSYKqZEVyEVx3s2bEbU0mzU
Wy66C+e7fe9OPpFYU/fHJmgWJQjWyw53JBfb74Y9/5vexhQ5dNne7x2NTMNXEyct
jCv2pkF0NgxmTteqpFrgIUR6cRqltQxYkOJcpbEL2bvHdISPkncEzQ3m525yLAJM
QHbrN5LwUaa6ecOgDrwLTZfXgT752Bi+zo/lNnF1J942X0FihxxMB+3ifRLery4A
yAVwHwS+Wx0wQwdcZ8Komic/Y6j4poNCOB6/dQ6d2x4o+lzBJjX21ysl23q2xFdw
Mc5MMVi+u7f+6KYsbxMrAltJnyBzjX0Fuj67FwWQcAsjeBKMaaFHAFkRdxZRxYhZ
wCGJrgctCVwUkRKzSyDBIK9/DhgYyuGYlvpmZa7tnY7rvDA+gPIsvjhlF7qQtFgw
6a4wtZiCryQXVyz6Ss/wF87uOH7AJ5nQISrKa5ad5wKXvNMcTc22YXQP6Rh0VBzT
JPyPaRlTXQromzfCQGwd82EMxI+rkcU/t6PbtqG6HtwfpcgjoMKxCS9DPnHlKygs
GXmuVbrtwz8DXkQzHD7miLv+HqYhelNdsTpvNwQ+wf+9fsCOtyQaHOpRdQZrSWTL
GwQ1etWmMvj4ulxO3Qy2/HFfLwGDoGeZcIiW3Mg6xWbreYoruU4=
=G4mO
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(address . 26159-done@debbugs.gnu.org)
87k27i4pjb.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (213 lines)
> Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and
> 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and
> build configurations related to asciidoc obsolete.
>
> * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml,
> libxml2 and libxslt.
> * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt.
> * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml.
> (perf)[inputs]: Remove docbook-xml and libxslt.
> * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt.
> * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove
> docbook-xml, docbook-xsl, libxml2 and libxslt.
> (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl,
> libxml2 and libxslt.
> * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml,
> docbook-xsl, libxml2, and libxslt.
> (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and
> libxslt.
> * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag.
> (i3-wm)[inputs]: Remove docbook-xml.
> [native-inputs]: Add libxml2.
> ---
> gnu/packages/compton.scm | 3 ---
> gnu/packages/linux.scm | 3 ---
> gnu/packages/mail.scm | 3 +--
> gnu/packages/text-editors.scm | 1 -
> gnu/packages/version-control.scm | 10 +---------
> gnu/packages/web.scm | 12 ++----------
> gnu/packages/wm.scm | 28 +++++++---------------------
> 7 files changed, 11 insertions(+), 49 deletions(-)
>
> diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
> index a0a644db7..323807091 100644
> --- a/gnu/packages/compton.scm
> +++ b/gnu/packages/compton.scm
> @@ -50,7 +50,6 @@
> (build-system gnu-build-system)
> (inputs
> `(("dbus" ,dbus)
> - ("docbook-xml" ,docbook-xml)
> ("libconfig" ,libconfig)
> ("libx11" ,libx11)
> ("libxcomposite" ,libxcomposite)
> @@ -58,10 +57,8 @@
> ("libxext" ,libxext)
> ("libxfixes" ,libxfixes)
> ("libxinerama" ,libxinerama)
> - ("libxml2" ,libxml2)
> ("libxrandr" ,libxrandr)
> ("libxrender" ,libxrender)
> - ("libxslt" ,libxslt)
> ("mesa" ,mesa)
> ("xprop" ,xprop)
> ("xwininfo" ,xwininfo)))
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index c7225dac3..4d7231986 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -2224,8 +2224,6 @@ in a digital read-out.")
>
> ;; Documentation.
> ("libxml2" ,libxml2) ;for $XML_CATALOG_FILES
> - ("libxslt" ,libxslt)
> - ("docbook-xml" ,docbook-xml)
> ("docbook-xsl" ,docbook-xsl)
> ("xmlto" ,xmlto)
> ("asciidoc" ,asciidoc)))
> @@ -2803,7 +2801,6 @@ and copy/paste text in the console and in xterm.")
> ("xmlto" ,xmlto)
> ;; For building documentation.
> ("libxml2" ,libxml2)
> - ("docbook-xml" ,docbook-xml)
> ("docbook-xsl" ,docbook-xsl)
> ;; For tests.
> ("which" ,which)))
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index 3bf0e6647..322b7e7f9 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -423,8 +423,7 @@ and corrections. It is based on a Bayesian filter.")
> "0i5dvygps1ai2qwgamab8kngrp0c5m3bgaw0jk34l8ypsk54wj8r"))))
> (build-system python-build-system)
> (native-inputs
> - `(("asciidoc" ,asciidoc)
> - ("libxslt" ,libxslt))) ; for xsltproc
> + `(("asciidoc" ,asciidoc)))
> (inputs `(("python2-pysqlite" ,python2-pysqlite)
> ("python2-six" ,python2-six)))
> (arguments
> diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
> index 4b6aa07ee..a093baa3b 100644
> --- a/gnu/packages/text-editors.scm
> +++ b/gnu/packages/text-editors.scm
> @@ -137,7 +137,6 @@ based command language.")
> ;; without them the tests fail.
> (zero? (system* "chmod" "-R" "u+w" "../test")))))))
> (native-inputs `(("gcc" ,gcc-5)
> - ("libxslt" ,libxslt)
> ("asciidoc" ,asciidoc)
> ("ruby" ,ruby)))
> (inputs `(("gcc:lib" ,gcc-5 "lib")
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index 1076c1890..4abd28db8 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -450,11 +450,7 @@ to lock down your entire repository.")
> #t)))))))
> (native-inputs
> ;; For building manpage.
> - `(("asciidoc" ,asciidoc)
> - ("docbook-xml" ,docbook-xml)
> - ("docbook-xsl" ,docbook-xsl)
> - ("xmllint" ,libxml2)
> - ("xsltprot" ,libxslt)))
> + `(("asciidoc" ,asciidoc)))
> (inputs
> `(("git:src" ,(package-source git@2.9))
> ("openssl" ,openssl)
> @@ -856,10 +852,6 @@ RCS, PRCS, and Aegis packages.")
> (list "CC=gcc" (string-append "prefix?=" (assoc-ref %outputs "out")))))
> (inputs `(("git" ,git)))
> (native-inputs `(("asciidoc" ,asciidoc)
> - ("docbook-xml" ,docbook-xml)
> - ("docbook-xsl" ,docbook-xsl)
> - ("xmllint" ,libxml2)
> - ("xsltproc" ,libxslt)
> ;; These are needed for the tests.
> ("cvs" ,cvs)
> ("python" ,python-2)
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index a0e76d52c..7fb94005e 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -626,11 +626,7 @@ used to validate and fix HTML data.")
> %standard-phases)))
> ;; All of the below are used to generate the documentation
> ;; (Should they be propagated inputs of asciidoc ??)
> - (native-inputs `(("asciidoc" ,asciidoc)
> - ("libxml2" ,libxml2)
> - ("docbook-xml" ,docbook-xml)
> - ("docbook-xsl" ,docbook-xsl)
> - ("libxslt" ,libxslt)))
> + (native-inputs `(("asciidoc" ,asciidoc)))
> (home-page "https://tinyproxy.github.io/")
> (synopsis "Light-weight HTTP/HTTPS proxy daemon")
> (description "Tinyproxy is a light-weight HTTP/HTTPS proxy
> @@ -4479,11 +4475,7 @@ exploit attempts.")
> "0pf91nc0xcykahc3x7ww525c9czm8zpg80nxl8n2mrzc4ilgvass"))))
> (build-system python-build-system)
> (native-inputs
> - `(("asciidoc" ,asciidoc)
> - ("docbook-xsl" ,docbook-xsl)
> - ("docbook-xml" ,docbook-xml)
> - ("libxml2" ,libxml2) ;for xmllint
> - ("libxslt" ,libxslt))) ;for xsltproc
> + `(("asciidoc" ,asciidoc)))
> (inputs
> `(("python-colorama" ,python-colorama)
> ("python-cssutils" ,python-cssutils)
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 7d76a2d20..b95f2e7a6 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -177,26 +177,12 @@ commands would.")
> (build-system gnu-build-system)
> (arguments
> `(#:make-flags
> - (let* ((docbook-xsl-name-version ,(string-append
> - (package-name docbook-xsl) "-"
> - (package-version docbook-xsl)))
> - (docbook-xsl-catalog-file (string-append
> - (assoc-ref %build-inputs "docbook-xsl")
> - "/xml/xsl/"
> - docbook-xsl-name-version
> - "/catalog.xml"))
> - (docbook-xml-catalog-file (string-append
> - (assoc-ref %build-inputs "docbook-xml")
> - "/xml/dtd/docbook/catalog.xml")))
> - ;; Reference the catalog files required to build the manpages.
> - (list (string-append "XML_CATALOG_FILES=" docbook-xsl-catalog-file " "
> - docbook-xml-catalog-file)
> - "CC=gcc"
> - (string-append "PREFIX=" %output)
> - ;; This works around the following error:
> - ;; 'error: ‘for’ loop initial declarations are only allowed in C99
> - ;; or C11 mode'
> - "CFLAGS=-std=c11"))
> + (list "CC=gcc"
> + (string-append "PREFIX=" %output)
> + ;; This works around the following error:
> + ;; 'error: ‘for’ loop initial declarations are only allowed in C99
> + ;; or C11 mode'
> + "CFLAGS=-std=c11")
> ;; The build system tries to build in a separate directory, but that
> ;; seems to be unnecessary.
> #:configure-flags '("--disable-builddir")
> @@ -215,7 +201,6 @@ commands would.")
> ("asciidoc" ,asciidoc)
> ("xmlto" ,xmlto)
> ("perl-pod-simple" ,perl-pod-simple)
> - ("docbook-xml" ,docbook-xml)
> ("libx11" ,libx11)
> ("pcre" ,pcre)
> ("startup-notification" ,startup-notification)
> @@ -226,6 +211,7 @@ commands would.")
> ("perl" ,perl)
> ("pkg-config" ,pkg-config)
> ;; For building the documentation.
> + ("libxml2" ,libxml2)
> ("docbook-xsl" ,docbook-xsl)))
> (home-page "https://i3wm.org/")
> (synopsis "Improved tiling window manager")

Patch was pushed to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljRRrgACgkQ5qXuPBlG
eg0aPA//VqUUSuN4EHzT5vslRM/Oecg/gTuBxmSntvvHMn/tr6GLI5xfPnZ9kUul
QEZ1NK9epk0MSzqhTE1Eravka4pGwRtsQD77WfARltNeW0UGeUkRvgidBB1srbFU
Ukp4RJCcg+9Ha4HSU29LpERD8DdI7eGd2PADXkT/NoZTPjUDOjURHeNI3q6S4/ci
ilIkiCPHzfkTjeRa1LUf1i8CR0PD79AJDsCNKL3wpwhq4rHNqTfo3QsLfYHTKY7w
VzpyumN29TE5ku3HY3dGProCwHK+m1Kfh644g4OT9hFw/E7QPeqwcqoRuWt55wbm
JAugqPd5xkeGxZI4UrRJWaKXYgVmcbBhhHDWiDvKFq3HtPGiI//BfaWUbNgl1frO
yUz73Zoc8ei3Ig7XACUgBQEXKR7vjjAIn739K0Wo1l/D5Gpt4FsOre8c74dcFdMx
8GSZwiXf4288NHoAN4C3uN9gwb6ve56BAssWy6L5gmypnyGqryCAPkX3eCv5IDj7
yLtHHRQEqubcTDd0JMTKGyY1uVi94PoWO0ptYXpACK8WUUetGhHnpnHRNVOEAIaV
hH+jWNer6QLGONfTnJTI1nXx794SwDmlMsw6HieZsF5USWa9Iw7WxLG8WDIyHDg+
i073NmMX4R2l+wIXhI3Yjbw2aNwbO7RI1FagVDqVS1mgj0fpcJc=
=71zb
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26159@debbugs.gnu.org)
87bmsuy5pi.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (45 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Kei Kebreau <kei@openmailbox.org> skribis:
>>
>>> Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and
>>> 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and
>>> build configurations related to asciidoc obsolete.
>>>
>>> * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml,
>>> libxml2 and libxslt.
>>> * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt.
>>> * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml.
>>> (perf)[inputs]: Remove docbook-xml and libxslt.
>>> * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt.
>>> * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove
>>> docbook-xml, docbook-xsl, libxml2 and libxslt.
>>> (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl,
>>> libxml2 and libxslt.
>>> * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml,
>>> docbook-xsl, libxml2, and libxslt.
>>> (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and
>>> libxslt.
>>> * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag.
>>> (i3-wm)[inputs]: Remove docbook-xml.
>>> [native-inputs]: Add libxml2.
>>> ---
>>> gnu/packages/compton.scm | 3 ---
>>> gnu/packages/linux.scm | 3 ---
>>> gnu/packages/mail.scm | 3 +--
>>> gnu/packages/text-editors.scm | 1 -
>>> gnu/packages/version-control.scm | 10 +---------
>>> gnu/packages/web.scm | 12 ++----------
>>> gnu/packages/wm.scm | 28 +++++++---------------------
>>> 7 files changed, 11 insertions(+), 49 deletions(-)
>> ^^^^^^^^^^^^
>> I like these stats. :-)
>>
>> Please go ahead if you’ve confirmed that these packages still build and
>> that this is not a mass-rebuild per ‘guix refresh -l’ (at first sight
>> it’s not a mass rebuild).
>>
>
> No mass-rebuilds here! Pushed to master as
> 4b0e63670119971864289d67fc1e11a438f58ea6.

Awesome, thank you!

Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26159@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26159
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help