Packaging megaglest ( games! :-) )

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Leo Famulari
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 18 Mar 2017 16:49
(address . guix-patches@gnu.org)
eb1ded2c.AEAAIKg09kgAAAAAAAAAAAOtUOAAAAACwQwAAAAAAAW9WABYzVcq@mailjet.com
I've packaged megaglest. Will send patches soon...
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAljNVxYACgkQLiXui2GA
K7P6Bgf5ASxmJaVqmcGEUd6IS5MI1gxTeMI5y/kYs7vZ9hut1d3Og9gGtRnVFSYS
VbNzbZcUOP3bA8jLK6HQbxWhxNoSx2cdzvK1rAglzpdi8spL7uiJ0lfon8Zt4plj
aJWxUGLoigoE8ZkEK+lKbkQQ2wUMwqpnpJWLISXGeX/mky2ubRo7nCPumTOhKu5y
Fz3XAmVZYj6hbIpYBW9ipf4DvhuHs4bap8bv9ymawMoEZeq3f1IzYPV/3jR/VZ8J
XiefmSYrC377VDwdnEX+telrz3C1GVjUd4Lws+Db9hCrHYK7G5Bz9pbdQHrsy+WU
WuzFB+qxNWyudaveDx9Ov/EJedzbAQ==
=Ifdw
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 18 Mar 2017 17:07
[PATCH 1/3] gnu: Add libircclient.
(address . 26154@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
373bb079.AEAAIKhg8YEAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABYzVtd@mailjet.com
* gnu/packages/messaging.scm (libircclient): New variable.
---
gnu/packages/messaging.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7aa7b7bfe..6bf477edc 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1329,4 +1330,39 @@ using ncurses and libmesode, inspired by Irssi.")
(home-page "http://www.profanity.im")
(license license:gpl3+)))
+(define-public libircclient
+ (package
+ (name "libircclient")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceforge.net/projects/libircclient/files/libircclient/1.9/libircclient-"
+ version ".tar.gz/download"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r60i76jh4drjh2jgp5sx71chagqllmkaq49zv67nrhqwvp9ghw1"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("openssl" ,openssl)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--libdir="
+ (assoc-ref %outputs "out") "/lib")
+ "--enable-shared"
+ "--enable-ipv6"
+ "--enable-openssl")
+ ;; no test suite
+ #:tests? #f))
+ (home-page "https://www.ulduzsoft.com/libircclient/")
+ (synopsis "Library implementing the client IRC protocol")
+ (description "Libircclient is a small but extremely powerful
+library which implements the client IRC protocol. It is designed to
+be small, fast, portable and compatible with the RFC standards as well
+as non-standard but popular features. It is perfect for building the
+IRC clients and bots.")
+ (license license:lgpl3+)))
+
;;; messaging.scm ends here
--
2.11.0
A
A
Arun Isaac wrote on 18 Mar 2017 17:07
[PATCH 2/3] gnu: Add megaglest-data.
(address . 26154@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
ea99ba00.AEEAIl8BoK4AAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABYzVtd@mailjet.com
* gnu/packages/games.scm (megaglest-data): New variable.
---
gnu/packages/games.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f264ef206..be14259c6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3267,3 +3268,30 @@ This command works on piped data. Pipe any ASCII or UTF-8 text to nms, and
it will apply the hollywood effect, initially showing encrypted data, then
starting a decryption sequence to reveal the original plaintext characters.")
(license license:expat)))
+
+(define-public megaglest-data
+ (package
+ (name "megaglest-data")
+ (version "3.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/MegaGlest/megaglest-data/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pif2n0py86kw2z3c7jlhlvf34cl6plscxnaddi2r3p7x80mcxwr"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://megaglest.org/")
+ (synopsis "3D real-time strategy (RTS) game (data files)")
+ (description "MegaGlest is an entertaining free and open source
+cross-platform 3D real-time strategy (RTS) game, where you control the
+armies of one of seven different factions: Tech, Magic, Egypt,
+Indians, Norsemen, Persian or Romans.
+
+This package contains the data files required for the game.")
+ (license license:cc-by-sa3.0)))
--
2.11.0
A
A
Arun Isaac wrote on 18 Mar 2017 17:07
[PATCH 3/3] gnu: Add megaglest.
(address . 26154@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
e9bd8476.AEAAIKhg8aEAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABYzVte@mailjet.com
* gnu/packages/games.scm (megaglest): New variable.
---
gnu/packages/games.scm | 60 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index be14259c6..c297d76f9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -108,6 +108,9 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages pcre)
#:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages messaging)
+ #:use-module (gnu packages upnp)
+ #:use-module (gnu packages wxwidgets)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
@@ -3295,3 +3298,60 @@ Indians, Norsemen, Persian or Romans.
This package contains the data files required for the game.")
(license license:cc-by-sa3.0)))
+
+(define-public megaglest
+ (package
+ (name "megaglest")
+ (version "3.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/MegaGlest/megaglest-source/releases/download/3.13.0/megaglest-source-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1ffck3ii1wp5k3nn5p0ga06jgp7pzk4zw0xln3xim2w7qrxzdzh9"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("freetype" ,freetype)
+ ("ftgl" ,ftgl)
+ ("glew" ,glew)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("megaglest-data" ,megaglest-data)
+ ("mesa" ,mesa)
+ ("miniupnpc" ,miniupnpc)
+ ("openal" ,openal)
+ ("libircclient" ,libircclient)
+ ("libpng" ,libpng)
+ ("libvorbis" ,libvorbis)
+ ("libxml2" ,libxml2)
+ ("lua" ,lua)
+ ("sdl2" ,sdl2)
+ ("wxwidgets" ,wxwidgets)))
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCUSTOM_DATA_INSTALL_PATH="
+ (assoc-ref %build-inputs "megaglest-data")
+ "/share/megaglest")
+ "-DBUILD_MEGAGLEST_TESTS=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-ini-search-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "source/glest_game/global/config.cpp"
+ (("/usr/share/megaglest/")
+ (string-append (assoc-ref outputs "out")
+ "/share/megaglest/"))))))
+ #:test-target "megaglest_tests"))
+ (home-page "https://megaglest.org/")
+ (synopsis "3D real-time strategy (RTS) game")
+ (description "MegaGlest is an entertaining free and open source
+cross-platform 3D real-time strategy (RTS) game, where you control the
+armies of one of seven different factions: Tech, Magic, Egypt,
+Indians, Norsemen, Persian or Romans.")
+ (license license:gpl2+)))
--
2.11.0
L
L
Leo Famulari wrote on 20 Mar 2017 00:20
Re: bug#26154: [PATCH 1/3] gnu: Add libircclient.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26154@debbugs.gnu.org)
20170319232039.GC26441@jasmine
On Sat, Mar 18, 2017 at 09:37:37PM +0530, Arun Isaac wrote:
Toggle quote (2 lines)
> * gnu/packages/messaging.scm (libircclient): New variable.

Thanks!

I pushed as 6fdbd86d0fcda40967e713c4226d19cee991bcd9 with the following
changes:

Toggle quote (5 lines)
> + (uri (string-append
> + "https://sourceforge.net/projects/libircclient/files/libircclient/1.9/libircclient-"
> + version ".tar.gz/download"))
> + (file-name (string-append name "-" version ".tar.gz"))

I made it use our sourceforge "mirror" URL, which made it possible to
drop (file-name).

Toggle quote (6 lines)
> + (description "Libircclient is a small but extremely powerful
> +library which implements the client IRC protocol. It is designed to
> +be small, fast, portable and compatible with the RFC standards as well
> +as non-standard but popular features. It is perfect for building the
> +IRC clients and bots.")

I edited the synopsis to remove "marketing" language like "small but
extremely powerful" and "perfect for building...".

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljPEkcACgkQJkb6MLrK
fwgP9w//RgI/k+Ln6n7HcmiVaftTAkV2aDCCYDMuyF8RZRSWFcklDfizeo2/VTiw
qQvGe9RlO87yeK9cwIaHzF2kX0DaspG4n9ztrQvDBRnxamLkPYgiNu+FmitoZC63
9mLJXuh6Lc+llkDYaJ8drMydLbfbr5WuVXJ7dgSaZnjsGqf+TI3mQqA8CxXHxvWm
k8J5Xvs0E8Veljlv1k44GF2m+d2+Bicc2oDIzVHef83yRKiLYCP5FxSM48CDMPcb
0wNuV3fDmWeLUs/k/jlFPnEGjrlSCQIusI2duI89TJTQeNGMiG+LgU8udJARCjM0
KqrGScp+U/NiT+3pRo8sdx4pjToqSM1NQ0jNe4X61xSH5dPD2DAVvh30pdKOoUwC
NAzE/m7301jdlHWUF15HopRAUsfeOzqRDx0GybNdGJplGrO8EUtyhUqX3dRfnNFq
0FDE2gpHopZX7MJWLdQNpC8dBOVFYYpMr435zbr3LnA19VBr6gE+aHcKpstK9gv0
9MXpCrLpYWUHcE8kAK3/umzJLnIg61M0IKOujAAD777GXVfA2G2pB7JatXlwQe/E
A1c25DXFpiC3TRp7Z6aDOSe6Tsg/aACQJxKbdkJ/AGNgNGX1O2yKKYSPO9lQhyEY
4VmCmiyBmfXvTYFGDWxUUrK+UuRsMf4lps5PYwgTOja5I+w1Q08=
=WFyQ
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 20 Mar 2017 00:22
Re: bug#26154: [PATCH 2/3] gnu: Add megaglest-data.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26154@debbugs.gnu.org)
20170319232247.GD26441@jasmine
On Sat, Mar 18, 2017 at 09:37:38PM +0530, Arun Isaac wrote:
Toggle quote (7 lines)
> * gnu/packages/games.scm (megaglest-data): New variable.

> + (uri (string-append
> + "https://github.com/MegaGlest/megaglest-data/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))

This tarball is just an auto-generated snapshot that GitHub creates
whenever you make a new release on the GitHub page. These are rarely
what the upstream developers want us to use.

Instead we should use either 'megaglest-data-3.13.0.tar.xz' or
'megaglest-standalone-data-3.13.0.tar.xz'. Can you try it?

Toggle quote (9 lines)
> + (sha256
> + (base32
> + "0pif2n0py86kw2z3c7jlhlvf34cl6plscxnaddi2r3p7x80mcxwr"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))
> + (home-page "https://megaglest.org/")
> + (synopsis "3D real-time strategy (RTS) game (data files)")

"Data files for MegaGlest".

Toggle quote (7 lines)
> + (description "MegaGlest is an entertaining free and open source
> +cross-platform 3D real-time strategy (RTS) game, where you control the
> +armies of one of seven different factions: Tech, Magic, Egypt,
> +Indians, Norsemen, Persian or Romans.
> +
> +This package contains the data files required for the game.")

I think the description can just include this final sentence.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljPEscACgkQJkb6MLrK
fwhEgRAA3Hhfw2GYKdf4wCbiw0iv1Yf9VVoyCdUGvqjVNRrINfah9C9UCgFPA50X
IcG9ew2y5fOXsMiy/M7+uPR1cm49Z4A+zJmNb4WOovqKcfbCe+kDArozqzDjeFQl
BcVMC0IPKPPwnQwr9CrKomZd2WzsGcfq5qOYGopFOYuoixzLpZQzM08bgBH065qF
lrYe7t4a43GtWhYJL+40sMULVqd7E4qyYU7oGJr6WhBTXHT5q/clI+iMs6Zromuh
jC4Uqah71quoUzUquxgWWv1B5O0venHI17j2eaLxh6y13cBJDszKm9h8DqOtV0pD
KoSIhzayYgy82ZutXMty9y0RX0IIT8ph73Dg8tA1myk5ivIU4/kFLhTeXPt9N63z
6e2R8T0oH96WdEXw2PBUCXFLSYYPqSYZR7YpjoPFuhPoSp+FPCy9XokR/l91MSZ8
IR76bUcj19CKdI3SwfvMa3Zr1ZBuvqfvEs2uVaO2KOdODSrd7BDvuX8tHh10AzVL
lWg0k/rM5gyO/6FlAkRFZWY9ONwSaRdHL75jIUIyR423jhF9XcLR9SYiWw6iq88i
EcqfL55zpn6iHhzkbI/xQVFMfxhnQyqkITAGVtFLbD8RbEoluMLvG+IgK7XCg8ZG
8pa5DmPiUF3WmAqHBQjgodrCnAVADrqGb2OVDWIBg7rvyN5AN+E=
=lDpJ
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 20 Mar 2017 00:25
Re: bug#26154: [PATCH 3/3] gnu: Add megaglest.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26154@debbugs.gnu.org)
20170319232550.GE26441@jasmine
On Sat, Mar 18, 2017 at 09:37:39PM +0530, Arun Isaac wrote:
Toggle quote (5 lines)
> * gnu/packages/games.scm (megaglest): New variable.

> + (uri (string-append
> + "https://github.com/MegaGlest/megaglest-source/releases/download/3.13.0/megaglest-source-"

This line is way toooooo long :)

Toggle quote (18 lines)
> + (inputs
> + `(("curl" ,curl)
> + ("freetype" ,freetype)
> + ("ftgl" ,ftgl)
> + ("glew" ,glew)
> + ("libjpeg-turbo" ,libjpeg-turbo)
> + ("megaglest-data" ,megaglest-data)
> + ("mesa" ,mesa)
> + ("miniupnpc" ,miniupnpc)
> + ("openal" ,openal)
> + ("libircclient" ,libircclient)
> + ("libpng" ,libpng)
> + ("libvorbis" ,libvorbis)
> + ("libxml2" ,libxml2)
> + ("lua" ,lua)
> + ("sdl2" ,sdl2)
> + ("wxwidgets" ,wxwidgets)))

Please double-check that the build package keeps references to all these
inputs with $(guix gc --reference $(./pre-inst-env guix build
megaglest)).

Toggle quote (6 lines)
> + (synopsis "3D real-time strategy (RTS) game")
> + (description "MegaGlest is an entertaining free and open source
> +cross-platform 3D real-time strategy (RTS) game, where you control the
> +armies of one of seven different factions: Tech, Magic, Egypt,
> +Indians, Norsemen, Persian or Romans.")

We can leave out the phrase "entertaining free and open source". Games
are expected to be entertaining, and all Guix packages are free
software, so we don't mention it.

Overall LGTM pending the change to the data file source tarball and the
reference check for megaglest.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljPE34ACgkQJkb6MLrK
fwgdeBAApujYj0CdLTx2iPuuuJ7bDgM1S0YbKxLi3ux+S6i1HTCQCEP94+f0bKa2
mZ947mROtTX2F/Z5nBYk6hW6LhUfeD10qszt1MSFB/KGIlt3a+ZIwxMh7nQCwpv2
HbiHE0EHAtmrK1BSrS0RFreHeX/FEo9DsOhWlNbDWKNV6sLpWSwQ8BiZ8UO9bU54
jI8wAj9mQNguk9Z8LsKlxypz5mfnqEgS+JeBG29Td5spK9FFmIkSOJL8JK6a4vO2
C/UYvp3VwfHyJcPGh5KKf7Vlsy35wqm8JJn+Bgh/vQ76vN1yId2qGfcMg8QOaHdx
QPYnoamG9etdp1QdnhBUMu+bYAEl/FHVs273q5yxdgaGzDOTTkVpL6ClrW2vGYMM
jRorNSI0mPGNXWumaMVV6uCI3CJjV5qACUrSep+EBC/yFuJQKj5CiZcalXWxdf9v
YFkMkPRrIOpzcjzm5wF0nv4fQbs/NBvuvqvV3k6eWAZaa5g0y6U3dmoO8ThK4qcX
+QRcp0tZoYvT7msH7DA6/iPhnJt+JuN9/ztAAhyqigs3c9cWGhVoWLlS+1OKLkGz
x9aAjlX6RD2uYiNNMKHwAMty1k2EuI2Ov8mzW8ncI/2CgFmEK01HLUcjy48A3LfO
S0EstE5e7s8qqgRR0WrRMAZjQR8KacT5wIaC0rQrVPZyv3EPeX8=
=N5kx
-----END PGP SIGNATURE-----


A
A
Arun Isaac wrote on 20 Mar 2017 09:41
(address . 26154@debbugs.gnu.org)
8b80708f.AEAAIMWEI5cAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABYz5Xs@mailjet.com
Toggle quote (3 lines)
> Overall LGTM pending the change to the data file source tarball and the
> reference check for megaglest.

I'll make all changes and send updated patches as soon as I'm done. My
moderate speed Internet connection is taking quite a while to download
the new megaglest-data tarball.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAljPlbEACgkQLiXui2GA
K7O6xQf/UiF/ulhp1+p8p3T5aB0DDMgRVz6su0X+zWSQAU/67n1/265FeI9t3Gi/
1hfIaJcvI+7iWYX7h8jR5LxZ6G+pweELCbD1d9le9od6U7X9foGEgKsmyYAq9VaN
TzyMRtRIMHDQnWYyrFK5+Fz5xwyERtjHzThyp7sdbljGWagSgokqGgpafJjhJM7X
DyCyg5CGueNQk2V27DdlDMxJVy3iMi+j2Ad1GJMOrMfu46bTs/isp3VAfq5gWHq4
nwQ/mWNjPtl+cDeE9keAfZ9tOODQGh4mDKgcmJEJeFW+gu6jXbUA+ygS5WG2BRFx
qDzaq9FMPOKKKuHRliHerY3Kdy/tFQ==
=+68O
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 20 Mar 2017 19:05
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26154@debbugs.gnu.org)
20170320180516.GB3820@jasmine
On Mon, Mar 20, 2017 at 02:11:21PM +0530, Arun Isaac wrote:
Toggle quote (8 lines)
>
> > Overall LGTM pending the change to the data file source tarball and the
> > reference check for megaglest.
>
> I'll make all changes and send updated patches as soon as I'm done. My
> moderate speed Internet connection is taking quite a while to download
> the new megaglest-data tarball.

If my request is not reasonable because the tarball is too large to
download for you, I can test the changes here.

Please let me know :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljQGdwACgkQJkb6MLrK
fwg19Q/8DQpnkXn0J2HWoLiPwohbpbygOrXS+4bjVcMoDFDsAnacT+Qzzqj3xPXC
ABCF7rg/u2b/G9fijg7JDG5IQfHSNUj/P1K9ODrzygqbmGLv4LJZ51OG+te/PKwC
Hm+Tes1wW4lKMuc59vvUAdL1nTzAqfpnoXKHEu68iMk/DMGWMTnyha8sbYX56OEq
GiGgbqyYn8/AuzeZgVvZQhXNQZHoN3fpAFk5THvgyO4BgdWlZZNXt+yE1/76LiZN
Zixnl7vgpGRuISn+Ah7DoB6jVPuU2Q+TSufQ9ojYhMeYu2myqCNm2qwiVQh6kF+Z
P/UnSKqBZM8fensnGm/4HeYZquPrSn+UvGXda8OM38x3sixIhfuG8JohwZvyFC+/
GvL/UfuMI+re57EgW/TtDUjoN7e62wzkiNbjxxRM9CwS5Fs6zDVNE03U3zOh8amU
Ebzcz3HJGZbM4RxHIIdqE4ZVdte8LYa8HtmMy7v21A/PdUzEioAOhx6pKmOUyP7y
BA/pDIVpcLSlP3mirb0fsuWC9GjJGw/fmWCma+aHJUE6wb1zJSxH3yXEKEqvm2Da
VZ6Rivp5W9wbArOMXD6GCL5mLKMfUEnq5Fdfto3TYVLjL72pzE4gWDt96l/p6jDz
fhYGNkC9ei5pQQdei4nqORq5dkmKEAn5Z1JRpl9E06xfazoM2xA=
=imF2
-----END PGP SIGNATURE-----


A
A
Arun Isaac wrote on 20 Mar 2017 20:06
(address . 26154@debbugs.gnu.org)
105b1957.ADsAAG5mJzUAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABY0Cg1@mailjet.com
Toggle quote (3 lines)
> If my request is not reasonable because the tarball is too large to
> download for you, I can test the changes here.

No, no, not a problem! :-)

The download finished a long time back. It turns out that the
megaglest-data release tarball does not have embedded fonts that were in
the auto-generated snapshot. So, the game was not rendering properly,
and crashing after a while. It took me several build iterations to
figure out that I needed to include fontconfig to inputs. Hence, the
delay. Sending the patches now...
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAljQKCcACgkQLiXui2GA
K7O/0wgAsdgYF6xbzCvHKvspZ7UJ9JAZ+3+p+1dfLxORV42JbE6g9mPn9U3+NPq8
JCckaGZAe6qYyU5FUjbPLQcN+capnh2nnCh+BA8TUkdUzX7chObdOhP+gn86ZMq1
7vWDy63V75rpMscCowp41J7dZypGrFLhHU+4N+8aHJLePgKd1tJzd75PIhCrzkGA
xC2gvmLjfripM98C744H6CfV4HkeaTqsyr8P06XiHl/glu+gmf0EHa+w/9A4hxpT
6WoAEzB08kczeH2bpZe8dTUYTwMR1so1pJtd2yTBiKflu6M/akrHG88zTMm4y8pe
b/6diwOzOa+nlDVsMIzUj15J+8E9JQ==
=QzRP
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 20 Mar 2017 20:16
[PATCH 2/3] gnu: Add megaglest-data.
(address . 26154@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
10142f0f.AEAAINYRMcEAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABY0Cqn@mailjet.com
* gnu/packages/games.scm (megaglest-data): New variable.
---
gnu/packages/games.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f264ef206..4c2c9821e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3267,3 +3268,26 @@ This command works on piped data. Pipe any ASCII or UTF-8 text to nms, and
it will apply the hollywood effect, initially showing encrypted data, then
starting a decryption sequence to reveal the original plaintext characters.")
(license license:expat)))
+
+(define-public megaglest-data
+ (package
+ (name "megaglest-data")
+ (version "3.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/MegaGlest/megaglest-data"
+ "/releases/download/" version "/megaglest-data-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0ipgza33z89fw3si32iafm981f3fvm0zldvbxj29whghd2k3rpj3"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://megaglest.org/")
+ (synopsis "Data files for MegaGlest")
+ (description "This package contains the data files required for the
+game.")
+ (license license:cc-by-sa3.0)))
--
2.11.0
A
A
Arun Isaac wrote on 20 Mar 2017 20:16
[PATCH 3/3] gnu: Add megaglest.
(address . 26154@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
62599016.AEUAII9ZLOoAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABY0Cqn@mailjet.com
* gnu/packages/games.scm (megaglest): New variable.
---
gnu/packages/games.scm | 59 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4c2c9821e..72aa6c94b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -108,6 +108,9 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages pcre)
#:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages messaging)
+ #:use-module (gnu packages upnp)
+ #:use-module (gnu packages wxwidgets)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
@@ -3291,3 +3294,59 @@ starting a decryption sequence to reveal the original plaintext characters.")
(description "This package contains the data files required for the
game.")
(license license:cc-by-sa3.0)))
+
+(define-public megaglest
+ (package
+ (name "megaglest")
+ (version "3.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/MegaGlest/megaglest-source"
+ "/releases/download/" version "/megaglest-source-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1ffck3ii1wp5k3nn5p0ga06jgp7pzk4zw0xln3xim2w7qrxzdzh9"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("fontconfig" ,fontconfig)
+ ("ftgl" ,ftgl)
+ ("glew" ,glew)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("megaglest-data" ,megaglest-data)
+ ("mesa" ,mesa)
+ ("miniupnpc" ,miniupnpc)
+ ("openal" ,openal)
+ ("libircclient" ,libircclient)
+ ("libpng" ,libpng)
+ ("libvorbis" ,libvorbis)
+ ("lua" ,lua)
+ ("sdl2" ,sdl2)
+ ("wxwidgets" ,wxwidgets)))
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCUSTOM_DATA_INSTALL_PATH="
+ (assoc-ref %build-inputs "megaglest-data")
+ "/share/megaglest")
+ "-DBUILD_MEGAGLEST_TESTS=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-ini-search-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "source/glest_game/global/config.cpp"
+ (("/usr/share/megaglest/")
+ (string-append (assoc-ref outputs "out")
+ "/share/megaglest/"))))))
+ #:test-target "megaglest_tests"))
+ (home-page "https://megaglest.org/")
+ (synopsis "3D real-time strategy (RTS) game")
+ (description "MegaGlest is a cross-platform 3D real-time strategy (RTS)
+game, where you control the armies of one of seven different factions: Tech,
+Magic, Egypt, Indians, Norsemen, Persian or Romans.")
+ (license license:gpl2+)))
--
2.11.0
A
A
Arun Isaac wrote on 20 Mar 2017 20:34
(address . 26154@debbugs.gnu.org)
d95ba41f.AEQAIbD-mwgAAAAAAAAAAAOtd04AAAACwQwAAAAAAAW9WABY0C7o@mailjet.com
Toggle quote (22 lines)
>> + (inputs
>> + `(("curl" ,curl)
>> + ("freetype" ,freetype)
>> + ("ftgl" ,ftgl)
>> + ("glew" ,glew)
>> + ("libjpeg-turbo" ,libjpeg-turbo)
>> + ("megaglest-data" ,megaglest-data)
>> + ("mesa" ,mesa)
>> + ("miniupnpc" ,miniupnpc)
>> + ("openal" ,openal)
>> + ("libircclient" ,libircclient)
>> + ("libpng" ,libpng)
>> + ("libvorbis" ,libvorbis)
>> + ("libxml2" ,libxml2)
>> + ("lua" ,lua)
>> + ("sdl2" ,sdl2)
>> + ("wxwidgets" ,wxwidgets)))
>
> Please double-check that the build package keeps references to all these
> inputs with $(guix gc --reference $(./pre-inst-env guix build
> megaglest)).

I double-checked this, and removed libxml2 and freetype.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAljQLtkACgkQLiXui2GA
K7PUSAf/UQxsrdr3XOv+vuGWaT0XT+COrvQA0ofApn1qUCkYiBoYtmrWG4mEVA0n
O3bxUohc4AdRWHkt0oGMHOTT1EdXaprCQwnk17S6VjQ1KK9eOWdgYb6HqKXNAsN6
S3PYrIojqNPXUctqFZHOWRsJePjNWPB4sO3zx9iRSwM/av56Ipda9aQZV58kdbnz
RB/TTrHZT4AFp6fubt69XkVD23JjsO/G8GziR/rjw6EvUgejFtUB2Y+m3CkprUpt
S+McV28ffGcq+uto31RRf4TDNXhUAw1irQOmVjF7rKcpYOecWtCF/GUUHrLNacqI
YOPUZhN5HL3BLUSrI+Aysagxp5AbPA==
=UGk9
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 21 Mar 2017 20:18
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26154@debbugs.gnu.org)
20170321191805.GA3826@jasmine
On Tue, Mar 21, 2017 at 12:46:37AM +0530, Arun Isaac wrote:
Toggle quote (2 lines)
> * gnu/packages/games.scm (megaglest): New variable.

Pushed as 0b608ec4ceaee45a0d00b2f081f6f0be69b90deb
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljRfG0ACgkQJkb6MLrK
fwg1jxAA6so0m0BOOWbZbABVC/FOSmJLpTW7AOV+z8ND7nZTuUgIju1Iovya/mCh
AoIhc4p6g27GkN1pPAQKseHM9gsc+N4SSAcLszWrfSyu+PwCmDlEUzaUphErf6fB
4hIyVSPFp62/DU0Jc/FJLJP0fKkpdP0ZzJNR4y2WyZe3Crjl0ZNOwqs/X48aJhUp
AeoA76obM4UOMf+VKXt5o4yB9aIeqyJj9CZvc0fK/tPLviWYlc/LbV023yDFn33h
3yEeX2TuKDA6K/jHSTj5KYGFs+ZnBE4/N3cS6YUft1i6Otclmf+8nc0f5KOBwKbb
gF8o8tdp8tH8NZHm5G67MAxlOje80DHLx/3WNXXdtljY576gka+mEWp20+VSOvb3
nLgHFsZdE9fLLjOGyXmjRoDhe97Cbw8NIsbPakJY9ge8DQel9JXl8Wh2psf/HO6A
kZWQfBsZEWAyVDdCs0Lpt1PQUicM0GV4MjFF5K1v90/Ozq6uLLLzFHp3wM3p53rp
oWiKHkthD4sHDTiW6H5uLkT1KmJ4m7EPN3jOVohKfcyoar0HxOHjCC/a5kKc2b07
en0kLHHMCLlxJ1dKc4hfNxbHYBC/97Gk0LxE7BqyEXng+4v4Mv1Q/DxGvxEDVDmx
Gj0ZSrzfWvqjWq6uR9VA/6asjjyGhhXMGY5QvdOso7AhRhhMbrA=
=x4uF
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 21 Mar 2017 20:18
Re: bug#26154: [PATCH 2/3] gnu: Add megaglest-data.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26154-done@debbugs.gnu.org)
20170321191840.GB3826@jasmine
On Tue, Mar 21, 2017 at 12:46:36AM +0530, Arun Isaac wrote:
Toggle quote (2 lines)
> * gnu/packages/games.scm (megaglest-data): New variable.

Pushed as fb731c92328fb3aa931e771a567738a565d4ada8.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAljRfJAACgkQJkb6MLrK
fwjBOxAAvKzBYflBvAOcPm2KKV/n/780FLIpQJdseWrPxmZaSPgJu88jMKlAJoD9
6GjJyW9bCbXX4pUksk2KgrNER1EBOep5kDhp7kVVjT6dvwz/3kd6e5sHivuLUHOQ
BL3f/J7OC0IyABS3uBQRd7tDH4MkbTWinqPI4Kd/DiIU9jrjE3NkNTR37/YlJzBl
Uz3adjUDf/uQfCWf23XCzoBfSOKUeF4pRBSNdo8twLH5qJmGRh//5aNLjWy3HcYB
j5BPf+IascfRxM+Aaps3IIUwxk+zgoIKi/QSsVA3aqbiGmOXHNZPZ4bCi72fF/Qg
iuUuWVuuYrK219+QFz9hk9acZgNFEY5WY3VK9kVIVLliNAhMxI7pP5CzOOgGKusR
UKX0+q2mRq6aIyww3e8bX7WQxS5VK/piaXtptNv6NjJc/6tMjQHR2Q02EH0v2TKb
eO9fG2QDO4F0TdziSwO8mx2NWCVRLQALrn2SJKF8tRqCin/oMvt9ykEzn2INx7DH
zWC4d79DWKydd0NBBRx4LoGlHwX1W3Ko3tWZUDMExJ1M5Ntph4TzSdlAr89pgZMw
d/O6qxSUqQ3I9o2vw0C6em+OdC8RwVSjvYzx7r7G2uulIIRSE8nyc87JXCXBE1+P
+Ck5tp4ifU5FDziDw6CgToaA7AF0RantLa0FGg9Fwdun5fz3gKE=
=ExZR
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26154@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26154
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch