[PATCH 4/7] gnu: Add maxflow.

  • Done
  • quality assurance status badge
Details
3 participants
  • John Darrington
  • John Darrington
  • Kei Kebreau
Owner
unassigned
Submitted by
John Darrington
Severity
normal

Debbugs page

John Darrington wrote 8 years ago
(address . guix-patches@gnu.org)(name . John Darrington)(address . jmd@gnu.org)
1489608324-23632-4-git-send-email-jmd@gnu.org
* gnu/packages/maths.scm (maxflow): New variable.
---
gnu/packages/maths.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8e7580c..12a3207 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1111,6 +1111,30 @@ modules is done either interactively using the graphical user interface or in
ASCII text files using Gmsh's own scripting language.")
(license license:gpl2+)))
+(define-public maxflow
+ (package
+ (name "maxflow")
+ (version "3.04")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gerddie/maxflow.git")
+ (commit "42401fa54823d16b9da47716f04e5d9ef1605875")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0rll38whw55h0vcjrrwdnh9ascvxby0ph7n1l0d12z17cg215kkb"))))
+ (build-system cmake-build-system)
+ (home-page "http://pub.ist.ac.at/~vnk/software.html")
+ (synopsis "Library implementing Maxflow algorithm")
+ (description "An implementation of the maxflow algorithm described in
+@cite{An Experimental Comparison of Min-Cut/Max-Flow Algorithms for
+Energy Minimization in Computer Vision.\n
+Yuri Boykov and Vladimir Kolmogorov.\n
+In IEEE Transactions on Pattern Analysis and Machine Intelligence,\n
+September 2004}")
+ (license license:gpl3+)))
+
(define-public petsc
(package
(name "petsc")
--
2.1.4
Kei Kebreau wrote 8 years ago
(name . John Darrington)(address . jmd@gnu.org)(address . 26113@debbugs.gnu.org)
87y3w360sy.fsf@openmailbox.org
John Darrington <jmd@gnu.org> writes:

Toggle quote (36 lines)
> * gnu/packages/maths.scm (maxflow): New variable.
> ---
> gnu/packages/maths.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 8e7580c..12a3207 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -1111,6 +1111,30 @@ modules is done either interactively using the graphical user interface or in
> ASCII text files using Gmsh's own scripting language.")
> (license license:gpl2+)))
>
> +(define-public maxflow
> + (package
> + (name "maxflow")
> + (version "3.04")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/gerddie/maxflow.git")
> + (commit "42401fa54823d16b9da47716f04e5d9ef1605875")))
> + (file-name (string-append name "-" version "-checkout"))
> + (sha256
> + (base32
> + "0rll38whw55h0vcjrrwdnh9ascvxby0ph7n1l0d12z17cg215kkb"))))
> + (build-system cmake-build-system)
> + (home-page "http://pub.ist.ac.at/~vnk/software.html")
> + (synopsis "Library implementing Maxflow algorithm")
> + (description "An implementation of the maxflow algorithm described in
> +@cite{An Experimental Comparison of Min-Cut/Max-Flow Algorithms for
> +Energy Minimization in Computer Vision.\n
> +Yuri Boykov and Vladimir Kolmogorov.\n
> +In IEEE Transactions on Pattern Analysis and Machine Intelligence,\n
> +September 2004}")

These aren't showing up as new lines. I tried replacing the newline
characters with the appropriate Texinfo substitute, @*, but that gave me
a parsing error. We might have to dive into some source code to fix this
(but hopefully not).

Toggle quote (6 lines)
> + (license license:gpl3+)))
> +
> (define-public petsc
> (package
> (name "petsc")

Otherwise LGTM.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljMV20ACgkQ5qXuPBlG
eg15bhAAjNkVuLWyZeuBJkh3xlSTlfUEpZmDQM/gpdwvoggbARvY00N/Od9u2rGY
TcGhmFVhVrRVOKeWSjZ2N1XeOc/WyF4HueEKmglnAAl9bUNomhhHJTTntWhVInNj
cfW4ijN+dvqu3oKoVYEEhdVazmptSjmt4WnfM73PcBajzLLOyRKPQT8x9oPUWQBb
9sOyqq/RnKztrYVtFXyHAZ5PdgBAoNToVSzTPLJjhlm27dvtzW1dsFJLz6djJWy6
Dj29lxxFzN4lDcyQfORAa1pyhzx4I4scyIFxRXQGJIDGnPzV3fdVms8dxmR7ZH7E
3btZUpN/fO73qDs3ILexuOETkCNqNE6LQk4rCY2vgqC4IWdl6V0TmFZCvS75+edL
pXT5+2h++pJyrkeDvBavy3IHBRv36S2iK6DfBnz4fZJNJuR0T49ALRo4YZSVPXmn
k8NU908TVBnzd8SuRLktjachQJLWi0xdmad/h4/2cP+DCOMMc9w24+p2Uutakpe+
1J0NQlmvyP2Kpz4F12roeS6Mz95LyjMuJsYIBN/MOquUaxeO2hXvadlS2GSQPozj
9BwlnrXEsQalcbmHkH8N2jo7iWOZf55NVvbSMmHoR6vVuoKJSt8ULHWv5oPLx0+p
cNN1x4vm9bv/v5Iwv9diWUPSh4w/Aky3YEJGRTN6oHCJL65vWW4=
=aUUs
-----END PGP SIGNATURE-----

John Darrington wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26113@debbugs.gnu.org)(name . John Darrington)(address . jmd@gnu.org)
20170317233954.GA1013@jocasta.intra
On Fri, Mar 17, 2017 at 05:38:53PM -0400, Kei Kebreau wrote:
> + (description "An implementation of the maxflow algorithm described in
> +@cite{An Experimental Comparison of Min-Cut/Max-Flow Algorithms for
> +Energy Minimization in Computer Vision.\n
> +Yuri Boykov and Vladimir Kolmogorov.\n
> +In IEEE Transactions on Pattern Analysis and Machine Intelligence,\n
> +September 2004}")
These aren't showing up as new lines. I tried replacing the newline
characters with the appropriate Texinfo substitute, @*, but that gave me
a parsing error. We might have to dive into some source code to fix this
(but hopefully not).


I think that would be in the Guile source and not the Guix source :(
I don't know what the answer is here. Does anyone else have an idea?


--
Avoid eavesdropping. Send strong encrypted email.
PGP Public key ID: 1024D/2DE827B3
fingerprint = 8797 A26D 0854 2EAB 0285 A290 8A67 719C 2DE8 27B3
See http://sks-keyservers.netor any PGP keyserver for public key.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAljMc8oACgkQimdxnC3oJ7MqJgCfS2DhCSdsmd3oTrdXnS9E1VgJ
UX8AnR1uiWEIXczH2DrHYa+ispNJ2Uqz
=ikLc
-----END PGP SIGNATURE-----


John Darrington wrote 8 years ago
Done
(address . 26113-done@debbugs.gnu.org)
201703180940.v2I9ecut013754@jocasta.intra
I pushed this.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26113@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26113
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help